Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Änderungen in etc aliases werden nicht übernommen

Mitglied: aAS2Ee

aAS2Ee (Level 1) - Jetzt verbinden

29.03.2010 um 08:14 Uhr, 6115 Aufrufe, 5 Kommentare

Ich habe einige Eintragungen in der Datei /etc/aliases vorgenommen, welche nicht übernommen werden.

Die Situation ist die folgende: Wir verfügen über einen Server welcher mittels Fetchmail auf dem Exchange Server Mails abholt. Mit einem Eintrag in /etc/aliases wird ein Skript aufgerufen, welches das abgeholte Mail auf einem FTP-Server ablegt. Ich hab nun die Aufgabe diese Funktion auf einem anderen Server zu installieren. Dazu habe ich Fetchmail installiert, die Konfiguration vom anderen Server übernommen, alle Skripts kopiert, den FTP Zugang eingerichten und natürlich die Einträge in /etc/aliases kopiert.

Fetchmail funktioniert gemäss dem Log-File wie es sollte. Die vorhandenen Mails werden gesehen und kopiert und auch Fehlermeldungen sind keine zu entdecken. Jedoch findet nie ein Connect auf den FTP-Server statt. Das obwohl der Zugriff funktioniert, wenn ich es manuell versuche. Da nicht einmal die Log Files zu den Scripts erstellt werden, gehe ich davon aus, dass diese gar nie aufgerufen werden.

Aus diesen Gründen, bin ich mir ziemlich sicher, dass die Einträge in /etc/aliases überhaupt nicht übernommen werden. Ich habe bereits "newaliases" und "sendmail -bi" ausgeführt. Beides hat leider nichts gebracht.

Falls relevant: Bei alten Server, d.h. dort wo die ganze Funktion funktioniert, handelt es sich um ein SLES9 Gerät. Auf dem neuen Server ist SLES10 installiert.

Persönlich hätte ich den Server mal gebootet, die ganze Fetchmail-Funktion ist auf dem Server aber eher nebensächlich. Der führt ansonsten Backups durch und kann unmöglich einfach heruntergefahren werden.

Vielen Dank für jede etwaige Hilfe. Ich komme hier wirklich nicht mehr weiter.
Mitglied: SlainteMhath
29.03.2010 um 09:31 Uhr
Moin,

gehe ich davon aus, dass diese gar nie aufgerufen werden.
evtl. stimmen die rechte nicht? Tippfehler im Pfad? etc. etc.

Persönlich hätte ich den Server mal gebootet,
Bitte las die Finger von Linuxservern, danke

lg,
Slainte
Bitte warten ..
Mitglied: aAS2Ee
29.03.2010 um 10:00 Uhr
Die Berechtigungen sind vorhanden. Alle Benutzer dürfen die Scripts ausführen. Die Pfade stimmen auch genau mit denen in /etc/aliases überein. Das hab ich beides bereits kontrolliert.

Wenn man die Möglichkeit dazu hat, ist booten auch bei Linux Servern häufig eine gute Lösung. Mir ist durchaus bekannt, dass es unter Linux für die meisten Probleme Möglichkeiten gibt, sie zu beheben, ohne den Server zu booten. Wenn es sich jedoch nicht um ein wichtiges Gerät handelt, wieso sollte man es dann nicht neu starten, anstatt lange nach einer Lösung zu suchen? Hat bei mir schon mehr als einmal geholfen.
Bitte warten ..
Mitglied: SlainteMhath
29.03.2010 um 10:14 Uhr
anstatt lange nach einer Lösung zu suchen?
Jo, und hinterher gings zwar, aber den Grund für das Problem kennst Du immer noch nicht.
Mir ist unter Linux noch nichts unter die Finger gekommen, weswegen ein Reboot nötig gewesen wäre (Kernalupdate ausgenommen *g*).
Aber das gehört jetzt in diesen Thread.

Dein Problem liegt entweder an der übergabe zwischen fetchmail unt deinem MTA oder an dem Script das ausgeführt werden soll.
Läuft das Script denn wenn Du es manuel (als sendmail-user) ausführst? Kommen denn andere Mails die per fetch geholt werden und an
lokale user zugestellt werden an? Wie sieht denn die mailq aus - evtl versucht deine Kiste die mails an ein anderes system weiterzuleiten.
Bitte warten ..
Mitglied: aAS2Ee
29.03.2010 um 10:45 Uhr
Wie kann ich das Script denn testen? Ich müsste dem ja irgendwie das Mail übergeben, ich hab aber keins. Legt Fetchmail die abgeholten Mails irgendwo ab? Das ganze mit anderen Mails zu testen ist relativ schwierig, ich hab eigentlich kein Postfach zur Verfügung, welches ich zum testen benutzen könnte. Gemäss Log, wurden die Mails jedoch abgeholt. Deshalb auch hier wieder die Frage: Werden die irgendwo abgelegt? Die mailq ist übrigens leer.
Bitte warten ..
Mitglied: alex-w
29.03.2010 um 16:50 Uhr
Ich denke mal das du eine alias.db brauchst bzw. das diese nicht aktuell ist.

Probiere mal ein:

postalias /etc/aliases

Gruß Alex
Bitte warten ..
Ähnliche Inhalte
Exchange Server

Alias Änderung am Exchange nicht im Outlook sichtbar

gelöst Frage von Oneil-1989Exchange Server2 Kommentare

Hallo zusammen, es hat jemand geheiratet nun habe ich überall, den Namen angepasst. Auch am Exchange den Alias, doch ...

Windows 7

Registry Eintrag per CMD ändern - Änderung wird nicht übernommen

gelöst Frage von BlubberbadWindows 73 Kommentare

Hey Leute :) ich möchte per CMD die Systemschriftgröße von Windows 7 ändern. Ich hab schon herausgefunden, dass ich ...

CMS

Joomla Seite auf Subdomain gespiegelt - Änderungen werden auf Hauptdomain übernommen

gelöst Frage von ischbindebaetmaenCMS3 Kommentare

Hallo Admins, folgende Frage: Ich habe heute eiune LIvewebseite auf eine Sudomain gespiegelt als Testumgebung. Joomla Ordner gesichter, Inhalt ...

iOS

MAC-Adresse als Alias in URL

Frage von HanutaiOS6 Kommentare

Hallo Zusammen, ist es möglich einen Alias in eine URL einzufügen, der automatisch die MAC-Adresse eines IPhones/IPADs einsetzt? VG ...

Neue Wissensbeiträge
Erkennung und -Abwehr

Ups: Einfaches Nullzeichen hebelte den Anti-Malware-Schutzt in Windows 10 aus

Information von kgborn vor 9 StundenErkennung und -Abwehr

Windows 10 ist das sicherste Windows aller Zeiten, wie Microsoft betont. Insidern ist aber klar, das es da Lücken, ...

Windows 10

Windows 10 on ARM: von Microsoft entfernte Info - Klartext, was nicht geht

Information von kgborn vor 11 StundenWindows 10

Windows 10 on ARM ist ja eine neue Variante, die Microsoft im Verbund mit Geräteherstellern am Markt etablieren will. ...

Microsoft
TV-Tipp: Das Microsoft-Dilemma
Information von kgborn vor 11 StundenMicrosoft7 Kommentare

Aktuell gibt es in Behörden und in Firmen eine fatale Abhängigkeit von Microsoft und dessen Produkten. Planlos agieren die ...

Windows 10
Zero-Day-Lücke in Microsoft Edge
Information von kgborn vor 2 TagenWindows 10

In Microsofts Edge-Browser klafft wohl eine nicht geschlossene (0-Day) Sicherheitslücke im Just In Time Compiler (JIT Compiler) für Javascript. ...

Heiß diskutierte Inhalte
Windows 10
Windows 10 (1709) Tastur und Maus wieder einschalten?
Frage von LochkartenstanzerWindows 1026 Kommentare

Moin, Ich habe von einem Kunden einen Win10-Rechner bekommen, bei dem weder Tastatur noch Maus geht. Die Hardware funktioniert ...

Firewall
RB2011 Firewall Rule eine bestimmte Mac oder IP Adresse nicht zu blockieren
Frage von lightmanFirewall15 Kommentare

Hallo liebes Forum mit ihren Spezialisten. Ich habe meine Firewall so konfiguriert das kein Endgerät ohne meine Speziellen Erlaubnis ...

Humor (lol)
Was könnte man mit einem Server machen? Idee gesucht
Frage von 2SeitenHumor (lol)15 Kommentare

Hey Zusammen Ich habe einen alten HP G2 Rackserver zu Hause rumliegen. 28GB Ram, 1xAMD Prozi mit etwa 2GHz. ...

Webbrowser
Welcher Browser ist der Beste?
Frage von justtinWebbrowser13 Kommentare

Hallo Leute Ich habe eine interessante Frage. Mich wurde mal interessieren welcher Browser ist eure meinung nach der beste? ...