Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Eine öffentliche IP, 2 Webserver Apache und IIS

Mitglied: flugfaust

flugfaust (Level 2) - Jetzt verbinden

31.07.2007, aktualisiert 18.10.2012, 7787 Aufrufe, 6 Kommentare

Hallo,

ich habe folgendes Problem.
Ich habe auf meinem DSL Router einen dynamsichen DNS Eintrag und forwarde port 80 auf einen Apache Webserver auf dem eine Homepage zur Verfügung gestellt wird.

Nun habe ich auf einem anderen Server einen Exchange Server laufen und will den Zugriff über das Web anhand von Outlook Web Access ermöglichen.
Dazu habe ich Port 443 vom DSL Router auf den Exchange Server geforwardet.
Wenn ich nun https://meinedomain/exchange eingebe, kommt nichts. Auf meine Domain komme ich problemlos per http://meinedomain
Wenn ich aber auf dem DSL Router Port 80 nicht auf den Apache Server sondern auf die IP des Exchange forwarde, komme ich per http://meinedomain/exchange drauf.

Was muss ich machen um den Zugriff auf den Exchange UND den Apache zu ermöglichen ?


DANKE schon mal im Vorraus
Mitglied: Alfredus
31.07.2007 um 11:28 Uhr
Apache kann als Frontend für den Exchange laufen. Siehe:

Howto

Die Frontend-Stellung hindert den Apache aber nicht daran, auch ganz normale http-Dienste anzubieten.

Gruß
Alfredus
Bitte warten ..
Mitglied: flugfaust
31.07.2007 um 11:47 Uhr
OK das sieht schon mal 1.sehr interessant und 2.sehr gut aus. Werde ich auf jeden Fall sobald ich mehr Zeit habe, testen.

Aber nichts desto trotz..........gibts noch einen anderen Weg? Ich meine das Portforwarding sollte doch so eigentlich auch klappen oder?
Bitte warten ..
Mitglied: Spao
31.07.2007 um 11:56 Uhr
Ist das ein oder zwei Rechner ?
Bitte warten ..
Mitglied: aqui
31.07.2007, aktualisiert 18.10.2012
Normalerweise kann der Router niemals auf Verzeichnisse in einer URL differenzieren...wie sollte er auch. Was er machen kann ist einzig und allein nach eingehenden Ports auf seiner öffentlichen IP Adresse zu differenzieren. Nichts anderes macht diese Port Forwarding Liste.
Die Angabe des Verzeichnisses \exchange ist in der Hinsicht also völlig sinnlos !!!
Wenn Port TCP 80 auf den Apache geht und Port TCP 443 auf den Exchange dann reicht es von remote wenn man
http://meinedomain angibt um auf den Apache zu kommen und
https://meinedomain um auf den Exchange Server zu kommen

Wichtig ist natürlich das der Exchange Server sofort mit der Exchange Seite antwortet sollte er per HTTPS angesprochen werden, was sich sicher bei MS einrichten lässt. Bei einem lokalen Test muss also bei https://<exchange ip adresse> sofort die Webmail Seite kommen.

Wenn der Exchange Webzugriff allerdings irgendwelche Daten zwischendurch per Port TCP 80 macht hast du ein Problem, da die dann immer an den Apache gehen, und das ist auch nicht zu verhindern.

Du solltest mal versuchen mit dem Router eine Port Translation als Test zu fahren, indem du den Exchange mit Port 8080 und 443 ansprichst !
Dazu legst du in der PFW Tabelle des Routers den Port TCP 8080 als incoming fest und gehst outgoing lokal auf die Exchange IP mit TCP 80. TCP 443 legst du gleich fest auf die lokale Exchange IP Adresse.
Wenn du nun den Exchange mit
http://meinedomain:8080
ansprichst müsste es klappen. Ggf. sogar wenn du https://meinedomain:8080 machst aber das ist davon abhängig wie dein Router die PFW Liste abhandelt....


Du solltest fairerweise auch oben noch dazuschreiben das dieser Thread ein Doppel von:
https://www.administrator.de/forum/portforwarding-funktioniert-nicht-so- ...
ist, den du nicht geschlossen hast
Bitte warten ..
Mitglied: flugfaust
31.07.2007 um 18:16 Uhr
OK. Also dass mit dem Portforwarding hab ich logischerweise schon versucht, allerdings hatte ich https://meinedomain/exchange
Kaum geb ich nur https://meinedomain an, geht es auch schon.
Also DANKE
Bitte warten ..
Mitglied: aqui
31.07.2007 um 18:17 Uhr
War eigentlich vorauszusehen....

Bitte
https://www.administrator.de/index.php?faq=32
nicht vergessen !
Bitte warten ..
Ähnliche Inhalte
Firewall

Exchange und Webserver mit nur einer öffentlichen IP Adresse?

Frage von meddieFirewall1 Kommentar

Hallo Leute, eine Frage ich habe bei mir zu Hause in meiner Versuchsumgebung einen Exchange den ich nach außen ...

HTML

Seitenaufbau beschleunigen - Apache Webserver

gelöst Frage von mabue88HTML5 Kommentare

Hallo, und schon wieder habe ich eine Frage, die ich selbst nicht beantworten kann. Ich habe einen Apache-Server. Eine ...

Informationsdienste

IIS als Frontend für interne Webserver

gelöst Frage von SKB-CGNInformationsdienste9 Kommentare

Hallo Zusammen, ich bin auf der Suche nach einer "Fähigkeit", wo ich nicht weiss, ob dies möglich ist - ...

Windows Server

Problem mit Webdav und Webserver IIS

Frage von JUJUS31Windows Server3 Kommentare

Hallo, ich versuche seit einigen Tagen den Webdav dienst des Windows IIS server ans laufen zu bekommen. Die Verbindung ...

Neue Wissensbeiträge
Sicherheit

MikroTik-Router patchen, Schwachstelle wird ausgenutzt

Information von kgborn vor 15 StundenSicherheit

Am 23. April 2018 wurde von Mikrotik ein Security Advisory herausgegeben, welches auf eine Schwachstelle im RouterOS hinwies. Mikrotik ...

Windows 10

Microcode-Updates KB4090007, KB4091663, KB4091664, KB4091666 für Windows 10

Information von kgborn vor 21 StundenWindows 101 Kommentar

Kurze Information für Administratoren von Windows 10-Systemen, die mit neueren Intel CPUs laufen. Microsoft hat zum 23. April 2018 ...

iOS
Updates für Iphone und Co
Information von sabines vor 1 TagiOS

Gestern abend ist iOS 11.3.1 erschienen, ein kleineres Update, dass einige Lücken schließt und "Lahmlegen" nach einem Display Tausch ...

Windows 7

Windows 7 - Server 2008 R2: Exploit für Total Meltdown verfügbar

Information von kgborn vor 2 TagenWindows 7

Kleine Information für Administratoren, die für die Updates von Windows 7 SP1 und Windows Server 2008 R2 SP1 verantwortlich ...

Heiß diskutierte Inhalte
Batch & Shell
Powershell: Im AD nach Rechnern mit bestimmten IP-Adressen suchen
gelöst Frage von Raven42Batch & Shell36 Kommentare

Hallo zusammen, ich suche nach einer Möglichkeit nach Computern im AD zu suchen , deren IP-Adresse mit 10.11.12. beginnt. ...

C und C++
Frage1 C Programmierung-Makefile Frage2 PHP-Programmierung HTTP-Fehler 404
Frage von KatalinaC und C++34 Kommentare

Hallo, ich habe 2 Fragen, die nichts miteinander zu tun haben aber mit denen ich mich gerade beschäftige: 1. ...

LAN, WAN, Wireless
Watchguard T15 VPN Einrichtung
gelöst Frage von thomasjayLAN, WAN, Wireless25 Kommentare

Hallo zusammen, wir möchten gerne über unsere Watchguard T15 einen VPN-Tunnel (Mobile VPN with IPSec) einrichten! Als Client nutzen ...

Windows Server
Alten DC entfernen
Frage von smartinoWindows Server24 Kommentare

Hallo zusammen, ich habe hier eine Umgebung übernommen und erstmal einen DCDIAG gemacht. Dabei fällt auf, daß eine ganze ...