Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst 2 Vlans über Trunk (LACP)

Mitglied: nestasko

nestasko (Level 1) - Jetzt verbinden

08.07.2009, aktualisiert 19:18 Uhr, 16580 Aufrufe, 4 Kommentare

Hallo zusammen,

ich arbeite an einem Projekt wo ich momentan nicht weiterkomme und hoffe dass der eine oder andere mir evtl dabei weiterhelfen kann.

Ich habe 2 Vlans erstellt mit der ID1 und ID2
VLAN1 (10.10.100.1/24) soll die komplette IT Infrastruktur aufnehmen (Switche, Controller, Server etc.) und VLAN2 (10.0.0.0/24) den Internet Traffic.
Eigesetzt habe ich diverse HP Switche 2900, 2626, dabei ist es so, dass sich ein Teil der Infrastruktur an einem anderen Platz befindet der mit dem IT Zentrum verbunden werden muss.
Um eine grösst mögliche Bandbreite zu haben benutze ich einen Trunk (channel bonding) vom Standord A über einen Hop (Standord B) nach Standord C.
Am Standord A wird der Trunk erstellt. Standord B übernimmt den Trunk und sendet ihn schliesslich nach Standord C.
Vom Standord B und C aus kann ich ohne Probleme auf jegliche Schnittstellen im VLAN1 zugrreifen, aber komme auf keine Schnittstelle im VLAN2.

Eingreichtet habe ich den Trunk folgendermaßen:

Switch am Standord A

VLAN1 VLAN2
Port 23/24 TRK1 untagged tagged


Switch am Standord B

VLAN1 VLAN2
Port 1/2 Dyn1 Dyn1 LACP (hier kommt der Trunk an)
Port 23/24 TRK1 untagged tagged (hier neu definiert)


Switch am Standord C

VLAN1 VLAN2
Port 23/24 TRK1 Dyn1 Dyn1 LACP


Wo ist mein Denkfehler hierbei? Das tagging muss ich einsetzen da man nicht 2 Vlans untagged über einen Port senden kann.
Ich habe diverse Endgeräte benutzt die VLAN Tagging beherrschen aber komme nicht auf diese Schnittstellen?

Ich wäre sehr dankbar für mögliche Ansatzpunkte!

Gruss
Mitglied: aqui
09.07.2009 um 10:59 Uhr
Dein Netzwerk sieht vermutlich so aus, richtig ??

83d3679a3a692e58e19e4c81cea1af58-hpvlan - Klicke auf das Bild, um es zu vergrößern

Als erstes musst du wissen das das VLAN 1 das Default VLAN ist und IMMER untagged bei HP über tagged Links übertragen wird !!! Wenn du es also tagged übertragen willst musst du eine andere VLAN ID wie z.B. 10 und 20 wählen aber es funktioniert auch so... !

Gemäss deiner o.a. Vorgaben und zusätzlich der Ports 9 bis 12 für Endgeräte im VLAN 2 sähe eine Konfig der Switches so aus:
Switch - A
interface 23
name "Trunk Link auf Switch B(Port-1)"
interface 24
name "Trunk Link auf Switch B(Port-2)"

vlan 1
name "DEFAULT_VLAN"
untagged 1-8, 13-24
ip address 172.16.1.254 255.255.255.0
no untagged 23-24
exit
vlan 2
name "Internet"
untagged 9-12
tagged 23-24
exit
spanning-tree protocol-version rstp
Interface eth23-eth24 lacp active

Switch - B
interface 1
name "Trunk Link auf Switch A(Port-23)"
interface 2
name "Trunk Link auf Switch A(Port-24)"
interface 23
name "Trunk Link auf Switch C(Port-23)"
interface 24
name "Trunk Link auf Switch C(Port-24)"

vlan 1
name "DEFAULT_VLAN"
untagged 1-8, 13-24
ip address 172.16.1.253 255.255.255.0
no untagged 23-24
exit
vlan 2
name "Internet"
untagged 9-12
tagged 1-2, 23-24
exit
spanning-tree protocol-version rstp
Interface eth1-eth2 lacp active
Interface eth23-eth24 lacp active

Switch - C
interface 23
name "Trunk Link auf Switch B(Port-23)"
interface 24
name "Trunk Link auf Switch B(Port-24)"

vlan 1
name "DEFAULT_VLAN"
untagged 1-8, 13-22
ip address 172.16.1.252 255.255.255.0
no untagged 23-24
exit
vlan 2
name "Internet"
untagged 9-12
tagged 23-24
exit
spanning-tree protocol-version rstp
Interface eth23-eth24 lacp active

Bedenke das die Trunks VOR dem Zusammenstecken der Switches konfiguriert werden müssen und das du STP einschaltest !
Damit sollte es dann sauber funktionieren !!
Wie gesagt VLAN 2 Endgeräte sind hier im Beispiel die Ports 9 bis 12 zugewiesen. Alles andere ist im Default VLAN 1 !

Weitere Infos zu Trunks steht hier:
http://ftp.hp.com/pub/networking/software/Mgmt-Oct2005-59906023-Chap12. ...
Bitte warten ..
Mitglied: aqui
11.07.2009 um 17:13 Uhr
Wenns das jetzt war dann bitte
https://www.administrator.de/index.php?faq=32
nicht vergessen !!
Bitte warten ..
Mitglied: nestasko
12.07.2009 um 13:45 Uhr
Hallo aqui,

Danke für deine Hilfe. Ich bin bereits selber drauf gekommen. HP steckt dynamische Trunks immer ins Default VLAN, deshalb kam ich nicht ins VLAN2.
Also die Lösung des Problems sind statische Trunks, das ist auch das was du oben beschreibst.

Gruß
Bitte warten ..
Mitglied: aqui
16.07.2009 um 13:13 Uhr
Das ist Unsinn, denn wenn du LACP benutzt dann benutzt du IMMER dynmaische Trunks. LACP ist ja das Protokoll was die Trunks dynmaisch aufbaut....
Da hast du wohl was nicht richtig verstanden bei Trunking ?!

Du hast wohl nur schlicht vergessen es einzuschalten !
Bitte warten ..
Ähnliche Inhalte
LAN, WAN, Wireless

LACP Trunk mit VLANS zwischen HP und Cisco

gelöst Frage von 14116LAN, WAN, Wireless4 Kommentare

Ich habe hier den bestehenden LACP Trunk um ein VLAN 60 und um ein VLAN 80 zu erweitern. Ich ...

Netzwerkprotokolle

Problem bei VLAN Trunk mit LACP zwischen HP und Cisco

gelöst Frage von markuswoNetzwerkprotokolle11 Kommentare

Hallo zusammen, folgende situation: - Ubuntu server 14.04 mit DHCP für verschiedene Ranges - Cisco SG300 L3 Switch welcher ...

Netzwerkmanagement

LACP Trunk über 2 HP V1910 Switches

gelöst Frage von ResalSRNetzwerkmanagement5 Kommentare

Hallo zusammen, wir haben hier 2 x HP V1910-24 PoE Switches und 1 x Windows HP ProLiant Server, auf ...

Windows Netzwerk

Trunk (LACP) mit 3 Leitungen Übertragungsrate

gelöst Frage von deredvtypWindows Netzwerk17 Kommentare

Hallo zusammen, ich habe gestern eine Testumgebung (mit einem HP Switch 2910-48G) und 2 Computern (2008R2 + Win7) aufgebaut. ...

Neue Wissensbeiträge
Server-Hardware
HP iLO ist gefährdet (iLO 4))
Tipp von AlFalcone vor 6 StundenServer-Hardware

Gemäss Twitter und Heise gibt es eine Angriffsmöglichkeit auf iLO Quelle: iLO ist gefährdet

CMS
Erneut kritische Zero-Day-Lücke in Drupal
Tipp von Reini82 vor 15 StundenCMS

Laut einem Bericht auf t3n gibt es eine Schwere Sicherheitslücke in Drupal die auch schon ausgenutzt wird. Betroffen sind ...

Sicherheit

MikroTik-Router patchen, Schwachstelle wird ausgenutzt

Information von kgborn vor 1 TagSicherheit

Am 23. April 2018 wurde von Mikrotik ein Security Advisory herausgegeben, welches auf eine Schwachstelle im RouterOS hinwies. Mikrotik ...

Windows 10

Microcode-Updates KB4090007, KB4091663, KB4091664, KB4091666 für Windows 10

Information von kgborn vor 1 TagWindows 101 Kommentar

Kurze Information für Administratoren von Windows 10-Systemen, die mit neueren Intel CPUs laufen. Microsoft hat zum 23. April 2018 ...

Heiß diskutierte Inhalte
Windows Server
Alten DC entfernen
gelöst Frage von smartinoWindows Server27 Kommentare

Hallo zusammen, ich habe hier eine Umgebung übernommen und erstmal einen DCDIAG gemacht. Dabei fällt auf, daß eine ganze ...

Ausbildung
Wie gelingt ein guter Einstieg in die FiSi-Ausbildung? (Umschulung)
Frage von SiAnKoAusbildung27 Kommentare

Schönen guten Tag, ich bin SiAnKo und habe seit dem 1.04.2018 eine Umschulung als FiSi angefangen. Ich möchte natürlich ...

Batch & Shell
Mit Powershell den Inhalt einer Excel mit einer Text Datei abgleichen
gelöst Frage von Bommi1961Batch & Shell21 Kommentare

Hallo zusammen, ich muss den Inhalt einer Excel Datei (Mappe1) mit dem Daten einer Text Datei abgleichen. Die Daten ...

Router & Routing
Subnetzmaske vergrößern
gelöst Frage von groovesurferRouter & Routing18 Kommentare

Hallo, hat jemand schonmal getestet was passiert, wenn man die Subnetzmaske bei laufendem Betrieb (wenn user im Netzwerk verbunden ...