Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

2K8R2 - Terminalserver-Farm (NLB) und Verbindungsbrocker funktioniert nicht

Mitglied: dkonly

dkonly (Level 1) - Jetzt verbinden

21.05.2011 um 23:24 Uhr, 6756 Aufrufe, 19 Kommentare

Hallo an die Runde.
Zum Testen habe ich eine virtuelle Umgebung (Hyper-V) aufgebaut. Besteht aus:
DC
Unternehmenszertifizierungsstelle
2 Clients
Gateway
Verbindungsbrocker
Web-Access Server
2 RD-Sitzungshosts (also, als TSFarm.contoso.com konfiguriert. NLB habe ich auch unter dem selben Namen konfiguriert. Ein Eintrag A habe ich in DNS erstellt)
Das bekannte Zertifikatfehlerproblem habe ich gelöst, alles funktioniert wunderbar: die Sitzungen werden auf unterschiedliche Server in der Serverfarm verteilt, nur der Verbindungsbrocker läuft irgendwie komisch/unsauber oder gar nicht. Es sieht folgendermaßen aus. Ich melde mich als Benutzer von einem Clienten über RDP auf der TSFARM an. In RDP-Einstellungen setze ich den Hacken bei "Anmeldeinformationen speichern". Die Sitzung landet auf einem Server in der Farm. Dann speichere ich diesen Server und schwupps .. bekomme ich den Anmeldebildschirm des zweiten Servers zu sehen. Aber wenn ich versuche, den selben Vorgang nochmal zu wiederholen, klappt es nicht mehr. Das Problem liegt bestimmt an irgendwelchen Anmeldeeinstellungen/GPOs und ich habe schon einiges ausprobiert, aber ohne Erfolg.
Nun bitte ich um Eure Hilfe.
Danke im Voraus
Mitglied: Eifeladmin
22.05.2011 um 09:06 Uhr
Hi,

welche Clients benutzt du?
Bei Windows XP Clients kann es vorkommen das du dich nochmals anmelden musst wenn die Session einen anderen Server verteilt wird als der TS der als erster in der Farm anwortet.
Unter Vista oder Windows 7 sollte dieses Problem nicht mehr auftreten.
Wenn es um XP geht könntest du über GPO Single Sign On auf den Clients aktivieren. Dazu muss man zwar einen Patch von MS installieren aber es funktioniert ohne Probleme.

VG
EA
Bitte warten ..
Mitglied: dkonly
22.05.2011 um 09:28 Uhr
Ich habe 2 Windows 7 Clients. Die GPO "Delegierung von Standatdanmeldeinformationen zulassen" ist aktiviert, aber das bringt nichts: mal läuft, dann wieder nicht. Vielleicht soll ich auf noch was achten? Kann es sein, dass das Problem am Hyper-V liegt?
Bitte warten ..
Mitglied: Eifeladmin
22.05.2011 um 09:47 Uhr
Wie hast du den die Farm eingerichtet?
Bitte warten ..
Mitglied: Eifeladmin
22.05.2011 um 11:04 Uhr
Hast du auch an den Netzwerkschnittstellen über den Hyper V an allen TS die MAC Adresse der Farm eingetragen?
Bitte warten ..
Mitglied: dkonly
22.05.2011 um 11:22 Uhr
Ups .. nein. Soll ich das als statische MAC-Adresse einrichten? Was mich aber wundert, dass die Sitzungen doch sauber verteilt werden ohne die MAC-Adresse anzupassen.
Nachtrag. Beim Versuch, MAC-Adresse des Adapters zu ändern, erscheint die Fehlermeldung: Fehler beim Hinzufügen des Geräts " Microsoft Synthetic Ethernet Port". Die statische Adresse für "Netzwerkkarte" 03BF0A0A0032 ist ungültig. Was mache ich falsch?
Bitte warten ..
Mitglied: Eifeladmin
22.05.2011 um 12:02 Uhr
Ich kann nur sagen das es bei einem unserer Server in der Farm nicht eingerichtet war und zu solchen seltsamen Problemen geführt hat.
Teste es doch einfach mal.
Bitte warten ..
Mitglied: dkonly
22.05.2011 um 12:32 Uhr
Ich habe meinen Beitrag nachträglich editiert. Hast Du einen Lösungsvorschlag?
Danke
Bitte warten ..
Mitglied: Eifeladmin
22.05.2011 um 12:53 Uhr
Wie hast du den versucht die Adresse zu ändern?
Bitte warten ..
Mitglied: dkonly
22.05.2011 um 13:18 Uhr
In Netzwerkkarteneigenschaften habe ich von "Dynamisch" auf "Statisch" umgestellt und dann versucht, die MAC-Adresse des Clusters bzw. der Farm einzugeben und dann auf "Anwenden" geklickt. Als Resultat habe ich dann die o.g Fehlermeldung bekommen.
Bitte warten ..
Mitglied: Eifeladmin
22.05.2011 um 13:24 Uhr
War die VM dabei noch gestartet oder ausgeschaltet?
Bitte warten ..
Mitglied: dkonly
22.05.2011 um 13:27 Uhr
Die VM war natürlich ausgeschaltet
Bitte warten ..
Mitglied: Eifeladmin
22.05.2011 um 14:28 Uhr
Ok. lassen wir das vielleicht mal kurz außer acht.
Was ich nicht ganz verstehe, du schreibst du speicherst den Server und dann erhälst den Anmeldebildschirm des zweiten Servers?
Kannst du mir das genauer erklären.

Versuch mal folgendes, wenn du als Admin auf dem Server anmeldest und die Terminalserverdienstverwaltung öffnest kannst du rechts alle Server eines Sitzungshostes laden. Werden dann beide Server angezeigt?
Bitte warten ..
Mitglied: dkonly
22.05.2011 um 17:08 Uhr
Also, es sieht folgendermaßen aus:
Ich melde mich als User1 über RDP vom Client1 an der TSFARM an. Die Sitzung landet auf TS1. Ich melde mich als User2 über RDP vom Client2 an der TSFARM an. Die Sitzung landet auf TS2. Das alles lässt sich ganz gut im Remotedesktopdienste-Manager auf einem Server beobachten. Dort kann man eine Computergruppe aus TS1 und TS2 erstellen. Dann speichere ich den Zustand vom TS1 im Hyper-V Manager oder halte ihn an. Dann erscheint kurz ein Fenster von RDP auf Client2 "Wiederherrstellung. Verbindungsversuch 1 von 20" und dann sehe ich den Anmeldungsbildschirm eines Servers wo ich mich als user2@contoso.com anmelde und lande auf TS1. Als Administrator verfolge ich das natürlich. Dann melde ich mich remote ab, starte TS2 wieder und versuche, genau das gleiche nochmal zu reproduzieren. Und das geht meistens nicht mehr. Es erscheint die o.g. RDP Meldung, dann laufen alle 20 Versuche ohne Ergebnis ducrch oder es friert das Ganze beim 2-3 Versuch ein. In diesem Fall muss ich dann auf den Button "Abrechen" klicken.
ps. Da ist was neues zum Thema: http://www.itnetx.ch/blog/?p=242 aber ich verstehe nicht ganz wie das läuft
Bitte warten ..
Mitglied: Eifeladmin
22.05.2011 um 17:28 Uhr
Ich denke du verstehst nicht ganz wofür der Sitzungshost Server zuständig ist.
Wenn du dich als User1 am der Farm anmeldst (die Session landet an Server1) und an deinem PC den Netzwerkstecker ziehst und einige Zeit wartest und ihn dann wieder einsteckst. Dich dann mit User 1 erneut an der Farm meldst solltest du die selbe Session an Server 1 wieder erhalten.
Bitte warten ..
Mitglied: dkonly
22.05.2011 um 17:35 Uhr
In diesem Fall geht es nich darum, wozu der Sitzungshost zuständig ist, sondern darum, wie sich der Verbindungsbrocker beim Ausfall eines Sitzungshosts verhält. Wenn ich richtig verstehe, muss die Sitzung (Session) auf den zweiten Server automatisch umgeleitet werden, sonst macht das Ganze keinenn Sinn.
Bitte warten ..
Mitglied: Eifeladmin
22.05.2011 um 18:31 Uhr
Ja klar fällt ein Host aus und ich mach einen reconnect werde ich auf einen verbleibenden Host umgeleitet und muss neu anmelden.
Bitte warten ..
Mitglied: dkonly
22.05.2011 um 19:39 Uhr
Was mir noch aufgefallen ist, ich habe die NLB-Netzwerkschnittstelle als multicast konfiguriert. Diese Microsoft Empfehlunfg bezieht sich aber auf eine produktive Umgebung. Wie sieht es mit einer virtuellen Umgebung aus, soll ich vielleicht mit unicast probieren?
Bitte warten ..
Mitglied: Eifeladmin
23.05.2011 um 08:02 Uhr
Deswegen wird auch die MAC Adresse nicht funktionieren.
Da es ja nur eine Test Umgebung ist würde ich Unicast einfach mal ausprobieren.
Ich hab Farmen bis jetzt immer im Unicast eingerichtet.
Bitte warten ..
Ähnliche Inhalte
Windows Server

Terminalserver Farm Problem mit User Abmeldung

gelöst Frage von dakoerryWindows Server3 Kommentare

Guten Tag an Alle, ich hoffe man kann mir hier Helfen. Ich habe eine Terminalserver Farm mit Server 2012 ...

Windows Server

Drucker via GPO auf Terminalserver-Farm

Frage von jogovogoWindows Server

Hallo zusammen, ich habe ein Problem beim zuordnen mehrerer Drucker auf einer Terminalserver-Farm. Wir haben fünf Terminalserver im Einsatz ...

Windows Server

Anwendungen auf einer 2012 R2 Terminalserver Farm (Sammlung) installierern!

Frage von BruceBudweiserWindows Server5 Kommentare

Hallo, gibt es eine effiziente Methode in einer Terminalserver Sammlung mit Windows Server 2012 R2 und Broker Anwendungen zu ...

Windows Server

Flickercode remote am Terminalserver auslesen funktioniert nicht

Frage von immobrauchWindows Server9 Kommentare

TS an Win Srv 2012 R2 64 bit Lexware Finanzmanager 2016 V. 23.39.0.135 (neueste Version) DDBAC 5.3.46.0 (neueste Version) ...

Neue Wissensbeiträge
Sicherheit

Zero Day-Schwachstelle im Internet Explorer - wird von APT bereits ausgenutzt

Information von kgborn vor 3 StundenSicherheit

Im Kernel des Internet Explorer scheint es eine Zero Day-Lücke zu geben, die von staatlichen Akteuren (APT) im Rahmen ...

Microsoft
Folder Security Viewer-Lizenzen zu gewinnen
Information von kgborn vor 3 StundenMicrosoft

Ich nehme das Thema mal in Absprache mit Frank hier auf, da es für den einen oder anderen Administrator ...

Hardware

Feueralarm killt Festplatten in Rechenzentrum - führt zu größerem Ausfall

Information von kgborn vor 3 StundenHardware6 Kommentare

Noch ein kleiner Beitrag für Administratoren, die in Rechenzentren aktiv sind - so als Fingerzeig. Denn es gibt Szenarien, ...

MikroTik RouterOS

Mikrotik Advisory: Vulnerability exploiting the Winbox port

Information von colinardo vor 3 StundenMikroTik RouterOS

Brand aktuell: Eine Schwachstelle im Winbox-Port bei Mikrotik Routern erlaubt das Auslesen der User-Datenbank der Router. Patch ist aktuell ...

Heiß diskutierte Inhalte
Linux
Linux Server oder Windows Server - lohnt eine Umstellung auf Linux und ebenso basierende SW bei einer langfristigen Planung?
Frage von motus5Linux22 Kommentare

Wir brauchen bei uns einen neuen Server. Dieser wird als Fileserver, Domäne Controller sowie Exchange Server verwendet. Wir versuchen ...

Netzwerkgrundlagen
VLAN - Offene Fragen
Frage von KnettenbrechNetzwerkgrundlagen17 Kommentare

Hallo zusammen, ich befasse mich derzeit mit dem Thema VLAN. Hierzu habe ich schon einige Guides gelesen, einschließlich des ...

DSL, VDSL
ISP Wechsel auf Vodefone Koax, Gebäudeverkabelung nur per Cat 7
gelöst Frage von wusa88DSL, VDSL13 Kommentare

Hallo Zusammen, ich bin momentan bei Mnet als Glasfaser Kunde und möchte Preis/Leistungs-Technisch zu Kabel Deutschland / Vodafone wechseln. ...

Windows Server
Domänencontroller trennen
Frage von Akit57Windows Server13 Kommentare

Hallo, ich hoffe das mir hier jemand meine Frage trotz der spärlichen Informationen die ich geben kann beantworten kann: ...