Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Access Suchengine funktioniert nicht richtig.

Mitglied: spiderman19

spiderman19 (Level 1) - Jetzt verbinden

11.10.2004, aktualisiert 15.10.2004, 5108 Aufrufe, 1 Kommentar

Hallo,

ich habe ein Problem bei einer Access Datenbank. In einer Tabelle mit Personaldaten soll nach allen Eigenschaften gesucht werden können, also z.B. Vorname, zweiter Vorname, Nachname, Straße, Staatsbürgerschaft, usw.
Die gefundenen Objekte sollen dann in einer Listbox angezeigt werden.
Wenn jetzt aber jemand z.B. keinen zweiten Vorname hat, oder eben irgendeine Eigenschaft in der Tabelle leer ist, wird die gesamte Person erst gar nicht angezeigt, egal ob nach nichts ("") oder nach irgendeinem Begriff gesucht wird.
Das Codestück sieht folgendermaßen aus:



strSQL = "SELECT PersonalNr, Vorname, Nachname, Staatsbürgerschaft" _
& " FROM Personal" _
& " WHERE ((Personal.Anrede) LIKE '*" & strKrit0 & "*')" _
& " AND ((Personal.Vorname) LIKE '*" & strKrit2 & "*')" _
& " AND ((Personal.ZweiterVorname) LIKE '*" & strKrit3 & "*')"

Me!Liste0.RowSource = strSQL




Durch SELECT PersonalNr, Vorname, Nachname, Staatsbürgerschaft werden die PersonalNr, der Vorname, der Nachname und die Staatsbürgerschaft in der Listbox angezeigt.
Gesucht wird in der Tabelle Personal (FROM Personal).
strKrit0, strKrit2, strKrit3 sind Variablen die den zu suchenden Begriff enthalten, also
wenn strKrit2 = "Stefan" ist sollen alle Personen die mit Vornamen Stefan heißen angezeigt werden.

Also noch mal zusammengefasst wenn eine Person eine Eigenschaft nicht hat nach der gesucht werden kann, also z.B. keinen zweiten Vornamen wird diese Person, egal wonach gesucht wird, nicht angezeigt.

danke im Voraus
Mitglied: spiderman19
15.10.2004 um 18:32 Uhr
habs schon gelöst
Lösung findet ihr unter:
http://support.microsoft.com/default.aspx?scid=kb%3Bde%3BD45182
Bitte warten ..
Ähnliche Inhalte
LAN, WAN, Wireless
Gast-WLAN funktioniert nicht richtig
Frage von Dukenukem263LAN, WAN, Wireless4 Kommentare

Hallo, ich habe privat daheim einen Kabel BW Anschluß ohne WLAN Funktion. Habe mir über ein Devolo 500 Wifi ...

Windows Server

Faxserver funktioniert vom Client aus nicht richtig

Frage von CharlyXLWindows Server9 Kommentare

Hallo zusammen, ich habe einen Windows Server 2012 R2, ohne Domäne und ein paar Clients. Auf dem Server hab ...

Exchange Server

Funktionspostfach funktioniert nicht richtig

gelöst Frage von JudgelgExchange Server25 Kommentare

Hallo, ich habe das Problem, das diverse Funktionspostfächer beim senden "von" nicht richtig funktionieren. Folgende Fehlermeldung bekomme ich, oder ...

Windows Server

GPO Fonts - funktioniert nicht richtig

gelöst Frage von Adnan88Windows Server10 Kommentare

Hallo, kann mir hier jemand eventuell helfen ? Ich will gewissen Fonts auf gewisse Rechner kopieren im Unternehmen, den ...

Neue Wissensbeiträge
Windows 10

Neue Sicherheitslücke in Windows 10 (Version 1709) durch Google öffentlich geworden

Information von kgborn vor 1 StundeWindows 10

Vor ein paar Tagen haben Googles Sicherheitsforscher vom Projekt Zero eine Sicherheitslücke im Edge-Browser publiziert. Jetzt wurde eine weitere ...

iOS
IOS 11.2.6 verfügbar
Information von sabines vor 6 StundeniOS

Mit dem Update soll der Bug behoben werden, bei dem eine bestimmte Zeichenkette IOS zum Absturz gebracht hat.

Sicherheit
Sicherheitsrisiko: Die Krux mit 7-Zip
Information von kgborn vor 20 StundenSicherheit7 Kommentare

Bei vielen Anwendern ist das Tool 7-Zip zum Entpacken von Archivdateien im Einsatz. Die Software ist kostenlos und steht ...

Internet

Datendealing im WWW Tracking Methoden immer brutaler

Information von sabines vor 1 TagInternet

Interessanter Artikel zum Thema Tracking im WWW und die immer "besseren" Methoden des Trackings. Professor Arvind Narayanan (Princeton-Universität) betreibt ...

Heiß diskutierte Inhalte
Server
Route-Befehl Unterstützung (unter CMD)
gelöst Frage von FKRR56Server38 Kommentare

Guten Tag , i.M. habe ich Probleme über den CMD-Route-Befehl ein Routing auf einen entfernten Server zuzulassen. Der Server ...

Router & Routing
LANCOM VPN CLIENT einrichten
Frage von Finchen961988Router & Routing26 Kommentare

Hallo, ich habe ein Problem und hoffe ihr könnt mir helfen, wir haben einen Kunden der hat einen Speedport ...

LAN, WAN, Wireless
VPN Cisco ASA5505 PaloAlto PA-200
gelöst Frage von YannoschLAN, WAN, Wireless20 Kommentare

Hallo zusammen, ich würde gerne ein Site-to-Site VPN zwischen den beiden Standorten aufbauen. PaloAlto PA200 Internetanschluss Deutsche Telekom GK ...

Microsoft
TV-Tipp: Das Microsoft-Dilemma
Information von kgbornMicrosoft17 Kommentare

Aktuell gibt es in Behörden und in Firmen eine fatale Abhängigkeit von Microsoft und dessen Produkten. Planlos agieren die ...