Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

ohne Adminrechte geht nix mehr

Mitglied: truecolor

truecolor (Level 1) - Jetzt verbinden

04.06.2008, aktualisiert 13:50 Uhr, 6922 Aufrufe, 10 Kommentare

Adminrechte vergeben und dann wieder entziehen bleibt wohl nicht ungestraft.

Hallo,

ich habe XP Pro. SP2 neu aufgesetzt. Dann irgendwann einem
"Normal-User" zwischen zwei Programminstallationen Adminrechte
vergeben, weil die immer öfter verlangt wurden. Nach Beendigung der
Programm-Installationen hab ich dem "Normal-User" wieder die
Admin-Rechte entzogen.

Nun laufen einige Programme unter dem "Normal-User" nicht mehr.

Und jetzt mal Tacheles. Mittlerweile bin ich sehr verunsichert, was das richtige Installieren von Programmen betrifft. Installiere ich sämtliche Programme unter einem Admin-User, sind diese unter Umständen als Normalunser entweder nicht sichtbar oder nicht lauffähig. Als Normaluser mit zeitweise Adminrechte bestraft mich das OS mit den o.g. Auswirkungen. Es macht wohl keinen Unterschied, ob ich die Programme via "ausführen als - Administrator" oder dadurch installiere, in dem ich dem NormalUser kurzzeitig Adminrechte verschaffe.

1. Wie kann ich sauber ALLE Programme installieren ohne mir selbst irgendwann den eigenen Ast
abzusägen?

2. Wie kann ich diese Programme unter "Normal-User" - Status wieder zum Laufen bewegen?
Gibt es dafür z.B. ein Tool ?

Gruß ... Frank
Mitglied: 60730
04.06.2008 um 09:49 Uhr
Moin Frank,

wenn du uns noch sagst, welche Programme dir Kopfzerbrechen machen

Trick Nr.1: Benutzer hat keine Schreibrechte im Ordner der Programmdatei - xcacls oder rechtsklick im Arbeitsplatz.
Trick Nr.2: Das Programm schreibt in einen Pfad der Registry - wo der User nicht schreiben darf - regmon und rechtsklick in Regedit wären da die Tipps.

ALLE Programme dafür gibts nur Trick 1 & Trick 2 - oder die kombination daraus.
Bitte warten ..
Mitglied: truecolor
04.06.2008 um 10:01 Uhr
Hallo Timo,

also momentan geht es um das Programm SimonTools PDF-Maker2004, läuft auf dem andern PC unter XP mit Adminrechte bestens. Der soll aber langsam in den Ruhestand geschickt werden.

Schicke ich einen Druckauftrag zum PDF-Maker, verweist der Druckauftrag auf ein Verzeichnis, dass ich als Normaluser nicht sehen kann.


Wie meinst Du das mit "Rechtsklick in Regedit"?
Bitte warten ..
Mitglied: 60730
04.06.2008 um 10:16 Uhr
Servus,

probier mal PDFCreator - der braucht keine Adminrechte und wäre evtl. ein guter Ersatz für deinen zukünftigen Ruheständler.

Die Zeile mit "Verzeichnis, dass ich als Normaluser nicht sehen kann" - verstehe ich nicht - ist das ein Share auf einem Server?
schreibt das noch mal genauer bitte.

Unter XP kannst du im Regedit Rechte auf Schlüssel bzw. auf auf deren Inhalt vergeben - dazu per Rechtsklick auf den betreffenden Schlüssel gehen und mit "Berechtigungen" dort die Schreibrechte für Benutzer eintragen.
Bitte warten ..
Mitglied: Logan000
04.06.2008 um 11:58 Uhr
1. Wie kann ich sauber ALLE Programme installieren ohne mir selbst irgendwann
den eigenen Ast abzusägen?
2. Wie kann ich diese Programme unter "Normal-User" - Status wieder zum
Laufen bewegen? Gibt es dafür z.B. ein Tool ?

Ein paar Regeln die Dir das Leben in Zukunft leichter machen:

- Dieses Rechtegeschummel (User -> Admin -> User) solltest Du bleiben lassen.
- Trick 1 & 2 von Timo beheben die gängigsten Probleme.
- Wenn Sich ein Programm nicht als User ausführen lässt:
Support anfragen. Sonst Weg damit & Geld zurück.

bevor Du ein Prog. anschaffst:
- Prüfe ob es Terminalserver fähig ist. Damit hast du dann meist keine Probleme.
- Teste die Installation. (z.B. mit DemoVersion)
Bitte warten ..
Mitglied: truecolor
04.06.2008 um 12:10 Uhr
Hallo Logan,

mit den beiden Tipps von Timo werde ich mir am Wochenende zusammen mit/vor dem Aufsetzen eines sauberen Systems zu Gemüte führen.

Das mit den Rechteschummeln war mir schon immer unangenehm.

Nur nochmal damit ich das richtig umsetze:

- XP installieren (incl. SP2)

- Normaluser anlegen

- unter Normaluser alle notwendigen Progamme istallieren
Was aber, wenn Adminrechte benötigt werden. Ist dann der Weg
"ausführen als Admin" korrekt? Oder geht´s da schon los mit Trick1&2?


Wenn das denn mal so richtig steht und funktioniert würde ich denn von dem "sauberen" System ein (Acronis TrueImage-)Backup erstellen, damit ich immer wieder drauf zugreifen kann.


Gruß ... Frank
Bitte warten ..
Mitglied: Logan000
04.06.2008 um 12:16 Uhr
Du installiert Programme IMMER als Admin
egal ob direkt angemeldet oder über ausführen als ...

Wenn die Installation als User geht schön. Aber wunder dich nicht wenn da Probleme auftreten.

Auf Timos Tips greifst Du erst zurück wenn ein als Admin installiertes Programm als User nicht läuft.
Bitte warten ..
Mitglied: truecolor
04.06.2008 um 12:32 Uhr
Logan,

also das nenn ich mal eine eindeutige Aussage. Vielen Dank!

Nur doof, wenn ich als Admin angemeldet bin, ein PRG istalliert habe, dann mich als User anmelde und in der Startleiste keine Einträge finde. Ist nicht so, dass ich jetzt deswegen gleich aus dem Fenster springe. Kann mir schon eine Verknüpfung auf den Desktop legen. Kann man das Fehlen der Einträge auch irgendwie abfangen?

Noch was ganz anderes: Bei der letzten Installation (XP-Pro) wurde ja (ganz normal) das Administratorkonto angelegt, und parallel dazu ein von mir genannter User ("Addi")mit Adminrechte, den ich anlegen mußte.
Wenn ich mich nun mit Admin-Rechte anmelden möchte, habe ich es bis jetzt nicht geschafft, mich als "Administrator" anzumelden (Passwort kenn ich nicht, hab ich auch nie vergeben) sondern immer nur als "Addi" mit Adminrechte. Was ist denn DA verkehrt gelaufen?
Wenn ich als Normal-User angemeldet bin und ein PRG mit "Ausführen als" den "Addi" auswählen möchte, finde ich DEN nicht, sondern den "Frank", der sich mit dem gleichen Passwort wie "Addi" zufrieden gibt und anscheinend auch Adminrechte besitzt. Auch hier wieder : Häää?

Mir wäre sehr geholfen, wenn mir mal jemand DAS erklären könnte...damit ich nicht irgendwann mal dumm ins Gras beissen muß(lach).

Gruß ... Frank
Bitte warten ..
Mitglied: truecolor
04.06.2008 um 13:32 Uhr
Hallo Timo,

PDF-Creator ist ab sofort fester Bestandteil meines PC´s. Danke für diesen und die anderen Tipps.

Gruß ... Frank
Bitte warten ..
Mitglied: Logan000
04.06.2008 um 13:35 Uhr
Nur doof, wenn ich als Admin angemeldet bin, ein PRG istalliert habe,
dann mich als User anmelde und in der Startleiste keine Einträge finde.
Ist nicht so, dass ich jetzt deswegen gleich aus dem Fenster springe.
Kann mir schon eine Verknüpfung auf den Desktop legen.
Kann man das Fehlen der Einträge auch irgendwie abfangen?
Nun Ob der User die Startmenü Verknüpfungen zu sehen bekommt liegt daran ob das Setup diese in das Profil des User (der installiert) kopiert oder
in All Users (womit dann alle diese Verknüpfungen haben).
Das ist Setup abhängig. Die meisten Installationen haben aber die Option "Für alle Anwender" oder "nur für den angemeldeten Benutzer".

Ob und was bei deiner XP istallation Falsch gelaufen ist, weiss ich nicht.
Aber unter Systemsteuerung Benutzerverwaltung solltest du alle Konten einsehen können und auch Namen oder die Kennwörter ändern können (solange Du mit Admin Rechten angemeldet bist).
Bitte warten ..
Mitglied: truecolor
04.06.2008 um 13:50 Uhr
Logan,

Danke für Deinen Beistand und Deine Hilfe.

Ich werd´am Wochenende mal das System neu aufsetzen und alles was hier geschrieben wurde mit einfliesen lassen.

Ich berichte, falls sich etwas spektakuläres ereignet hat.

Gruß ... Frank
Bitte warten ..
Ähnliche Inhalte
Webbrowser

Googeladservices - geht heute nix mehr ohne ?

Frage von HenereWebbrowser10 Kommentare

Hallo zusammen, ich habe aus diversen Gründen einen DNS-Eintrag für die Domain googleadservices.com ohne weiteren Inhalt gemacht. Jahrelang angenehmes ...

Hardware

Thinkpad x201 und Qualcomm Gobi 2000 - nix geht

Frage von lam0rHardware

Hallo zusammen. Habe hier ein TPx201 und eine Gobi nachträglich eingebaut. Die Bios-Fehler wg falscher Hardware habe ich jetzt ...

Windows Installation

Programminstallation ohne Adminrechte

Frage von MarcysWindows Installation10 Kommentare

Hallo Zusammen, wir haben eine ganz normale Domänenumgebung. Mit W2k3 als Domänencontroller. Es gibt den üblichen Admin mit allen ...

Hyper-V

HyperV - VMs weg finde nix mehr

gelöst Frage von NemonautilusHyper-V15 Kommentare

Hallo Leute. Also jetzt bin ich absolut ratlos :( HyperV ist irgendwie "nicht verfügbar" oder so was. Der Dienst ...

Neue Wissensbeiträge
Backup

2016 - Restore mit WBAdmin - iSCSI Device als Sicherungsziel

Erfahrungsbericht von Henere vor 1 TagBackup1 Kommentar

Servus zusammen, was mich eben einige graue Haare gekostet hat Server 2016. Ich habe meinem Server eine weitere M2 ...

Humor (lol)
(Part num your Hacked phone. +XX XXXXXX5200)
Erfahrungsbericht von Henere vor 3 TagenHumor (lol)7 Kommentare

Mein Handy hat aber ne ganz andere Endnummer. Muss ich mir jetzt Sorgen machen ? :-) Vielleicht betrifft es ...

Exchange Server

Letztes Update für Exchange 2016 CU9 war in gewisser Weise destruktiv

Erfahrungsbericht von DerWoWusste vor 3 TagenExchange Server9 Kommentare

Kurzer Erfahrungsbericht zu Exchange2016-KB4340731-x64 Der Exchangeserver hat wie gewöhnlich versucht, es in der Nacht automatisch zu installieren - abgesehen ...

Erkennung und -Abwehr

Neue Sicherheitslücke Foreshadow (L1TF) gefährdet fast alle Intel-Prozessoren

Information von Frank vor 4 TagenErkennung und -Abwehr3 Kommentare

Eine neue Sicherheitslücke, genannt Foreshadow (alias L1TF) wurde auf der Usenix Security 18 von einem Team internationaler Experten veröffentlicht. ...

Heiß diskutierte Inhalte
E-Mail
Deutsche e-Mail Adresse auf iPhone in Katar. Nur Probleme
gelöst Frage von vanTastE-Mail25 Kommentare

Moin, ich habe hier in Deutschland auf einem Exchange 2013 eine e-Mail Adresse (name@domain.de) für einen Kollegen in Katar ...

Windows Server
Domäne beitreten nicht möglich, unter VMWare windows Server 2016 Core
Frage von AmanuelWindows Server11 Kommentare

Ich habe auf meinem Mac unter VMWare Windows Server 2016 Core und Windows Server 2016 Desktopversion installiert. Beide Systeme ...

RedHat, CentOS, Fedora
OTRS 5 kann keine Mails mehr abrufen
gelöst Frage von opc123RedHat, CentOS, Fedora11 Kommentare

Hallo, OTRS kann keine Mails mehr abrufen. Verschicken ja. Dadurch kommen keine Tickets mehr rein. Gibt es Anlaufpunkte was ...

Windows Server
Server 2016 Autotiering Storage Space
Frage von HenereWindows Server11 Kommentare

Servus, ich habe jetzt ein StorageSpace auf einem Server 2016 in Betrieb zum Testen. 1x M2 mit 512GB (970pro) ...