Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Anmeldescript mit persönlichem Laufwerk läuft nicht bei Windows 8.1

Mitglied: jonhau8708

jonhau8708 (Level 1) - Jetzt verbinden

03.02.2014 um 09:55 Uhr, 2306 Aufrufe, 3 Kommentare, 1 Danke

Guten Tag allerseits

In unserem Netzwerk benutzen wir ein Anmeldescript, das per GPO an alle Benutzer und Administratoren versendet wird.

In diesem Anmeldescript wird unter anderem ein persönliches Laufwerk verbunden.

Dieses persönliche Laufwerk wird nichtmehr verbunden. Stattdessen mappt sich die Freigabe: \\Servername\Freigabe_aller_Persönlichen_Laufwerke$\


Der Code des Anmeldescripts:

UserName = WSHShell.ExpandEnvironmentStrings("%USERNAME%")

WshNetwork.MapNetworkDrive "Z:", "\\Servername\Freigabe_aller_Persönlichen_Laufwerke$\" & USERNAME

Bei XP und Windows 7 Computern funktioniert dieses Script einwandfrei, bei den Administrator-Konten der Windows 8 Rechnern allerdings nicht.

Damit auf Windows 8 Adminkonten überhaupt Netzlaufwerke beim Anmelden verbunden werden können mussten wir bereits im Vorfeld einen Registry-Key einfügen.

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System\EnableLinkedConnections auf 1 setzten.

Das spezielle ist, dass das Anmeldescript bei nachträglicher Ausführung einwandfrei funktioniert.

Daher stellt sich die Frage, was der Unterschied zwischen dem automatischen Ausführen per GPO und dem manuellen Ausführen ist.

Könnte es möglicherweise etwas mit den Berechtigungen des Systems zu tun haben?

Freundliche Grüsse und vielen Dank für die professionellen Antworten

jonhau
Mitglied: XenClient
03.02.2014 um 10:08 Uhr
Hey,

Skripte sind auch nicht mehr erwünscht bei Windows 8 / 8.1 ebenso wurde die Startverzögerung auch bei Skripten eingesetzt, wodurch Skripte erst nach 5 Minuten ordnungsgemäß ziehen.

Vorschlag:
Laufwerke würde ich über eine GPO Mappen (geht viel einfacher und mittlerweile zuverlässiger!)

Gruß XenClient
Bitte warten ..
Mitglied: jonhau8708
03.02.2014 um 11:03 Uhr
Hallo XenClient

Danke für die Antwort

Weisst du gerade, wie und ob es möglich ist, das persönliche Laufwerk per GPO zu mappen?

Ehrlichgesagt sagt mir eine solche Lösung nicht besonders zu, da dies höchst wahrscheindlich in einer Baselarbeit endet und ich Ausnahmen in unserem System nicht gerade befürworte.

Gibt es keinerlei Möglichkeiten, das Script zum laufen zu bringen?
Bitte warten ..
Mitglied: jonhau8708
07.02.2014 um 15:05 Uhr
Hat niemand eine Idee?

Bitte meldet euch, ist ein sehr nerviges Problem
Bitte warten ..
Ähnliche Inhalte
Netzwerke

Shrew VPN mit Windows 8.1 läuft nicht

gelöst Frage von TomJonesNetzwerke14 Kommentare

Hallo zusammen, ich habe einen Client mit Windows 8.1 x64. Ich bekomme auf diesem die IPSec VPN Verbindung nicht ...

Windows 8

Windows 8.1 Pro Lizenz läuft ab ?

gelöst Frage von nursoeinerWindows 85 Kommentare

Hallo, ich habe mir ein Toshiba Satellite Pro L70-A gekauft, Windows 7 Pro vorinstalliert sowie die Datenträger von Windows ...

Windows 8

Windows 8.1 auf 8.1 Pro upgraden

Frage von EisernWindows 822 Kommentare

Hallo, wir haben für unser Unternehmen 5 AIO PCs günstig erstanden, dabei aber nicht beachtet das Win8.1 (nicht pro) ...

Windows 8

Upgrade von Windows 8.1 auf 8.1 Pro

gelöst Frage von geTr0ffEnWindows 88 Kommentare

Hallo zusammen, bisher (4-5x) hatte ich keine Probleme o.g. Upgrade durchzuführen. Ich habe heute aber an einem Laptop, ist ...

Neue Wissensbeiträge
Windows 10
Zero-Day-Lücke in Microsoft Edge
Information von kgborn vor 1 TagWindows 10

In Microsofts Edge-Browser klafft wohl eine nicht geschlossene (0-Day) Sicherheitslücke im Just In Time Compiler (JIT Compiler) für Javascript. ...

Sicherheit
Microsoft und Skype: Sicherheit
Information von kgborn vor 1 TagSicherheit

Die Tage gab es ja einige Berichte zur Sicherheit des Skype-Updaters. Der Updater von Skype läuft unter dem Konto ...

Datenschutz

Behörden ignorieren Sicherheitsbedenken gegenüber Windows 10

Information von Penny.Cilin vor 2 TagenDatenschutz8 Kommentare

Hallo, passend zum Thema Ablösung LIMUX in München ein interessanter Beitrag dazu: Behörden ignorieren Sicherheitsbedenken gegenüber Windows 10 Anscheinend ...

Sicherheit
Information Security Hub Munich airport
Information von brammer vor 2 TagenSicherheit

Hallo, Neues Center für Cyber Kriminalität am Münchener Flughafen brammer

Heiß diskutierte Inhalte
DSL, VDSL
Mindestgeschwindigkeiten DSL Telekom
Frage von justlukasDSL, VDSL13 Kommentare

Hallo zusammen, Seit diesem Jahr habe ich Verständnisprobleme mit dem Verhalten der Telekom. Wir haben seit einem Jahr VDSL ...

Switche und Hubs
LANCOM-Switch: Probleme (no link) mit SFP-Modulen?
Frage von THETOBSwitche und Hubs11 Kommentare

Hi zusammen, ich habe folgendes Problem: Und zwar habe ich an einem Standort drei Switche verbaut - LANCOM GS-2326P+, ...

Humor (lol)
Was könnte man mit einem Server machen? Idee gesucht
Frage von 2SeitenHumor (lol)10 Kommentare

Hey Zusammen Ich habe einen alten HP G2 Rackserver zu Hause rumliegen. 28GB Ram, 1xAMD Prozi mit etwa 2GHz. ...

Firewall
RB2011 Firewall Rule eine bestimmte Mac oder IP Adresse nicht zu blockieren
Frage von lightmanFirewall10 Kommentare

Hallo liebes Forum mit ihren Spezialisten. Ich habe meine Firewall so konfiguriert das kein Endgerät ohne meine Speziellen Erlaubnis ...