Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Anmeldeskript in Organisationseinheit wird nicht ausgeführt

Mitglied: sauger345

sauger345 (Level 1) - Jetzt verbinden

06.08.2011, aktualisiert 18:20 Uhr, 4732 Aufrufe, 20 Kommentare

Hallo,
zunächst möchte sagen das mir diese Seite schon viel geholfen hat, jedoch habe ich ein Problem was ich hier nicht gefunden habe...
Auch möchte ich sagen das ich mich noch nicht wirklich mit dem Thema auskenne, ich aber mein bestes gebe um ans Ziel zu kommen, und dabei lernt man ja schließlich auch was.

Nun zum Ausgangspunkt. Ich habe 10 Clients in mehreren Räumen + Server 2003.
In jedem Raum sollen die Rechner zumteil die gleichen Netzlaufwerke, zum teil nur Raumspezifische Laufwerke gemappt bekommen.

Ich habe dann eine Organisationseinheit angelegt, und darin auch noch Untereinheit.
Die Sieht so aus:
MeineDomain.local
>DomainPC
>>Raum1
>>Raum2

Ich habe also DomainPC sowie Raum 1 und 2 angelegt.
Dann die entsprechenden PC dorthinein geschoben. Sieht schon sehr Übersichtlich aus (vorher war alles in einem Ordner)

Habe dann das Group Policy Managment aufgerufen und siehe da, ich sehe Domain PC und Raum 1 und 2.

Habe dann eine neue Gruppenrichtlinie erstellt.
Und nun mein vermutlich erster Denkfehler:
Ich habe in der Benutzerkonfiguration ein skript Hinterlegt (was auch funktioniert) und dann diese Richtlinie mit Raum 2 verknüpft.

Ging nicht. Kam dann selber zum ergebnis das es natürlich quatsch ist, eine Benutzer Konfig zu nehmen wenn kein Benutzer Drin ist. Also wieder aus der Benutzer Konfig raus und ab ins Start skript unter Computer Konfiguration.

Ging auch nicht...

Habe es jetzt mal so gelöst das ich in einem Globalen skript die PCs mit EOF ausgeschlossen habe und sie dann nicht die Laufwerke mappen. Was aber nicht mein Ziel war, es sollte nur laufen.

Ich hatte schon die Idee eine Gruppe zumachen (wie bei Usern) und dort dann die PCs rein, nur weiß ich nicht wie ich das dann einstellen soll.

Könnt Ihr mir eventuell helfen?
Danke
Mitglied: Xaero1982
06.08.2011 um 14:39 Uhr
Hi,

was sagt das Eventlog des Clients?

gpresult? auf den Clients...

Wie sieht dein Script aus? Wo liegt das Script? genauer Pfad...

VG
Bitte warten ..
Mitglied: sauger345
06.08.2011 um 14:53 Uhr
Das skript sieht so aus:
net use x: \\192.168.1.2\Transfer
net use p: \\192.168.1.2\Projekte

Es liegt in Netlogon (alle anderen Skripte liegen auch da)

im gpresult steht auch im Bereich Computerkonfiguation, das es angewendet wird....

Aber die Laufwerke sind nicht da... (Außer ich führe die Bat von Hand aus)
Bitte warten ..
Mitglied: Xaero1982
06.08.2011 um 15:57 Uhr
Ok und was steht im Eventlog des Clients ...

Sonst siehts ja erst mal gut aus

VG
Bitte warten ..
Mitglied: DerWoWusste
06.08.2011 um 16:13 Uhr
Moin.

Als Startskript für Computerobjekte handelt das Systemkonto - die Laufwerke werden für dieses verbunden, aber Netzlaufwerke sind nicht systemweit sichtbar. Du musst es als Anmeldeskript mit Benutzerobjekten verknüpfen.
Bitte warten ..
Mitglied: sauger345
06.08.2011 um 18:19 Uhr
Jetzt muss ich ne ganz doofe frage stellen:
Wie mache ich das?
Bitte warten ..
Mitglied: Pjordorf
06.08.2011 um 18:22 Uhr
Hallo,

Zitat von sauger345:
Wie mache ich das?
Hier im Forum wurde das Thema schon zig mal durchgekaut (Suchen hilft). Ansonsten ist Gruppenrichtlinien dein Favorit.

Gruß,
Peter

[Nachtrag]
Da du es bisher versäumt hast uns deine Client OSe mitzuteilen nur soviel dazu. XP <> Vista, XP <> Windows 7. Bei XP gibt es keine UAC. Demzufolge was bei XP geht, muss nicht zwangsläufig bei Windows 7 (Vista) gehen.
[/Nachtrag]
Bitte warten ..
Mitglied: sauger345
06.08.2011 um 18:44 Uhr
es muss sowohl auf XP als auch auf 7 gehen. Und wenn ich das Skript so ausführe gehts jau auch...

Ich kann nur schlecht das Anmelde skript mit Usern verküpfen weil in der OU keine User drin sind. die sind in der OU User.
Und wenn ichs mit den Usern verknüpfe, dann haben sie die Laufwerke ja überall... Irgendwie dachte ich das sei einfacher...
Bitte warten ..
Mitglied: Pjordorf
06.08.2011 um 19:04 Uhr
Hallo,

Zitat von sauger345:
es muss sowohl auf XP als auch auf 7 gehen.
Und genau das geht nicht immer. Daran ist unter anderem die UAC beteiligt. XP kennt davon nichts. lies dich mal in das Thema UAC bei Windows 7 ein!
http://technet.microsoft.com/en-us/library/cc709691(WS.10).aspx
http://technet.microsoft.com/en-us/library/cc731416(WS.10).aspx
http://technet.microsoft.com/de-de/library/cc709628(WS.10).aspx
http://de.wikipedia.org/wiki/Benutzerkontensteuerung
http://technet.microsoft.com/en-us/magazine/2009.07.uac.aspx

Und wenn ich das Skript so ausführe gehts jau auch..
Weil wenn du es startest, du als Benutzer SCHON angemeldet bist und zum Mappen von Laufwerken evtl. entsprechende Rechte hast.

Ein Script beim Computerstart kennt noch keine Benutzer!

Gruß,
Peter
Bitte warten ..
Mitglied: Xaero1982
06.08.2011 um 20:02 Uhr
Hi,

also:

UAC hat bisher noch nie Probleme gemacht beim Laufwerksmapping, also warum sollte es hier Probleme machen?
Hat meiner Meinung nach nichts damit zu tun.

Dann musst du die User ebenfalls in die entsprechenden OUs packen wo die Rechner drin sind.

Du kannst aber auch ein GPO einem User zuweisen ... in dem du das GPO auswählst und dann unter Sicherheitsfilterung den entsprechenden Nutzer zuweist ..
http://technet.microsoft.com/de-de/library/cc781988(WS.10).aspx

VG
Bitte warten ..
Mitglied: DerWoWusste
07.08.2011 um 12:30 Uhr
Moin sauger.

Und wenn ichs mit den Usern verknüpfe, dann haben sie die Laufwerke ja überall
Ja, ohne Weiteres ist das so. Man kann dies jedoch verhindern, indem man sagt "prüfe, an welchem Computer der User sitzt und handle entsprechend".
Dazu kann man entweder ein Skript nutzen, das den Computernamen oder dessen Mitgliedschaft prüft oder man nutzt ganz einfach GPPs (Group Policy preferences) und benutzt die eingebauten WMI-Filter, die eine solche Prüfung inklusive bieten.

Zu den GPPs brauchst Du
-xp oder Vista mit kb943729 installiert, Win7 kann das schon von sich aus.
-RSAT auf Vista/Win7 um Dich mit Deinem 2003er DC zu verbinden und entsprechende Richtlinien (mit GPPs) zu erzeugen.
-Eine GPP, die Netzlaufwerke verbindet und itemlevel targeting benutzt

Klingt zunächst viel, aber lässt sich schnell umsetzen, weniger als ein Tag samt einlesen. Und der Nutzen ist hoch: endlich kannst Du (über RSAT) Policies für Win7 und Vista nutzen trotz 2003er DC.
Bitte warten ..
Mitglied: DerWoWusste
07.08.2011 um 12:55 Uhr
@xaero
UAC hat bisher noch nie Probleme gemacht beim Laufwerksmapping
Doch. Siehe http://technet.microsoft.com/en-us/library/cc766208(WS.10).aspx Abschnitt "Group Policy Scripts can fail due to User Account Control". Zitat:
UAC may prevent Group Policy logon scripts from appearing to work properly. For example, a domain environment contains a GPO that includes a logon script to map network drives. A nonadministrative user logs on to the domain from a Windows Vista computer. After Windows Vista loads the desktop, the nonadministrative user starts Windows Explorer. The user sees their mapped drives. Under the same environment, an administrative user logs on to the domain from a Windows Vista computer. After Windows Vista loads the desktop, the administrative user starts Windows Explorer. The user does not see their mapped drives. When the administrative user logs on, Windows processes the logon scripts using the elevated token. The script actually works and maps the drive. However, Windows blocks the view of the mapped network drives because the desktop uses the limited token while the drives were mapped using the elevated token.

Dies kann man auf zwei Wegen unterbinden: einen nennt MS dort, der andere ist das Setzen des Regkeys enablelinkedconnections=1 ->Google.
Zudem gibt es ein weiteres, von MS hier ungenanntes Problem mit VBS-Anmeldeskripten. Aufgrund von Grundeinstellungen des Internetexplorers 8 in Win7 verarbeitet der VB-Skripte angeblich nicht mehr korrekt ohne Adminrechte - Batch hingegen geht problemlos. War in diversen MS-Foren zu lesen.
Bitte warten ..
Mitglied: Xaero1982
07.08.2011 um 15:53 Uhr
Zitat von DerWoWusste:
@xaero
> UAC hat bisher noch nie Probleme gemacht beim Laufwerksmapping
Doch. Siehe http://technet.microsoft.com/en-us/library/cc766208(WS.10).aspx Abschnitt "Group Policy Scripts can fail due to
User Account Control". Zitat:
> UAC may prevent Group Policy logon scripts from appearing to work properly. For example, a domain environment contains a GPO
that includes a logon script to map network drives. A nonadministrative user logs on to the domain from a Windows Vista computer.
After Windows Vista loads the desktop, the nonadministrative user starts Windows Explorer. The user sees their mapped drives.
Under the same environment, an administrative user logs on to the domain from a Windows Vista computer. After Windows Vista loads
the desktop, the administrative user starts Windows Explorer. The user does not see their mapped drives. When the administrative
user logs on, Windows processes the logon scripts using the elevated token. The script actually works and maps the drive. However,
Windows blocks the view of the mapped network drives because the desktop uses the limited token while the drives were mapped using
the elevated token.

Dies kann man auf zwei Wegen unterbinden: einen nennt MS dort, der andere ist das Setzen des Regkeys enablelinkedconnections=1
->Google.
Zudem gibt es ein weiteres, von MS hier ungenanntes Problem mit VBS-Anmeldeskripten. Aufgrund von Grundeinstellungen des
Internetexplorers 8 in Win7 verarbeitet der VB-Skripte angeblich nicht mehr korrekt ohne Adminrechte - Batch hingegen geht
problemlos. War in diversen MS-Foren zu lesen.


Ok Überzeugt, auch wenn ich kein Vista benutze ... wird sicher auch für W7 gelten, allerdings hatte ich solche Probleme bisher nicht.
Aber Sachen gibts ...

VG
Bitte warten ..
Mitglied: sauger345
07.08.2011 um 20:27 Uhr
Ich dachte mir das ich eventuell das mit einem Skript löse, und habe etwas gesucht.
Und habe das habe ich gefunden:
for /f "Tokens=2 Delims=," %%i in ('dsquery computer -name %computername%') do set aktuelleOU=%%i

Nur leider klappt das leider auf den Clients ja nicht weil es dort ja kein dsquery gibt...
Bitte warten ..
Mitglied: Xaero1982
07.08.2011 um 21:00 Uhr
So, letzter Beitrag hier:

Sauger, scheinbar bist du der Meinung, dass du unsere Tipps und Lösungen nicht beherzigen musst und dir irgendwelche anderen komischen Lösungen, die keine Lösungen sind, weil sie nicht funktionieren, suchen.

Wir haben es dir in aller Fülle geschrieben und wir haben dir die Kurzversion geschrieben.

Wenn du das nicht umsetzen willst, lass die Finger von Servern.

VG
Bitte warten ..
Mitglied: Pjordorf
07.08.2011 um 21:36 Uhr
Hallo,

Zitat von Xaero1982:
wird sicher auch für W7 gelten
Das brauchst du nicht erst zu vermuten. Es ist so.

@Suager345:
Warum
01.
for /f "Tokens=2 Delims=," %%i in ('dsquery computer -name %computername%') do set aktuelleOU=%%i
so kompliziert? Ein einfaches
01.
If "%%ComputerName%%"=="RaumX" then
hilft dir doch bestimmt weiter.

Wird dein Benutzer Script sichtbar ausgeführt? Poste mal dein Script hier rein. (Code Tags benutzen). Mal schauen was dann wird.

Gruß,
Peter

[Nachtrag]
Es gibt unter anderem auch noch die möglichkeit mit IFMember. Das musst du aber erst vom MS laden und Installieren.
[/Nachtrag]
Bitte warten ..
Mitglied: Xaero1982
07.08.2011 um 21:55 Uhr
Zitat von Pjordorf:
Hallo,

> Zitat von Xaero1982:
> wird sicher auch für W7 gelten
Das brauchst du nicht erst zu vermuten. Es ist so.

Na dann wirst du mir ja sicher noch mal erklären können unter welchen Umständen dies passiert, denn ich habe schon x Scripte erstellt unter W7 und Laufwerke gemappt und hatte keine Probleme ...

VG
Bitte warten ..
Mitglied: sauger345
07.08.2011 um 22:26 Uhr
dann habe ich schlicht nur was falsch verstanden, dennweiter oben hieß es, ich könne es eventuell mit einem skript machen das die Mitgliedschaft überprüft.

Die andere Lösung (GPP) kann ich leider erst Dienstag probieren, so wollte ich halt etwas machen was ich jetzt machen kann.

Bitte nicht falsch verstehen.
Bitte warten ..
Mitglied: Xaero1982
07.08.2011 um 22:40 Uhr
War ja auch nicht böse gemeint, aber manchmal ist es echt anstrengend, wenn man versucht dem Hilfesuchendem Tipps zu geben, wie er das Problem lösen kann und er dann immer mit irgendwas anderem ankommt, ohne wirklich auf die Tipps einzugehen.

Klar kannst du es mit Ifmember machen, aber sowas hab ich ehrlich gesagt noch nie erlebt bei Laufwerksmapping. Notfalls kannst du das Script auch direkt im Userprofil angeben im AD.

VG
Bitte warten ..
Mitglied: sauger345
07.08.2011 um 23:20 Uhr
ginge das eventuell mit Gruppen?
Also das ich die PCs die die Laufwerke bekommen sollen in eine bestimmet Gruppe stecke, so wie ich User in eine Gruppe stecke wenn sie auf verschiedene sachen zugriff haben sollen?

Oder geht sowas erst recht nicht?

Ansonsten Probiere ich die tage mal die GPP lösung.
Bitte warten ..
Mitglied: DerWoWusste
07.08.2011 um 23:29 Uhr
Doch, so habe ich es auch beschrieben. Natürlich kannst Du auch PCs in eine Gruppe stecken und dann mit GPPs item level targeting machen und nach der Gruppe filtern.
Bitte warten ..
Ähnliche Inhalte
Windows Netzwerk

AD-Domäne: Wird das Anmeldeskript auf den Clients auch ausgeführt wenn diese keine Netzwerkverbindung haben?

Frage von HamsertWindows Netzwerk9 Kommentare

Hi, wir haben eine AD Domäne und manche MA benutzen ihre Laptops im HO. Da die Laptops zuhause vor ...

Netzwerkprotokolle

Anmeldeskript im Netzerk

Frage von ManneKLNetzwerkprotokolle3 Kommentare

Hallo, Habe ein NAS ins Netzwerk eingebunden und das Anmeldeskript - bat. Datei entsprechende Einträge z. Bsp: NET USE ...

Windows Server

Computer automatisch in Organisationseinheit nach Computername einordnen

Frage von WarrenderWindows Server2 Kommentare

Hallo, ich suche nach einer Möglichkeit, um Computer beim Eintritt ins AD automatisch in die richtige Organisationseinheit einzuordnen. Unsere ...

Windows Server

Anmeldeskript in der Computerkonfiguration möglich?

Frage von goalgetter123Windows Server1 Kommentar

Guten Tag, ich habe schon erfolgreich Skripte angelegt, welche in eine Textdatei die Zeitangaben beim Hoch- und Herunterfahren der ...

Neue Wissensbeiträge
Sonstige Systeme
Es war einmal ein BeOS - Wer erinnert sich noch?
Information von BassFishFox vor 1 TagSonstige Systeme5 Kommentare

Hallo, Bin gerade ueber Haiku gestolpert, von dessen Existenz als "Nachfolger des BeOS" ich wusste nur mich nie wirklich ...

Datenschutz

Microsoft und DSGVO - ob das wohl jemals klappt (Probleme beim Datenabfluss für Office Pro Plus)?

Tipp von VGem-e vor 1 TagDatenschutz3 Kommentare

Servus Kollegen, siehe Aber wer setzt schon MS Office Pro Plus ein? Wie dann der Stand beim "normalen" MS ...

Windows 10

Macht Windows 10.1809 Probleme mit gemappten Netzlaufwerken (betrifft wohl insbes. AMD-Hardware und Trend Micro AV-Produkte)?

Tipp von VGem-e vor 1 TagWindows 103 Kommentare

Moin Kollegen, grad dazu gefunden und Hatten wir dies nicht bei früheren W10-Upgrades ebenfalls? Da bleibt nur, das Upgrade ...

Humor (lol)

Das neue Miniatur Wunderland OFFICIAL VIDEO - worlds largest model railway - railroad

Information von StefanKittel vor 2 TagenHumor (lol)2 Kommentare

Hallo, wer noch nie im Miniatur Wunderland war, sollte es dringend mal nachholen. Es gibt eine neues Video. Viele ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
Gäste-WLAN durch DD-WRT AP nach einem MikroTik Routerboard
Frage von NukolarLAN, WAN, Wireless16 Kommentare

Hallo, wie der Titel schon sagt möchte ich gerne ein Gäste-WLAN innerhalb eines bestehenden LANs einrichten. Dass die Gäste ...

DSL, VDSL
DSL Monitoring Tool - Quick and dirty?
Frage von george44DSL, VDSL15 Kommentare

Liebe Gemeinde, ich suche ein einfaches und vor allem schnell zu installierendes Monitoring-Tool zur kontinuierlichen Dokumentation (nur) der Internetanbindung. ...

Exchange Server
Outlook findet Postfach nicht
Frage von MaximaxExchange Server11 Kommentare

Hallo, und zwar haben wir auf der Arbeit ein kleines (großes) Exchange 2016 Problem. Exchange meldete gestern, dass die ...

Informationsdienste
Probleme auf dem Server
Frage von LangeLangeInformationsdienste9 Kommentare

Hallo zusammen, ich betreibe die Seite Keine Werbelinks. In der Analyse stellen wir fest, dass die Ladezeit in der ...