Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Apache 2 - var-www - Verzeichniss soll bleiben, aber die Verlinkung soll auf einen USB-HD verweisen

Mitglied: Slut

Slut (Level 1) - Jetzt verbinden

23.04.2012 um 10:42 Uhr, 3532 Aufrufe, 22 Kommentare

Hallo Admins,

ich habe folgendes Problem :
die Index.html, liegt im Ordner var/www, so soll das auch bleiben ( Intranet).
Das Problem die Fotos, Musik, Filme liegen auf einer USB-HD.
Stelle ich eine Verlinkung zu einem Musiktitel dar, meinte Apache das das so nicht geht.

Wo ist der Fehler, muss ich die Documenten-Root, auch dafür ändern ?
Aber wie da ?

Vielen Dank im Vorraus
Slut
Mitglied: mak-xxl
23.04.2012 um 12:02 Uhr
Moin TO,

eine der vielen Möglichkeiten wäre, in '/var/www' ein Verzeichnis, i.e. '/var/www/media' zu erstellen und dort hinein die USB-HDD (-Partition) zu mounten - allerdings müssen dann diese Inhalte per Angabe (Pfad) im HTML gefunden werden.

Den Root (per Mount) auf die USB-HDD zu lenken wäre keine so gute Idee ...

Freundliche Grüße von der Insel - Mario
Bitte warten ..
Mitglied: Slut
23.04.2012 um 14:12 Uhr
Hallo TO,

das Verzeichniss zu erstellen ist kein Problem, sicher ist auch die Pfadangabe kein Problem.
NUR, wie mount ich die HD in diesem Verzeichniss ??

Dank
Slut
Bitte warten ..
Mitglied: michi1983
23.04.2012 um 14:34 Uhr
Zitat von Slut:
Hallo TO,

das Verzeichniss zu erstellen ist kein Problem, sicher ist auch die Pfadangabe kein Problem.
NUR, wie mount ich die HD in diesem Verzeichniss ??

Dank
Slut

TO = Thread Opener ;)
Bitte warten ..
Mitglied: mak-xxl
23.04.2012 um 14:39 Uhr
Moin TO,

wenn die USB-HDD als '/dev/sdb' erkannt wird und nur eine Partition hat, dann etwa so:
mount /dev/sdb1 /var/www/media
Weitere Angaben (wie Dateisystemtyp etc.) sollten nicht notwendig sein, das deutet dann eher darauf hin, dass gemachte Angaben nicht stimmen.

Infos zur Platte ergibt z.B. die Sequenz:
dmesg | grep usb
Gibt es mehrere Partitionen auf der HDD, hilft ein:
[c]fdisk /dev/sdb
je nach verwendetem OS zum Finden der fraglichen Partitionsnummer.

Freundliche Grüße von der Insel - Mario
Bitte warten ..
Mitglied: Slut
24.04.2012 um 11:36 Uhr
Hallo Mario,

nun habe ich noch eine Problem, das Terminal "schreit rum ", das, das nur unter root geht - heir ist meine Latein am Ende.

Was sollte ich da tun ? bei mir läuft Ubuntu 11.10
Ich war " Jahrhunderte " Bill Gates abhängig, nun wollte ich was Neues ausprobieren, tut mir leid wenn ich nerve.

Vielen Dank
Slut
Bitte warten ..
Mitglied: Slut
24.04.2012 um 11:47 Uhr
Ja, ich nochmal, ich habe sudo, davor gestellt, und es hat funktioniert, mit der root, aber das nächste Problem tat sich auf :

mount: /dev/sdd ist bereits eingehängt oder /var/www/media wird gerade benutzt

???????????????????????????????????????????????????

Dank
Bitte warten ..
Mitglied: mak-xxl
24.04.2012 um 11:52 Uhr
Moin TO,

nein Du nervst nicht, wenn unter Linux etwas mit root-Rechten gemacht werden muss, gibt es die Möglichkeiten:

- als 'root' einzuloggen, das geht i.A. nur direkt an der Konsole und ist nur in Ausnahmefällen zu tun
- an der Konsole als 'normaler' User einzuloggen und den Befehlen, die es erfordern, ein 'sudo' voranstellen.
sudo mount /dev/sdb1 /var/www/media
- am GUI eine Root-Konsole zu öffnen
- am GUI eine normale Konsole zu öffnen und den Befehlen, die es erfordern, ein 'sudo' voranstellen.

Und es sei Dir dringend empfohlen, die wichtigsten Grundlagen des Betriebssystems zu verinnerlichen, eine Hilfe wäre hier zu finden, zum speziellen Problem hier..

Ansonsten: Herzlich willkommen in Linuxlanden, viel Erfolg und Freude allzeit, freundliche Grüße von der Insel - Mario
Bitte warten ..
Mitglied: mak-xxl
24.04.2012 um 11:56 Uhr
Moin TO,

Zitat von Slut:
mount: /dev/sdd ist bereits eingehängt oder /var/www/media wird gerade benutzt

eher so (beachte die Ziffer hinter 'sdd'):

sudo mount /dev/sdd1 /var/www/media
Das gilt, wenn die erste (und evtl. einzige?) Partition die fraglichen Daten enthält. Ansonsten: siehe Post vom 23.04.2012, 14:39:51.

Freundliche Grüße von der Insel - Mario
Bitte warten ..
Mitglied: Slut
25.04.2012 um 11:25 Uhr
Hallo Mario,
sag mal, ist es doch nicht einfacher die Documenten-root zuändern ?
- die Frage :
- wie und wo ändere ich diese ( die USB-HD, heißt sdd1 ) (grins)

Ich habe mich schon belesen, aber ich wär einfach nicht schlau, aus der ganzen Sache.

Danke im Vorraus
Slut
Bitte warten ..
Mitglied: mak-xxl
25.04.2012 um 11:32 Uhr
Moin TO,

Gegenfrage: Klappt das Mounten der externen HDD, wie oben besprochen? Wenn nein, welche Fehlermeldung folgt auf welchen Befehl von Dir? Wenn ja, was ist jetzt das eigentliche Problem?

Freundliche Grüße von der Insel - Mario
Bitte warten ..
Mitglied: Slut
25.04.2012 um 11:40 Uhr
Hallo, nein das funktioniert nich.

Mount is denied because the NTFS volume is already exclusively opened.
The volume may be already mounted, or another software may use it which
could be identified for example by the help of the 'fuser' command.

Das ist schreibt, Ubuntu

Danke
Bitte warten ..
Mitglied: mak-xxl
25.04.2012 um 11:48 Uhr
Moin TO,

Als erstes solltest Du unter Ubuntu den Befehl
sudo umount -a
ausführen, vermutlich ist das Volume bereits per <fstab> gemountet. Danach ein
sudo mount /dev/sdd1 /var/www/media
Kommt die Fehlermeldung wieder, dann solltest Du die externe HDD zunächst einmal unter Win32 einem chkdsk-Lauf unterziehen.

Freundliche Grüße von der Insel - Mario
Bitte warten ..
Mitglied: Slut
25.04.2012 um 11:55 Uhr
Vielen Dank, das hat funktioniert, nur noch einen letzte Frage, bleibt die HD auch nach einem Neustart in diesem Verzeichniss und ist sie gleich gemountet ?

Danke
Bitte warten ..
Mitglied: mak-xxl
25.04.2012 um 12:01 Uhr
Moin TO,

Zitat von Slut:
... bleibt die HD auch nach einem Neustart in diesem Verzeichniss und ist sie gleich gemountet ?

Nein, ein 'permanenter' Mount wird in der Datei '/etc/fstab' eingetragen - und bei Deinem System steht da offensichtlich schon etwas drin ...
Poste mal den Inhalt der <fstab>, wir werden diese dann anpassen.

Freundliche Grüße von der Insel - Mario
Bitte warten ..
Mitglied: Slut
25.04.2012 um 12:07 Uhr
Hallo Mario,

das "Dingsi" sieht so aus :

  1. /etc/fstab: static file system information.
  1. <file system> <mount point> <type> <options> <dump> <pass>

#Entry for /dev/sda1 :
UUID=55d9a6ab-cfd9-4ab7-a6fd-588c8d1517fe / ext4 defaults 0 1
#Entry for /dev/sdd1 :
UUID=206EFC606EFC2FE0 /media/\040Sicherung\040extern_ ntfs-3g defaults,nosuid,nodev,locale=de_DE.UTF-8 0 0
#Entry for /dev/sdc1 :
UUID=066a894d-fb0c-4245-8531-5559b90ed5d7 /usr ext4 defaults 0 2
#Entry for /dev/sdb5 :
UUID=9634b371-8dc5-4f58-8bab-a9c3325cce10 /usr/local ext4 defaults 0 2
#Entry for /dev/sdb1 :
UUID=9567c66b-ca71-450d-b800-653d52c312ce swap swap sw 0 0
Bitte warten ..
Mitglied: mak-xxl
25.04.2012 um 12:13 Uhr
Moin TO,

Zitat von Slut:
UUID=206EFC606EFC2FE0 /media/\040Sicherung\040extern_ ntfs-3g defaults,nosuid,nodev,locale=de_DE.UTF-8 0 0

Diese Zeile hat welchen Grund? Wenn keiner ersichtlich, dann so ändern:
UUID=206EFC606EFC2FE0	/var/www/media ntfs-3g	defaults,nosuid,nodev,locale=de_DE.UTF-8	0	0
Anschließend ein 'sudo umount -a' und danach ein 'sudo mount -a' eingeben, anschließend Kontrolle und letztlich ein Neustart zur endgültigen Funktionskontrolle.

[Edit]Mount-Zeile ergänzt[/Edit]

Freundliche Grüße von der Insel - Mario
Bitte warten ..
Mitglied: Slut
25.04.2012 um 12:31 Uhr
Hallo Mario,

jetzt kommt das - mount: unbekannter Dateisystemtyp „locale=de_DE.UTF-8“

Danke
Bitte warten ..
Mitglied: mak-xxl
25.04.2012 um 12:41 Uhr
Moin TO,

Sorry, zuviel weggelöscht, also so:

UUID=206EFC606EFC2FE0	/var/www/media ntfs-3g	defaults,nosuid,nodev,locale=de_DE.UTF-8	0	0
[Edit]Im Originalpost ebenfalls ergänzt[/Edit]

Freundliche Grüße von der Insel - Mario
Bitte warten ..
Mitglied: Slut
25.04.2012 um 13:05 Uhr
Hallo Mario,
es funktioniert alles, er mountet die HD nach dem Neustart, eine Link auf die HD funktioniert auch.

Ich bin glücklich, Vielen Dank

Slut

P.S: Gibt es Probleme, habe ich jetzt ja einen Fachmann !!!

Vielen Dank und einen schönen Tag noch

Slut
Bitte warten ..
Mitglied: Slut
26.04.2012 um 09:40 Uhr
Hallo Mario,

nur noch einen Frage, ist ein Virenscanner bei Ubuntu nötig.
- einige schreiben ja, die anderen nein -
In meinem Netzwerk sind auch noch Windowsrechner, besteht davon eine Gefahr ?

Tschau Slut
Bitte warten ..
Mitglied: mak-xxl
26.04.2012 um 09:52 Uhr
Moin TO,

eine kurze Überlegung bringt Licht ins Dunkel:

Die Aussage, es gäbe keine Viren für Linux, mag heute (noch) einigermaßen nachvollziehbar sein, aber schon die Schlussfolgerung, desshalb keinen Virenschutz/-scanner unter Linux verwenden zu müssen, ist mehr als leichtsinnig.
Win-Rechner im Netzwerk sollten einen eigenen, aktiven Virenschutz haben und sind deshalb nicht mehr oder weniger gefährdet, weil ein ungeschützter Linux-Rechner zusätzlich im Netz steht.
Aber: In dem Moment, wo Nicht-Linux-Partitionen (DOS, Win) im Linux-System eingehängt sind und unter diesem System ein Internet-Zugriff (Mails, http, ftp, WebDAV etc.) stattfindet (besser: möglich ist) und Dateien zur weiteren Verwendung evtl. sogar auf die gemounteten Volumes gespeichert werden - muss ich das weiter ausführen?
Der Einsatz eines Virenscanners für Win und Linux vom gleichen Hersteller hat Vorteile (Bedienung, Konfiguration relativ gleich), ist aber keine Bedingung.

Das Thema Firewall ist dann logischerweise und sicherlich eine Deiner nächsten Baustellen, schon allein deswegen, weil der Begriff fest mit Linux/Unix verbunden ist - aber das ist dann ein neuer Thread ...

Freundliche Grüße von der Insel - Mario
Bitte warten ..
Mitglied: Slut
26.04.2012 um 11:08 Uhr
Hallo Mario,

vielen Dank für die Info.

einen schönen Tag noch

Slut
Bitte warten ..
Ähnliche Inhalte
Apache Server

VirtualHost Verzeichnisse ohne www nicht erkannt . mit www alles ok

Frage von hand.andosApache Server

Hallo. In meiner Apache2-Domain-Config Datei habe ich eine Domain eingetragen; mit und ohne www: Zusätzlich habe ich Unterverzeichnisse gesondert ...

Apache Server

Apache hat anscheinend keine Rechte auf www ordner

Frage von bilaluiApache Server16 Kommentare

Hallo zusammen, ich dachte mir ich könnte mir auf nen Debian Server den Apache Webserver installieren. Installation war super ...

Apache Server

Non-www auf www-Adresse umleiten unter Apache 2.4.x auf Ubuntu 14.04

gelöst Frage von bolshiApache Server1 Kommentar

Hallo, aktuell ist unser Drupal7-CMS unter erreichbar. Die soll nun auf umleiten. Unter /etc/apache2/sites-available wurde folgende domain.conf angelegt: Die ...

Batch & Shell

Ausgegebene Information einer var zuordnen und var mit Text vergleichen

Frage von iGriefU1Batch & Shell2 Kommentare

Ich möchte ein Unterprogramm machen: Es soll prüfen, ob ich einen WLAN HotSpot erstellen kann. Da habe ich die ...

Neue Wissensbeiträge
Windows 10
Zero-Day-Lücke in Microsoft Edge
Information von kgborn vor 1 TagWindows 10

In Microsofts Edge-Browser klafft wohl eine nicht geschlossene (0-Day) Sicherheitslücke im Just In Time Compiler (JIT Compiler) für Javascript. ...

Sicherheit
Microsoft und Skype: Sicherheit
Information von kgborn vor 1 TagSicherheit

Die Tage gab es ja einige Berichte zur Sicherheit des Skype-Updaters. Der Updater von Skype läuft unter dem Konto ...

Datenschutz

Behörden ignorieren Sicherheitsbedenken gegenüber Windows 10

Information von Penny.Cilin vor 2 TagenDatenschutz8 Kommentare

Hallo, passend zum Thema Ablösung LIMUX in München ein interessanter Beitrag dazu: Behörden ignorieren Sicherheitsbedenken gegenüber Windows 10 Anscheinend ...

Sicherheit
Information Security Hub Munich airport
Information von brammer vor 2 TagenSicherheit

Hallo, Neues Center für Cyber Kriminalität am Münchener Flughafen brammer

Heiß diskutierte Inhalte
DSL, VDSL
Mindestgeschwindigkeiten DSL Telekom
Frage von justlukasDSL, VDSL14 Kommentare

Hallo zusammen, Seit diesem Jahr habe ich Verständnisprobleme mit dem Verhalten der Telekom. Wir haben seit einem Jahr VDSL ...

Switche und Hubs
LANCOM-Switch: Probleme (no link) mit SFP-Modulen?
Frage von THETOBSwitche und Hubs11 Kommentare

Hi zusammen, ich habe folgendes Problem: Und zwar habe ich an einem Standort drei Switche verbaut - LANCOM GS-2326P+, ...

Humor (lol)
Was könnte man mit einem Server machen? Idee gesucht
Frage von 2SeitenHumor (lol)11 Kommentare

Hey Zusammen Ich habe einen alten HP G2 Rackserver zu Hause rumliegen. 28GB Ram, 1xAMD Prozi mit etwa 2GHz. ...

Firewall
RB2011 Firewall Rule eine bestimmte Mac oder IP Adresse nicht zu blockieren
Frage von lightmanFirewall10 Kommentare

Hallo liebes Forum mit ihren Spezialisten. Ich habe meine Firewall so konfiguriert das kein Endgerät ohne meine Speziellen Erlaubnis ...