Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Apache2 schmiert beim ausführen von PHP Skripten ab

Mitglied: chrisbl

chrisbl (Level 1) - Jetzt verbinden

05.01.2007, aktualisiert 17:44 Uhr, 4644 Aufrufe, 8 Kommentare

Hallo. Habe da ein etwas kleineres Problem

Ich habe einen Strato Server, den ich von vorne Aufziehn will. Dazü gehört auchn Webserver mit PHP und MySQL

Den Webserver und MySQL habe ich schon. Nur PHP macht probleme. Apache läuft und im Apache Monitor wird sogar angezeigt, dass der Apache mit PHP5.2.1 konfiguriert wurde.

Das hier is in der HTTPD.CONF drinne:

  1. For PHP 5 do something like this:
LoadModule php5_module "c:/php/php5apache2_2.dll"
AddType application/x-httpd-php .php

  1. configure the path to php.ini
PHPIniDir "C:/php"


Das Hier:
Die Datei php4ts.dll die sich im extrahierten PHP-Ordner befindet, muss noch in das Verzeichnis c:\windows\system kopiert werden.

Die Datei php.ini-dist in das Verzeichnis c:\windows kopieren und in php.ini umbenennen.

habe ich auch gemacht. Den PC habe ich dann Rebootet. Dann hat mich Windows Server ma wieder mit der komischen Dateiausführungsblabla konfrontiert. Habe das zugelassen und so und dann habe ich n Fenster gekriegt, dass apache einen Fehler ermittelt hat und sich beendet hat. Mehr nicht.

Dann habe ich apache2 wieder über den Apache Manager gestartet und danach lief der Webserver auch wider MIT Php.

Dann habe ich n PHPinfo skript ausgeführt. Das wurde auch korrekt dargestellt und noch wärend dem Laden der Seite hat sich der HTTPD beenden. Warum weis ich nicht..

Ich habe aber diese PHPinfo noch angezeigt bekommen und habe diese Mal in eine PDF Datei gestellt:
http://www.christian-bless.de/phpinfo.pdf

Ich weiß nicht was ich sonst noch Falsch gemacht habe.

Umgebungsvaribale ist KEINE Vorhanden.

Für weitere vorschläge wäre ich euch sehr sehr dankbar.

MfG
chrisBL
Mitglied: Devian
05.01.2007 um 13:11 Uhr
Soll das ein Produktivsystem werden? Ich frag nur weil du einen "RC-dev" installiert hast..
Bitte warten ..
Mitglied: chrisbl
05.01.2007 um 13:14 Uhr
soll eins werden. dann greif ich wieder auf die nicht RC-DEV version zurück. Ist momentan noch auf meinem Homi der aber das gleiche OS wie der Richtige server hat. und erst wenns daheim klappt dann setz ich das auch auf meinem richtigen auf

darf ich fragen, warum du frägst?
Bitte warten ..
Mitglied: Devian
05.01.2007 um 13:23 Uhr
Weil ich mit den RC-dev Versionen ebenfalls leichte Probleme.. (PHP parste sehr langsam, Apache wurde instabil etc..)

Hast du es mal mit einem Official Release ausprobiert? Wie verhält sich der HTTPD dann?
Bitte warten ..
Mitglied: chrisbl
05.01.2007 um 14:48 Uhr
leider genauso. auch bei dem official candidate
Bitte warten ..
Mitglied: Devian
05.01.2007 um 15:00 Uhr
Das du einige (scheinbar) Fehlkonfigurationen in den Pfaden hast hast du aber gewusst, oder?

(pfad von Pear zeigt nach C:\PHP5 sonst ist überall C:\PHP angegeben)

.. versuch mal die Temp-Pfade von deinem User zu entfernen.. (z.B. nach c:\temp\php oder so)
Bitte warten ..
Mitglied: chrisbl
05.01.2007 um 15:04 Uhr
(pfad von Pear zeigt nach C:\PHP5 sonst ist überall C:\PHP angegeben)

ähm .... und woher kommt das?
wie kann ich das ändern?
Nein. Das habe ich nicht gewusst.

versuch mal die Temp-Pfade von deinem User zu entfernen

Verstehe ich momentan nicht.
Wie hast du das gemeint?
Bitte warten ..
Mitglied: Devian
05.01.2007 um 16:10 Uhr
Such mal in deiner PHP.INI nach

"include_path = " .. da findest du z.B. Pear
"upload_tmp_dir" .. ist eigentlich selbsterklärend
"session.save_path" .. auch selbsterklärend..

Kurz:

Lad dir die PHP.INI mal in einen Editor und durchsuch einfach alle "path"-Einträge..
Das sollte schonmal einiges bringen.

Nachtrag:
Wenn schon die INI geöffnet hast guck mal in der Sektion "Paths and Directories". Da sind noch mehr einträge die evtl. auf ungewünschte Verzeichnisse zeigen.
Bitte warten ..
Mitglied: chrisbl
05.01.2007 um 17:44 Uhr
;;;;;;;;;;;;;;;;;;;;;;;;;
; Paths and Directories ;
;;;;;;;;;;;;;;;;;;;;;;;;;

; UNIX: "/path1:/path2"
;include_path = ".:/php/includes"
;
; Windows: "\path1;\path2"
include_path = ".;c:\php"

;;;;;;;;;;;;;;;;
; File Uploads ;
;;;;;;;;;;;;;;;;

; Whether to allow HTTP file uploads.
file_uploads = On

; Temporary directory for HTTP uploaded files (will use system default if not
; specified).
upload_tmp_dir ="C:\PHP\tmp"

; Default timeout for socket based streams (seconds)
default_socket_timeout = 60
upload_tmp_dir="C:\PHP\tmp"
session.save_path="C:\PHP\tmp"

soweit eigentlich alles ok .... nur es geht immer noch nicht ... danke Devian habs grad geändert und apache restarted. .... leider erfolglos

Achja, wenn ich den Homeserver neustarte kommt beim Anmelden "Dieses Programm wurde aus Sicherheitsgründen geschlossen": Apache Foundation HTTP Server
Kann das Sein, dass Windows den Dienst gekillt hat, als dieser Versucht hat, PHP Scripts auszuführen. Grund: Datenausführungsverhinderung

Mittlerweile habe ich die errorlogs im Apache gefunden. Da kommen dann einträge wie:
PHP Warning: Unknown(): Unable to load dynamic library 'C:\\Programme\\PHP5\\ext\\php_pdo_firebird.dll' - Das angegebene Modul wurde nicht gefunden.\r\n in Unknown on line 0
PHP Warning: Unknown(): Unable to load dynamic library 'C:\\Programme\\PHP5\\ext\\php_pdo_mssql.dll' - Das angegebene Modul wurde nicht gefunden.\r\n in Unknown on line 0
PHP Warning: Unknown(): Unable to load dynamic library 'C:\\Programme\\PHP5\\ext\\php_pdo_mysql.dll' - Das angegebene Modul wurde nicht gefunden.\r\n in Unknown on line 0
PHP Warning: Unknown(): Unable to load dynamic library 'C:\\Programme\\PHP5\\ext\\php_pdo_oci.dll' - Das angegebene Modul wurde nicht gefunden.\r\n in Unknown on line 0
PHP Warning: Unknown(): Unable to load dynamic library 'C:\\Programme\\PHP5\\ext\\php_pdo_oci8.dll' - Das angegebene Modul wurde nicht gefunden.\r\n in Unknown on line 0
PHP Warning: Unknown(): Unable to load dynamic library 'C:\\Programme\\PHP5\\ext\\php_pdo_odbc.dll' - Das angegebene Modul wurde nicht gefunden.\r\n in Unknown on line 0
PHP Warning: Unknown(): Unable to load dynamic library 'C:\\Programme\\PHP5\\ext\\php_pdo_pgsql.dll' - Das angegebene Modul wurde nicht gefunden.\r\n in Unknown on line 0
PHP Warning: Unknown(): Unable to load dynamic library 'C:\\Programme\\PHP5\\ext\\php_pdo_sqlite.dll' - Das angegebene Modul wurde nicht gefunden.\r\n in Unknown on line 0


was soll das sein? Waurm kommen da diese einträge und warum die 2 \\
Bitte warten ..
Ähnliche Inhalte
PHP

PHP - Variable in anderes PHP-Skript mitgeben

gelöst Frage von Jens4everPHP3 Kommentare

Hi zusammen, könnt ihr mir kurz helfen? Ich habe folgendes vor: Ich möchte, dass beim Aufruf von "check1.php" eine ...

Linux Tools

Raspberry: Skript richtig ausführen

gelöst Frage von Jens4everLinux Tools2 Kommentare

Moin zusammen, ich habe auf meinem Raspberry ein Skript ) installiert, das es mir ermöglicht über die Dropbox API ...

Windows Server

Skript aufgrund von Netzadresse ausführen

Frage von anak1mWindows Server12 Kommentare

Hallo zusammen, kennt jemand eine Möglichkeit ein Skript aufgrund einer Netzadresse auszuführen? Ich möchte folgendes damit umsetzen: Wenn die ...

Batch & Shell

Powershell kann keine Skripte ausführen

gelöst Frage von MineralwasserBatch & Shell5 Kommentare

Ich habe eine Powershell Profile angelegt und Set-ExecutionPolicy -ExecutionPolicy Unrestricted gesetzt. Nun wenn ich die powershell via einen Link ...

Neue Wissensbeiträge
Hardware

100.000 Mikrotik-Router ungefragt von Hacker abgesichert

Information von 7Gizmo7 vor 12 StundenHardware1 Kommentar

Hallo zusammen, da hier ja öfters mal von Mikrotik gesprochen wird. Trotz Updates klafft eine Sicherheitslücke in Hundertausenden Mikrotik-Routern. ...

Sicherheit

Oracle gibt kritische Updates für diverse Produkte frei (16. Oktober 2018)

Information von kgborn vor 23 StundenSicherheit

Oracle hat zum 16. Oktober 2018 eine ganze Reihe an kritischen Updates für seine Produkte freigegeben. Eine Kurzübersicht mit ...

Windows 10
FYI: Fristen beim Windows 10 Downgrade-Recht
Information von kgborn vor 23 StundenWindows 101 Kommentar

Möglicherweise ist das bei euch bekannt - ich habe es gerade aus einem Newsletter eines OEMs herausgefischt. Beim Downgrade-Recht ...

CMS
Freie Wähler Bayern MySQL PW online
Information von sabines vor 1 TagCMS6 Kommentare

Die Typo3 Installation der Freien Wähler Bayern scheint wohl längere Zeit nicht mehr angefasst und/oder fehlkonfiguriert zu sein. Nach ...

Heiß diskutierte Inhalte
Windows 10
Sysprep Fehler im Log kann nicht starten
Frage von grillinator95Windows 1021 Kommentare

Hallo, kann leider SYSPREP nicht mehr starten, Win10 64bit. Logfile sagt folgendes: 2018-10-17 13:44:56, Info SYSPRP 2018-10-17 13:44:56, Info ...

Internet
Ist diese URL denkbar (Syntax)?
gelöst Frage von departure69Internet17 Kommentare

Hallo. Der Sohn eines Arbeitskollegen hat im Gymnasium EDV-Unterricht. Leider hat er in der letzten Klassenarbeit einen Fünfer geschrieben. ...

Exchange Server
Outlook Anywhere - Anmeldefenster muss mit Domain gefüllt werden
Frage von leon123Exchange Server16 Kommentare

Hallo zusammen, ich habe relativ erfolgreich einen Exchange 2016 aufgesetzt, sowie ein SAN-Zertifikat eingespielt und Outlook Anywhere aktiviert. Beim ...

Debian
Linux debian 9 Installation
Frage von Green14Debian15 Kommentare

Hallo zusammen, ich habe mich ein wenig mit Debian auseinandergesetzt und möchte mir eine Standard-Installation als Grundlage für andere ...