Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Astaro Proxy - kein Zugriff auf meinen Webspace über FTP...?

Mitglied: zeiman

zeiman (Level 1) - Jetzt verbinden

16.01.2007, aktualisiert 30.05.2008, 14199 Aufrufe, 16 Kommentare

Hallo! Ich habe einen Astaro Proxy laufen den in nach dem Astaro Manual grundinstalliert habe.

Jetzt gibt sich ein kleines Problem:

Ich kann mit meinem FTP-Progamm nicht mehr auf meinen Webspace zugreifen - obwohl in meinen Proxy im Programm eingestellt habe.

Im FTP-Prog habe ich den Proxy als HTTP mit Port 1080 einsgestellt.
Muss ich nen Socks 5 verwenden?

Worauf muss man im Programm und im Astaro achten um die Verbindung herzustellen?

Danke im Voraus!

MfG Simon
Mitglied: Sven-UP
23.02.2007 um 00:55 Uhr
Hallo Simon,

du brauchst ein Programm was mit einem HTTP Proxy eine FTP Verbindung aufbauen kann. Wir haben viele Astaros im Einsatz... überhaupt kein Problem!

Grüße
Sven
Bitte warten ..
Mitglied: 65728
30.05.2008 um 09:29 Uhr
Hallo Simon,

kannst du mir bitte mitteilen mit welchen Einstellungen eure Astaros konfiguriert sind, damit ausgehende FTP-Verbindungen via HTTP-Proxy zustande kommen?


Habe hier Astaro 6 aufgesetzt und SmartFtp v3.0 auf Windows XP SP2 laufen.
Der Astaro ist als transparenter HTTP-Proxy eingerichtet, die dortigen "target services" sind sowohl ftp als auch ftp-control.
SmartFTP ist angewiesen den HTTP-Proxy als generellen Proxy zu nutzen.
Ein spezieller FTP-Proxy wurde nicht in SmartFTP eingetragen, da alle verfügbaren Varianten (in der derzeitigen Konfiguration) nicht zum Erfolg führten.
Eine Verbindung mit SmartFTP kommt zustande, wird aber durch den Proxy (so meine Vermutzung) unterbrochen - siehe beigefügtes SmartFTP-Log.


Vielen Dank im voraus für deinen Rat.


Schöne Grüße

Micha


[09:16:57] SmartFTP v3.0.1016.13
[09:16:59] Ermittle IP zu Hostnamen <ZIEL-HOSTNAME>
[09:16:59] Proxy: Hostnamen <ASTARO> ermitteln.
[09:16:59] Verbindung mit <ZIEL-IP-ADRESSE> Port: 21
[09:16:59] Proxy: Verbinde zu HTTP Proxyserver <ASTARO> Port: <PROXYPORT>
[09:16:59] Proxy: Verbunden mit Proxyserver. Sende Verbindungsanfrage.
[09:16:59] Verbunden mit <ZIEL-HOSTNAME>.
[09:16:59] 220 ProFTPD 1.2.10 Server (ZIEL) [IP]
[09:16:59] USER <USER>
[09:16:59] 331 Password required for <USER>.
[09:16:59] PASS (unsichtbar)
[09:16:59] 230 Willkommen auf dem FTP-Server
[09:16:59] SYST
[09:17:00] 215 UNIX Type: L8
[09:17:00] Erkannter Servertyp: UNIX
[09:17:00] FEAT
[09:17:00] 211-Features:
[09:17:00] MDTM
[09:17:00] REST STREAM
[09:17:00] SIZE
[09:17:00] 211 End
[09:17:00] PWD
[09:17:00] 257 "/" is current directory.
[09:17:00] TYPE A
[09:17:00] 200 Type set to A
[09:17:00] PASV
[09:17:00] 227 Entering Passive Mode
[09:17:00] Proxy: Hostnamen <ASTARO> ermitteln.
[09:17:00] Öffne Datenverbindung zu <ZIEL-IP-ADRESSE> Port: 32944
[09:17:00] Proxy: Verbinde zu HTTP Proxyserver <ASTARO> Port: <PROXYPORT>
[09:17:00] LIST -aL
[09:17:00] Proxy: Verbunden mit Proxyserver. Sende Verbindungsanfrage.
[09:17:00] Proxy: Anfrage fehlgeschlagen. HTTP/1.0 403 Forbidden
[09:17:00] Eine bestehende Verbindung wurde softwaregesteuert
[09:17:00] durch den Hostcomputer abgebrochen.
Bitte warten ..
Mitglied: Sven-UP
30.05.2008 um 09:35 Uhr
Hallo Micha,

der transparente HTTP Proxy unterstütz kein FTP!


Gruß
Sven
Bitte warten ..
Mitglied: 65728
30.05.2008 um 10:28 Uhr
Hallo Sven,

danke für die prompte Antwort!

Legst du Wert auf die Feststellung, dass der transparente HTTP-Proxy kein FTP unterstützt oder der HTTP-Proxy im Allgemeinen?

Für eine Klarstellung wär ich dankbar.


Schöne Grüße
Micha
Bitte warten ..
Mitglied: Sven-UP
30.05.2008 um 10:31 Uhr
Hallo Micha,

wie schon geschrieben meinte ich ausschließlich den transparenten Proxy.

Der HTTP Proxy im Standard Modus kann FTP!


Gruß
Sven
Bitte warten ..
Mitglied: 65728
30.05.2008 um 10:43 Uhr
Hallo Sven,

auch nach Umstellung des HTTP-Proxies auf Standard ist mit SmartFTP keine Übertragung möglich.

Kannst du mir bitte einen FTP-Client benennen mit dem die Übertragung in dieser Proxy-Konfiguration nachweislich funktioniert?

Danke für deine Bemühungen!

Viele Grüße
Micha
Bitte warten ..
Mitglied: Sven-UP
30.05.2008 um 10:47 Uhr
Hallo Micha,

muss gehen mit dem Prog.

Proxy musst du wie folgt eintragen: IP:8080


Gruß
Sven
Bitte warten ..
Mitglied: 65728
30.05.2008 um 11:23 Uhr
Hallo Sven,

da SmartFTP extra anpries mit HTTP-Proxies umgehen zu können, wundert mich das ja auch so sehr.

Folgende Einstellungen in SmartFTP wurden vorgenommen:

Extras -> Einstellungen -> Favoriten -> bearbeiten -> Verbindung -> Proxy:
Typ: HTTP-Proxy - Verbindungstunnel
Hostcomputer: <PROXY-IP>
Port: 8080
Extras -> Einstellungen -> Favoriten -> bearbeiten -> FTP -> Verbindung -> Proxy:
Typ: ohne
Hostcomputer: <leer>
Port: <leer>

Folgende Einstellungen wurden in Astaro vorgenommen:

Proxies -> HTTP:
Status: enabled
Operation Mode: Standard
Log Level: Access Log
Anonymity: None
Allowed Networks: <MYNETWORK>
...
Caching: Disabled
Block CONNECT method on HTTP port: Disabled
No server keepalive: Disabled
Allowed Target Services: FTP, FTP-CONTROL, HTTP, HTTPS
TCP Port: 8080



Vielleicht läßt sich anhand meiner Einstellungen nachvollziehen, was hier quer schießt - ich bin ratlos.

Vielen Dank für deine Hilfe.

Grüße
Micha
Bitte warten ..
Mitglied: Sven-UP
30.05.2008 um 12:11 Uhr
Auf welchem FTP Server mit welchem Port greifst du denn zu?
Bitte warten ..
Mitglied: 65728
30.05.2008 um 14:27 Uhr
Hallo Sven!

Sind den meine SmartFTP-/Astaro-Einstellungen deiner Meinung nach korrekt?

Ich habe mehrere FTP-Server probiert, u.a. auch ftp://download.astaro.com:21
Im Speziellen benötigen unsere Planer schreibenden Zugriff (also nicht via IE) auf den FTP-Server eines Copy-Centers/Repro-Services unter ftp://ftp.copy-center.de:21 (hierfür ist eine vorliegende Registrierung beim Copy-Service notwendig).

Nur der Vollständigkeit halber:
Der ftp-Zugriff auf ftp://download.astaro.com:21 via IE7 klappt reibungslos - ich weiß also, dass der Server erreichbar ist - auch wenn vermutlich via IE7 eine andere Zugriffsart verwendet wird.


Vielen Dank für deinen Rat und schöne Grüße
Micha

EDIT: Port-Nummer hinzugefügt
Bitte warten ..
Mitglied: Sven-UP
30.05.2008 um 14:31 Uhr
Ich kenne das SmartFTP Programm nicht - aber nachdem was du schreibst sieht erstmal alles richtig aus.
Bitte warten ..
Mitglied: 65728
30.05.2008 um 14:55 Uhr
Aus deiner Antwort schließe ich, dass meine Astaro-Einstellungen augenscheinlich auch richtig sein sollten.

Um ausschließen zu können, dass der Fehler bei SmartFTP liegt, möchte ich gern noch einen anderen FTP-Client testen:
Kannst du (oder jemand anders der hier mitliest) mir einen anderen FTP-Client nennen, der via Astaro-HTTP-Proxy nachweislich funktioniert?

Vielen Dank für deine bisherigen Bemühungen dieses Problem zu lösen.


Grüße
Micha
Bitte warten ..
Mitglied: Sven-UP
30.05.2008 um 15:43 Uhr
Versuch es mal mit dem Total Commander.
Bitte warten ..
Mitglied: 65728
30.05.2008 um 15:57 Uhr
Hallo Sven,

ich habe noch CoreFTP LE v2.1 probiert - ebenso ohne Erfolg.
Mit Total Commander v7.02a hingegen funktioniert es (!) unter Verwendung des Proxys "HTTP-Proxy mit FTP-Unterstützung" - anzugeben in den "FTP:Verbindungsdetails" der jeweiligen Verbindung.

Lösung:
bei Verwendung der o.g. HTTP-Proxy-Einstellungen in Astaro (siehe mein Kommentar vom 30.05.2008 um 11:23:01 Uhr) funktioniert die FTP-Verbindung mit Total Commander unter Angabe des Proxys


Danke schön für deine Hilfe!

Gruß Micha


EDIT 2008-05-30_15:55: Das Löschen von Dateien ist anscheinend nicht möglich:
Es kommt die Fehlermeldung
01.
HTTP/1.0 501 Not implemented
Bitte warten ..
Mitglied: Sven-UP
30.05.2008 um 16:02 Uhr
Hallo Micha,

mit FlashFXP oder Filezilla FTP (Open-Source) funktioniert der Spass auch! Das löschen per HTTP Proxy funktioniert leider erst mit der V7 - ist also ein Update Wert!


Also dir ein schönes Wochenende!
Sven
Bitte warten ..
Mitglied: 65728
30.05.2008 um 16:25 Uhr
Hallo Sven,

habe es nochmal mit Filezilla getestet - dieses Programm habe ich als erstes probiert (aber über den ganzen Stress vergessen, dies zu erwähnen).
Mir ist jedoch nicht klar, wie die Proxy-Einstellungen in FileZilla lauten müssen - mit den dort angeboteten benutzerdefinierten Einstellungen komme ich nicht klar.

Kannst du mir ggf. deine Proxy-Einstellungen in Filezilla nennen?

Das Update auf V7 wird in nächster Zeit in Angriff genommen.


Vielen Dank und ein schönes Wochenende noch!

Micha
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
FTP Skript über Proxy
Frage von newit1Batch & Shell3 Kommentare

Hallo, ich versuche über ein Shell-Skript Daten auf einen FTP-Server hochzuladen. Ich scheitere leider am Proxy. Fehlermeldung: Wie muss ...

Windows 7

Automatisierter FTP download über Proxy?

gelöst Frage von MyApps2GO.deWindows 72 Kommentare

Servus zusammen, ich würde gerne einen automatisierten FTP abruf über einen Proxyserver machen. Also eigentlich bräuchte ich ein Programm ...

Webentwicklung

Webspace Ranking

Frage von malikaWebentwicklung5 Kommentare

Guten Tag, ich habe heute mit einem Webentwickler gesprochen und er meinte, wenn eine Website in Russland besseren Ranking ...

HTML

Empfehlung Webspace

Frage von WPFORGEHTML6 Kommentare

Hallo ich soll für eine Webseite ein zuverlässiges Hosting suchen. Es handelt sich dabei wohl um eine "reine" HTML ...

Neue Wissensbeiträge
Peripheriegeräte
Unterschrank für HP Drucker
Tipp von NixVerstehen vor 3 TagenPeripheriegeräte3 Kommentare

Als kurzen Freitags-Tipp möchte ich gerne meinen neuen Drucker-Unterschrank Modell Amica KS 15423W vorstellen. Das Gerät eignet sich hervorragend ...

Windows 10
Windows 10 - Probleme mit Point-And-Print
Tipp von emeriks vor 4 TagenWindows 103 Kommentare

Hi, wir kämpfen z.Z. mit einigen Druckertreibern, welche unter Win10 beim Verbinden eines Druckers von Printserver mit dem Dialog ...

Windows 10

Windows 10 1803 - Ihr Roamingbenutzerprofil wurde nicht vollständig synchronisiert

Anleitung von Deepsys vor 4 TagenWindows 101 Kommentar

Bei allen Windows 10 1803 PCs traten Probleme mit den Servergespeicherten Profilen auf. Das Abmelden dauerte sehr lange und ...

Exchange Server
Exchange - Fehler mit 2018-07 Sicherheitsupdate
Tipp von ArnoNymous vor 6 TagenExchange Server7 Kommentare

Hallo, es gibt mal wieder Freude mit den MS-Updates. KB4338814 führt dazu, dass der Exchange keine Mails mehr zustellt. ...

Heiß diskutierte Inhalte
Server-Hardware
DL380p Gen8 LEDs Laufwerksaktivität funktionieren nicht
gelöst Frage von Cisco7971Server-Hardware29 Kommentare

Hallo zusammen, ich habe hier ein seltsames Problem: Die LEDs an den Smart Carriern, die bei Laufwerksaktivität rotieren, tun ...

Windows Server
Leistungsindikatoren WS2012R2
Frage von Der.ITlerWindows Server20 Kommentare

Hallo Gemeinde, seit gestern habe ich auf zwei von meinem 8 Hardwareservern folgendes Problem, dass die Leistungsindikatoren nicht gestartet ...

VB for Applications
VBA - Vergleich eine Zelle mit einem Bereich
gelöst Frage von SilvanaSabauVB for Applications17 Kommentare

Hallo zusammen, ich hoffe es gibt jemanden der mir helfen kann !! das folgende Beispiel entspricht zwar nicht mein ...

Server-Hardware
Einsteigerfragen zu HP ProLiant DL380p Gen 8
gelöst Frage von brain2011Server-Hardware15 Kommentare

Hallo, ich habe mir einen HP ProLiant DL380p Gen 8 zugelegt, um mich grundlegend mit dieser Geräteklasse und der ...