Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Automatische Proxykonfiguration WPAD wird nicht übernommen (funktioniert nicht)

Mitglied: firehero29

firehero29 (Level 1) - Jetzt verbinden

22.09.2011, aktualisiert 17:50 Uhr, 17625 Aufrufe, 8 Kommentare

Hallo, ich habe ein Problem mit der automatischen Proxykonfiguration WPAD unter IE 8 und Firefox 6.0.2.

Ich habe folgende lokale WPAD Datei als wpad.dat abgespeichert:

function FindProxyForURL(url, host) {
return “PROXY 192.168.2.1:3128";
}

Im Internetexplorer und Firefox habe ich eingestellt, dass er eine automatische Proxykonfiguration verwenden soll, unter der Angabe des Dateipfades. Rufe ich allerdings nun irgendeine Website im Internet Explorer auf, erhalte ich die Fehlermeldung "Zeitüberschreitung".

Zudem habe ich auf meinem IIS Server eine Seite angelegt, die die wpad.dat Datei zur Verfügung stellt und auch beim direkten Ansprechen über den Webbrowser herunterladbar ist. In dnsmasq wurde ebenfalls ein Eintrag mit der dhcp-Option 252 vermerkt, zu dem direkten Verzeichnis. Trage ich nun die Einstellungen ebenfalls in IE oder Firefox ein, erhalte ich den gleichen Fehler.

Bei dem Proxy handelt es sich um einen squid 2.7 Staple 3 auf einem Debian 5.

Muss ich irgendwelche weiteren Ports auf dem proxy freischalten damit dieser reagiert? In den Logs des squid werden keine Einträge geschrieben.

Bei der direkten Eingabe der Proxyeinstellungen funktioniert alles wie gewünscht. Danke schonmal für Eure Hilfe!!!

Lieber Gruß firehero29
Mitglied: micneu
23.09.2011 um 13:41 Uhr
was setzt du als dhcp/dns server ein?
dor muß angegeben werden wo die datei runtergeladen werden kann.
siehe auch....
http://wiki.bsdforen.de/howto/automatische_proxy-konfiguration

gruß michael
Bitte warten ..
Mitglied: firehero29
23.09.2011 um 14:04 Uhr
Danke für deine Antwort. Wie bereits beschrieben verwende ich dnsmasq als DHCP und DNS Server.

Der Eintrag lautet entsprechen:

dhcp-option=252,http://192.168.2.14/wpad.dat
Bitte warten ..
Mitglied: firehero29
24.09.2011 um 11:09 Uhr
So, ich bin nun endlich ein Schritt weiter gekommen. Inzwischen funktioniert die automatische Proxykonfiguration unter Mac und Linux. Da wir allerdings in der Domäne Windowsrechner haben, ist dies natürlich ein Problem.

Es wurde nun mit Windows XP SP3 und Windows 7 ausprobiert - doch leider ohne Erfolg.

Die Einstellungen im dnsmasq lautet nun:
"dhcp-option=252,http://192.168.31.14/proxy.pac;

Hat jemand noch eine Idee woran es liegen könnte? Ich habe im Internet immer wieder einen Hinweis auf einen zusätzlichen DNS Eintrag für wpad gefunden. Was hat es mit diesem auf sich?

Danke für die Hilfe!
Bitte warten ..
Mitglied: firehero29
24.09.2011 um 11:40 Uhr
Das Problem wurde soeben gelöst.

Damit auch die Windows Clients auf die automatische Proxykonfiguration zugreifen können, muss zum einen die dhcp-option 252 wie folgt lauten

dhcp-option=252,http://wpad/wpad.dat

und es muss zusätzlich im DNS Server ein CNAME hinterlegt werden, die auf die entsprechende IP-Adresse/Seite verweist.

Ein zusätzlicher ipconfig /dnsflush löscht noch einmal den DNS Cache auf dem Client und ein ping wpad sollte eine erfolgreiche Auflösung bringen.

Anschließend nur noch das Häkchen im Internet Explorer auf "Automatische Proxykonfiguration im Netzwerk suchen" setzen und voila - es klappt!!!

Danke für die Hilfe!!! Lieber Gruß firehero29
Bitte warten ..
Mitglied: Ruffy1984
06.01.2012 um 11:18 Uhr
Hallo firehero,


was ist aber wenn ich kein DNS zur verfügung habe ?

Ich werde langsam wahnsiniig.

Grüße
Bitte warten ..
Mitglied: firehero29
06.01.2012 um 11:24 Uhr
Hallo Ruffy1984,

leider bin ich selber nicht so sonderlich mit der Materie vertraut. Allerdings weiß ich, dass der Windows Server 2008 von Haus aus erstmal wpad-Dateien blockiert. Hast Du dies rausgemacht? Ich habe ein entsprechenden Link gefunden. http://www.msxfaq.de/verschiedenes/wpad.htm

Auf was für einem System arbeitest Du den?

Gruüße firehero29
Bitte warten ..
Mitglied: Ruffy1984
06.01.2012 um 13:13 Uhr
Hallo firehero29,

ja genau, die Blockade habe ich schon rausgenommen. Ich benutze Windows xp Sp 3 clients, ich habe im Netz gelesen das dies nur noch mit einem DNS- Eintrag funktioniert.

Also meine Systeme :

ISA Server 2006
DHCP Server: Windows 2008 R2
Clients: Windows Xp SP3

Habe auf dem Isa alles soweit eingestellt und auf dem DHCP-Server den Eintrag, sobald ich KEIN DNS Eintrag habe funktioniert es nicht, wenn ich den DNS EIntrag erstellt ziehen die CLients sofort die WPAD.dat. Das Problem ist aber das ich in einer anderen Umgebung keine Zugriff auf das DNS habe und somit keinen WPAD CNAME erstellen kann.

Grüüüße Ruffy
Bitte warten ..
Mitglied: coltred
12.04.2012 um 12:38 Uhr
Hast du sichergestellt, dass deine wpad.dat vom Webserver mit folgendem Header ausgeliefert wird?

Content-Type: application/x-ns-proxy-autoconfig

s. auch http://de.wikipedia.org/wiki/Web_Proxy_Autodiscovery_Protocol

Prüfe die Header explizit mit fiddler (www.fiddlertool.com) oder einem Kommandozeilen wget (Option "-S")
Bitte warten ..
Ähnliche Inhalte
Exchange Server

Exchange 2013 fragt nach Proxykonfiguration

gelöst Frage von ukulele-7Exchange Server2 Kommentare

Sry für die vielen Posts, mein Exchange macht mich langsam irre. Ich habe einen Exchange 2013 auf Windows 2012 ...

Windows Netzwerk

Android und IE Proxykonfiguration WPAD.dat

Frage von aRanIoNWindows Netzwerk4 Kommentare

Hallo zusammen, ich teste seit kurzem die Proxykonfiguration mittels WPAD. Ich habe dort entsprechend eine Option im DHCP definiert ...

DNS

Kann wpad Eintrag nicht erstellen

gelöst Frage von Ex0r2k16DNS3 Kommentare

Guten Morgen zusammen, ich kann auf meinem w2k12r2 DNS keinen DNS Eintrag für den wpad IIS Server erstellen. Also ...

Windows Netzwerk

Windows 7 Clients: WPAD wird nicht gelesen

Frage von pdiddlWindows Netzwerk2 Kommentare

Hallo zusammen, seit ein paar Tagen haben wir in unserem Netzwerk folgendes Problem. PC's mit Windows 7 als Betriebbsystem ...

Neue Wissensbeiträge
Sonstige Systeme
Es war einmal ein BeOS - Wer erinnert sich noch?
Information von BassFishFox vor 1 TagSonstige Systeme5 Kommentare

Hallo, Bin gerade ueber Haiku gestolpert, von dessen Existenz als "Nachfolger des BeOS" ich wusste nur mich nie wirklich ...

Datenschutz

Microsoft und DSGVO - ob das wohl jemals klappt (Probleme beim Datenabfluss für Office Pro Plus)?

Tipp von VGem-e vor 1 TagDatenschutz3 Kommentare

Servus Kollegen, siehe Aber wer setzt schon MS Office Pro Plus ein? Wie dann der Stand beim "normalen" MS ...

Windows 10

Macht Windows 10.1809 Probleme mit gemappten Netzlaufwerken (betrifft wohl insbes. AMD-Hardware und Trend Micro AV-Produkte)?

Tipp von VGem-e vor 2 TagenWindows 103 Kommentare

Moin Kollegen, grad dazu gefunden und Hatten wir dies nicht bei früheren W10-Upgrades ebenfalls? Da bleibt nur, das Upgrade ...

Humor (lol)

Das neue Miniatur Wunderland OFFICIAL VIDEO - worlds largest model railway - railroad

Information von StefanKittel vor 2 TagenHumor (lol)2 Kommentare

Hallo, wer noch nie im Miniatur Wunderland war, sollte es dringend mal nachholen. Es gibt eine neues Video. Viele ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
Gäste-WLAN durch DD-WRT AP nach einem MikroTik Routerboard
Frage von NukolarLAN, WAN, Wireless16 Kommentare

Hallo, wie der Titel schon sagt möchte ich gerne ein Gäste-WLAN innerhalb eines bestehenden LANs einrichten. Dass die Gäste ...

DSL, VDSL
DSL Monitoring Tool - Quick and dirty?
Frage von george44DSL, VDSL15 Kommentare

Liebe Gemeinde, ich suche ein einfaches und vor allem schnell zu installierendes Monitoring-Tool zur kontinuierlichen Dokumentation (nur) der Internetanbindung. ...

Exchange Server
Outlook findet Postfach nicht
Frage von MaximaxExchange Server11 Kommentare

Hallo, und zwar haben wir auf der Arbeit ein kleines (großes) Exchange 2016 Problem. Exchange meldete gestern, dass die ...

Informationsdienste
Probleme auf dem Server
Frage von LangeLangeInformationsdienste9 Kommentare

Hallo zusammen, ich betreibe die Seite Keine Werbelinks. In der Analyse stellen wir fest, dass die Ladezeit in der ...