Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Autoproxykonf. läuft nicht

Mitglied: Schnick

Schnick (Level 1) - Jetzt verbinden

04.01.2006, aktualisiert 27.01.2008, 6430 Aufrufe, 11 Kommentare

Die automatische Erkennung der Proxyeinstellungen funktionieren nicht

Hallo,

ich möchste die Proxyeinstellungen nicht in jedem Browser immer noch Hand erweitern, sondern dies soll automatisch über eine zentrale Datei geschehen.
Hierfür habe ich eine WPAD.DAT -Datei erstellt und diese in ein Verzeichnis auf einen internen Webserver gelegt. Im DNS-Server wurde ebenfalls ein Eintrag gemacht. Also ein ping auf WPAD geht einwandfrei. WPAD zeigt auf ein Verzeichnis auf unserem internen Webserver. Wenn ich den Pfad direkt im Browser angebe, dann zeigt er mir den Inhalt der WPAD-Datei an. Leider finden die beiden Browser IE/FF nur nach sehr langem suchen den richtigen Weg in's Internet. Erst nach mehreren Minuten der Suche, öffnet er die Seite. Bein jedem weiteren Klick auf einen Link passiert erstmal minutenlang nichts. Der Browser hängt sich regelrecht auf. Hier nun meine Datei:

function FindProxyForURL(url, host)
{
if (isInNet(host, "192.168.59.0", "255.255.255.0"))
return "PROXY 10.10.10.55:8080";

if (dnsDomainIs(host, "intranet") || isInNet(host, "10.0.0.0", "255.240.0.0"))
return "DIRECT";

return "PROXY 10.10.10.50:8080";
}

Der Zugriff in das Internet geht über 2 ISA-Server (10.10.10.50 und 10.10.10.55)

Wenn ich die WPAD-DAT umbenenne in proxy.pac und im Browser den Pfad direkt angebe, dann funktioniert es besser. Der FF jedoch zeigt nach wie vor das gleiche Verhalten.

Hat vielleicht einer von Euch einen Tipp, was da falsch läuft?

Gruß

Viktor
Mitglied: 10545
04.01.2006 um 11:04 Uhr
Moin,

hmmm, soweit ich sehe, ist alles korrekt, aber:

function FindProxyForURL(url, host)
{
if (isInNet(host, "192.168.59.0",

Hast Du das "host" nur hier aus "Sicherheitsgründen" drinstehen? Da sollte Deine IP-Adresse stehen.

Gruß, Rene
Bitte warten ..
Mitglied: Schnick
04.01.2006 um 12:16 Uhr
Hi Rene,

host soll ja nicht auf meine IP beschränkt sein, sondern variabel. Die Clients laufen alle über DHCP.

Gruß

Viktor
Bitte warten ..
Mitglied: Schnick
05.01.2006 um 07:32 Uhr
Hi Ihr,

ich bin schon etwas weiter gekommen. Ich habe einmal die Logfiles für das wpad-Verzeichnis angeschaut und es sieht so aus als ob nur der FF auf die wpad.dat-Datei zugreift. Mit dem IE gibt es keine Zugriffe.

Gruß

Viktor
Bitte warten ..
Mitglied: Dani
07.01.2006 um 11:22 Uhr
Hi Vitor,
funktioniert dein WPAD in der zwischen zeit??
Bitte warten ..
Mitglied: Schnick
09.01.2006 um 07:47 Uhr
Hi,

leider noch nicht. Ich suche noch. Es könnte auch sein, daß es am DNS-Server liegt.

Warum der IE nicht auf die Datei zugreift, ist mir allerdings ein Rätsel. Der FF greift bei jedem Start auf die Datei zu.

Gruß

Viktor
Bitte warten ..
Mitglied: Schnick
09.01.2006 um 15:32 Uhr
Hi Ihr,

also der FF funktioniert jetzt.

Kann mir bitte mal einer erklären, wie der Zugriff des IE auf die WPAD.DAT Datei erfolgt? Nach was sucht der denn?? Der greift leider nicht auf die Datei zu. Warum macht der FF das, und der IE nicht? Kann es sein, daß der IE nicht nach einem WPAD-DNS-Eintrag sucht?


Gruß

Viktor
Bitte warten ..
Mitglied: Dani
09.01.2006 um 17:17 Uhr
Hab mir schon überlegt, obs im regedit n Eintrag gibt wo man ändern muss?!
Bitte warten ..
Mitglied: Schnick
10.01.2006 um 07:52 Uhr
Hi,

laut MicrosoftFAQ nicht. Das muß alles über DNS laufen. Sollte zumindest. Mir würde ja schon reichen wenn mir einer sagen könnte, wonach der IE eigentlich sucht?
Hier weitere Infos:

Der PC bekommt seine IP über DHCP. Dort ist der ISA/Proxy als GW eingetragen. Auf dem Client ist ebenfalls der ISA-Client installiert. Wenn ich im IE den Proxy direkt eintrage, geht alles. Wenn ich Ihn direkt in's LAN schicke, dann geht das INet ebenfalls. Nur bei der automatischen Suche geht das INet nicht. Egal ob mit oder ohne ISA-Client.

Schickt der IE jetzt seine Anfrage automatisch an den ISA/Proxy und der sucht dann nach WPAD/WSPAD? Kann auch nicht sein, da wie gesagt kein Zugriff auf die Datei stattfindet.

Ping auf wpad geht, sonst würde der FF nicht funktionieren. Was macht jetzt der FF anders, als der IE?

Gruß

Viktor
Bitte warten ..
Mitglied: Dani
12.01.2006 um 19:43 Uhr
Probier's mal mit dem Link. Is glaub zwar scho ein bisschen älter aber vielleicht hilfst dir.

http://www.msisafaq.de/Anleitungen/2000/Installation/wpad.htm
Bitte warten ..
Mitglied: Schnick
13.01.2006 um 07:57 Uhr
Hi,

also ich hab jetzt mal folgendes gemacht. Ich hab mir eine Testumgebung mit 3 Systemen (VMWare) aufgebaut. Einen Win2003-Server (AD,DHCP,DNS,IIS), einen ISA-2004 und einen WinXP-Client.
Auf dem IIS liegt die wpad.dat-Datei. Ping wpad geht. Wenn ich den FF auf dem XP-PC starte, dann greift dieser auf die wpad-Datei zu. Der IE jedoch nicht. Es ist auf dem Client kein ISA-Client installiert. Ich hab hier eine ganz gute Seite gefunden:

http://homepages.tesco.net/%7EJ.deBoynePollard/FGA/web-browser-auto-pro ...

Was bei Microsoft nirgends steht, daß man im IIS einen MIME-Type setzten muß auf .dat

Nur ich versteh nach wie vor nicht, warum der FF auf wpad geht, der IE jedoch nicht.

Wenn ich im IE in den Optionen sage, er soll automatisch nach der Proxyeinstellungen suchen, was sucht er denn genau und vor allem wonach? Wpad kann's ja nicht sein.

Gruß

Viktor
Bitte warten ..
Mitglied: leipy
27.01.2008 um 19:36 Uhr
Hallo !
Konntest Du inzwischen mehr herausfinden, wonach der IE sucht ?

Stehe im Moment vor demselben Problem, FF tut, nur IE mag net.

Danke und Gruss
Stefan
Bitte warten ..
Ähnliche Inhalte
E-Mail
Gmail läuft nicht
gelöst Frage von schattenhackerE-Mail10 Kommentare

Hallo, habe ein gmail email konto mit ca. 18000 mails. Mit incredimail konnte ich die bislang anschauen und bearbeiten. ...

Microsoft

Server Essentials Verwaltungsdienst läuft nicht

gelöst Frage von tomolpiMicrosoft10 Kommentare

Hallo, seit ca. 5h lässt mich unser Server 2012 R2 Essentials nicht mehr ins Dashboard. Grund: der "Windows Server ...

LAN, WAN, Wireless

Kein WLAN wenn IPTV läuft

Frage von technicosLAN, WAN, Wireless8 Kommentare

Hallo zusammen Mein Netzwerk ist volgendermassen aufgebaut: Das Problem ist nun, dass W-Lan router #2 ausgefallen/kaputt ist und ich ...

Batch & Shell

Batch Skript läuft merkwürdig.

Frage von pixel0815Batch & Shell15 Kommentare

Hallo zusammen, ich habe ein komisches Phänomen. Dieses unten stehende Skript läuft in einer Citrix Umgebung Dies dient dazu ...

Neue Wissensbeiträge
Windows 10

USB Maus und Tastatur versagen Dienst unter Windows 10

Erfahrungsbericht von hardykopff vor 1 StundeWindows 10

Da steht man ziemlich dumm da, wenn der PC sich wegen fehlender USB Tastatur und Maus nicht bedienen lässt. ...

Administrator.de Feedback
Update der Seite: Alles zentriert
Information von Frank vor 4 StundenAdministrator.de Feedback8 Kommentare

Hallo User, die größte Änderung von Release 5.8 ist das Zentrieren der Webseite (auf großen Bildschirmen) und ein "Welcome"-Teaser ...

Humor (lol)

WhatsApp-Nachrichten endlich auch per Bluetooth versendbar

Information von BassFishFox vor 22 StundenHumor (lol)4 Kommentare

Genau darauf habe ich gewartet! ;-) Der beliebte Messaging-Dienst WhatsApp erhält eine praktische neue Funktion: Ab dem nächsten Update ...

Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 1 TagGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Heiß diskutierte Inhalte
Server-Hardware
Welche Rolle spielt Design bei Enterprise IT Hardware?
Frage von ApolloXServer-Hardware17 Kommentare

Ich arbeite für einen internationalen Elektronikhersteller in der Forschung und meine Aufgabe ist es, Feedback von Nutzern in Hinsicht ...

Windows Netzwerk
WSUS4 und Windows 10 Updates automatisch installieren
Frage von sammy65Windows Netzwerk15 Kommentare

Hallo miteinander, ich habe mit einen neuen WSUS Server aufgesetzt Server 2016 darauf einen aktuellen WSUS. Grund, wir stellen ...

Switche und Hubs
Cisco SG350X-48 AdminIP in anderes VLAN
Frage von lcer00Switche und Hubs14 Kommentare

Hallo zusammen, ich habe ein Problem mir einem Cisco SG350X-48 bei der Erstinstallation wurde eine IP 192.168.0.254 (Default VLAN ...

Speicherkarten
Vergessliche USB-Sticks?
Frage von hanheikSpeicherkarten14 Kommentare

Ich habe in den letzten Tagen 500 USB-Sticks mit Bilddateien bespielt. Obwohl ich die Dateien mit größter Sorgfalt kopiert ...