Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Autoproxykonf. läuft nicht

Mitglied: Schnick

Schnick (Level 1) - Jetzt verbinden

04.01.2006, aktualisiert 27.01.2008, 6536 Aufrufe, 11 Kommentare

Die automatische Erkennung der Proxyeinstellungen funktionieren nicht

Hallo,

ich möchste die Proxyeinstellungen nicht in jedem Browser immer noch Hand erweitern, sondern dies soll automatisch über eine zentrale Datei geschehen.
Hierfür habe ich eine WPAD.DAT -Datei erstellt und diese in ein Verzeichnis auf einen internen Webserver gelegt. Im DNS-Server wurde ebenfalls ein Eintrag gemacht. Also ein ping auf WPAD geht einwandfrei. WPAD zeigt auf ein Verzeichnis auf unserem internen Webserver. Wenn ich den Pfad direkt im Browser angebe, dann zeigt er mir den Inhalt der WPAD-Datei an. Leider finden die beiden Browser IE/FF nur nach sehr langem suchen den richtigen Weg in's Internet. Erst nach mehreren Minuten der Suche, öffnet er die Seite. Bein jedem weiteren Klick auf einen Link passiert erstmal minutenlang nichts. Der Browser hängt sich regelrecht auf. Hier nun meine Datei:

function FindProxyForURL(url, host)
{
if (isInNet(host, "192.168.59.0", "255.255.255.0"))
return "PROXY 10.10.10.55:8080";

if (dnsDomainIs(host, "intranet") || isInNet(host, "10.0.0.0", "255.240.0.0"))
return "DIRECT";

return "PROXY 10.10.10.50:8080";
}

Der Zugriff in das Internet geht über 2 ISA-Server (10.10.10.50 und 10.10.10.55)

Wenn ich die WPAD-DAT umbenenne in proxy.pac und im Browser den Pfad direkt angebe, dann funktioniert es besser. Der FF jedoch zeigt nach wie vor das gleiche Verhalten.

Hat vielleicht einer von Euch einen Tipp, was da falsch läuft?

Gruß

Viktor
Mitglied: 10545
04.01.2006 um 11:04 Uhr
Moin,

hmmm, soweit ich sehe, ist alles korrekt, aber:

function FindProxyForURL(url, host)
{
if (isInNet(host, "192.168.59.0",

Hast Du das "host" nur hier aus "Sicherheitsgründen" drinstehen? Da sollte Deine IP-Adresse stehen.

Gruß, Rene
Bitte warten ..
Mitglied: Schnick
04.01.2006 um 12:16 Uhr
Hi Rene,

host soll ja nicht auf meine IP beschränkt sein, sondern variabel. Die Clients laufen alle über DHCP.

Gruß

Viktor
Bitte warten ..
Mitglied: Schnick
05.01.2006 um 07:32 Uhr
Hi Ihr,

ich bin schon etwas weiter gekommen. Ich habe einmal die Logfiles für das wpad-Verzeichnis angeschaut und es sieht so aus als ob nur der FF auf die wpad.dat-Datei zugreift. Mit dem IE gibt es keine Zugriffe.

Gruß

Viktor
Bitte warten ..
Mitglied: Dani
07.01.2006 um 11:22 Uhr
Hi Vitor,
funktioniert dein WPAD in der zwischen zeit??
Bitte warten ..
Mitglied: Schnick
09.01.2006 um 07:47 Uhr
Hi,

leider noch nicht. Ich suche noch. Es könnte auch sein, daß es am DNS-Server liegt.

Warum der IE nicht auf die Datei zugreift, ist mir allerdings ein Rätsel. Der FF greift bei jedem Start auf die Datei zu.

Gruß

Viktor
Bitte warten ..
Mitglied: Schnick
09.01.2006 um 15:32 Uhr
Hi Ihr,

also der FF funktioniert jetzt.

Kann mir bitte mal einer erklären, wie der Zugriff des IE auf die WPAD.DAT Datei erfolgt? Nach was sucht der denn?? Der greift leider nicht auf die Datei zu. Warum macht der FF das, und der IE nicht? Kann es sein, daß der IE nicht nach einem WPAD-DNS-Eintrag sucht?


Gruß

Viktor
Bitte warten ..
Mitglied: Dani
09.01.2006 um 17:17 Uhr
Hab mir schon überlegt, obs im regedit n Eintrag gibt wo man ändern muss?!
Bitte warten ..
Mitglied: Schnick
10.01.2006 um 07:52 Uhr
Hi,

laut MicrosoftFAQ nicht. Das muß alles über DNS laufen. Sollte zumindest. Mir würde ja schon reichen wenn mir einer sagen könnte, wonach der IE eigentlich sucht?
Hier weitere Infos:

Der PC bekommt seine IP über DHCP. Dort ist der ISA/Proxy als GW eingetragen. Auf dem Client ist ebenfalls der ISA-Client installiert. Wenn ich im IE den Proxy direkt eintrage, geht alles. Wenn ich Ihn direkt in's LAN schicke, dann geht das INet ebenfalls. Nur bei der automatischen Suche geht das INet nicht. Egal ob mit oder ohne ISA-Client.

Schickt der IE jetzt seine Anfrage automatisch an den ISA/Proxy und der sucht dann nach WPAD/WSPAD? Kann auch nicht sein, da wie gesagt kein Zugriff auf die Datei stattfindet.

Ping auf wpad geht, sonst würde der FF nicht funktionieren. Was macht jetzt der FF anders, als der IE?

Gruß

Viktor
Bitte warten ..
Mitglied: Dani
12.01.2006 um 19:43 Uhr
Probier's mal mit dem Link. Is glaub zwar scho ein bisschen älter aber vielleicht hilfst dir.

http://www.msisafaq.de/Anleitungen/2000/Installation/wpad.htm
Bitte warten ..
Mitglied: Schnick
13.01.2006 um 07:57 Uhr
Hi,

also ich hab jetzt mal folgendes gemacht. Ich hab mir eine Testumgebung mit 3 Systemen (VMWare) aufgebaut. Einen Win2003-Server (AD,DHCP,DNS,IIS), einen ISA-2004 und einen WinXP-Client.
Auf dem IIS liegt die wpad.dat-Datei. Ping wpad geht. Wenn ich den FF auf dem XP-PC starte, dann greift dieser auf die wpad-Datei zu. Der IE jedoch nicht. Es ist auf dem Client kein ISA-Client installiert. Ich hab hier eine ganz gute Seite gefunden:

http://homepages.tesco.net/%7EJ.deBoynePollard/FGA/web-browser-auto-pro ...

Was bei Microsoft nirgends steht, daß man im IIS einen MIME-Type setzten muß auf .dat

Nur ich versteh nach wie vor nicht, warum der FF auf wpad geht, der IE jedoch nicht.

Wenn ich im IE in den Optionen sage, er soll automatisch nach der Proxyeinstellungen suchen, was sucht er denn genau und vor allem wonach? Wpad kann's ja nicht sein.

Gruß

Viktor
Bitte warten ..
Mitglied: leipy
27.01.2008 um 19:36 Uhr
Hallo !
Konntest Du inzwischen mehr herausfinden, wonach der IE sucht ?

Stehe im Moment vor demselben Problem, FF tut, nur IE mag net.

Danke und Gruss
Stefan
Bitte warten ..
Ähnliche Inhalte
E-Mail
Gmail läuft nicht
gelöst Frage von schattenhackerE-Mail10 Kommentare

Hallo, habe ein gmail email konto mit ca. 18000 mails. Mit incredimail konnte ich die bislang anschauen und bearbeiten. ...

Microsoft

Server Essentials Verwaltungsdienst läuft nicht

gelöst Frage von tomolpiMicrosoft10 Kommentare

Hallo, seit ca. 5h lässt mich unser Server 2012 R2 Essentials nicht mehr ins Dashboard. Grund: der "Windows Server ...

LAN, WAN, Wireless

Kein WLAN wenn IPTV läuft

Frage von technicosLAN, WAN, Wireless8 Kommentare

Hallo zusammen Mein Netzwerk ist volgendermassen aufgebaut: Das Problem ist nun, dass W-Lan router #2 ausgefallen/kaputt ist und ich ...

Batch & Shell

Batch Skript läuft merkwürdig.

Frage von pixel0815Batch & Shell15 Kommentare

Hallo zusammen, ich habe ein komisches Phänomen. Dieses unten stehende Skript läuft in einer Citrix Umgebung Dies dient dazu ...

Neue Wissensbeiträge
Sonstige Systeme
Es war einmal ein BeOS - Wer erinnert sich noch?
Information von BassFishFox vor 1 TagSonstige Systeme5 Kommentare

Hallo, Bin gerade ueber Haiku gestolpert, von dessen Existenz als "Nachfolger des BeOS" ich wusste nur mich nie wirklich ...

Datenschutz

Microsoft und DSGVO - ob das wohl jemals klappt (Probleme beim Datenabfluss für Office Pro Plus)?

Tipp von VGem-e vor 1 TagDatenschutz3 Kommentare

Servus Kollegen, siehe Aber wer setzt schon MS Office Pro Plus ein? Wie dann der Stand beim "normalen" MS ...

Windows 10

Macht Windows 10.1809 Probleme mit gemappten Netzlaufwerken (betrifft wohl insbes. AMD-Hardware und Trend Micro AV-Produkte)?

Tipp von VGem-e vor 1 TagWindows 103 Kommentare

Moin Kollegen, grad dazu gefunden und Hatten wir dies nicht bei früheren W10-Upgrades ebenfalls? Da bleibt nur, das Upgrade ...

Humor (lol)

Das neue Miniatur Wunderland OFFICIAL VIDEO - worlds largest model railway - railroad

Information von StefanKittel vor 1 TagHumor (lol)2 Kommentare

Hallo, wer noch nie im Miniatur Wunderland war, sollte es dringend mal nachholen. Es gibt eine neues Video. Viele ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
Gäste-WLAN durch DD-WRT AP nach einem MikroTik Routerboard
Frage von NukolarLAN, WAN, Wireless16 Kommentare

Hallo, wie der Titel schon sagt möchte ich gerne ein Gäste-WLAN innerhalb eines bestehenden LANs einrichten. Dass die Gäste ...

DSL, VDSL
DSL Monitoring Tool - Quick and dirty?
Frage von george44DSL, VDSL15 Kommentare

Liebe Gemeinde, ich suche ein einfaches und vor allem schnell zu installierendes Monitoring-Tool zur kontinuierlichen Dokumentation (nur) der Internetanbindung. ...

Exchange Server
Outlook findet Postfach nicht
Frage von MaximaxExchange Server11 Kommentare

Hallo, und zwar haben wir auf der Arbeit ein kleines (großes) Exchange 2016 Problem. Exchange meldete gestern, dass die ...

Viren und Trojaner
Virus gefunden Mailanhang
Frage von MartyMcFlurry90Viren und Trojaner10 Kommentare

Hallo zusammen, sind eine kleine Firma und mein Virenschutz hat mir heute diese Meldung als Report geliefert. Meiner Recherche ...