Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Autostart und Schleifenkonstruktionen

Mitglied: SamTrex

SamTrex (Level 1) - Jetzt verbinden

14.08.2006, aktualisiert 15.08.2006, 3926 Aufrufe, 2 Kommentare

Hallo mal wieder!
Ich möchte mich mit zwei Fragen an euch wenden ...
Es geht um .Net in VB Studio 2005

1.
Eine Windows Applikation beginnt ja mit:
Private Sub frmMAIN_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

Aber alles was ich darin ausführe wird mir nicht angezeigt, da die App ja noch läd. So habe ich bisher immer einen "Start-Button" einsetzen müssen. Welche Möglichkeit habe ich, das die Form läd und anschließend ein Sub ausführt?

2.
Ich habe folgende Schleife:
Do
PB.Value = PB.Minimum
Do
PB.Value += 1
Thread.Sleep(100)
Loop Until PB.Value = PB.Maximum
If but_STATUSHOLD.Checked = True Then Exit Sub
Loop



Wenn ich jetz in meiner Form den Button but_STATUSHOLD anklicke verreckt mir die ganze Anwendung.
Im Prinziep soll die Anwendung eigentlich nur ein Progressbar anzeigen. Um eine Warte oder Ruhestellung zu simulieren.
Sprich but_STANDBY -> Progressbar Marquee laufen lassen
Wird dann but_STATUSHOLD geklickt -> Progressbar anhalten

Kann mir da wer helfen?
Bin neu auf dem Gebiet und brüte schon den ganzen Abend daran....

Danke im Voraus.
Gruß Sam
Mitglied: maneich
15.08.2006 um 00:58 Uhr
Hallo,

ich kenne mich zwar mit VB Studio nicht so aus, aber die MS-Scriptsprachen habe alle ziemlich die gleiche Logic.

Du hast 2 mal do und 3 mal loop, das passt nicht zusammen, jedes do benötigt nur ein loop.

Darüber hinaus kannst du in ener if-Abfrage zwar do > loop ausführen, aber nicht loop ohne vorher end if, wenn do ausßerhalb von if... steht.

MfG maneich
Bitte warten ..
Mitglied: SamTrex
15.08.2006 um 13:36 Uhr
Ja, danke für den Hinweis mit dem Loop. War ein kopierfehler von mir. In der App stimmte es aber. Nur wie kann ich währen die App mit der Schleife beschäftigt ist einen Button ändern ohne das mir alles abstürzt?
Habe schon versucht die Progressbar auf einen eigenen Thread zu legen, nur bekomme ich die Parameter nicht übergeben. Und wenn ich das nicht tue sagt er mir das ein Thread einen nicht erlaubten Zugriff auf eine Variable versucht.

Gruß Dirk
Bitte warten ..
Ähnliche Inhalte
Windows 7
Firewall im Autostart ?
Frage von michi-monsterWindows 78 Kommentare

Halli, seit einem Update o.Ä. wird die Firewall nicht automatisch beim Booten aktiviert. Ich habe im WIN Menü bzw. ...

Windows Server
Autostart einer MMC
gelöst Frage von manuel1985Windows Server3 Kommentare

Hi, kurze, vermutlich doofe Frage: Kann ich unter Windows Server 2012 R2/Windows 8.1 den Hyper-V Manager in den Autostart ...

Windows 7
USB Autostart
gelöst Frage von H4XOuVWindows 738 Kommentare

Hi, Folgendes Problem: Ich möchte das mein USB-Stick beim einstecken eine Batch-Datei ausführt. Bis jetzt habe ich jedoch nur ...

Windows 7
Autostart ohne Eintrag
gelöst Frage von ProfilkillerWindows 76 Kommentare

Hallo, Nach einem Upgrade unserer CNC Fräse mit einem neuen PC lief erstmal alles gut. Doch seit ein paar ...

Neue Wissensbeiträge
Windows 10

USB Maus und Tastatur versagen Dienst unter Windows 10

Erfahrungsbericht von hardykopff vor 2 TagenWindows 105 Kommentare

Da steht man ziemlich dumm da, wenn der PC sich wegen fehlender USB Tastatur und Maus nicht bedienen lässt. ...

Administrator.de Feedback
Update der Seite: Alles zentriert
Information von Frank vor 2 TagenAdministrator.de Feedback18 Kommentare

Hallo User, die größte Änderung von Release 5.8 ist das Zentrieren der Webseite (auf großen Bildschirmen) und ein "Welcome"-Teaser ...

Humor (lol)

WhatsApp-Nachrichten endlich auch per Bluetooth versendbar

Information von BassFishFox vor 3 TagenHumor (lol)4 Kommentare

Genau darauf habe ich gewartet! ;-) Der beliebte Messaging-Dienst WhatsApp erhält eine praktische neue Funktion: Ab dem nächsten Update ...

Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 3 TagenGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Heiß diskutierte Inhalte
Router & Routing
Router auf Orginal Firmware zurück flashen mit Tftpd
Frage von ILeonardRouter & Routing21 Kommentare

Hallo, Ich habe zwei Router, einmal TP-Link 841n v11 und TP-Link 940N v5. Ich wollte fragen, ob jemand mir ...

Router & Routing
WRT keine Verbindung zum Web Interface
gelöst Frage von ILeonardRouter & Routing18 Kommentare

Hallo, Ich habe einen TP-Link WR841n mit wrt geflasht, das Problem ist ich kann mich mit 192.168.1.1 nicht verbinden. ...

Windows Server
Standortvernetzung zu einem Strato VServer (Windows)
Frage von matzefratze81Windows Server10 Kommentare

Moin, ich komme aus einem Enterprise-Umfeld und habe den Fehler gemacht, dass ich mich auf ein kleines Unternehmen eingelassen ...

TK-Netze & Geräte
Telefonie zweier Fritzboxen mit je eigenem DSL Anschluss verbinden
Frage von hannsgmaulwurfTK-Netze & Geräte10 Kommentare

Hallo zusammen, ich habe hier einen Haushalt mit zwei Anschlüssen. Einmal ISDN, einmal DSL. An jedem Anschluss hängt eine ...