Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Batch-Aufgabe unter Vista

Mitglied: der-nickel

der-nickel (Level 1) - Jetzt verbinden

31.03.2008 um 16:48 Uhr, 8438 Aufrufe, 8 Kommentare

Hallo,

wir haben bei uns folgendes Problem:

Wir setzen zum ersten mal Windows Vista Business bei uns im Unternehmen ein und sind schnell auf erste Probleme gestoßen. Wir möchten in der Aufgabenplanung einen Task hinterlegen, welcher via ERUNT den Systemstatus der Maschine sichert. Das Tool an sich funktioniert und auch via Batch-File lässt sich die Sicherung starten. Lege ich jedoch einen Task an welcher dieses Batch-Script aufrufen soll, führt er den Task zwar durch, das Script an sich wird aber nicht gestartet. Ich erhalte weder eine Fehlermeldung noch sonst irgendeinen Hinweis. Hat jemand von euch ein ähnliches Problem? Ich wüsste gern wie ich dieses Problem beheben kann.

Auch ist es nicht möglich den "ausführenden Benutzer" zu ändern, da er ein Problem mit dem eigentlichen Domänen-Namen und dem NetBios-Namen hat und den vollen Namen des Domänen-Benutzers nicht übernimmt. (sub-domäne: bln.firma.de NetBios: XXBLN) Folgerichtig kann er den User in der Domäne anschließend nicht finden, da er nach dem User bln\benutzer sucht?! eigentlich müsste es aber XXBLN\benutzer heißen.

Für Abhilfe wäre ich sehr dankbar!

Viele Grüße und vielen Dank im Vorraus...

Sebastian
Mitglied: der-nickel
24.03.2009 um 12:41 Uhr
Hallo,

Dies ist ein bekannter Bug in Vista/Server 2008... einen Hotfix dafür gibt es hier:

http://support.microsoft.com/kb/953153/de

Umgehen lässt sich das Problem auch, indem man den Task auf einer 2003er Maschine erstellt und in die 'Geplante Tasks'-Freigabe auf den Server 2008 kopiert. Aber ein eher unschöner Weg.

Gruß,

Sebastian
Bitte warten ..
Mitglied: 71988
11.06.2009 um 21:45 Uhr
aber es löst nicht das problem das der task ergebnislos abläuft, ich hab das selbe problem unter server 2008, die batch läuft durch, laut verlauf auch alles Reibungslos aber es passiert nichts.
Bitte warten ..
Mitglied: der-nickel
11.06.2009 um 21:58 Uhr
Hallo Hector,

in unserem Fall hat es das Problem tatsächlich gelöst. Also die Tasks laufen einwandfrei. Hast du mal geprüft, ob der User, welcher den Task ausführt die Berechtigung "Anmelden als Stapelverarbeitung" hat? Dazu gibt es eine Domänenrichtlinie...

Viele Grüße,

Sebastian
Bitte warten ..
Mitglied: 71988
12.06.2009 um 06:18 Uhr
Hm schau ich nachher mal, den hotfix hab ich noch nicht eingespielt, weil ich eben zu dem Problem nichts gelesen hab und es ging auch schon mal. Die Benutzerrechte sind Admins bis her aber ich schau mal wegen der Stapelverarbeitung.

Danke
Gruß
Hector

edit:

So ich hab nur "Anmeldung als Stapelverarbeitungsauftrag" gefunden :/
Bitte warten ..
Mitglied: 71988
15.06.2009 um 11:19 Uhr
wobei ich inzwischen nicht mehr glaube, dass es an Dateirechten liegt, da auch von der Console aus ich die Datei, in meinem Falle, nicht umbennen kann, per klick mit der Maus kein Thema aber per "ren" nein :>
Bitte warten ..
Mitglied: der-nickel
15.06.2009 um 12:18 Uhr
Zitat von 71988:

So ich hab nur "Anmeldung als Stapelverarbeitungsauftrag"
gefunden :/

Hallo Hector,

genau das ist es. Der User unter dem der Task ausgeführt wird muss diese Berechtigung erhalten. Erst dann darf der Task Batch-Files auch komplett ausführen.

Viele Grüße,

Sebastian
Bitte warten ..
Mitglied: Biber
15.06.2009 um 12:25 Uhr
Moin Hector,

<OT>
, nicht umbennen kann
#401
</OT>

da auch von der Console aus ich die Datei, in meinem Falle, nicht ...
Das ist jetzt aber ein ganz anderer Film als oben, oder?
Der Thread fing doch an mit "das (Task-)Script an sich wird aber nicht gestartet" ???
Und von daher kam der-nickel ja auf "keine Rechte zum Task-starten".

Was Du jetzt erzählst, lässt aber eher darauf schließen, dass ein, zwei Codezeilen in der Batchdatei ein bisschen zu flapsig und zu optimistisch formuliert sind.

Poste doch bitte mal Dein Task-Skript, soweit sachdienlich.
Oder startet es nach wie vor gar nicht?

Grüße
Biber
Bitte warten ..
Mitglied: 71988
16.06.2009 um 19:38 Uhr
Hi, hab den wahren Grund gefunden

Die Option "Ausführen in" ist nicht wirklich optional sondern zwingend wenn man die Batch in einem bestimmten Ordner arbeiten lassen will

Gruß
Hector
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
Batch Aufgabe mit Logfile
gelöst Frage von CAPO123Batch & Shell2 Kommentare

Hallo zusammen, ich habe bereits eine Batch Datei XY, die funktioniert. Meine Aufgabe ist es nun ein Logfile für ...

Windows 7
Hilfe bei Batch Aufgabe (Anfänger)
Frage von Miss-carrieWindows 73 Kommentare

Hallo, ich habe ein Beispiel bekommen von meinem Ausbildner und komme leider überhaupt nicht weiter und würde euch daher ...

Batch & Shell

Komplexe (möchst Batch)-Aufgabe programmierbar?

gelöst Frage von Peter32Batch & Shell2 Kommentare

Hallo liebe Administratoren, ich hoffe, ihr könnt mir bei folgender Problematik weiterhelfen - möglichst per Batch - wenn es ...

Entwicklung

Aufgabe zum überprüfen einer anderen Aufgabe

Frage von treshaEntwicklung4 Kommentare

Hallo Gemeinde! Ich möchte ein Skript erstellen, die eine Aufgabe überprüft und evtl "repariert" (also die auftretenden Fehler behebt). ...

Neue Wissensbeiträge
Ausbildung

Linux-Ausstieg in Niedersachsen - Windows statt Bugfix

Information von StefanKittel vor 2 TagenAusbildung35 Kommentare

Sind ja nur Steuergelder

Speicherkarten

Neuer Speicherkartentyp - zunächst nur für Huawei-Smartphones (künftig auch für Notebooks u. Tablets?)

Tipp von VGem-e vor 4 TagenSpeicherkarten5 Kommentare

Servus, als ob das "Chaos" i.S. Speicherkarten noch nicht groß genug wäre?! Evtl. kommt dieser neue Kartentyp bald auch ...

Sicherheit

Diverse D-Link-Router durch drei Schwachstellen kompromittierbar

Information von kgborn vor 4 TagenSicherheit1 Kommentar

Hat jemand D-Link-Router in Verwendung? Einige Modelle sind sicherheitstechnisch offen wie ein Scheunentor. Äußerst unschöne Sache, aber nichts neues ...

Hardware

100.000 Mikrotik-Router ungefragt von Hacker abgesichert

Information von 7Gizmo7 vor 5 TagenHardware4 Kommentare

Hallo zusammen, da hier ja öfters mal von Mikrotik gesprochen wird. Trotz Updates klafft eine Sicherheitslücke in Hundertausenden Mikrotik-Routern. ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Passwortwechsel Zeitpunkt festlegen
Frage von Looser27Windows Userverwaltung27 Kommentare

Guten Morgen liebe Kolleginnen und Kollegen, da es eine Userin in meinem Urlaub geschafft hat, sich vom AD vollständig ...

Windows Server
Probleme im AD am Außenstandort
gelöst Frage von emeriksWindows Server19 Kommentare

Hi, wir haben ein Problem mit AD und GPO am Außenstandort und ich stehe momentan mächtig auf dem Schlauch. ...

Switche und Hubs
POE-Switche
gelöst Frage von MiStSwitche und Hubs13 Kommentare

Guten Morgen, ich überlege ob ich in unserem Netzwerk die aktuellen Switche (D-LINK DGS-1210-28) durch PoE-Switche ersetzen soll. Der ...

Windows Server
DNS - Bedingte Weiterleitung
gelöst Frage von m8ichaelWindows Server11 Kommentare

Guten Tag zusammen, ich stehe gerade bzgl. einer bedingten DNS-Weiterleitung etwas auf dem Schlauch: Ich möchte, dass für bestimmte ...