Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Batch in batch in der Aufgabenplanung?

Mitglied: FLX1990

FLX1990 (Level 1) - Jetzt verbinden

15.01.2013 um 13:01 Uhr, 2684 Aufrufe, 3 Kommentare

Hallo,

ich muss für einen Win08-Server einen Task planen.
Das macht man ja seit neusten in der Aufgabenplanung.

Problem ist, dass ich rake (Ruby) benutze, falls das jemand kennt, und rake selber ne batch-Datei ist.

Irgendwie will das nicht funktionieren, also die batch wird ausgeführt nur der Befehl, der die andere Batch ausführt nicht.
Ich habe das getestet indem ich einfach ein notepad.exe hinten an die batch gehangen habe. Und der editor lief dann auch im hintergrund als Prozess ab... Nur mein rake-Kommando nicht.
Warum?

So sieht das Kommando aus:

rake redmine:email:receive_imap RAILS_ENV="production" host=outlookv.server.com username=redmine password=* allow_override=tracker,priority

probiert habe ich auch

call rake.bat redmine:email:receive_imap RAILS_ENV="production" host=outlookv.server.com username=redmine password=* allow_override=tracker,priority

oder

start rake.bat redmine:email:receive_imap RAILS_ENV="production" host=outlookv.server.com username=redmine password=* allow_override=tracker,priority

leider ohne erfolg...


Führe ich die Batch jeodch normal über cmd oder doppelklick aus, läuft alles wunderbar...
Also leigt es wohl an der Aufgabenplanung.


Auf meinem Server laufen auch ein paar BackUp-Scripte, die so aussehen und funktionieren:

filedump_redmine.bat:
del C:\xampp\Backup\redmine.zip
C:\Programme\7-Zip\7z.exe a C:\xampp\Backup\redmine.zip "C:\xampp\Redmine"


Hoffe ihr könnt mir weiterhelfen...
Mitglied: M.Gluschke
15.01.2013 um 20:17 Uhr
Hi,

also ich hab das jetzt gerade einmal bei mir getestet. Bei einer anderen Batch hat er bei mir auch abgebrochen das stimmt und notepad.exe wurde ganz normal ausgeführt.

Aber ich glaube das er die notepade Exe nur deshalb ausführt weil der Pfad Windows so ja automatisch bekannt ist.

Hab dann einmal versucht in der Batch die 2. Batch mit Pfad anzugeben und dann hatte es zumindest bei mir funktioniert. Kenne mich so jetzt nicht mit Rake aus. Weiß zwar was es ist aber das wars auch.

Was ich auch einmal hatte bei einem Kunden wo ich eine SQL Sicherung eingerichtet hatte, da habe ich ganz normal mit "ping 127.0.0.1" eine künstliche kurze Pause erzeugt damit die anderen sachen erst laufen konnten und dann ist das dort auch gelaufen.
Bitte warten ..
Mitglied: FLX1990
16.01.2013 um 07:59 Uhr
hallo,

erstmal danke für die antwort...

also das mit der Pfadangabe hat leider nicht funktioniert:
C:\xampp\Tools\Ruby\bin\rake.bat redmine:email:receive_imap RAILS_ENV="production" host=outlookv.server.com username=redmine password=* allow_override=tracker,priority

was mir die Pause bringen soll, bei einem einzige auszuführenden Kommando verstehe ich nicht ganz.

Sonst noch Ideen?

Gruß
Bitte warten ..
Mitglied: FLX1990
16.01.2013 um 08:33 Uhr
Also das funktioniert wohl nicht... ich weiß leider nicht warum.
Der Batch lag im Ordner C:\xampp\Redmine, wo die rakefile auch leigt.

Ich führe den batch jetzt aus einem anderen Ordner aus und übergebe die rakefile mittels eines f-Switches:
rake -f C:\xampp\Redmine\rakefile redmine:email:receive_imap RAILS_ENV="production" host=outlookv.server.com username=redmine password=*** allow_override=tracker,priority

Jetzt läuft es komischer Weise.
Berechtigungen der beiden Ordner sind identisch.
komisch... nunja hauptsache es läuft jetzt :D
Bitte warten ..
Ähnliche Inhalte
Batch & Shell

WinSCP in einer Batch starten durch Aufgabenplanung

gelöst Frage von Xanathos57Batch & Shell13 Kommentare

Hallo zusammen, ich hätte da ein Problem. Ich will mittels einer Aufgabenplanung eine Batch-Datei ausführen lassen. In der genannten ...

Windows Server

Batch-Datei startet in der Aufgabenplanung nicht

gelöst Frage von koehloWindows Server12 Kommentare

Hallo zusammen, ich bekomme das einfach nicht hin und hoffe jetzt auf Hilfe von den Profis. Ich arbeite mit ...

Windows 7

Batch über Aufgabenplanung ausführen

gelöst Frage von chef1568Windows 74 Kommentare

Hallo zusammen, ich möchte folgendes Skript via Aufgabenplanung Win7 64Bit ausführen. Als Aktion habe ich folgende Einstellung: Aktion Programm ...

Batch & Shell

Batch Datei wird per Aufgabenplanung nicht ausgeführt

Frage von CorraggiounoBatch & Shell7 Kommentare

Hi, ich hoffe ihr könnt mir weiterhelfen. Folgende Konfiguration habe ich vorgenommen um ein batch-script auszuführen: Unter Programm/Skript habe ...

Neue Wissensbeiträge
Humor (lol)

WhatsApp-Nachrichten endlich auch per Bluetooth versendbar

Information von BassFishFox vor 1 StundeHumor (lol)

Genau darauf habe ich gewartet! ;-) Der beliebte Messaging-Dienst WhatsApp erhält eine praktische neue Funktion: Ab dem nächsten Update ...

Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 14 StundenGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Sicherheit

Intel gibt neue Spectre V2-Microcode-Updates frei (20.02.2018)

Information von kgborn vor 14 StundenSicherheit

Intel hat zum 20. Februar 2018 weitere Microcode-Updates für OEMs freigegeben, um Systeme mit neueren Prozessoren gegen die Spectre ...

Microsoft
ARD-Doku - Das Microsoft Dilemma
Tipp von Knorkator vor 18 StundenMicrosoft3 Kommentare

Hallo zusammen, vor einigen Tagen lief in der ARD u.a. Reportage. Das Youtube Video dazu dürfte länger verfügbar sein. ...

Heiß diskutierte Inhalte
Windows Server
AD DS findet Domäne nicht, behebbar?
Frage von schapitzWindows Server40 Kommentare

Guten Tag, ich habe bei einem Kunden ein Problem mit den AD DS. Umgebung ist folgende: Windows Server 2016 ...

Router & Routing
LANCOM VPN CLIENT einrichten
Frage von Finchen961988Router & Routing27 Kommentare

Hallo, ich habe ein Problem und hoffe ihr könnt mir helfen, wir haben einen Kunden der hat einen Speedport ...

Router & Routing
ISC DHCP 2 Subnetze
gelöst Frage von janosch12Router & Routing19 Kommentare

Hallo, ich betreibe bei mir im Netzwerk einen ISC DHCP Server auf Debian, der DHCP verwaltet aktuell ein /24 ...

Switche und Hubs
Cisco SG350X-48 AdminIP in anderes VLAN
Frage von lcer00Switche und Hubs14 Kommentare

Hallo zusammen, ich habe ein Problem mir einem Cisco SG350X-48 bei der Erstinstallation wurde eine IP 192.168.0.254 (Default VLAN ...