Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Benutzerrechte im WebDav ordnungsgemäß einstellen

Mitglied: PalRock

PalRock (Level 1) - Jetzt verbinden

05.12.2012, aktualisiert 15:03 Uhr, 3555 Aufrufe, 13 Kommentare

Hallo an Alle,

wie ich in meiner anderen Frage schon bemerkt habe, ich bin relativ neu im Admin-Breich, also verzeiht mir bitte doofe Fragen. Und ja, ich habe auch schon die Suchfunktion benutzt, aber nicht so Recht was passendes gefunden.

Ich habe also nun WebDav eingerichtet, auch mit SSL, hat alles super geklappt.
Ich habe dazu nun 2-3 Fragen, um mich abzusichern:

Ich möchte für jeden Benutzer ein Unterverzeichnis im übergeordneten WebDav einrichten. Dann soll jeder Benutzer sich nur in seinem Verzeichnis aufhalten dürfen, nicht im übergeordneten Verzeichnis, oder im Verzeichnis der Anderen.

In seinem Verzeichnis soll er aber alles machen dürfen. Dazu habe ich bisher 2 Benutzer, einen für mich, der überall hin soll und ein Benutzer für einen Kunden "dav-user1". dav-user1 soll in Verzeichnis1 eingesperrt werden, aber dort alles machen dürfen.
Meine Einstellung bisher:
NameVirtualHost * 
<VirtualHost *> 
        ServerAdmin webmaster@localhost 
 
        Alias /webdav /pfad/zum/webdav/ 
 
        DocumentRoot /pfad/zum/webdav/ 
        <Directory /pfad/zum/webdav/> 
                ForceType text/plain 
                Options Indexes MultiViews 
                AllowOverride None 
                Order allow,deny 
                allow from all 
        </Directory> 
 
        <Location /webdav> 
           DAV On 
           AuthType Basic 
           AuthName "webdav" 
           AuthUserFile /etc/apache2/htpasswd 
           Require valid-user 
       </Location> 
</VirtualHost> 
 
NameVirtualHost * 
<VirtualHost *> 
        ServerAdmin webmaster@localhost 
 
        Alias /verzeichnis1 /pfad/zum/webdav/verzeichnis1/ 
 
        DocumentRoot /pfad/zum/webdav/verzeichnis1/ 
        <Directory /pfad/zum/webdav/verzeichnis1/> 
                ForceType text/plain 
                Options Indexes MultiViews 
                AllowOverride None 
                Order allow,deny 
                allow from all 
        </Directory> 
 
        <Location /verzeichnis1> 
           DAV On 
           AuthType Basic 
           AuthName "webdav" 
           AuthUserFile /etc/apache2/htpasswd 
           <LimitExcept OPTIONS> 
                Require user dav-user1 
           </LimitExcept> 
       </Location> 
</VirtualHost>
Seit dem ich den 2. VirtualHost eingerichtet habe, bekomme ich bei Neustart des Apache2 diese Warnung:
Warnung : [Wed Dec 05 14:25:43 2012] [warn] NameVirtualHost *:0 has no VirtualHosts

Müssen da überhaupt 2 VirtualHosts sein ?
Falls doch, müssen die seperate Namen haben ?
Oder kann ich mehrere "Alias" (mit ihren entsprechenden Eigenschaften) in einen Vhost stecken?
Oder verstehe ich da was falsch ?

Das funktioniert bisher super, aber die Warnung gefällt mir nicht.

Könnte dav-user1 auch mit seinem Login auf das übergeordnete webdav zugreifen, wenn er "https://server.de/verzeichnis1/" ohne das "verzeichnis1" aufruft ?

ForceType text/plain
Sorgt doch dafür, dass die Dateien geöffnet und nicht ausgeführt ?

Ich möchte nichts falsch machen und möchte auch korrekte Rechte einrichten !
Das war's erst einmal. Vielen Dank schon mal !!
Mitglied: Hitman4021
05.12.2012, aktualisiert um 15:27 Uhr
Hallo,

Als erstes Schreib hier mal deine IP und den Port in den VHost gehört auch ein Servername. Und "NameVirtualHost" darf nur einmal vorkommen.
01.
Administrator/Bafabu49 
02.
<code> 
03.
NameVirtualHost IP:PORT 
04.
<VirtualHost *>  
05.
        ServerAdmin webmaster@localhost  
06.
        ServerName FQDN 
07.
        Alias /webdav /pfad/zum/webdav/  
08.
        DocumentRoot /pfad/zum/webdav/  
09.
        <Directory /pfad/zum/webdav/>  
10.
                ForceType text/plain  
11.
                Options Indexes MultiViews  
12.
                AllowOverride None  
13.
                Order allow,deny  
14.
                allow from all  
15.
        </Directory>  
16.
        <Location />  
17.
           DAV On  
18.
           AuthType Basic  
19.
           AuthName "webdav"  
20.
           AuthUserFile /etc/apache2/htpasswd_admin  
21.
           <LimitExcept OPTIONS>  
22.
                Require user dein_user  
23.
           </LimitExcept>  
24.
       </Location>  
25.
	    
26.
	    Alias /verzeichnis1 /pfad/zum/webdav/verzeichnis1/  
27.
		<Directory /pfad/zum/webdav/verzeichnis1/>  
28.
                ForceType text/plain  
29.
                Options Indexes MultiViews  
30.
                AllowOverride None  
31.
                Order allow,deny  
32.
                allow from all  
33.
        </Directory>  
34.
		<Location /verzeichnis1>  
35.
           DAV On  
36.
           AuthType Basic  
37.
           AuthName "webdav"  
38.
           AuthUserFile /etc/apache2/htpasswd  
39.
           <LimitExcept OPTIONS>  
40.
                Require user dav-user1  
41.
           </LimitExcept>  
42.
       </Location>  
43.
</VirtualHost> 
Wenn du das anpasst dürfte es funktionieren.

Könnte dav-user1 auch mit seinem Login auf das übergeordnete webdav zugreifen, wenn er "https://server.de/verzeichnis1/" ohne das "verzeichnis1" aufruft ?
Wie wre es mit versuchen?
Aber da ich heute so gut drauf bin. Ja könnte er. Sein User ist auch ein "valid-user" in dein Htpasswd. Bei meiner Config kann er das nicht.

Müssen da überhaupt 2 VirtualHosts sein ?
Falls doch, müssen die seperate Namen haben ?
Oder kann ich mehrere "Alias" (mit ihren entsprechenden Eigenschaften) in einen Vhost stecken?
Oder verstehe ich da was falsch ?
Siehe config oben
Gruß
Bitte warten ..
Mitglied: PalRock
05.12.2012, aktualisiert um 15:53 Uhr
Jetzt komme ich nicht mehr drauf, außerdem kommt diese Warnung:
[Wed Dec 05 15:43:25 2012] [warn] NameVirtualHost IP:PORT has no VirtualHosts

Ohne IP und Port gehts, dann auch ohne Warnung...
Bitte warten ..
Mitglied: Hitman4021
05.12.2012 um 15:54 Uhr
Hallo,

IP und Port hast du getauscht in deine Angaben?
Die Listening Direktiven sind auch gesetzt?
Hier noch ein Fehler von mir
01.
<VirtualHost *>
sollte auch
01.
<VirtualHost IP:PORT>
sein.

Was sagt dein ErrorLog beim Neustart?

Gruß
Bitte warten ..
Mitglied: PalRock
06.12.2012, aktualisiert um 10:09 Uhr
Hallo,

läuft jetzt alles mit den Angaben.
Es ist nur erstaunlich zu sehen, dass man die Verbindung zum WebDav unter XP ein wenig anders macht, als bei Win7 und SBS_11...

Eins ist nur merkwürdig:
Wenn ich von WinXP auf eine Text-Datei zugreife, will er sie mir im Browser öffnen, und Win7 läuft alles wie erwartet.
Ich dachte das verhindert die Zeile: "ForceType text/plain"

Außerdem muss ich nur noch das Robocopy-Script zum laufen bekommen, aber das ist hier wohl der falsche Bereich
Oder könnt Ihr mir da auch helfen, oder soll ich dafür eine neue frage starten ??
Bitte warten ..
Mitglied: Hitman4021
06.12.2012 um 11:40 Uhr
Hallo,

Zitat von PalRock:
Eins ist nur merkwürdig:
Wenn ich von WinXP auf eine Text-Datei zugreife, will er sie mir im Browser öffnen, und Win7 läuft alles wie erwartet.
Ich dachte das verhindert die Zeile: "ForceType text/plain"
Wie der Rechner etwas öffnet hängt von der Dateiendung, Dem Dateiheader und deinem eingestellten Standardprogramm ab.
Außerdem habe ich keine Ahnung wie du dich verbunden hast.

Außerdem muss ich nur noch das Robocopy-Script zum laufen bekommen, aber das ist hier wohl der falsche Bereich
Oder könnt Ihr mir da auch helfen, oder soll ich dafür eine neue frage starten ??
Die hast du doch schon gestellt.
https://www.administrator.de/forum/backup-von-sbs2011-zum-webserver-debi ...
Und meine Meinung zu dem ganzen habe ich dir ja auch schon gesagt.
Vorallem wenn anscheinend User auch darauf arbeiten sollen.

Gruß
Bitte warten ..
Mitglied: PalRock
06.12.2012, aktualisiert um 12:03 Uhr
Hallo Hitman,

bisher sollen keine User da drauf arbeiten. Eigentlich soll das nur für das Backup sein.
Ich kann über den Windows-Explorer problemlos auf die Dateien zugreifen, kopieren, erstellen etc.
klappt alles nur weiter geht's dann nicht
Ich habe das WebDav-Verzeichnis des dav-user1 als Netzwerklaufwerk verbunden.

Zur Anmerkung: Ich habe für die https-Verbindung ein eigenes SSL-Zertifikat erstellt, weil auf dem Server noch keins war.

Schöne Grüße
Bitte warten ..
Mitglied: Hitman4021
06.12.2012 um 12:04 Uhr
Hallo,

dann geh mal in deinem anderen Beitrag.
Und poste bitte dein robocopy batch.
Intressant wäre auch ob das Laufwerk verbunden ist wenn du darauf zugreifen willst.

Gruß
Bitte warten ..
Mitglied: 16568
06.12.2012 um 12:24 Uhr
@Hitman4021: tu mir doch den Gefallen, und schreib hier keinen Blödsinn rein, wenn Du GAR KEINE Ahnung von Apache und WebDAV hast.

Linux ist da ein klein wenig anders als Windows, okay?


Lonesome Walker
Bitte warten ..
Mitglied: Hitman4021
06.12.2012, aktualisiert um 12:42 Uhr
@Lonesome Walker
Und wo genau habe ich Blödsinn geschrieben?
Das ich von WebDAV keine Ahnung habe stimmt, aber wie man einen Apache einrichtet weiß ich.

Gruß
Bitte warten ..
Mitglied: PalRock
06.12.2012 um 13:07 Uhr
OK... Dann ab jetzt wieder im Anderen Beitrag weiter...
Bitte warten ..
Mitglied: 16568
06.12.2012, aktualisiert um 13:32 Uhr
Zitat von Hitman4021:
Und wo genau habe ich Blödsinn geschrieben?
Das ich von WebDAV keine Ahnung habe stimmt, aber wie man einen Apache einrichtet weiß ich.

Zitat von Hitman4021:
Als erstes Schreib hier mal deine IP und den Port in den VHost

Es wird keine IP benötigt...
Wie/wo/was/warum jetzt im Detail erspare ich Dir, aber auf apache.org oder mit man apache2 wirst Du mehr finden


@PalRock:
im anderen Thread bitte robocopy-Batch, weil Windows, und hier bitte mal Deine GESAMTE Apache-Config!
Du hast sicherlich SSL vergessen, welches aber, um Probleme bei Windows zu vermeiden, grundsätzlich aktiv sein sollte, und zum anderen, die WebDAV-Freigabe sollte ein Wurzelverzeichnis der Domain sein, sprich:

https://www.example.com/
oder
https://webdav.example.com/
oder
https://irgendeinesubdomain.example.com/

Wenn Du:
https://www.example.com/irgendeinunterpfad/
verwendest, wirst Du über kurz oder lang mit sehr vielen Problemen zu kämpfen haben.

Zum Thema User/Gruppen ist ein Besuch hier und hier vielleicht ein grundlegendes Informationskapitel; dort findest Du alle weiteren Schlagworte zum selber-weiter-forschen


Lonesome Walker
Bitte warten ..
Mitglied: PalRock
06.12.2012 um 13:42 Uhr
Das "Wurzel-Webdav" ist in der Wurzel-Domain (hoffe ich drücke mich verständlich aus).
https://server.de/
SSl ist aktiv, erst mal mit einem selbst erstellten Zertifikat, da auf dem Server keins war.

https://server.de/Verzeichnis1 soll dann für dav-user1 sein
https://server.de/Verzeichnis2 soll dann für dav-user2 sein
......

Oder verwechsle ich nun etwas ?

Bisher klappt aber nun alles.
Bitte warten ..
Mitglied: Hitman4021
06.12.2012 um 15:26 Uhr
Hallo,

Zitat von 16568:
Es wird keine IP benötigt...
Wie/wo/was/warum jetzt im Detail erspare ich Dir, aber auf apache.org oder mit man apache2 wirst Du mehr finden
Das es nicht benötigt wird ist mir klar. Aber ich finde eine Konfiguration so um einiges sauberer.
Außerdem hat es mit dem Stern den Nachteil das Apache auf alle IP-Adressen die ihm zugewiesen sind lauscht.
So aber nur auf der die ich will.
Aber über das kann man diskutieren.
Auf jeden Fall habe ich nicht gesagt das es so sein MUSS.

@PalRock
Lonesome Walker hat gemeint das für jedes Verzeichnis ein eigene SubDomain zur Verfügung gestellt wird, soweit ich das verstanden habe.

Gruß
Bitte warten ..
Ähnliche Inhalte
Samba

Benutzerrechte auf Samba Freigabe einstellen!

Frage von mike7050Samba1 Kommentar

Hallo, ich habe einen Ubuntu 14.04 LTS Rechner der als File Server fungiert! Des Weiteren sind einige Windows Pc ...

Linux Tools

Freenas bzw Nas4free Benutzerrechte einstellen

Frage von metal-shotLinux Tools2 Kommentare

Hallo Bitte nicht über den Sinn und Unsinn meines Unterfanges nachdenken, es ist vielmehr eine Art Resteverwertung mit Herrumspielen. ...

Windows Server

Webdav Zugriffe

Frage von Xaero1982Windows Server10 Kommentare

Moin Zusammen, ich hab nen IIS laufen mit Webdavzugriff. Server 2008 R2. Auf dem Server ist ein Datenordner mit ...

Apache Server

Apache und WebDAV

Frage von crazymarc1989Apache Server1 Kommentar

Hallo zusammen, derzeit versuche ich über meinen Server eine WebDAV-Verbindung als Netzlaufwerk herzustellen. Dies funktioniert soweit alles korrekt, wenn ...

Neue Wissensbeiträge
Sicherheit

MikroTik-Router patchen, Schwachstelle wird ausgenutzt

Information von kgborn vor 5 StundenSicherheit

Am 23. April 2018 wurde von Mikrotik ein Security Advisory herausgegeben, welches auf eine Schwachstelle im RouterOS hinwies. Mikrotik ...

Windows 10

Microcode-Updates KB4090007, KB4091663, KB4091664, KB4091666 für Windows 10

Information von kgborn vor 12 StundenWindows 101 Kommentar

Kurze Information für Administratoren von Windows 10-Systemen, die mit neueren Intel CPUs laufen. Microsoft hat zum 23. April 2018 ...

iOS
Updates für Iphone und Co
Information von sabines vor 15 StundeniOS

Gestern abend ist iOS 11.3.1 erschienen, ein kleineres Update, dass einige Lücken schließt und "Lahmlegen" nach einem Display Tausch ...

Windows 7

Windows 7 - Server 2008 R2: Exploit für Total Meltdown verfügbar

Information von kgborn vor 1 TagWindows 7

Kleine Information für Administratoren, die für die Updates von Windows 7 SP1 und Windows Server 2008 R2 SP1 verantwortlich ...

Heiß diskutierte Inhalte
Batch & Shell
Powershell: Im AD nach Rechnern mit bestimmten IP-Adressen suchen
gelöst Frage von Raven42Batch & Shell36 Kommentare

Hallo zusammen, ich suche nach einer Möglichkeit nach Computern im AD zu suchen , deren IP-Adresse mit 10.11.12. beginnt. ...

C und C++
Frage1 C Programmierung-Makefile Frage2 PHP-Programmierung HTTP-Fehler 404
Frage von KatalinaC und C++34 Kommentare

Hallo, ich habe 2 Fragen, die nichts miteinander zu tun haben aber mit denen ich mich gerade beschäftige: 1. ...

LAN, WAN, Wireless
Watchguard T15 VPN Einrichtung
gelöst Frage von thomasjayLAN, WAN, Wireless25 Kommentare

Hallo zusammen, wir möchten gerne über unsere Watchguard T15 einen VPN-Tunnel (Mobile VPN with IPSec) einrichten! Als Client nutzen ...

Windows Server
Alten DC entfernen
Frage von smartinoWindows Server24 Kommentare

Hallo zusammen, ich habe hier eine Umgebung übernommen und erstmal einen DCDIAG gemacht. Dabei fällt auf, daß eine ganze ...