Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

CACTI SNMP error

Mitglied: LeChuck

LeChuck (Level 1) - Jetzt verbinden

10.03.2008, aktualisiert 02.10.2008, 11314 Aufrufe, 10 Kommentare

System: Win XP SP2

Problem:
Wenn ich bei Cacti ein Device hinzufüge erhalte ich diese Meldung: "SNMP error"
Ich möchte auf einen Cisco Router zugreifen und verwende SNMPv3


1) Cisco - CPU Usage ----- Is Being Graphed
2) SNMP - Generic OID Template ----- Is Being Graphed
3) ucd/net - Load Average ----- Is Being Graphed

Hier steht zwar, dass Graphen erstellt wurden, jedoch bekomme ich nur den Platzhalter eines Bildes zu sehen.


ich hoffe ihr könnt mir weiterhelfen




viele grüße
Mitglied: aqui
10.03.2008 um 17:40 Uhr
  • Stimmen SNMP community Strings von deinem Cacti Host und die am Cisco konfigurierten überein ?
  • Stimmen das SNMPv3 Passwort überein zwischen Cisco und Host ?
  • Ist auf dem Cisco überhaupt SNMPv3 aktiviert ? (Default ist v2 !)
  • Was sagt ein SNMP debug Output vom Cisco ??
Bitte warten ..
Mitglied: 51705
10.03.2008 um 20:36 Uhr
Hallo LeChuck,

Hier steht zwar, dass Graphen erstellt
wurden, jedoch bekomme ich nur den
Platzhalter eines Bildes zu sehen.

genaugenommen steht da doch 'Graphen werden erstellt', also wird dieser Vorgang wohl nicht abgeschlossen.

Vielleicht hilft dir das,
Grüße, Steffen
Bitte warten ..
Mitglied: LeChuck
11.03.2008 um 10:11 Uhr
ja, der cisco router arbeitet auf jeden fall mit SNMPv3.
passwort, username, verschlüsselung ...etc...stimmt auch (mehrfach überprüft)
Bitte warten ..
Mitglied: LeChuck
13.03.2008 um 11:25 Uhr
ich habe jetzt mal den Poller (spine.exe) in der cmd-console gestartet.
der meldet mir dann folgendes:

03/13/2008 11:22:43 AM - SPINE: Poller[0] Host[3] Hostnanme[50.50.3.110] NOTICE: HOST EVENT: Host Returned from DOWN State
03/13/2008 11:22:43 AM - SPINE: Poller[0] Host[3] DS[11] WARNING: SNMP timeout detected [500 ms], ignoring host '50.50.3.110'
03/13/2008 11:22:43 AM - SPINE: Poller[0] Host[3] DS[24] WARNING: SNMP timeout detected [500 ms], ignoring host '50.50.3.110'
03/13/2008 11:23:36 AM - SPINE: Poller[0] ERROR: Spine Timed Out While Processing Hosts Internal
Creating directory: /var
Failed to create the persistent directory for /var/net-snmp/spine.conf
read_config_store open failure on /var/net-snmp/spine.conf
Creating directory: /var
Failed to create the persistent directory for /var/net-snmp/snmpapp.conf
read_config_store open failure on /var/net-snmp/snmpapp.conf
Creating directory: /var
Failed to create the persistent directory for /var/net-snmp/snmpapp.conf
read_config_store open failure on /var/net-snmp/snmpapp.conf
SPINE: Time: 54.0830 s, Threads: 10, Hosts: 4

kann jemand damit was anfangen?
Bitte warten ..
Mitglied: aqui
14.03.2008 um 09:50 Uhr
Sieht so aus als ob 50.50.3.110 gar nicht auf SNMP Requests antwortet ??
Bitte warten ..
Mitglied: LeChuck
18.03.2008 um 10:25 Uhr
so...aktueller stand:
Cacti betreibe ich auf einer viertuellen Linux Maschine in VMware (Hostsystem immer noch WinXP).
Habe mal den Datenverkehr zum Router mittels Wireshark mitgeschnitten:

wenn ich cmd.php als poller verwende kommt kein einziges SNMP paket durch... bei
spine kommt ein SNMP get-request durch und es kommt ein SNMP report zurück.

Hier ein Ausschnitt aus wireshark:

Simple Network Management Protocol
msgVersion: snmpv3 (3)
msgGlobalData
...
...
msgAuthoritativeEngineID: <MISSING>
msgAuthoritativeEngineBoots: 0
msgAuthoritativeEngineTime: 0
msgUserName:
msgAuthenticationParameters: <MISSING>
msgPrivacyParameters: <MISSING>
...


ich verstehe nicht warm da "MISSING" steht.
die daten sind 100%tig in Cacti eingetragen, sowol unter Settings als auch
beim Device direkt.
Bitte warten ..
Mitglied: aqui
19.03.2008 um 14:39 Uhr
Das sind dann Leerstrings also ohne Inhalt. Ist fraglich ob eine Engine ID nötig ist. Bei den Authentication Parametern sieht das schon nicht so gut aus, denn SNMPv3 benötigt die zwingend.

Das musst du klären, warum die Applikation das nicht mitsendet.
Bitte warten ..
Mitglied: LeChuck
25.03.2008 um 10:06 Uhr
net-snmp neu installiert -> Problem gelöst. Cacti läuft jetzt einwandfrei
Bitte warten ..
Mitglied: LeChuck
27.03.2008 um 11:29 Uhr
neues problem:

Nach der erfolgreichen Einrichtung von Cacti sollte das Ganze nun auf einem Server eingerichtet werden. Habe die Installation und Konfiguration genau wie beim Testsystem
gehandhabt. Wenn ich hier dann ein neues "Device" erstelle erhalte ich wieder mal einen "SNMP error".

Nach der Einrichtung des Servers erhalte ich plötzlich auch wieder auf der Testmaschine einen SNMP error.
Cacti(auf der Testmaschine) sammelt jedoch weiter erfolgreich Daten der 3 Router und zeigt auch die Graphen an.
Man könnte meinen, solange alles funktioniert sollte diese Fehlermeldung unwichtig erscheinen. Mal angenommen es würde ein neuer Router in die Überwachung mit einbezogen werden, dann benötige ich erst die Informationen zu den einzelnen Schnittstellen. Diese werden mir nicht angezeigt.
Auch auf dem neuen Server habe ich diese Informationen nicht erhalten.
Durch einfaches Kopieren des gesammten cacti Ordners und der MySQL Datenbank konnte ich dieses Problem für die 3 bereits angelegten Router umgehen. Außerdem habe ich nun den schönen Nebeneffekt, dass die bereits gesammelten Statistiken übernommen wurden.

Hoffe jemand kann mir helfen
Bitte warten ..
Mitglied: victorbw
02.10.2008 um 10:05 Uhr
hast den snmp dienst aktiviert?

könnte durchaus daran liegen, dass kleines eben mal vergessen wurde und somit grosse wirkungen hat
Bitte warten ..
Ähnliche Inhalte
Netzwerkprotokolle
SNMP Verbindungsproblem
Frage von mames92Netzwerkprotokolle2 Kommentare

Hallo zusammen, ich versuche Informationen von einiegen Servern über SNMP zu bekommen. Mein Testserver ist ein Windows 2008 auf ...

Monitoring
SNMP Problem
gelöst Frage von msalcherMonitoring1 Kommentar

Hey Leute :) Ich würde gerne meinen PC (Win8) über SNMP monitoren. Hab den Service konfiguriert. So wenn ich ...

Netzwerkmanagement
SNMP - Wie vorführen?
Frage von animatedNetzwerkmanagement6 Kommentare

Hallo Zusammen! Das ist mein erster post in diesem Forum, daher schnell ein bisschen zu meiner Person/Situation: Ich bin ...

Festplatten, SSD, Raid
SNMP-Dienst bleibt hängen
Frage von SFischer-SCTFestplatten, SSD, Raid2 Kommentare

Hallo, wir haben bei einem unserer Kunden folgendes Problem: Wir monitoren einen Adaptec-Raidcontroller mittels SNMP (HDDs und VDrives) Dies ...

Neue Wissensbeiträge
Humor (lol)
(Part num your Hacked phone. +XX XXXXXX5200)
Erfahrungsbericht von Henere vor 21 StundenHumor (lol)1 Kommentar

Mein Handy hat aber ne ganz andere Endnummer. Muss ich mir jetzt Sorgen machen ? :-) Vielleicht betrifft es ...

Exchange Server

Letztes Update für Exchange 2016 CU9 war in gewisser Weise destruktiv

Erfahrungsbericht von DerWoWusste vor 23 StundenExchange Server6 Kommentare

Kurzer Erfahrungsbericht zu Exchange2016-KB4340731-x64 Der Exchangeserver hat wie gewöhnlich versucht, es in der Nacht automatisch zu installieren - abgesehen ...

Erkennung und -Abwehr

Neue Sicherheitslücke Foreshadow (L1TF) gefährdet fast alle Intel-Prozessoren

Information von Frank vor 1 TagErkennung und -Abwehr3 Kommentare

Eine neue Sicherheitslücke, genannt Foreshadow (alias L1TF) wurde auf der Usenix Security 18 von einem Team internationaler Experten veröffentlicht. ...

Vmware
VMware Updates gegen L1 Lücke
Information von sabines vor 2 TagenVmware

Für die Vmware Produkte vCenter Server, ESXi, Workstation und Fusion stehe Updates bereit um die L1 Lücke zu schließen. ...

Heiß diskutierte Inhalte
Windows Server
Domäne einsilbig mit nur einem Namen benannt - sowie AD und MX auf einer VM Kardinalsfehler?
Frage von TomTestWindows Server50 Kommentare

Hallo liebe Freunde gepflegter Probleme, seit kurzem soll ich eine Domäne verwalten die zuvor von einem IT-Dienstleister erstellt und ...

DSL, VDSL
Router Neustarts
Frage von XerebusDSL, VDSL16 Kommentare

Hallo an alle, ich hab eine Problem mit dem Neustart von meiner Fritz Box wo ich einfach nicht mehr ...

DNS
Gibt es eine Art DNS Proxy?
Frage von icepietDNS16 Kommentare

Hallo Nerds, Ich würde gerne folgendes machen: ts.domain.de:3389 soll auf 1.2.3.4:3389 auflösen ts2.domain.de:3389 soll auf 1.2.3.4:3390 auflösen Gibt es ...

Windows Server
Windows Server per Web auf Daten zugreifen und verwalten
Frage von matze2090Windows Server16 Kommentare

Hallo, ich würde gerne von außen auf meinem Windows Server zugreifen um auf meine Daten zu verwalten. Meine frage ...