Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Chinese Zeichen falsch dargestellt/MySQL

Mitglied: pendragon302

pendragon302 (Level 1) - Jetzt verbinden

14.12.2006, aktualisiert 21:34 Uhr, 6078 Aufrufe, 1 Kommentar

Hallo zusammen,

mich plagt momentan ein Problem mit der Speicherung von chinesischen Schriftzeichen in einer MySQL Tabelle. Habe auf dem Webserver (IIS6) die Unterstützung von ostasiatischen Sprachen installiert. Desweiteren hab ich dies auch auf meinem Heim PC installiert.

Um zu testen ob alles mit den chinesishcen Schriftzeichen klappt, habe ich ein PHP Script geschrieben, dass die Zeichen in die DB speichert und auch wieder einliesst. Nun hat sich aber folgende Tücke ergeben:
Speicher ich die Schriftzeichen per PHP-Script so werden diese dort auch wieder richtig angezeigt, aber wenn ich mir die Tabelle mit phpMyAdmin anschaue dann sind dort keine chinesischen Schriftzeichen sondern ganz andere Zeichen, sie scheinen irgendwie codiert zu sein.

Speicher ich chinesischen Text manuell per phpMyAdmin so werden sie dort auch richtig angezeigt, will ich sie aber mit nem php-Script wieder auslesen, so erscheinen lediglich Fragezeichen anstelle der chin. Schriftzeichen. Woran kann das liegen? Welche Einstellung hab ich vergessen?

Das folgende Bild zeigt die Struktur der MySQL Tabelle
<img src=http://pendragon302.pe.funpic.de/bild1.jpg>;

Die das Feld in das die chin Einträge reinkommen sollen, hat die Kollation utf8_unicode_ci

Das Bild zeigt die beiden Einträge
<img src=http://pendragon302.pe.funpic.de/bild2.jpg>;
Der erste wurde mit PHP-Scrpt eingefügt und der zweite manuell per phpMyAdmin.

Als Ergebnis bekomme ich beim Auslesen folgendes:
<img src=http://pendragon302.pe.funpic.de/bild3.jpg>;

Woran liegt das?

Gruß
Mitglied: pendragon302
14.12.2006 um 21:34 Uhr
Mein Problem hat sich soeben gelöst.

Es fehlte nur ein mysql_query("SET names 'utf8'");

Gruß
Bitte warten ..
Ähnliche Inhalte
Outlook & Mail

Signatur wird im Outlook(2010) falsch dargestellt

gelöst Frage von Dr.CornwallisOutlook & Mail7 Kommentare

Hallo zusammen! Wenn man im Outlook eine email versenden/weiterleiten will, werden die Links der Signatur falsch dargestellt(siehe Bild). Versuche ...

Exchange Server

Umlaute Autoresponder Exchange 2013 werden falsch dargestellt

Frage von AirportExchange Server

Hallo zusammen, nach einer mehrstufigen Migration Exchange 2003 auf 2010 und dann 2013 werden die Umlaute bei der Abwesenheitsbenachrichtigung ...

CSS

Bootstrap-Webseite wird zuerst (iPhone) falsch dargestellt

Frage von t.dietlCSS

Guten Mittag liebe Gemeinde, als Neuling auf diesem Forum habe ich gleich eine Frage an euch! Ich habe die ...

Apache Server

Nach PHP-Update von 5.4 auf 5.6 werden Umlaute falsch dargestellt

gelöst Frage von coltseaversApache Server2 Kommentare

Hallo zusammen, ich habe auf einem Websever (Debian 7 stable, Apache 2.2) ein PHP-Update von Version 5.4 auf 5.6 ...

Neue Wissensbeiträge
Hardware

100.000 Mikrotik-Router ungefragt von Hacker abgesichert

Information von 7Gizmo7 vor 6 StundenHardware

Hallo zusammen, da hier ja öfters mal von Mikrotik gesprochen wird. Trotz Updates klafft eine Sicherheitslücke in Hundertausenden Mikrotik-Routern. ...

Sicherheit

Oracle gibt kritische Updates für diverse Produkte frei (16. Oktober 2018)

Information von kgborn vor 17 StundenSicherheit

Oracle hat zum 16. Oktober 2018 eine ganze Reihe an kritischen Updates für seine Produkte freigegeben. Eine Kurzübersicht mit ...

Windows 10
FYI: Fristen beim Windows 10 Downgrade-Recht
Information von kgborn vor 18 StundenWindows 10

Möglicherweise ist das bei euch bekannt - ich habe es gerade aus einem Newsletter eines OEMs herausgefischt. Beim Downgrade-Recht ...

CMS
Freie Wähler Bayern MySQL PW online
Information von sabines vor 21 StundenCMS6 Kommentare

Die Typo3 Installation der Freien Wähler Bayern scheint wohl längere Zeit nicht mehr angefasst und/oder fehlkonfiguriert zu sein. Nach ...

Heiß diskutierte Inhalte
Windows 10
Sysprep Fehler im Log kann nicht starten
Frage von grillinator95Windows 1021 Kommentare

Hallo, kann leider SYSPREP nicht mehr starten, Win10 64bit. Logfile sagt folgendes: 2018-10-17 13:44:56, Info SYSPRP 2018-10-17 13:44:56, Info ...

Internet
Ist diese URL denkbar (Syntax)?
gelöst Frage von departure69Internet17 Kommentare

Hallo. Der Sohn eines Arbeitskollegen hat im Gymnasium EDV-Unterricht. Leider hat er in der letzten Klassenarbeit einen Fünfer geschrieben. ...

Exchange Server
Outlook Anywhere - Anmeldefenster muss mit Domain gefüllt werden
Frage von leon123Exchange Server15 Kommentare

Hallo zusammen, ich habe relativ erfolgreich einen Exchange 2016 aufgesetzt, sowie ein SAN-Zertifikat eingespielt und Outlook Anywhere aktiviert. Beim ...

Debian
Linux debian 9 Installation
Frage von Green14Debian15 Kommentare

Hallo zusammen, ich habe mich ein wenig mit Debian auseinandergesetzt und möchte mir eine Standard-Installation als Grundlage für andere ...