Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Cisco 2600 Series FTP Port freischalten

Mitglied: Saensation

Saensation (Level 1) - Jetzt verbinden

04.05.2011, aktualisiert 10:00 Uhr, 5210 Aufrufe, 2 Kommentare

Guten Morgen,

ich habe eine nur eine kurze Frage und scheinbar schlichte. Und zwar arbeite ich zur Zeit an einem Cisco 2621 und steuer diesen über Telnet an. Ich muss lediglich den FTP Port freischalten, damit Kunden Zugriff auf einen hinter dem Router liegenden FTP-Server haben.
Ich habe bereits NAT-Einträge hinzugefügt (also öffentliche IP-Adresse auf private weitergeleitet).
Das funktioniert nun auch reibungslos (habe einen Webserver testweise dahinter gehängt, aber dieser benötigt ja auch kein FTP...)
Hab es jetzt mal mit "ip nat service list 10 ftp tcp port 2021" probiert aber ohne Erfolg.

Wenn ich zu wenige Informationen geliefert habe, kann ich gerne welche nachliefern.

Hier noch meine Config mit geänderten IP-Adressen:
01.
Current configuration : 1103 bytes 
02.
03.
version 12.3 
04.
service timestamps debug datetime msec 
05.
service timestamps log datetime msec 
06.
service password-encryption 
07.
08.
hostname Cisco Router 
09.
10.
boot-start-marker 
11.
boot-end-marker 
12.
13.
enable secret 5 "geheim1" 
14.
enable password 7 "geheim2" 
15.
16.
no aaa new-model 
17.
ip subnet-zero 
18.
ip cef 
19.
20.
21.
ip name-server 54.146.129.115 
22.
23.
24.
25.
interface FastEthernet0/0 
26.
 description öffentlich 
27.
 ip address 54.146.129.116 255.255.255.0 
28.
 ip nat outside 
29.
 duplex auto 
30.
 speed auto 
31.
32.
interface FastEthernet0/1 
33.
 description privat 
34.
 ip address 192.168.100.1 255.255.255.0 
35.
 ip nat inside 
36.
 duplex auto 
37.
 speed auto 
38.
39.
ip nat inside source list 103 interface FastEthernet0/0 overload 
40.
ip nat inside source static 192.168.100.5 54.146.129.212 
41.
ip nat inside source static 192.168.100.6 54.146.129.213 
42.
ip nat service list 10 ftp tcp port 2021 
43.
ip http server 
44.
ip classless 
45.
ip route 0.0.0.0 0.0.0.0 54.146.129.117 
46.
47.
48.
access-list 103 permit ip 192.168.100.0 0.0.0.255 any 
49.
snmp-server community public RO 
50.
snmp-server enable traps tty 
51.
52.
line con 0 
53.
 exec-timeout 0 0 
54.
line aux 0 
55.
line vty 0 4 
56.
 password 7 "geheim3" 
57.
 login 
58.
59.
60.
61.
end
Mitglied: Dani
04.05.2011 um 09:59 Uhr
Moin,
probier's mal nach dieser Anleitung: http://portforward.com/english/routers/port_forwarding/Cisco/Cisco800Se ...


Grüße,
Dani
Bitte warten ..
Mitglied: aqui
04.05.2011 um 10:10 Uhr
Die Frage ist was du genau vorhast ??
In deiner o.a. Konfig setzt du ja schon statisch die externe IP 54.146.129.212 auf die 192.168.100.5 um und analog die 54.146.129.213 auf die 192.168.100.6 !
Das betrifft ALLE Ports und Dienste. Sprich ein FTP Connect auf die 54.146.129.212 landet dann bei der internen .5er IP und ein FTP Connect auf die .213 landet bei der .6.
Das funktioniert fehlerfrei sofern auch die internen lokalen Firewall entsprechend angepasst sind für externe IPs und Dienste Pakete zuzulassen, (ein beliebter Fehler hier im Forum !) und die Frage ist jetzt: wo dein Problem ist, wenn du FTP auf diese beiden internen Server machen willst von außen ??
Generell wir ja in deiner Konfig alles umgesetzt.
Das "ip nat service list" Kommando ist völliger Unsinn bei dir, denn es betrifft NAT Dienste die nicht auf den Standard Ports laufen sollen (Port Translation) was bei dir ja nicht der Fall ist. Zudem fehlt die Accessliste 10 bei dir in der Konfig. Dieses Kommando ist also überflüssig und auch Kontraprotuktiv, da eine nicht vorhandene ACL immer mit einem "deny any any" abgearbeitet wird also alles geblockt wird. Entferne den Mist also besser sofern du das nur unreflektiert aus einer beispielseite abgetippt hast.
Generelle Infos zur Funktion von NAT auf dem Router findest du hier:
http://www.cisco.com/en/US/tech/tk648/tk361/technologies_tech_note09186 ...

Soll der Dienst nur auf FTP beschränkt sein dann muss das Kommando folgendermaßen lauten:
ip nat inside source static tcp 192.168.100.5 20 54.146.129.212 20
ip nat inside source static tcp 192.168.100.5 21 54.146.129.212 21

Analog dann auch für die Kombination .213 auf die .6 !
Bedenke das du revers über einen NAT prozess gehst ! Dein FTP Client (und Server) muss also zwingend den FTP Passive Mode supporten !
Wenn du nicht weisst was das ist kannst du das hier nachlesen:
http://www.alenfelder.com/Informatik/pass-akt-ftp.html
bzw.
http://slacksite.com/other/ftp.html
Bitte warten ..
Ähnliche Inhalte
LAN, WAN, Wireless

Cisco 2500 Wireless Controller - Port freischalten

Frage von HanswurstVeggiLAN, WAN, Wireless2 Kommentare

Hallo Leute erst einmal :-) ich habe folgende Frage an Euch, wie kann ich beim Cisco 2500 Wireless Controller ...

ISDN & Analoganschlüsse

Cisco 2600 als Media Gateway

Frage von Herbrich19ISDN & Analoganschlüsse3 Kommentare

Hallo, Ich würde gerne mit denn OCS2007 / Lync 2010 VoIP einrichten. Es handelt sich nur um Testversionen. Ich ...

Router & Routing

Cisco 2600 ISDN-BRI Wie Konfigurieren?

gelöst Frage von Herbrich19Router & Routing6 Kommentare

Hallo, Ich vwersuche Folgendes hinzubekommen: ISDN <> Cisco 3600 <> SIP Ich habe ein Cisco 2600 Router, diesen würde ...

LAN, WAN, Wireless

Cisco Aeronet Serie - Unterschiede

Frage von receiverboxLAN, WAN, Wireless3 Kommentare

Hallo, ich möchte den bestehenden WLAN-Wirwar (verschieden Konsumer-Produkte) im Betrieb auflösen und durch eine saubere, gemanagte Lösung ersetzen. Der ...

Neue Wissensbeiträge
Sicherheit
Sicherheitsrisiko: Die Krux mit 7-Zip
Information von kgborn vor 12 StundenSicherheit

Bei vielen Anwendern ist das Tool 7-Zip zum Entpacken von Archivdateien im Einsatz. Die Software ist kostenlos und steht ...

Internet

Datendealing im WWW Tracking Methoden immer brutaler

Information von sabines vor 22 StundenInternet

Interessanter Artikel zum Thema Tracking im WWW und die immer "besseren" Methoden des Trackings. Professor Arvind Narayanan (Princeton-Universität) betreibt ...

Erkennung und -Abwehr

Ups: Einfaches Nullzeichen hebelte den Anti-Malware-Schutzt in Windows 10 aus

Information von kgborn vor 1 TagErkennung und -Abwehr

Windows 10 ist das sicherste Windows aller Zeiten, wie Microsoft betont. Insidern ist aber klar, das es da Lücken, ...

Windows 10

Windows 10 on ARM: von Microsoft entfernte Info - Klartext, was nicht geht

Information von kgborn vor 1 TagWindows 10

Windows 10 on ARM ist ja eine neue Variante, die Microsoft im Verbund mit Geräteherstellern am Markt etablieren will. ...

Heiß diskutierte Inhalte
Server
Route-Befehl Unterstützung (unter CMD)
gelöst Frage von FKRR56Server36 Kommentare

Guten Tag , i.M. habe ich Probleme über den CMD-Route-Befehl ein Routing auf einen entfernten Server zuzulassen. Der Server ...

Windows 10
Windows 10 (1709) Tastur und Maus wieder einschalten?
Frage von LochkartenstanzerWindows 1028 Kommentare

Moin, Ich habe von einem Kunden einen Win10-Rechner bekommen, bei dem weder Tastatur noch Maus geht. Die Hardware funktioniert ...

Microsoft
TV-Tipp: Das Microsoft-Dilemma
Information von kgbornMicrosoft17 Kommentare

Aktuell gibt es in Behörden und in Firmen eine fatale Abhängigkeit von Microsoft und dessen Produkten. Planlos agieren die ...

Webbrowser
Welcher Browser ist der Beste?
Frage von justtinWebbrowser15 Kommentare

Hallo Leute Ich habe eine interessante Frage. Mich wurde mal interessieren welcher Browser ist eure meinung nach der beste? ...