Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Cisco 2900XL untagged Trunkport

Mitglied: marolli1983

marolli1983 (Level 1) - Jetzt verbinden

07.06.2013 um 12:17 Uhr, 2384 Aufrufe, 5 Kommentare, 2 Danke

Hallo,
Hab momentan ein Projekt für die Schule, soll einen cisco catalyst 2900 XL konfigurieren, klappt auch soweit bis auf meinen trunk port.
Bin zu Hause am ausprobieren und habe den switch an meinem Router hängen und meinen Laptop an einem vlan. Jetzt soll der trunk port aber untagged sein, und da Hänge ich. Ich weiß nicht wie ich es hinbekomme das alle vlans auf diesem trunk port untagged übertragen werden. Wenn ich es native mit dem vlan mache wo mein Lappi dran hängt geht es, aber so kann man ja nur ein vlan übertragen. Bräuche bitte Hilfe.
Mitglied: MrNetman
07.06.2013 um 13:49 Uhr
Das geht so nicht.

Ein Trunkport stellt
entweder die Verbindung zwischen zwei Switchen her
oder die Verbindung zu einem VLAN fähigen Router oder eine VLAN-fähigen Firewall.

Wenn du diesen Port untagged setzt, dann werden ja alle Trennung im Switch an dieser Stelle aufgehoben und eingehende Pakete dort gehen wohin? ins Nirwana oder an alle.
Also keine gute Option.

Wenn dein Home-Router keine VLANs unterstützt hast du hier schlechte Karten. Möglich ist noch ein PC mit Linux-OS, der mit getaggten Ports umgehen kann und dann auch das Routen übernimmt. Könnte auch eine VMWare Installation sein.

Gruß
Netman
Bitte warten ..
Mitglied: marolli1983
07.06.2013 um 15:21 Uhr
Laut Lehrer soll eine Firewall daran kommen aber er hat gesagt das der Trunk untagged sein soll. Warum auch immer.
Bitte warten ..
Mitglied: aqui
07.06.2013, aktualisiert um 19:12 Uhr
So sieht dein Trunkport (Cisco Sprech) aus:

interface GigabitEthernet 0/0
description Trunk Uplink zur Firewall
switchport mode trunk
switchport trunk allow vlan all
(switchport trunk encapsulation dot1q)
(switchport trunk native vlan 1)

Fertig ist der Lack !
Beachte das dort Spanning Tree rennt und der Cisco ca. 35 Sekunden benötigt den Port in den Forwarding Modus zu schalten. Hast du kein redundantes Netzwerk kannst du das auch mit dem Interface Kommando "spanning-tree portfast" beschleunigen.

Hier findest du im Kapitel "VLAN Setup Switch" und "Praxisbeispiel" eine lauffähige Konfig für so ein Umfeld mit Firewall und Cisco Catalyst:
https://www.administrator.de/contentid/110259

Trunk "untagged" ist natürlich technischer Blödsinn, das kannst du deinem Lehrer auch so sagen !
Es ist aber zu vermuten das er ggf. der speziellen Cisco Nomenklatur auf den Leim gegangen ist. Dann hat er wieder Recht:

Tagged VLAN Uplink = "Trunk" in Cisco Sprech = "Tagged Uplink" für den Rest der Switchwelt !
Link Aggregation = Bündelung von mehreren Links zu einem logischen = "Trunk" im Rest der Switchwelt = "Ether Channel" in der Cisco Welt !

Sag also dem Lehrer er soll wenigstens präzise Ansagen machen damit du das ausführen kannst was er will !

Meint er dennoch Link Aggregation also das Bündeln mehrerer Ports sieht das dann so aus auf dem Cisco wenn die beiden Interfaces Fast Ethernet 1 und 2 einen Trunk / Etherchannel bilden:
Switch# configure terminal
Switch(config)# interface range fastethernet0/1-2
Switch(config-if-range)# channel-group 1 mode active
Switch(config-if-range)# end

Switch(config)# interface port-channel 1
Switch(config-if)# switchport mode access
Switch(config-if)# switchport access vlan 1
Switch(config-if)# end

Bzw. falls der LAG auch ein tagged Uplink sein soll dann so:
Switch(config)# interface port-channel 1
Switch(config-if)# switchport mode trunk
Switch(config-if)# switchport trunk allow vlan all

So, nun hast du alle Möglichkeiten durch, die der Lehrer meinen könnte !
Bitte warten ..
Mitglied: marolli1983
07.06.2013 um 19:35 Uhr
Super,
Vielen vielen dank für eure Hilfe!
Bitte warten ..
Ähnliche Inhalte
Netzwerkgrundlagen
Nativ Vlan per Trunkport?
gelöst Frage von MikePostNetzwerkgrundlagen10 Kommentare

Hallo zusammen Ich dachte bis letzter Woche das man pro Switch/Trunkport nur ein Native Vlan haben kann. Per default ...

Switche und Hubs
Verschiedene Vlans Tagged und untagged
gelöst Frage von roeggiSwitche und Hubs4 Kommentare

Hallo Zusammen Ich bin gerade an einer Wlan Installation mit Gästenetzwerk am einrichten. Folgende Komponenten sind im Einsatz: Draytek ...

Netzwerkgrundlagen

VLAN Tagged, Untagged klappt leider nicht so

gelöst Frage von rastalNetzwerkgrundlagen6 Kommentare

Hallo zusammen, ich habe noch ein Problem mit einem Tagged VLAN über 2 Switche. Beides HP Switch. Switch 1 ...

Switche und Hubs

VLAN erstellen - Tagged-Untagged-Excluded

Frage von SchauerSwitche und Hubs13 Kommentare

Guten Tag. Ich habe einen HP ProCurve 1810G. Ich möchte gern ein VLAN einrichten. Wobei das erstellen ja einfach ...

Neue Wissensbeiträge
Sicherheit
Sicherheitsrisiko: Die Krux mit 7-Zip
Information von kgborn vor 3 StundenSicherheit

Bei vielen Anwendern ist das Tool 7-Zip zum Entpacken von Archivdateien im Einsatz. Die Software ist kostenlos und steht ...

Internet

Datendealing im WWW Tracking Methoden immer brutaler

Information von sabines vor 12 StundenInternet

Interessanter Artikel zum Thema Tracking im WWW und die immer "besseren" Methoden des Trackings. Professor Arvind Narayanan (Princeton-Universität) betreibt ...

Erkennung und -Abwehr

Ups: Einfaches Nullzeichen hebelte den Anti-Malware-Schutzt in Windows 10 aus

Information von kgborn vor 1 TagErkennung und -Abwehr

Windows 10 ist das sicherste Windows aller Zeiten, wie Microsoft betont. Insidern ist aber klar, das es da Lücken, ...

Windows 10

Windows 10 on ARM: von Microsoft entfernte Info - Klartext, was nicht geht

Information von kgborn vor 1 TagWindows 10

Windows 10 on ARM ist ja eine neue Variante, die Microsoft im Verbund mit Geräteherstellern am Markt etablieren will. ...

Heiß diskutierte Inhalte
Server
Route-Befehl Unterstützung (unter CMD)
gelöst Frage von FKRR56Server36 Kommentare

Guten Tag , i.M. habe ich Probleme über den CMD-Route-Befehl ein Routing auf einen entfernten Server zuzulassen. Der Server ...

Windows 10
Windows 10 (1709) Tastur und Maus wieder einschalten?
Frage von LochkartenstanzerWindows 1028 Kommentare

Moin, Ich habe von einem Kunden einen Win10-Rechner bekommen, bei dem weder Tastatur noch Maus geht. Die Hardware funktioniert ...

Microsoft
TV-Tipp: Das Microsoft-Dilemma
Information von kgbornMicrosoft17 Kommentare

Aktuell gibt es in Behörden und in Firmen eine fatale Abhängigkeit von Microsoft und dessen Produkten. Planlos agieren die ...

Webbrowser
Welcher Browser ist der Beste?
Frage von justtinWebbrowser15 Kommentare

Hallo Leute Ich habe eine interessante Frage. Mich wurde mal interessieren welcher Browser ist eure meinung nach der beste? ...