Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Cisco SG300 - DHCP Server mit VLAN funktioniert nicht nach Layer 3 downgrade

Mitglied: HomeUser6866

HomeUser6866 (Level 1) - Jetzt verbinden

05.10.2014, aktualisiert 21:18 Uhr, 4262 Aufrufe, 3 Kommentare

Ich bin am verzweifeln.

Bisher hatte ich meinen Cisco SG 300 als layer 3 switch eingesetzt und alles funktionierte prima.

Nachdem ich mir eine Sohos UTM Firewall zugelegt habe, soll diese das Routine der VLANS übernehmen. Also habe ich den SG 300 auf Layer 2 zurückgestellt und alles neu konfiguriert. Der SG300 ist weiterhin der DHCP Server - DHCP Pools sind angelegt wie vorher.

Funktioniert auch mit einer Ausnahme:

Die angeschlossenen PC's erhalten bei DHCP keine IP Adresse.

Was mir nicht klar ist, woher der DHCP Server wissen soll, aus welchem Pool er einem VLAN Client eines IP-Adresse zuweisen soll.

Ich vermute auch dass dies das Problem ist, aber ich habe keine Ahnung wie dieser Bezug hergestellt wird.

Die default Gateways der einzelnen VLANS Liegen jetzt auf einem externen Server (UTM z.B. 192.168.20.1 für VLAN 20 - Firewall ist vorerst völlig offen VLAN xx ->any->any)).

Hat jemand eine Idee - ich bin am verzweifeln.

Statisch zugewiesenen IP's funktionieren!!!!

Viele Dank für Eure Hilfe im Voraus
Mitglied: aqui
LÖSUNG 05.10.2014, aktualisiert um 21:18 Uhr
Ich bin am verzweifeln.
Muss man hier nicht. Wir haben für (fast) alles eine Lösung
SG 300 als layer 3 switch eingesetzt und alles funktionierte prima.
Das sollte er auch....
Die angeschlossenen PC's erhalten bei DHCP keine IP Adresse.
Das ist sehr ungewöhnlich das der Switch selber DHCP Server ist. Bist du dir da ganz sicher ?? Wo ist diese Funktion im Handbuch beschrieben ?
In der Regel ist ein L3 Switch ein DHCP Relay Server oder DHCP Helper, d.h. er forwardet Pakete aus allen VLANs auf einen zentralen DHCP Server die die IPs vergibt.
woher der DHCP Server wissen soll, aus welchem Pool er einem VLAN Client eines IP-Adresse zuweisen soll.
Im Relay Mode bei L3 Betrieb ersetzt der DHCP Relay Server die Absender IP mit der IP Adresse seines eigenen VLAN Interfaces. Der zentrale DHCP Server erkennt dann anhand der Absender IP den richtigen Scope und vergibt einen IP aus dem Bereich.
Im L2 Mode funktioniert das logischerweise nicht mehr und es ist deshalb stark zu bezweifeln das der Switch selber Server sein kann, denn über ein VLAN Index müsste er irgendwie den Scope detektieren, was mehr als ungewöhnlich ist und vermutlich auch nicht supportet, deshalb wäre hier der Abschnitt im Manual interessant der diese Funktion beschreibt.

Wenn der Switch dann selber kein Routing mehr macht durch die deaktivierten L3 Funktionen hast du die UTM vermutlich mit einem tagged Uplink zentral an den Switch angeschlossen wie in diesem Forums Tutorial beschrieben:
https://www.administrator.de/wissen/vlan-installation-und-routing-mit-m0 ...
Richtig ??
Dann musst du vermutlich die UTM DHCP Server für die einzelnen VLAN Segmente spielen lassen wie es in solch einem Design üblich ist.
Es ist wie gesagt zu bezweifeln das der Switch selber noch irgendeine DHCP Funktion dann ausführt was wie gesagt generell ja üblich ist für L2 Switches.
Die default Gateways der einzelnen VLANS Liegen jetzt auf einem externen Server
Die UTM ist doch kein "Server" sondern einen Firewall ! Oder was meinst du mit "Server" ??
Statisch zugewiesenen IP's funktionieren!!!!
Ääähh, ja, das ist klar aber vermutlich nicht dein Ziel ?!
Bitte warten ..
Mitglied: Pjordorf
05.10.2014 um 19:48 Uhr
Hallo,

Zitat von aqui:
Das ist sehr ungewöhnlich das der Switch selber DHCP Server ist.
Ja, das kann der...

Bist du dir da ganz sicher ?? Wo ist diese Funktion im Handbuch beschrieben ?
http://www.cisco.com/c/dam/en/us/td/docs/switches/lan/csbms/sf30x_sg30x ... ab Seite 268. Scheint das dort ein vollwertiger DHCP drin steckt.
Entweder DHCP Server oder DHCP Relay und DHCP Server nur wenn er selbst kein Dynamische IP selbst erhält....

Gruß,
Peter
Bitte warten ..
Mitglied: HomeUser6866
05.10.2014 um 21:21 Uhr
Genau der Unterschied zwischen Layer 3 und Layer 2 bei der Zuweisung von DHCP Pools zum VLAN war das Problem.
Bin Deinem Vorschlag gefolgt und habe DHCP Server auf dem Cisco SG300 gelöscht und auf der UTM angelegt.
geht prima !!!!!

Nochmals herzlichen Dank

PS: Ob und wie man es mit dem DHCP Server auf dem Cisco SG300 in Layer 2 Mode zum laufen kriegt, habe ich nicht weiter verfolgt.
Bitte warten ..
Ähnliche Inhalte
Router & Routing
Cisco SG300 Layer 3 Routing
Frage von Maik20Router & Routing4 Kommentare

Hallo, ich habe soeben auf dem SG300 ein neues VLAN (ID 310) angelegt und dieses als Tagged auf einen ...

Netzwerkmanagement
Cisco SG300 DHCP an VLAN
gelöst Frage von Maik82Netzwerkmanagement17 Kommentare

Guten Tag, Ich bin ganz neu in der Cisco Wellt. Ich habe mir einen CISCO SG300 /28 Zugelegt um ...

Switche und Hubs

Cisco SG300-28 Layer 3 Konfiguration VLAN dynamisch

gelöst Frage von MartinLSwitche und Hubs4 Kommentare

Liebe Gemeinde, ich habe eine Frage bezüglich der Konfiguration von VLAN`s auf einem Cisco SG300-28. Ich habe schon viel ...

Router & Routing

Cisco SG300 - Kein Routing ins VLAN

gelöst Frage von Fluxx1337Router & Routing4 Kommentare

Hallo zusammen, Was ich möchte sieht man gut auf der Skizze. PC1 soll sich im dhcp Netz der Fritzbox ...

Neue Wissensbeiträge
Sicherheit
Sicherheitsrisiko: Die Krux mit 7-Zip
Information von kgborn vor 40 MinutenSicherheit

Bei vielen Anwendern ist das Tool 7-Zip zum Entpacken von Archivdateien im Einsatz. Die Software ist kostenlos und steht ...

Internet

Datendealing im WWW Tracking Methoden immer brutaler

Information von sabines vor 10 StundenInternet

Interessanter Artikel zum Thema Tracking im WWW und die immer "besseren" Methoden des Trackings. Professor Arvind Narayanan (Princeton-Universität) betreibt ...

Erkennung und -Abwehr

Ups: Einfaches Nullzeichen hebelte den Anti-Malware-Schutzt in Windows 10 aus

Information von kgborn vor 22 StundenErkennung und -Abwehr

Windows 10 ist das sicherste Windows aller Zeiten, wie Microsoft betont. Insidern ist aber klar, das es da Lücken, ...

Windows 10

Windows 10 on ARM: von Microsoft entfernte Info - Klartext, was nicht geht

Information von kgborn vor 1 TagWindows 10

Windows 10 on ARM ist ja eine neue Variante, die Microsoft im Verbund mit Geräteherstellern am Markt etablieren will. ...

Heiß diskutierte Inhalte
Server
Route-Befehl Unterstützung (unter CMD)
gelöst Frage von FKRR56Server36 Kommentare

Guten Tag , i.M. habe ich Probleme über den CMD-Route-Befehl ein Routing auf einen entfernten Server zuzulassen. Der Server ...

Windows 10
Windows 10 (1709) Tastur und Maus wieder einschalten?
Frage von LochkartenstanzerWindows 1028 Kommentare

Moin, Ich habe von einem Kunden einen Win10-Rechner bekommen, bei dem weder Tastatur noch Maus geht. Die Hardware funktioniert ...

Microsoft
TV-Tipp: Das Microsoft-Dilemma
Information von kgbornMicrosoft17 Kommentare

Aktuell gibt es in Behörden und in Firmen eine fatale Abhängigkeit von Microsoft und dessen Produkten. Planlos agieren die ...

Firewall
RB2011 Firewall Rule eine bestimmte Mac oder IP Adresse nicht zu blockieren
Frage von lightmanFirewall15 Kommentare

Hallo liebes Forum mit ihren Spezialisten. Ich habe meine Firewall so konfiguriert das kein Endgerät ohne meine Speziellen Erlaubnis ...