Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Citrix TS - XENAPP5 - MMC wird nicht ausgeführt ausser ich starte vorher ein anderes Programm

Mitglied: Smoke-the-Lord

Smoke-the-Lord (Level 1) - Jetzt verbinden

12.07.2010, aktualisiert 12:47 Uhr, 5034 Aufrufe, 7 Kommentare

Hi Gemeinde,
ich habe folgendes Problem:

Ich starte eine MMC + MSC (liegen lokal) die über Citrix veröffentlicht wurde. Der User wird am Server angemeldet (Anmeldefenster erscheint)... nichts passiert... der User wird abgemeldet (Abmeldefenster erscheint).

Wenn ich nun aber eine andere App (z.B IE8) auf dem Server starte um mich dort anzumelden und dann erst die MMC starte öfffnet sie sich ohne Probleme. Dieses Verhalten habe ich nur beim W2K8 SP2 mit XENAPP5. Dieser ist Mitglied in einer PS 4.5 Farm mit W2K3 Maschinen. Auf denen funktioniert das öffnen auch problemlos.

Woran kann das liegen?

Danke für die Antworten.
Mitglied: BigWim
12.07.2010 um 11:16 Uhr
Mal so ein Schuß ins Blaue.

Hört sich danach, dann der W2K8-Server die Task nicht erkennen kann als geöffnetes Programm.

Citrix führt eine Liste der OS-Task, um zu erkennen, wann die PA beendet ist. Vielleicht solltest Du diese mal etwas näher unter die Lupe nehmen ....

Markus
Bitte warten ..
Mitglied: Smoke-the-Lord
12.07.2010 um 12:47 Uhr
a31cabeae82d0f47e15d54540be77efe - Klicke auf das Bild, um es zu vergrößern

Danke für die Antwort. Citrix führt die MMC in der Prozessliste vom Server. Von daher denk ich vorbei geschossen. Oder meinst du was anderes?
Bitte warten ..
Mitglied: BigWim
12.07.2010 um 14:05 Uhr
ich meine, die Funktionalität rund um den Key HKLM->System->CurrentControlSet->Control>Terminal Server->SysProcs


Markus
Bitte warten ..
Mitglied: Smoke-the-Lord
12.07.2010 um 16:37 Uhr
Jetzt weiß ich worauf du hinaus willst. Du meinst wenn dort mmc.exe gelistet wäre, würde die connection beendet werden, obwohl die mmc auf dem Server noch läuft. Richtig verstanden?
Dann müsste logischerweise, nachdem ich den IE8 und die MMC geöfnnet habe, die Connection bei beenden vom IE getrennt werden. Ist leider nicht der Fall... die MMC läuft weiter.

Das hier ist im Key zu finden, für mich würde nichts auf das Problem hinweisen.

screg.exe REG_DWORD 0x0
netdde.exe REG_DWORD 0x0
clipsrv.exe REG_DWORD 0x0
lmsvcs.exe REG_DWORD 0x0
MsgSvc.exe REG_DWORD 0x0
NETSTRS.EXE REG_DWORD 0x0
nddeagnt.exe REG_DWORD 0x0
os2srv.exe REG_DWORD 0x0
wfshell.exe REG_DWORD 0x0
win.com REG_DWORD 0x0
conime.exe REG_DWORD 0x0
proquota.exe REG_DWORD 0x0
imepadsv.exe REG_DWORD 0x0
ctfmon.exe REG_DWORD 0x0
TaskEng.exe REG_DWORD 0x0
dwm.exe REG_DWORD 0x0
rdpclip.exe REG_DWORD 0x0
ssonsvr.exe REG_DWORD 0x0
Bitte warten ..
Mitglied: BigWim
13.07.2010 um 09:12 Uhr
Zitat von Smoke-the-Lord:
Jetzt weiß ich worauf du hinaus willst. Du meinst wenn dort mmc.exe gelistet wäre, würde die connection beendet
werden, obwohl die mmc auf dem Server noch läuft. Richtig verstanden?
Ja, das war mein Hintergedanke. Konnte ich hier nicht prüfen, haben "nur" W2K3 SE

Dann könnte ich mir noch vorstellen, dass Du vor einem Timing-Problem stehst. Warum und wie auch immer. Ich würde das vorab testen, in dem ich den Startaufruf der PA in eine CMD verpacke mit einem Sleep oder eine Pause.

Also sinngemäß so:

01.
Sleep 10 
02.
start mmc.exe
oder eben statt des Sleep ein "Pause", um zu sehen, was da passiert ....

Markus
Bitte warten ..
Mitglied: Smoke-the-Lord
13.07.2010 um 14:02 Uhr
Anscheinend startet er die mmc garnicht. Wenn ich eine cmd hinterlege bleibt das Verhalten unverändert. Ein Echo >> Datei in der cmd wird auch nicht geschrieben.

Im Windows Application Log hab ich folgendes Event gefunden was die erfolgreiche und missglückte Anmeldung unterscheidet.

Information 13.07.2010 13:03:32 Source: Microsoft-Windows-Winlogon Event ID:4004 Task:None
The Windows logon process has failed to terminate the currently logged on user's processes.

MS spuckt das hier aus:
http://technet.microsoft.com/en-us/library/dd363910%28WS.10%29.aspx


Allerdings ist mir der Unterschied zwischen einer Iexplore.exe und einer mmc.exe in diesem Zusammenhang nicht ersichtlich.
Bitte warten ..
Mitglied: BigWim
13.07.2010 um 15:08 Uhr
Zitat von Smoke-the-Lord:
Allerdings ist mir der Unterschied zwischen einer Iexplore.exe und einer mmc.exe in diesem Zusammenhang nicht ersichtlich.
Stimme ich Dir zu; kann ich jetzt auch so nichts entdecken.

Anscheinend startet er die mmc garnicht. Wenn ich eine cmd hinterlege bleibt das Verhalten unverändert. Ein Echo >>
Datei in der cmd wird auch nicht geschrieben.
Ich kann das hier leider nicht nachstellen und mir gehen. Hast Du es auch mit einer Pause probiert.
Bei diesem Test käme es mir wirklich darauf, dass der Server mit dem Start der Anwendung beschäftigt ist.

Einen IE zu starten oder eine "kleine" mmc.exe wird sich schon zeitlich auswirken. Mit der Pause kannst dann sehen, ob er wirklich nicht startet.

Kann es evtl. sein, dass eine "Verbotsliste" dafür sorgt, dass die Anwendung als PA nicht gestartet werden darf?

Ansonsten gehen mir jetzt die Idee aus ...

Markus
Bitte warten ..
Ähnliche Inhalte
Windows Server

Powershell Programm über Citrix starten

Frage von Florian86Windows Server2 Kommentare

Hallo, ich habe eine Verknüpfung auf unseren Citrixserver welche ich über die Powershell starte und über Citrix verteile. Eine ...

Webbrowser

Plug-in wird nur ausgeführt, wenn es vorher als Admin ausgeführt wurde

gelöst Frage von ganymedWebbrowser4 Kommentare

Hallo, ich möchte Benutzern ermöglichen das Lync Web App Plug-in in folgender Umgebung zu verwenden. Win 7 Client in ...

Batch & Shell

Programm wird sehr langsam ausgeführt

gelöst Frage von Peter32Batch & Shell19 Kommentare

Hallo, ich habe ein kleines Programm gebastelt (mit Anfängerskills!), welches erst überprüft, wieviele Benutzer angemeldet sind und wenn mehr ...

Windows Server

Citrix Voraussetzungen für Programme

Frage von ChristophEWindows Server4 Kommentare

Hallo Miteinander, ich bin Azubi und komplett unerfahren mit Citrix und habe daher folgende Frage die ich nach langem ...

Neue Wissensbeiträge
Humor (lol)
IoT-Gefahr: Smartes Aquarium leckt!
Information von Lochkartenstanzer vor 19 StundenHumor (lol)3 Kommentare

Moin, Die IoT-Manie hat weitere Opfer gefunden. Ein Casino-Leck durch ein smartes Aquarium: Allerdings haben sie kein Wasser, sondern ...

Router & Routing

Alte Fritzbox 7270 mit VPN und SIP-Telefonie hinter O2 Homebox 6641 als "Modem"

Erfahrungsbericht von the-buccaneer vor 1 TagRouter & Routing3 Kommentare

Nun war es soweit: Auch O2 hat mich mit VOIP zwangsbeglückt. Heute am Privatanschluss, in 2 Wochen ist das ...

Sicherheit

Ungepatchte Remote Code Execution-Lücke in LG NAS

Information von kgborn vor 1 TagSicherheit

Nutzt wer LG NAS-Einheiten? In den NAS-Einheiten der LG Network Storage-Einheiten gibt es eine sehr unschöne Schwachstelle, die einen ...

Windows Update

Neue Version KB4099950 NIC Einstellungen gehen verloren

Information von sabines vor 1 TagWindows Update2 Kommentare

Es ist eine neue Version des KB4099950 verfügbar, die das Problem mit den verlorenen Netzwerkeinstellungen lösen soll. Das Datum ...

Heiß diskutierte Inhalte
Sicherheit
Verbindliche Zustellung per E-Mail?
Frage von ahussainSicherheit18 Kommentare

Hallo allerseits, ein Kunde von mir nutzt intensiv Fax. Hauptgrund: zusammen mit einer Empfangsbestätigung ist eine verbindliche Zustellung gewährleistet. ...

Sonstige Systeme
Wie Normenkataloge im Unternehmen bereit stellen?
Frage von MuzzepuckelSonstige Systeme14 Kommentare

Hallo Kollegen, ich lese schon lange hier mit, nun mein ersrer Beitrag, bzw. Frage. :-) Wir benötigen für unsere ...

Linux Netzwerk
Raspberry Pi 3: WLAN Power save deaktivieren
Frage von nordie92Linux Netzwerk13 Kommentare

Moin moin, mein Raspberry Pi 3 Model B benötigt eine dauerhaft aktive WLAN-Verbindung. Leider bricht die WLAN-Verbindung nach einigen ...

SAN, NAS, DAS
Entscheidung SAN Dell oder HP
Frage von VincorSAN, NAS, DAS13 Kommentare

Hallo, wir wollen uns für unsere Hyper V Umgebung eine neue SAN Anschaffen. Es laufen 30 VM's darunter, DC; ...