Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Cmd ping funktioniert nicht mehr - process tried to write to a nonexisting pipe

Mitglied: jutzin

jutzin (Level 1) - Jetzt verbinden

11.06.2014, aktualisiert 18:24 Uhr, 1574 Aufrufe, 7 Kommentare, 3 Danke

hallo zusammen,

das problem:
seit einigen stunden funktioniert der ping befehl auf einer windows 7 pro maschine nicht mehr; es wird einfach nichts zurueckgegeben. wenn ich mit str+c abbreche, wird seitenweise in etwa folgendes ausgegeben
^^^^^^^^^^^^^^^^^^^^^^^^^^^CCCCCCCCCCCCCCCCCCCCCCC^^^^^CCCCCCCCCCCCCC^C^C^CCCCCCCCCCC process tried to write to a nonexisting pipe ^CCCCCCCCCCCCCCCCC^CCCCCCCCCCCCCCC^CCCCCCCCCCCC 
usw., bis ich das cmd fenster schliesze oder den cmd.exe prozess gewaltsam beende (was beides relativ lange dauert).

ping funktioniert in einem anderen benutzerkonto auf derselben maschine nach wie vor ganz normal.

was ich vorher gemacht habe:
etwa 12 stunden lang
ping 10.10.10.50 -t
; danach so ungefaehr diesen befehl
for /f "tokens=*" %%a in ('ping -n 1 10.10.10.50 ^|find "Pinging abc.def.ghj.klm"') do echo %%a 2>&1>>ping.txt
ausgefuehrt (oder so aehnlich). klar, ging natuerlich nicht, in etwa so
 ... 2>&1 | tee ping.txt
waere besser gewesen (unxutils).

was ich seitdem gemacht habe:
neu gestartet; im abgesicherten modus gestartet; set ausgefuehrt um zu sehen, ob mir eine umgebungsvariable einen strich durch die rechnung macht. hat mich alles nicht weiter gebracht.

bevor ich den account loesche und neu anlege -- und natuerlich aus reiner neugier -- hat vielleicht jemand eine idee, was hier passiert ist bzw. wie man das normale verhalten wieder herstellen kann?

gruesze
jutzin
Mitglied: Xaero1982
11.06.2014 um 16:25 Uhr
Hi,

ist es egal was du pingst?

Gruß
Bitte warten ..
Mitglied: jutzin
11.06.2014, aktualisiert um 17:00 Uhr
ja, voellig egal, auch 127.0.0.1 geht nicht. von einem anderen benutzerkonto aus kann ich loopback und externe adressen pingen.
Bitte warten ..
Mitglied: Xaero1982
LÖSUNG 11.06.2014, aktualisiert um 18:24 Uhr
Faszinierend...

Keine Ahnung, ob es hilft... schon mal ein netsh int ip reset versucht?

Cmd als Admin ausgeführt? Also Rechtsklick...
Bitte warten ..
Mitglied: jutzin
11.06.2014, aktualisiert um 18:24 Uhr
indeed.

netsh int ip reset verlaeuft erfolgreich, aendert aber nichts (hatte zudem auch vorher bereits den netzwerkadapter erntfernt und wieder hinzugefuegt, nur oben vergessen zu erwaehnen).

der zweite tipp hat etwas ergeben: das betroffene konto ist der administrator; habe cmd zuvor immer per win+r ausgefuehrt (mit schild und this process will be run with administrative privileges). hatte angenommen, das entspraeche dem gleichen uac mode wie per rechtsklick als administrator ausfuehren. ist aber offenbar nicht so, denn wenn ich cmd aus dem startmenue per rechtsklick als administrator ausfuehre, wird ganz normal gepingt.

sagt Dir das was? in jedem anderen account geht's auch per win+r cmd, nur im administratorkonto (wo es vorher auch so ging) geht's nun nicht mehr ohne rechtsklick.
Bitte warten ..
Mitglied: Xaero1982
LÖSUNG 11.06.2014, aktualisiert 12.06.2014
Interessant...

Ich hab versucht das zu rekonstruieren, aber "leider" ohne Erfolg. Bei mir pingt er munter weiter.

Ich hab ehrlich gesagt keine Ahnung warum es nicht funktioniert und was da schief gegangen ist. Mehr hast du sicher nicht gemacht? Da hängt auch nichts mehr quer? Da gibt es auch keine andere Datei in dem Ordner mit dem Namen Ping?

Ist es auch so, wenn du in dem Konto indem es nicht geht das ganze aus einem anderen Ordner ausführst?
Bitte warten ..
Mitglied: jutzin
12.06.2014 um 08:33 Uhr
Zitat von Xaero1982:

... Da gibt es auch keine andere Datei in dem Ordner mit dem Namen Ping?

Ist es auch so, wenn du in dem Konto indem es nicht geht das ganze aus einem anderen Ordner ausführst?...

chapeau, nagel aum kopp. muss wohl sowas wie
for /f "tokens=*" %%a in ('ping -n 1 10.10.10.50 ^|find "Pinging abc.def.ghj.klm"') do echo %%a 2>&1>>ping.BAT
ausgefuehrt haben, sodass im profile folder des administrators nun eine kaputte ping.bat liegt. haette mir ja auch mal auffallen koennen... argh, the shame!!

krasse ferndiagnose, tx.
Bitte warten ..
Mitglied: Xaero1982
12.06.2014 um 08:39 Uhr
Freut mich, dass wir das lösen konnten

Naja manchmal sieht man das Naheliegendste nicht

Gruß
Bitte warten ..
Ähnliche Inhalte
Batch & Shell

Ping-Befehl mit FIND-Pipe in IF-Befehl einbauen

gelöst Frage von ThraexBatch & Shell3 Kommentare

Schöne Grüße an die Community,, derzeit bereitet mir eine simple Anforderung arge Probleme. Ich hoffe mit dem Wissen aus ...

Batch & Shell

Powershell-ISE - Buggy? Start-Process cmd - mit anderen Credentials

Frage von Raaja89Batch & Shell8 Kommentare

Hallo zusammen, ich habe folgenden Befehlt: Als Get-Credential wird ein Benutzer mit Admin Rechten benutzt Warum funktioniert dieser Befehl ...

IDE & Editoren

Benutzeranmeldung CMD funktioniert nicht

gelöst Frage von JustinpkIDE & Editoren4 Kommentare

Weshalb funktioniert dieser Script nicht? Sollte eine normale Anmeldung sein echo off color c echo Sign in to get ...

Windows 7

CMD ftp funktioniert nicht aber wieso?

gelöst Frage von DomiiAUTWindows 710 Kommentare

Ich habe alles versuch und ich habe festgestellt, dass cmd das Problem ist. Sobald ich ftp eingebe und anschließend ...

Neue Wissensbeiträge
Sicherheit

Ungepatchte Remote Code Execution-Lücke in LG NAS

Information von kgborn vor 12 StundenSicherheit

Nutzt wer LG NAS-Einheiten? In den NAS-Einheiten der LG Network Storage-Einheiten gibt es eine sehr unschöne Schwachstelle, die einen ...

Windows Update

Neue Version KB4099950 NIC Einstellungen gehen verloren

Information von sabines vor 18 StundenWindows Update2 Kommentare

Es ist eine neue Version des KB4099950 verfügbar, die das Problem mit den verlorenen Netzwerkeinstellungen lösen soll. Das Datum ...

Microsoft Office

MS Office 2019 ohne OneNote - OneNote App speichert nur in Cloud

Information von Deepsys vor 1 TagMicrosoft Office5 Kommentare

Microsoft zeigt deutlich wohin alles bei Ihnen geht, OneNote 2019 wird es nicht mehr geben, und die Windows 10 ...

Humor (lol)

Warum man sein Gast-WLAN nicht beliebig nennen sollte

Erfahrungsbericht von Henere vor 2 TagenHumor (lol)5 Kommentare

Servus, mal was aus dem Alltag. Zu Hause. Eigentlich wollte ich nur einen weiteren WLAN-AP ins Netz bringen, damit ...

Heiß diskutierte Inhalte
Festplatten, SSD, Raid
Server SSD: NVMe PCIe 3.0 RAID?
Frage von bouneeFestplatten, SSD, Raid15 Kommentare

Hallo liebe Admins, mir stellt sich gerade die Frage, ob ein neuer Server mit SSD NVMe PCIe 3.0 Sinn ...

Sonstige Systeme
Wie Normenkataloge im Unternehmen bereit stellen?
Frage von MuzzepuckelSonstige Systeme14 Kommentare

Hallo Kollegen, ich lese schon lange hier mit, nun mein ersrer Beitrag, bzw. Frage. :-) Wir benötigen für unsere ...

Windows 10
Windows 10 Startmenü-Einstellungen Systemweit festlegen
Frage von flotautWindows 1013 Kommentare

Guten Morgen liebe Admins, wir möchten bei uns am Lehrstuhl demnächst auf Windows 10 umsteigen. Wir installieren unsere PC's ...

LAN, WAN, Wireless
OpenVPN Client Fehlermeldungen
Frage von chris84LAN, WAN, Wireless12 Kommentare

Hallo Zusammen, wir nutzen seit kurzem einen neuen Router und den OpenVPN Client. Die VPN Verbindung klappt; allerdings kommen ...