Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

ComSpec Umgebungsvariable in Verbindung mit telnet und Windows Server 2008 R2 funktioniert nicht mehr

Mitglied: 92692

92692 (Level 1)

09.11.2011 um 17:13 Uhr, 3825 Aufrufe, 2 Kommentare

Hallo zusammen,
wir nutzen bisher eine VT220 Emulation über Telnet von einem MDE-Gerät zu einem Windows 2000 Server mit installierten Telnetserver. Dieser soll nun migriert werden auf Windows Server 2008 R2.

Damals haben wir in den Umgebungsvariablen des Benutzers die ComSpec Variable dafür genutzt, das emulierte Terminalprogramm (.exe) automatisch nach Anmeldung des Benutzers via Telnet zu starten. Zusätzlich haben wir in den Profileinstellungen des Benutzers auf dem Server den lokalen Pfad so eingestellt, dass dieser gleich ist mit dem Pfad in der die .exe des Programms liegt. Bei gleicher Vorgehensweise lässt sich dies aber nicht auf dem neuen Windows Server 2008 R2 umsetzen.

Nach einer Anmeldung via Telnet landen wir nur in dem "lokalen Pfad". Wenn man nun manuell über eine aktive Telnetsitzung die .exe des Programms aus dem lokalen Verzeichnis aufruft läuft wiederum alles.

Hat jemand eine Idee? Vielen Dank im Voraus.

Mit freundlichen Grüßen
Daniel
Mitglied: 60730
10.11.2011 um 01:11 Uhr
moin,

irgendwie blicke ich da nicht durch...

ComSpec Umgebungsvariable in Verbindung mit telnet und Windows Server 2008 R2 funktioniert nicht mehr
so lautet die Überschrift.
Damals haben wir in den Umgebungsvariablen des Benutzers die ComSpec Variable dafür genutzt, das emulierte Terminalprogramm (.exe) automatisch nach Anmeldung des Benutzers via Telnet zu starten.

Also sollte die Überschrift eigentlich lauten
  • Verbiegen der %Comspec%, um ein emuliertes Terminalprogramm.exe automatisch...

Hat jemand eine Idee?
  • ja du schreibst nochmal - da darfst du dann gerne Absatzmarken/Zeilenschalter benutzen, das ganze auf, denn ich lese da nur Bahnhof.

Immer dran denken, du sitzt vor dem "Problem" und findest keine Lösung, wie sollte es uns dann gehen?

Gruß
Bitte warten ..
Mitglied: 92692
10.11.2011 um 14:36 Uhr
Hallo TimoBeil,
entschuldige, wenn ich mich unverständlich ausgedrückt habe.

Wir haben das Problem mittlerweile soweit eingrenzen können, dass wir folgendes festgestellt haben:
  • bei einer Anmeldung via Telnet werden keine Benutzrerumgebungsvariablen geladen
  • bei vorheriger Anmeldung am Windows Desktop und nachträglicher Anmeldung über Telnet funktioniert die %comspec% Variable

Vielleicht nochmal zum Verständnis:
  • es wird eine Telnetverbindung auf einen Windows Server 2008 R2 gestartet (telnet 192.168.x.x)
  • sobald die Verbindung steht, wird automatisch eine VT220 Terminalemulation gestartet (vt220.exe)

... und genau dieser Automatismus soll wieder funktionieren. Ich möchte halt jetzt nicht immer den Benutzer xy am Windows Dekstop anmelden um anschließend von einem MDE-Gerät (Intermec CK-3) die Telnetsitzung öffnen zu können.

Ich hoffe ich konnte das Problem nun etwas besser beschreiben. Vielen Dank im Voraus!

Gruß
Bitte warten ..
Ähnliche Inhalte
Netzwerke
Telnet auf Switch funktioniert nicht
Frage von 118400Netzwerke9 Kommentare

Ich möchte mittels Telnet auf einen Switch zugreiffen. Ich bekomme jedoch immer den folgenden Fehler: es konnte keine verbindung ...

Windows Server

Windows-Explorer funktioniert nicht mehr Windows Server 2008 R2

gelöst Frage von Zeus0815Windows Server4 Kommentare

Hallo zusammen, ich kann die Ursache für folgenden Fehler einfach nicht finden: Jedes mal wenn ich rechtsklick (z.B. auf ...

Windows Server

Windows Server 2008 Update funktioniert nicht

gelöst Frage von csd2001Windows Server5 Kommentare

Hallo alle zusammen, wir haben eine Windows 2008 Server der eigentlich immer die Wöchentlichen Sicherheitsupdates allein fährt. Dieses funktuniert ...

Windows Server

Windows Server 2008 R2 härten

Frage von wolphyWindows Server11 Kommentare

Hallo zusammen, ich bin seit 2 Tagen in der "zivilen" IT tätig (war vorher Bundeswehr), und habe den spannenden ...

Neue Wissensbeiträge
Linux Netzwerk

Installation eines Logservers mit Loganalyzer als Debian-VM auf Hyper-V

Anleitung von lcer00 vor 6 StundenLinux Netzwerk

Zuerst sei auf den schönen Beitrag von aqui hier im Forum verwiesen, in dem die loganalyzer-installation bereits beschrieben ist: ...

Humor (lol)
Antennagate 2018
Information von magicteddy vor 6 StundenHumor (lol)2 Kommentare

Da haut der angekaute Elektronikhersteller die teuersten Geräte auf den Markt und bekommt anscheinend die Basics mal wieder nicht ...

Datenschutz

Die Datenkrake Google verlängert ihr Arme mal wieder ein wenig, automatische Anmeldung

Tipp von magicteddy vor 1 TagDatenschutz3 Kommentare

Benutzer mit einem Google Account und gespeicherten Zugangsdaten werden von chrome 69 automatisch bei Google angemeldet, natürlich alles zum ...

Verschlüsselung & Zertifikate
Meine Wissenssammlung zu Bitlocker
Erfahrungsbericht von DerWoWusste vor 2 TagenVerschlüsselung & Zertifikate3 Kommentare

Die Motivation für diesen Beitrag waren die vielen Posts rund um dieses Thema, die deutlich machen, wie viele Einzelaspekte ...

Heiß diskutierte Inhalte
E-Mail
Welche ist die beste E-Mail Groupware für die Zukunft?
Frage von ITCrowdSupporterE-Mail24 Kommentare

Guten Tag allerseits :) Ich möchte mich mit einer Frage heute mal an die Schwarmintelligenz wenden. Aktuell befasse ich ...

Windows Server
In-Place Upgrade von Windows Server 2008 R2 Datacenter zu Windows Server 2016 Datacenter (Zwischenschritt über 2012 R2)
gelöst Frage von TowerpleaseWindows Server16 Kommentare

Hallo Administratoren, Wir haben uns vor ein paar Monaten Windows Server 2016 Datacenter Lizenzen gekauft und wollen nun unsere ...

Firewall
Wesyb Offline
Frage von DkuehlbornFirewall14 Kommentare

Hallo Kollegen, ein Kunde hat von Wesyb die Sicherheitslösung im Einsatz. Seit August scheint deren Internetseite nicht mehr verfügbar ...

Video & Streaming
DVD auf Festplatte sichern
Frage von Thor01Video & Streaming13 Kommentare

Hallo, mittlerweile hat meine DVD Sammlung ein alter erreicht wo die eine oder andere DVD schon das Zeitliche gesegnet ...