Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst cron wird nicht ausgeführt

Mitglied: Passepartout

Passepartout (Level 1) - Jetzt verbinden

11.05.2009, aktualisiert 12:09 Uhr, 4627 Aufrufe, 12 Kommentare

Der Cronjob für eine einfache automatische Datensicherung funktioniert leider nicht

Hallo liebe Forumsgemeinde,

ich habe einen (File-)Server auf xubuntu-Basis eingerichtet, auf dem ich für unser kleines Netzwerk die Daten zentral speichere.
Ich möchte diese auf eine externe Festplatte sichern, die auf /media/disk eingehängt ist.

Dazu verwende ich folgende Bash

01.
#!/bin/bash 
02.
DATUM=`date +%y-%m-%d~%H:%M` 
03.
mv /media/disk/_current/ /media/disk/${DATUM}/ 
04.
rsync -a --link-dest=/media/disk/${DATUM}/ /home/ /media/disk/_current/ 
Die auch, wenn ich sie aus der Konsole aufrufe, einwandfrei das tut, was ich möchte.

Nun habe ich in der Crontab folgende Zeile drin (aus debug-Zwecken hatte ich vorerst auf alle 2 Minuten eingestellt)

01.
# m h  dom mon dow   command 
02.
*/2 * * * * root /bin/bash /etc/backup.sh > /home/backup.log
In den Zugriffsstatistiken registriert der Server auch, dass cron was tut, aber in den entsprechenden Ordner werden keine Dateien gesichert.
Leider wird auch in die backup.log nichts geschrieben.

Hat vielleicht jemand einen Tipp für mich? Für Hilfe wäre ich dankbar und sende Euch

Grüße aus Hamburg,

Michael
Mitglied: 75823
11.05.2009 um 12:22 Uhr
Versuch mal den Script die Rechte für Ausführung geben und lasse in den Crontab nur /etc/backup.sh
Bitte warten ..
Mitglied: Passepartout
11.05.2009 um 12:35 Uhr
Hallo,

danke für Deinen schnellen Tipp, hat leider gar nichts geändert

Rechte der Datei
01.
-rwxrwx--x   1 root root       208 2009-05-11 10:08 backup.sh
Neuer Inhalt crontab
01.
# m h  dom mon dow   command 
02.
*/2 * * * * root /etc/backup.sh > /home/backup.log
Liebe Grüße,
Michael
Bitte warten ..
Mitglied: 75823
11.05.2009 um 12:48 Uhr
Also nur:
*/2 * * * * root /etc/backup.sh
nicht:
*/2 * * * * root /etc/backup.sh > /home/backup.log
Bitte warten ..
Mitglied: Passepartout
11.05.2009 um 13:16 Uhr
Hallo,

leider keine Änderung
Was mich wundert, er scheint das Skript aufzurufen, das Skript funktioniert ohne Cron wunderbar... woran kann das liegen?

Liebe Grüße,
Michael
Bitte warten ..
Mitglied: dog
11.05.2009 um 13:27 Uhr
Das könnte z.B. an deinem $PATH liegen.

Bedenke:
01.
> Datei
loggt nur den STDOUT nach Datei.
Du willst aber STDOUT und STDERROR haben.
Dazu musst du schreiben:
01.
&> Datei
Vermutlich wird es darauf hinauslaufen, dass rsync nicht gefunden wird.
Darum solltest du in cron-Scripts unbedingt den absoluten Pfad zu einem Programm verwenden (den findest du mit which rsync)

Wenn dein Server richtig konfiguriert ist, solltet du übrigens E-Mails mit den Fehlermeldungen erhalten haben.

Grüße

Max
Bitte warten ..
Mitglied: Passepartout
11.05.2009 um 13:35 Uhr
Hallo,

danke für den Hinweis. Habe nun folgende Zeile im Crontab stehen.
01.
*/2 * * * * root /etc/backup.sh &> /home/backup.log
Außerdem habe ich den Pfad von rsync angepasst.
Leider tut sich trotzdem nichts.

Da der Server nur für Dateiverwaltung zuständig ist, habe mailtechnisch gar nichts eingerichtet.

Vielleicht noch eine Idee?
Liebe Grüße,

Michael
Bitte warten ..
Mitglied: 75823
11.05.2009 um 14:39 Uhr
Ok, mein letzte Versuch. Probiere dann exec hinzufügen:
*/2 * * * * root exec /etc/backup.sh
Bitte warten ..
Mitglied: Passepartout
11.05.2009 um 14:58 Uhr
leider auch das ohne Erfolg...
Bitte warten ..
Mitglied: dog
11.05.2009 um 15:17 Uhr
Bist du dir sicher, dass cron überhaupt ausgeführt wird?

Auf Debian-Systemen sollte sich dann z.B. in der /var/log/syslog folgendes befinden:

01.
May 11 11:11:11 servername /USR/SBIN/CRON[PID]: (root) CMD (/befehl.sh &> /tmp/ouput)
Grüße

Max
Bitte warten ..
Mitglied: Passepartout
12.05.2009 um 07:49 Uhr
Hallo,

hier ein Auszug aus dem Syslog.
Könnte es sein, dass die anderen Fehler für das komische Verhalten verantwortlich sind?

01.
May 11 08:34:02 FileServer /USR/SBIN/CRON[22466]: (root) CMD (root /bin/ bash /etc/backup.sh > /home/backup.log) 
02.
May 11 08:34:17 FileServer kernel: [2331966.828018] Filesystem "sdf1": xfs_log_force: error 5 returned. 
03.
May 11 08:34:53 FileServer kernel: [2332002.828026] Filesystem "sdf1": xfs_log_force: error 5 returned. 
04.
May 11 08:35:29 FileServer kernel: [2332038.828027] Filesystem "sdf1": xfs_log_force: error 5 returned. 
05.
May 11 08:36:01 FileServer /USR/SBIN/CRON[22705]: (root) CMD (root /bin/ bash /etc/backup.sh > /home/backup.log) 
06.
May 11 08:36:05 FileServer kernel: [2332074.828026] Filesystem "sdf1": xfs_log_force: error 5 returned. 
07.
May 11 08:36:41 FileServer kernel: [2332110.828028] Filesystem "sdf1": xfs_log_force: error 5 returned. 
08.
May 11 08:37:17 FileServer kernel: [2332146.828021] Filesystem "sdf1": xfs_log_force: error 5 returned. 
09.
May 11 08:37:53 FileServer kernel: [2332182.828027] Filesystem "sdf1": xfs_log_force: error 5 returned. 
10.
May 11 08:38:01 FileServer /USR/SBIN/CRON[22867]: (root) CMD (root /bin/ bash /etc/backup.sh > /home/backup.log) 
11.
May 11 08:38:29 FileServer kernel: [2332218.828028] Filesystem "sdf1": xfs_log_force: error 5 returned. 
12.
May 11 08:39:05 FileServer kernel: [2332254.828020] Filesystem "sdf1": xfs_log_force: error 5 returned. 
13.
May 11 08:39:41 FileServer kernel: [2332290.828027] Filesystem "sdf1": xfs_log_force: error 5 returned. 
14.
May 11 08:40:01 FileServer /USR/SBIN/CRON[22888]: (root) CMD (root /bin/ bash /etc/backup.sh > /home/backup.log) 
15.
 
Vielen Dank und liebe Grüße,

Michael
Bitte warten ..
Mitglied: 75823
12.05.2009 um 08:02 Uhr
Ist das was mit Formatierung ? Oder hasst du da ein Leerzeichen zwischen /bin/ und bash? Zweitens, du hasst da ein root zu viel. Syslog soll so aussehen:
(root) CMD ( /bin/bash /etc/backup.sh > /home/backup.log )
oder auch so:
(root) CMD ( exec /etc/backup.sh > /home/backup.log )
aber nich wie es bei dir der Fall ist.
Bitte warten ..
Mitglied: Passepartout
12.05.2009 um 09:30 Uhr
Hallo,

ich habe es nun hinbekommen.
Habe einfach die gleiche Zeile nicht über
01.
sudo crontab -e
sondern mit vim in /etc/crontab direkt eingetragen.

Nun funktioniert alles wunderbar, ganz lieben Dank!

Michael
Bitte warten ..
Ähnliche Inhalte
Ubuntu
Grafisches Tool via Cron
gelöst Frage von schneerunzelUbuntu3 Kommentare

Hallo zusammen, ich möchte die Software FreeFileSync per Cron ausführen. Leider gibt es keine richtige Meldung im Log. Wenn ...

Apache Server
JavaScript wird nicht ausgeführt
Frage von schneerunzelApache Server

Hallo zusammen ich wollte gerade das Tool open3A installieren. Dabei bekomme ich einen Fehler die Dateien sind alle mit ...

Batch & Shell
Crontab wird nicht ausgeführt?
Frage von PhilosophBatch & Shell7 Kommentare

Hallo alle zusammen, ich habe ein crontab angelegt, aber irgendwie läuft es einfach nicht. So bin ich vorgegangen: 1. ...

Webbrowser

Plug-in wird nur ausgeführt, wenn es vorher als Admin ausgeführt wurde

gelöst Frage von ganymedWebbrowser4 Kommentare

Hallo, ich möchte Benutzern ermöglichen das Lync Web App Plug-in in folgender Umgebung zu verwenden. Win 7 Client in ...

Neue Wissensbeiträge
Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 5 StundenGoogle Android2 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Sicherheit

Intel gibt neue Spectre V2-Microcode-Updates frei (20.02.2018)

Information von kgborn vor 5 StundenSicherheit

Intel hat zum 20. Februar 2018 weitere Microcode-Updates für OEMs freigegeben, um Systeme mit neueren Prozessoren gegen die Spectre ...

Microsoft
ARD-Doku - Das Microsoft Dilemma
Tipp von Knorkator vor 8 StundenMicrosoft3 Kommentare

Hallo zusammen, vor einigen Tagen lief in der ARD u.a. Reportage. Das Youtube Video dazu dürfte länger verfügbar sein. ...

Windows 10

Neue Sicherheitslücke in Windows 10 (Version 1709) durch Google öffentlich geworden

Information von kgborn vor 1 TagWindows 10

Vor ein paar Tagen haben Googles Sicherheitsforscher vom Projekt Zero eine Sicherheitslücke im Edge-Browser publiziert. Jetzt wurde eine weitere ...

Heiß diskutierte Inhalte
Windows Server
AD DS findet Domäne nicht, behebbar?
Frage von schapitzWindows Server39 Kommentare

Guten Tag, ich habe bei einem Kunden ein Problem mit den AD DS. Umgebung ist folgende: Windows Server 2016 ...

Router & Routing
LANCOM VPN CLIENT einrichten
Frage von Finchen961988Router & Routing27 Kommentare

Hallo, ich habe ein Problem und hoffe ihr könnt mir helfen, wir haben einen Kunden der hat einen Speedport ...

Router & Routing
ISC DHCP 2 Subnetze
gelöst Frage von janosch12Router & Routing18 Kommentare

Hallo, ich betreibe bei mir im Netzwerk einen ISC DHCP Server auf Debian, der DHCP verwaltet aktuell ein /24 ...

CPU, RAM, Mainboards
32 gb RAM zu wenig?
Frage von pcguyCPU, RAM, Mainboards13 Kommentare

Hallo zusammen, mein PC verfügt über 32GB Ram. Nun kriege ich bei grossen Dateien im Illustrator die Fehlermeldung das ...