Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Crystal Reports XI und Windows 7

Mitglied: n3ck5hot8o8

n3ck5hot8o8 (Level 1) - Jetzt verbinden

19.11.2009, aktualisiert 24.11.2009, 12884 Aufrufe, 6 Kommentare

Hallo zusammen… ich versuche schon den ganzen Tag mit einem Windows 7 PC und dem IE 8 Crystal Reports (die über einen Crystal Reports Webserver veröffentlich sind) zu öffnen.

Leider bis dato ohne Erfolg… Die Sache ist so, dass ich hier drei absolut identische (Abgesehen vom User) DELL Optiplex 360 PCs habe… selbe Hardware, selbe Software… alle drei User sind lokale Admins… bei einem der 3 PCs bekomme ich die Reports auf, bei den anderen beiden nicht.

Daraufhin habe ich mir die installierten ADD-ONs im IE 8 mal angesehen und festgestellt, dass bei dem funktionierenden folgendes ADD-ON läuft:“Crystal ActiveX Report Viewer Control 10.0“… dieses Teil fehlt auf den beiden anderen.

Beim ersten Besuch der Report Server Webseite fragt das System den User ob selbiges installiert werden soll, hier habe ich bei allen dreien auf „Software von BusinessObjects immer vertrauen“ geklickt… .
Scheinbar mit teilweise mäßigem Erfolg.

Obwohl die PCs versuchen die Reports zu öffnen… im Title der Fensters steht sogar Crystal Report Viewer.

Auch die Idee auf den Safari, bzw. Firefox umzusteigen brachte wenig Freude… der Safari Browser öffnet die Reports zwar (!!!) aber kommt mir regelmäßig mit Server Timeouts… (Bei etwa 30 Leuten die hier permanent Reports öffnen n bisschen komisch.
Naja und der Feuerfuchs fragt die Parameter ab und es tut sich nix mehr.

Ich vermute das bei der Installation des Add-Ons was schief gelaufen ist… hat jemand von euch eine Idee wie ich das Add-On neu installieren kann oder wie ich IE Add-Ons löschen kann wenn sie nicht in der Add-On Liste auftauchen??? Alternativ wäre auch genial wenn ich das Add-On (liegt mir in form von dll’s von dem funktionierenden PC vor) in den IE reinbekomme??

Danke und Gruß n3ck5hot8o8
Mitglied: Seelbreaker
19.11.2009 um 16:51 Uhr
Abend
Schonmal den Browser explizit via Rechtsklick Als Administrator gestartet?

Auf die Art und Weise hatte ich im FF ein Plugin unter Win7 installieren können, ohne diese Berechtigung hat es nie geklappt...

Gruß
Bitte warten ..
Mitglied: n3ck5hot8o8
19.11.2009 um 16:59 Uhr
Danke für die schnelle Anwort.

Ja hab ich, aber da war die fehlerhafte Viewer Installation schon drauf, d.h. der IE denkt er hat das Add-On schon und versucht es nicht nochmal zu installieren... falls er es versucht sehe ich dank "Inhalten immer vertrauen" nix davon.... Die Vermutung das es an dem genialen Berechtigungsprinzip von Windows >= Vista liegt hatte ich auch schon... nur leider hilft das nicht viel... ich bräuchte den Installer für den Viewer... oder ne Möglichkeit die DLLs einzubindern... nur sowas find ich nirgendwo...

Gruß
Bitte warten ..
Mitglied: n3ck5hot8o8
20.11.2009 um 08:11 Uhr
Hatte denn außer mir noch Niemand Probleme damit???
Bitte warten ..
Mitglied: n3ck5hot8o8
24.11.2009 um 11:00 Uhr
Also das Problem hab ich mit nem kleinen Trick gelöst.

Mit einer frischen Windows 7 Installation (WM-Ware), angemeldet als Domain-Admin hab ich das Crystal ActiveX Control normal installieren können und hiervon mittels Install-Rite (Uraltes Tool zum Install Pakete erstellen... nach dem System-Abbild vorher und nachher Prinzip) ein Install- Paket erstellt. Dieses ließ sich ohne Probleme Installieren (Rechte MT --> Als Admin ausführen)

Ich vermute das dieser ganze Müll auf ein Berechtigungsproblem bei der Installation zurückzuführen ist.

Übrigens kann ich Install-Rite für solche Fälle wärmstens empfehlen...
Bitte warten ..
Mitglied: Seelbreaker
26.11.2009 um 00:12 Uhr
Ui ein solches Programm für Installpakete habe ich auch schon mal gesucht, bekomme ich damit auch MSI-Pakete hin? Damit ich die via GPO verteilen kann? Hast du einen Link parat?

Gruß

Und danke für deine Lösung!
Bitte warten ..
Mitglied: n3ck5hot8o8
26.11.2009 um 07:46 Uhr
Du kannst deine Softwarevia GPO auch als *.ZAP Datei verteilen.
Das geniale daran ist das du beliebige Dateiformate... also auch exe und bat files verteilen kannst.

1. Notepad
2. [Application]
FriendlyName = Test Software
SetupCommand = <Pfad>\<Datei>.exe
3. Im GPO wie eine msi veröffentlichen

Gibt noch diverse andere Zeilen mit Infos zur Software die man hier einfügen kann.... das hier ist das Minimum, reicht aber im Prinzip aus.

Du kannst hier auch Schalter (z.B. /q für quiet) nutzen und die Installation unbeaufsichtigt durchführen... oder du
siehst dir mal "AutoIt" an.... um zu verhindern das die User die Installationen jedes Mal abbrechen... oder Blödsinn einstellen...
Das ist nämlich ne Software, mit der du sämtliche Usereingaben vorweg nehmen kannst... und noch diverses mehr... is auch ne Freeware.

Aber ich komm grad vom Thema ab, um deine Frage zu beantworten: Nimm ein zap File oder du nimmst WinINSTALLE.... kostet aber Geld glaub ich.
WinINSTALLLE funktioniert genauso wie InstallRite... erst wird die Registry undd die Platte gescannt... dann installierst du was... danach scannt er nochmal und schreibt sich sämtliche Änderungen weg, pack sie in ein MSI bzw. exe File und fertig is die Laube.

Das war Teil meiner Abschlussarbeit... ich glaub ich schreib am Wochenende mal ne ausführlichere Anleitung.

Gruß
Bitte warten ..
Ähnliche Inhalte
Entwicklung
Crystal Report mit Zeit rechnen
gelöst Frage von a.grotheEntwicklung1 Kommentar

Hallo zusammen, wer kann weiterhelfen: (siehe Anhang) Ich habe mehrere Spalten und errechne mit der Formel (hier aus dem ...

Windows Tools

Welches Tool für Crystal Reports Scheduling?

gelöst Frage von lnino1982Windows Tools7 Kommentare

Hallo an alle, ich bin auf der Suche nach einem Tool mit dem ich meine Crystal Reports Schedulen kann. ...

Entwicklung

Crystal Report - mit Zeit ermitteln

gelöst Frage von a.grotheEntwicklung9 Kommentare

Hallo zusammen, ich habe ein Problem mit Crystal Report. In meiner Datenbank steht eine Datum Uhrzeit Angabe. z.B. 2014-08-01T10:44:23.6366+02:00 ...

Datenbanken

Crystal Reports: Übertrag an Seitenende und Seitenanfang

gelöst Frage von BirdyBDatenbanken4 Kommentare

Hallo zusammen, Ich hätte da nochmal eine Frage an die CrystalReports-Profis: Im Moment erstelle ich eine Rechnung, die einige ...

Neue Wissensbeiträge
Humor (lol)
IoT-Gefahr: Smartes Aquarium leckt!
Information von Lochkartenstanzer vor 2 TagenHumor (lol)3 Kommentare

Moin, Die IoT-Manie hat weitere Opfer gefunden. Ein Casino-Leck durch ein smartes Aquarium: Allerdings haben sie kein Wasser, sondern ...

Router & Routing

Alte Fritzbox 7270 mit VPN und SIP-Telefonie hinter O2 Homebox 6641 als "Modem"

Erfahrungsbericht von the-buccaneer vor 3 TagenRouter & Routing3 Kommentare

Nun war es soweit: Auch O2 hat mich mit VOIP zwangsbeglückt. Heute am Privatanschluss, in 2 Wochen ist das ...

Sicherheit

Ungepatchte Remote Code Execution-Lücke in LG NAS

Information von kgborn vor 3 TagenSicherheit

Nutzt wer LG NAS-Einheiten? In den NAS-Einheiten der LG Network Storage-Einheiten gibt es eine sehr unschöne Schwachstelle, die einen ...

Windows Update

Neue Version KB4099950 NIC Einstellungen gehen verloren

Information von sabines vor 3 TagenWindows Update2 Kommentare

Es ist eine neue Version des KB4099950 verfügbar, die das Problem mit den verlorenen Netzwerkeinstellungen lösen soll. Das Datum ...

Heiß diskutierte Inhalte
Netzwerkmanagement
Netzwerkmanagment im Haus mit Switch, Panel und pfsense
gelöst Frage von CorraggiounoNetzwerkmanagement19 Kommentare

hi zusammen, wir sind gerade dabei das ganze Haus bzw. die einzelnen Zimmer mit netzwerkdosen zu versorgen. Vom Keller ...

Netzwerkgrundlagen
VLAN - Offene Fragen
Frage von KnettenbrechNetzwerkgrundlagen17 Kommentare

Hallo zusammen, ich befasse mich derzeit mit dem Thema VLAN. Hierzu habe ich schon einige Guides gelesen, einschließlich des ...

Google Android
Empfehlung: Android Ortungsapp
gelöst Frage von certifiedit.netGoogle Android13 Kommentare

Guten Morgen, grundsätzlich vorweg, ich wollte mich eben schlau machen, bzgl einer Ortungsapp, welche Androidbasiert einem anderen Androidsmartphone mitteilt, ...

Router & Routing
VPN hinter zweiter Fritzbox nutzen im Nachbarhaus
gelöst Frage von georg2204Router & Routing11 Kommentare

Hallo zusammen, ich blicke hier leider nicht mehr so ganz durch. In Haus 1 steht eine Fritzbox 7390, diese ...