Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

CSS Link-Menü aktiver Link soll rot werden

Mitglied: admin1987

admin1987 (Level 2) - Jetzt verbinden

28.04.2006, aktualisiert 29.08.2006, 5019 Aufrufe, 1 Kommentar

CMS ist TYPO3 aber Problem ein CSS-Problem denke ich auf jeden Fall!?



Hallo seit Tagen versuche ich vergeblich das mein Subpart "NAVI" der ein HMENU ist, die Seite wo ich mich gerade befinde oben in der Navigation rot markiert solange ich mich dort aufhalte!

Also ich habe: Unternehmen | News | Kontakt ...

Standarmässig ist alles weiß und bei hover kurz rot ich möchte aber das wenn ich mich auf der Seite Unternehmen befinde, Unternehmen rot und fett wird, bitte helft mir ich kriege das echt nicht hin.

Unten mal meine CSS-Datei, des muss ja irgendein CSS-Befehl sein denke ich mal.

Vielen Dank++

CSS:
p {
margin: 0;
}

#rootline {
position: absolute;
top: 1px;
left: 20px;
width: 450px;
height: 13px;
background: #158BC6;
font: normal 9px Verdana, Arial, Helvetica, sans-serif;
color: white;
text-decoration: none;
}

#rootline li {
color: white;
}

#rootline li a {
text-decoration: none;
color: white;
}

#rootline li a:hover {
color: white;
}

#content {
position: absolute;
top: 225px;
left: 333px;
width: 600px;
background: #158BC6;
font: normal 15px Verdana, Arial, Helvetica, sans-serif;
color: white;
}


#head {
position: absolute;
top: 15px;
left: 20px;
width: 534px;
height: 117px;
background-image: url(img.gif);
}

#header-text {
position: relative;
top: 135px;
left: 285px;
width: 450px;
height: 12px;
background: #158BC6;
font: normal 15px Verdana, Arial, Helvetica, sans-serif;
}

#navi {
position: absolute;
left: 25px;
top: 170px;
background: #158BC6;
width: 800px;
height: 45px;
}

#navi ul {
margin: 0;
padding: 0;
}

#navi li {
float: left;
display: block;
color: white;
padding: 0 17px 0 0;
font: normal 17px Verdana,Arial,Helvetica,sans-serif;
}

#navi li a {
text-decoration: none;
color: white;
}

#navi li a:hover {
color: red;
}

#navi li.ACT a,
#navi li.CUR a {
font-size: 18 px;
color: red;
position: relative;
top: -4pxM
}


#topmenu {
position: absolute;
left: 42px;
bottom: 10px;
background: black;
float: left;
display: block;
color= #000000;
padding: 0 10px 0 0;
font: normal 14px Verdana, Arial, Helvetica, sans-serif;
}


#right {
position: absolute;
height: 250px;
top: 295px;
left: 21px;
width: 275px;
background: #158BC6;
}

#left {
position: absolute;
top: 220px;
left: 21px;^
width: 275px;
background: #158BC6;
}


#left ul {
margin: 0;
padding: 0;
list-style-type: none;
}

#left li {
text-decoration: none;
font: normal 13 px Verdana, Arial, Helvetica, sans-serif;
padding: 5px 15px 5px 10px;
color: white;
}

#left li a {
text-decoration: none;
color: white;

}

#left li a:hover {
color: red;
}

#left li.ACT,
#left li.CUR {
font-size: 18 px;
position: relative;
top: -4pxM
}


body, html {
border: 0;
margin: 0;
width: 100%;
height: 100%;
background: #158BC6;
font: normal 100.01% Verdana, Arial, Helvetic, sans-serif;
color: white;
scrollbar-highlight-color: #158BC6;
}


H1 {
font-family : Verdana, sans-serif;
font-size : 16px;
color : white;
margin-bottom : 0px;
margin-top : 10px;
}
H2 {
font-family : Verdana, sans-serif;
font-size : 15px;
color : white;
margin-bottom : 10px;
margin-top : 20px;
}
H3 {
font-family : Verdana, sans-serif;
font-size : 12px;
color : white;
margin-bottom : 0px;
margin-top : 10px;
}
H4 {
font-family : Verdana, sans-serif;
font-size : 10px;
color : white;
margin-bottom : 0px;
margin-top : 10px;
}
.subhead1 {
font-family : Verdana, sans-serif;
font-size : 10px;
color : black;
}
.subhead2 {
font-family : Verdana, sans-serif;
font-size : 10px;
color : green;
}
.subhead3 {
font-family : Verdana, sans-serif;
font-size : 10px;
color : red;
}
.headerdate {
font-family : Verdana, sans-serif;
font-size : 10px;
color : red;
font-weight: normal;
}

li {
text-decoration: none;
color: white;
}
li a {
color: white;
}
li a:hover {
color: red;
}

strong {
text-decoration: none;
color: white;
}




A {
color:white;
}

A:hover {
color:red;
}

A:active {
color:white;
}



[Dieser Beitrag wurde 1 mal bearbeitet. Zuletzt am 28.04.2006 um 10:21]
Mitglied: micha149
29.08.2006 um 08:57 Uhr
Das hängt auf jeden Fall vom TYPO3 ab. Kenne das jetzt nicht, aber ich weis das bei anderen CMS-Systemen eine CSS-id existiert mit der du den aktiven Link formatieren kannst. Guck mal ob du irgendwo eine auflistung der möglichen CSS-ids für Typo3 bekommst....
Bitte warten ..
Ähnliche Inhalte
HTML

Angebundenes CSS funktioniert nach Link nicht mehr

gelöst Frage von fuguHTML4 Kommentare

Moin Com, ich habe das Problem, dass beim einem Link auf die gleiche Seite zum Ausführen eines Scripts das ...

CSS

CSS: Menü ein- und ausblenden

gelöst Frage von honeybeeCSS6 Kommentare

Hallo, ich erstelle gerade ein Navigationsmenü mit CSS. Leider kann ich das Untermenü nicht ein- und ausblenden. Habe ich ...

Windows Server

Win2k3 SRV keine Netzwerkverbindung trotz aktivem Link

gelöst Frage von killtecWindows Server5 Kommentare

Hallo, ich habe hier einen alten Windows 2003 Server den wir zu Archivzwecken noch benötigen. Nun ist es so, ...

Notebook & Zubehör

Netzwerkkarte hat keinen Link

Frage von Windows10GegnerNotebook & Zubehör10 Kommentare

Hallo, ich habe derzeit an meinem ZBook 15 keine Verbindung über die Ethernet Buchse. Die Buchse hat bis vor ...

Neue Wissensbeiträge
Speicherkarten

Neuer Speicherkartentyp - zunächst nur für einzelne Huawei-Smartphones

Tipp von VGem-e vor 33 MinutenSpeicherkarten

Servus, als ob das "Chaos" i.S. Speicherkarten noch nicht groß genug wäre?! Evtl. kommt dieser neue Kartentyp bald auch ...

Sicherheit

Diverse D-Link-Router durch drei Schwachstellen kompromittierbar

Information von kgborn vor 2 StundenSicherheit

Hat jemand D-Link-Router in Verwendung? Einige Modelle sind sicherheitstechnisch offen wie ein Scheunentor. Äußerst unschöne Sache, aber nichts neues ...

Hardware

100.000 Mikrotik-Router ungefragt von Hacker abgesichert

Information von 7Gizmo7 vor 16 StundenHardware1 Kommentar

Hallo zusammen, da hier ja öfters mal von Mikrotik gesprochen wird. Trotz Updates klafft eine Sicherheitslücke in Hundertausenden Mikrotik-Routern. ...

Sicherheit

Oracle gibt kritische Updates für diverse Produkte frei (16. Oktober 2018)

Information von kgborn vor 1 TagSicherheit

Oracle hat zum 16. Oktober 2018 eine ganze Reihe an kritischen Updates für seine Produkte freigegeben. Eine Kurzübersicht mit ...

Heiß diskutierte Inhalte
Windows 10
Sysprep Fehler im Log kann nicht starten
Frage von grillinator95Windows 1022 Kommentare

Hallo, kann leider SYSPREP nicht mehr starten, Win10 64bit. Logfile sagt folgendes: 2018-10-17 13:44:56, Info SYSPRP 2018-10-17 13:44:56, Info ...

Internet
Ist diese URL denkbar (Syntax)?
gelöst Frage von departure69Internet17 Kommentare

Hallo. Der Sohn eines Arbeitskollegen hat im Gymnasium EDV-Unterricht. Leider hat er in der letzten Klassenarbeit einen Fünfer geschrieben. ...

Debian
Linux debian 9 Installation
Frage von Green14Debian16 Kommentare

Hallo zusammen, ich habe mich ein wenig mit Debian auseinandergesetzt und möchte mir eine Standard-Installation als Grundlage für andere ...

Outlook & Mail
Outlook schiebt Mails aus Posteingang sofort in den Papierkorb
Frage von hermesOutlook & Mail13 Kommentare

Hallo Outlook Fachleute, wir haben hier das Problem, dass Outlook 2010 alle ankommenden Mails seit zwei Tagen einfach in ...