Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Cyrus Imap Server - Problem mit Umlauten in Benutzernamen

Mitglied: CondCPP

CondCPP (Level 1) - Jetzt verbinden

09.02.2010 um 12:55 Uhr, 7557 Aufrufe, 7 Kommentare

Ich versuche derzeit auf einem Suse Enterprise Server einen Cyrus IMAP Server einzurichten mit LDAP Zugang zu einem Windows Server 2003 Active Directory, was bisher auch relativ gut funktioniert hat. Doch jetzt habe ich ein kleineres (?) Problem:

Beinahe alle Nutzer der Windows Domäne können sich problemlos am Linux Server anmelden, außer Nutzer die Umlaute im Anmeldenamen haben.
Wenn ich mir über getent passwd die bekannten Nutzer auflisten lasse, dann werden alle Nutzer (auch die mit Umlauten) richtig angezeigt.

Im Prinzip ist es auch egal ob sich diese Benutzer am Server anmelden können, wichtig ist, dass die entsprechenden Postfächer erstellt und abgerufen werden können.
Deshalb habe ich direkt über cyradm versucht die entsprechenden Postfächer zu erstellen und den Benutzern mit Umlauten zuzuweisen.

Sobald ein Umlaut im Postfach Namen enthalten ist bekomme ich die Fehlermeldung "Invalid Mailbox Name"
Mitglied: iVirusYx
09.02.2010 um 13:03 Uhr
Hast du keine Einstellung zur Zeichenunterstützung?
Ist da vielleicht was falsch konfiguriert.

Wenn sonst nix ist, dann wird es nicht unterstützt und du hast ein Problem...
Am besten macht du ein Skript welches dir die Umlaute für Cyrus ueberleitet.
Bitte warten ..
Mitglied: CondCPP
09.02.2010 um 13:20 Uhr
Am Suse Server selbst ist UTF8 als Zeichensatz definiert, in der Konsole werden die Namen auch richtig angezeigt (über getent passwd ). Aber selbst am Server selbst kann ich mich nicht mit Umlauten anmelden....deswegen glaube ich das der Fehler nicht direkt ein Problem von Cyrus ist, sondern eher ein allgemeines Problem des Suse Servers....

Muß eventuell noch an einer anderen Stelle des Servers UTF8 definiert werden und nicht nur über YAST ?
Bitte warten ..
Mitglied: iVirusYx
09.02.2010 um 13:32 Uhr
Also wenn ich mich bai Google so umsehe, sehe ich dass es viele Probleme mit Umlauten gibt,
wenn es um Userverwaltungen unter Linux geht.

Hast du nicht besser die paar User auf ue,oe,ae, etc zu migrieren?
Ist zwar etwas arbeit, ab er sicher weniger als das mit den Umlauten.
Bitte warten ..
Mitglied: 45877
09.02.2010 um 14:06 Uhr
man hat keine usernamen mit umlauten = problem gelöst.
umlaute machen nur aerger...
Bitte warten ..
Mitglied: CondCPP
09.02.2010 um 14:23 Uhr
Ohne die Umlaute hätte ich das Problem nicht, das ist wohl war......aber leider sollen die Benutzernamen nicht geändert werden...leider : \
Bitte warten ..
Mitglied: CondCPP
09.02.2010 um 15:23 Uhr
Beim rumprobieren ist mir noch etwas aufgefallen:

Sowohl per SSH als auch per lokaler Anmeldung (Kommandozeile) kann ich mich auch mit Umlaut enthaltenden Benutzernamen anmelden.

Wenn ich aber eine grafische Oberfläche starte (Gnome) und mich dort anmelden will funktioniert es nicht......
Bitte warten ..
Mitglied: CondCPP
12.02.2010 um 10:21 Uhr
Ich habe jetzt eine Lösung für mein Problem gefunden......umbenennen war schon die richtige Idee:

Wie schon gesagt kommen die Benutzer aus der Windows Domäne (inzwischen ist dabei übrigens noch ein zweites Problem aufgetaucht: Leerzeichen im Namen). Im Active Directory kann ich ja zwischen Benutzeranmeldename und Prä Windows 2000 Anmeldenamen unterscheiden.
Linux nutzt den Prä Windows 2000 Anmeldenamen......also bekommen alle Benutzer als Prä Windows 2000 Anmeldenamen einen neuen Namen (ums einfach zu machen der Teil ihrer E-Mail Adresse vor dem @)
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
Problem mit bestimmten Umlaut
gelöst Frage von joe65Batch & Shell6 Kommentare

Hallo, ich muss nochmal hier nachfragen, da ich mit einen Umlaut (=ß) ein Problem habe und ich nicht weiterkomme. ...

HTML
Problem Joomla3.3, php5.6 und Umlaute
Frage von charly74HTML4 Kommentare

Hallo, mir dachte das Problem der Kollationen schaffe ich irgendwie - aber offenbar schaffen diese mich Vielleicht kann mir ...

Linux Tools
Logwatch mit cyrus
Frage von MoeSzyslakLinux Tools

Hallo, ich würde gerne logwatch mit cyrus nutzen. Sonst funtkioniert es sehr gut, bringt aber keine Bereichte zu den ...

Python
Python IMAP Idle Problem
Frage von tingelPython

Hallo zusammen, ich habe in Python ein kleines Scirpt, welches Mail abruft und diese auswertet. Das läuft und läuft. ...

Neue Wissensbeiträge
Humor (lol)
IoT-Gefahr: Smartes Aquarium leckt!
Information von Lochkartenstanzer vor 2 TagenHumor (lol)3 Kommentare

Moin, Die IoT-Manie hat weitere Opfer gefunden. Ein Casino-Leck durch ein smartes Aquarium: Allerdings haben sie kein Wasser, sondern ...

Router & Routing

Alte Fritzbox 7270 mit VPN und SIP-Telefonie hinter O2 Homebox 6641 als "Modem"

Erfahrungsbericht von the-buccaneer vor 2 TagenRouter & Routing3 Kommentare

Nun war es soweit: Auch O2 hat mich mit VOIP zwangsbeglückt. Heute am Privatanschluss, in 2 Wochen ist das ...

Sicherheit

Ungepatchte Remote Code Execution-Lücke in LG NAS

Information von kgborn vor 3 TagenSicherheit

Nutzt wer LG NAS-Einheiten? In den NAS-Einheiten der LG Network Storage-Einheiten gibt es eine sehr unschöne Schwachstelle, die einen ...

Windows Update

Neue Version KB4099950 NIC Einstellungen gehen verloren

Information von sabines vor 3 TagenWindows Update2 Kommentare

Es ist eine neue Version des KB4099950 verfügbar, die das Problem mit den verlorenen Netzwerkeinstellungen lösen soll. Das Datum ...

Heiß diskutierte Inhalte
Netzwerkmanagement
Netzwerkmanagment im Haus mit Switch, Panel und pfsense
gelöst Frage von CorraggiounoNetzwerkmanagement15 Kommentare

hi zusammen, wir sind gerade dabei das ganze Haus bzw. die einzelnen Zimmer mit netzwerkdosen zu versorgen. Vom Keller ...

Netzwerkgrundlagen
VLAN - Offene Fragen
Frage von KnettenbrechNetzwerkgrundlagen14 Kommentare

Hallo zusammen, ich befasse mich derzeit mit dem Thema VLAN. Hierzu habe ich schon einige Guides gelesen, einschließlich des ...

Google Android
Empfehlung: Android Ortungsapp
gelöst Frage von certifiedit.netGoogle Android13 Kommentare

Guten Morgen, grundsätzlich vorweg, ich wollte mich eben schlau machen, bzgl einer Ortungsapp, welche Androidbasiert einem anderen Androidsmartphone mitteilt, ...

Vmware
Server 2008 r2 vmware terminalserver
Frage von MasterCVmware12 Kommentare

Guten Abend zusammen, ich hoffe , dass einer von euch mir weiterhelfen kann ,bei meinem kack Problem ! Ist ...