Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Dateisystemfehler: Viele Zeiger auf Dateien falsch nach SWAP

Mitglied: ybBln

ybBln (Level 2) - Jetzt verbinden

06.09.2006, aktualisiert 19.09.2006, 5021 Aufrufe, 6 Kommentare

Was ich schon seit Jahren unproblematisch durchführe, das Einswappen einer IDE-Festplatte im Standby von Windows XP wollte ich jetzt auch wieder machen, wo ich die Festplatte mal unter Windows 2000 brauchte.
Leider habe ich vorher nicht dran gedacht, dass ich auf der XP-Festplatte die Master/Slave-Jumper so gesetzt hatte, dass beide sowohl einzeln, als auch gemeinsam arbeiten können, aber dies noch nicht mit der Festplatte, auf der das Windows 2000 läuft durchgeführt habe.
Nach dem Aufwecken aus dem Standby wurde somit nicht die Festplatte erkannt, die ich einswappen wollte. Sah aber recht harmlos aus - normal heruntergefahren, Jumper gesetzt und neu gestartet.
Nu kommt´s:
Das Windows-Scanndisk wurde aufgerufen und unzählige Fehler im Dateisystem wurden gefunden und korregiert.
Nachdem Windows dann vollständig hochgefahren war, sah auch alles ganz normal aus. Scheinbar kein Datenverlust, soweit man das bei 160GB Daten mit über 400000 Dateien so auf die Schnelle beurteilen kann. Nur inzwischen scheint mir, dass Scandisk wohl erst das im Folgenden beschriebene Durcheinander geschaffen hat.

Bemerkt habe ich erst, dass etwas schief gegangen war, als ich mir etwas Musik anmachen wollte. Da waren auf einmal zahlreiche Musikdateien als beschädigt bezeichnet, wenn ich sie versucht habe, zu öffnen.
Bei einer intensiveren Suche innerhalb nur der Musikdateien, stellte ich folgende vier Gruppen fest, in die sich die Musikdateien einordnen lassen:
1) Datei ist vollständig abspielbar und trägt den Namen, der zum Stück passt.
2) Datei fängt an, das zu spielen, was sie laut Bezeichnung sein soll, bricht aber vorher ab.
3) Es wird nicht das wiedergegeben, was die Datei vom Namen her sein soll, sondern irgendwo in einem anderen Musikstück irgendwo in der Mitte begonnen.
4) Die Datei ist gar nicht abspielbar.

Die Musikdateien sind jetzt nur Beispiele, ich habe die MSDNA-Images auf der Festplatte, das gesamte Schulungsmaterial meines (abgeschossenen) Studiums, in das ich gern ab und an hineingucke, Fotos meiner Kinder aus ihren ersten Lebensjahren... kurzum, ich schleppe auf dieser Festplatte Dateien aus der Anfangszeit meiner Computerzeit mit mir herum.

Ihr könnt Euch sicher vorstellen, dass mir der Verlust dieser Daten einen großen persönlichen Verlust bedeuten würde.

Letztlich sehe ich das so: Offenbar sind auf der einen Seite alle Dateien noch vorhanden und auf der anderen Seite das Inhaltsverzeichnis ebenfalls vollständig. Was durcheinandergeraten ist, ist der Zeiger, der vom Inhaltsverzeichnis auf die Datei zeigt, also praktisch die 'Seitenzahl' fehlt.

Das Dateisystem ist NTFS.

Gibt es Hoffnungen, alles wieder herzustellen?

Gruß - ybBln

P.S.: Ja, ich unterlasse in Zukunft dieses 'lauwarm'-Swapping im Standby, aber das soll nicht Thema sein.
Mitglied: kokopelli
13.09.2006 um 18:20 Uhr
Hallo!

Ich habe GENAU das selbe Problem hier.
Entstanden durch einen Festplattenwechsel von einem Rechner in einen anderen.
Auch bei mir hat chkdsk eine vermeintlicher Reparatur getartet und scheinbar ist
war auch alles i.O.
Nur ca. drei Viertel meiner 200GB sind unbrauchbar. Die Dateien sind vorhanden
und lassen sich auch kopieren. Nur sie sind eindeutig falsch zugeordnet, denn
wenn ich beispielsweise ein nicht mehr funktionierendes AVI-File im Editor öffne
stimmt auch der Header nicht, sondern ich habe einfach irgendein Datenfragment,
wie falsch gesplittet. Ein Teil der Dateien ist noch in Ordnung und einige wenige
sind nicht die, die sie sein sollten.

Ich kann mich meinem Vorredner nur anschließen: Auf der Platte sind ca. die letzten
vier Jahre meines Lebens d'rauf.... Ich werd' wahnsinnig, wenn ich das nicht wieder
hinkriege.

System ist Windows 2000 SP4 UpdateRollup v2
Platte ist eine Samsung mit 350Gig auch mit NFTS

Grüße

Uwe
Bitte warten ..
Mitglied: ybBln
13.09.2006 um 21:40 Uhr
jetzt hab ich grade eine PM geschickt, in der ich aufgezählt hab, was alle bisher vergebens war aber jetzt schon, kurz danach, möchte mal vorsichtig in Aussicht stellen, dass ich das Problem möglicherweise gelöst hab...

Zumindest ein paar Dateien, von denen ich noch wusste, dass sie nicht mehr gingen, tun es jetzt wieder.

Scandisk hat offenbar nichts beschädigt - soweit schonmal gut.

Beide haben wir das Problem auf einer Windows 2000 - Kiste. Auch ich hab die neuesten Updates drauf gehabt.

Beide haben wie verhältnismäßig große Festplatten drin.

Die Lösung liegt in einem ungepatchten Registry-Eintrag zur long LBA bei W2K-Rechnern. Einige XP-Maschinen sollen das Problem zwar auch haben, denn es gibt von MS auch einen Artikel zum Aktiviren von long LBA unter XP, aber bei W2K ist es wohl obligatorisch.

Der Artikel http://support.microsoft.com/kb/305098/DE bei support.microsoft.com zeigt die Problematik und erklärt die Lösung.

Ich will noch nicht in Jubel verfallen, aber es sieht nicht schlecht aus, nach ersten Dateiüberprüfungen.

Sollte DAS die Lösung gewesen sein, werde ich den Artikel in einigen Tagen als gelöst markieren.

Gruß - ybBln
Bitte warten ..
Mitglied: kokopelli
15.09.2006 um 10:29 Uhr
Vielen Dank für die Antwort!

Und, wie schaut es aus? War dies die Lösung des Problems? Ich muss ehrlich gesagt
gestehen, dass ich zur Zeit sehr große Hemmungen habe noch irgendetwas mit dieser
Platte in Richtung Scandisk zu veranstalten. Denn dann sind die Datein vielleicht ent-
gültig über den Jordan...

Viele Grüße

Uwe
Bitte warten ..
Mitglied: ybBln
15.09.2006 um 17:51 Uhr
Wie ich ja in meiner PM geschrieben hatte, hatte ich die Datenrettungsversuche auf einer Sicherheitskopie mit Linux´s 'dd' der betroffenen Partition auf einer extra dafür angeschafften Festplatte unternommen. Somit konnte ich rücksichtslos alles zur logischen Datenrettung unternehmen, was möglich war.

Windows´'scandisk' mag allerdings wirlich nicht das richtige Werkzeug sein.

Allerdings war die Anschaffung der Rettungsfestplatte nur Lehrgeld, das ich bezahlt hab, da nicht wirklich notwendig.

Es war der long-LBA - Registry-Eintrag, der fehlte.

Vorausgesetzt, die große Festplatte ist nicht Systemfestplatte:

Das Überprüfen, ob der Registry-Eintrag bei Dir vorhanden ist, braucht ja nicht mal die betroffene Festplatte. Diesen Eintrag exakt nach Beschreibung einzutragen (Groß/Kleinschreibung, Schlüsseltyp und Wert müssen übereinstimmen) ändert auch nichts an der betroffenen Festplatte.
Dann herunterfahren und MIT der betroffenen Festplatte neu starten und dann einfach mal gucken, ob wieder alles da ist

Gruß - ybBln
Bitte warten ..
Mitglied: kokopelli
16.09.2006 um 22:44 Uhr
Genial!

Übrigens: Mein Problem ist seit heute auch gelöst! Denn: Ich habe die Platte wieder in ihren
Ursprungsrechner gesteckt (zu Hause) und siehe da: Alles ist da und geht! Jetzt bin ich ge-
spannt, ob wenn ich wieder in meiner Arbeits-Wohnung an meinem Rechner bin und den
Registrierungsschlüssel hinzufüge, das Problem gelöst sein wird.

Auf jeden Fall vielen, vielen Dank für Deine Mühen und Experimentierfreudigkeit!

MfG

Uwe
Bitte warten ..
Mitglied: kokopelli
19.09.2006 um 15:39 Uhr
Hallo nochmal!

Also: Das ist mir wirklich unverständlich... Mein Zweit-Rechner in meiner Arbeitswohnung
hatte tatsächlich diesen beschriebenen Registry-Key nicht sitzen, obwohl ich ihn sogar
direkt mit einer Windows 2000 SP4 Version installiert habe...

Unglaublich... Aber jetzt geht alles so wie es soll und ich hatte schon das Schlimmste
befürchtet. Nochmal 1000-Dank!

MfG

UWe
Bitte warten ..
Ähnliche Inhalte
Drucker und Scanner

Drucker, die über Gruppenrichtlinien bereitgestellt werden, zeigen auf Clientcomputern falsche Treiber an

gelöst Frage von Michael.ADrucker und Scanner3 Kommentare

Hallo, Info vor ab Windows Server 2016 (neuste Updates installiert) Clientencomputer Windows 10 Pro (neuste Updates installiert) Drucker Kyocera ...

Vmware

OS Swap + Vmware Swap (Best Practive) ?

Frage von K-ist-KVmware2 Kommentare

Hallo werte ITler, ich suche schon eine Weile nach einer Best Practive Methoade, zum Thema SWAP File. Bleiben wir ...

Windows 7

Optische Laufwerke zeigen keine Dateien auf Datenträgern an

gelöst Frage von kobuschWindows 715 Kommentare

Hallo zusammen! Wie im Titel schon erwähnt ist mein Problem, dass die optischen Laufwerke (2x DVD-RW) am Client (Win7 ...

C und C++

Vektoren und Zeiger

gelöst Frage von How-ToC und C++3 Kommentare

Hallo zusammen, kann mir jemand den Unterschied zwischen - vector<MeineKlasse *> meinVektor; und - vector<MeineKlasse> * meinVektor; erklären? Irgendwie ...

Neue Wissensbeiträge
Sonstige Systeme
Es war einmal ein BeOS - Wer erinnert sich noch?
Information von BassFishFox vor 1 TagSonstige Systeme5 Kommentare

Hallo, Bin gerade ueber Haiku gestolpert, von dessen Existenz als "Nachfolger des BeOS" ich wusste nur mich nie wirklich ...

Datenschutz

Microsoft und DSGVO - ob das wohl jemals klappt (Probleme beim Datenabfluss für Office Pro Plus)?

Tipp von VGem-e vor 1 TagDatenschutz3 Kommentare

Servus Kollegen, siehe Aber wer setzt schon MS Office Pro Plus ein? Wie dann der Stand beim "normalen" MS ...

Windows 10

Macht Windows 10.1809 Probleme mit gemappten Netzlaufwerken (betrifft wohl insbes. AMD-Hardware und Trend Micro AV-Produkte)?

Tipp von VGem-e vor 1 TagWindows 103 Kommentare

Moin Kollegen, grad dazu gefunden und Hatten wir dies nicht bei früheren W10-Upgrades ebenfalls? Da bleibt nur, das Upgrade ...

Humor (lol)

Das neue Miniatur Wunderland OFFICIAL VIDEO - worlds largest model railway - railroad

Information von StefanKittel vor 2 TagenHumor (lol)2 Kommentare

Hallo, wer noch nie im Miniatur Wunderland war, sollte es dringend mal nachholen. Es gibt eine neues Video. Viele ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
Gäste-WLAN durch DD-WRT AP nach einem MikroTik Routerboard
Frage von NukolarLAN, WAN, Wireless16 Kommentare

Hallo, wie der Titel schon sagt möchte ich gerne ein Gäste-WLAN innerhalb eines bestehenden LANs einrichten. Dass die Gäste ...

DSL, VDSL
DSL Monitoring Tool - Quick and dirty?
Frage von george44DSL, VDSL15 Kommentare

Liebe Gemeinde, ich suche ein einfaches und vor allem schnell zu installierendes Monitoring-Tool zur kontinuierlichen Dokumentation (nur) der Internetanbindung. ...

Exchange Server
Outlook findet Postfach nicht
Frage von MaximaxExchange Server11 Kommentare

Hallo, und zwar haben wir auf der Arbeit ein kleines (großes) Exchange 2016 Problem. Exchange meldete gestern, dass die ...

Informationsdienste
Probleme auf dem Server
Frage von LangeLangeInformationsdienste9 Kommentare

Hallo zusammen, ich betreibe die Seite Keine Werbelinks. In der Analyse stellen wir fest, dass die Ladezeit in der ...