Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Wie Datenrettung bei immer währenden REBUILD des RAID5

Mitglied: deadron

deadron (Level 1) - Jetzt verbinden

06.12.2010 um 08:43 Uhr, 3060 Aufrufe, 6 Kommentare

Hallo,

in meiner Frage geht es um ein Intel® Entry Storage System SS4200-E.

Konfiguration:
- RAID 5 aus 4x 1,5 TB Seagate mit dem im ICH7 enthaltenen Raidcontroller.
- 2x 2 TB Volumes
- Windows Home Server 1 PP3 (Windows Server 2003R2)
- Ordnerduplizierung deaktiviert
- DriveExtender ist aktiv

Vorgeschichte:
Das System arbeitete fast ein Jahr Problemlos bis sich der belegte Speicherplatz der 80% Marke näherte. Es wurde langsamer bis es mir schlussendlich meldete das eine der Platten im RAID defekt sei. Die SMART werte der "defekten" Platte waren bis auf die Masse defekten Sektoren im Normalbereich, jedenfalls bewertete die Platte sich selbst noch als OK. Sei es drum, die Platte wurde durch eine 2 TB von Seagate ersetzt. Nach dem Rebuild, der ca.7 Tage benötigte, wurde mir aber die nächste Platte als defekt gemeldet (immer von RAID-Controller).

Ich konnte dies nicht glauben und startete einen weiteren REBUILD, doch nach diesem, oh wunder, war plötzlich die Neue 2 TB wieder schuld. Nach 5 weiteren REBUILD's hatte ich dann alle Platten durch, soll heißen, dass jede einmal als Fehlerhaft gekennzeichnet war.

Die Rettung meiner Daten steht nun im Vordergrund da vermutlicher Weise der Controller oder andrere Komponenten nicht mehr i.O. sind.
Das Dateisystem hat schon seine Spuren davongetragen.

Frage:
Wie würdet Ihr mir empfehlen die Daten zu Sichern?
- Während des REBUILD, wenn an dessen Anfang oder Ende?
- Falls möglich vor dem REBUILD?

Oder gibt es andere Vorschläge?

Wäre für jede hilfreiche Antwort sehr dankbar!

Gruß
Mitglied: StefanKittel
06.12.2010 um 08:49 Uhr
Hallo,
erstmal einen richtigen RAID-Controller kaufen
Neue Platten daran anschliessen und die Arrays kopieren

Das ganze nicht während der Arbeitszeit und wenn möglich vor einem Rebuild. Das kann immer schiefgehen.

Hast Du eine Datensicherung?

Stefan
Bitte warten ..
Mitglied: deadron
06.12.2010 um 10:18 Uhr
Datensicherung habe ich keine, hätte ich ja theoretisch nochmal so ein Ding gebraucht^^.
Wie es meistens so ist, war ich kurz davor eine externe Platte über eSata anzuhängen für die tägliche Sicherung, leider zu spät.

Die mitlerweile zurückgekommene neue 1,5 TB sitzt in einem anderen Rechner und dient als Volume für meine jetzt zu sichernden Daten.

Ein Problem ist, dass je nach Platte(die "fehlerhaft" ist) das System-Volume betroffen ist, nicht mehr Bootet und einen REBUILD-Start vorraussetzt.

Vemutlich gehen mir bei jedem REBUILD Daten verloren.

Gibt es eine Möglichkeit die Volumes ohne REBUILD zu aktivieren oder Irgendwie darauf zuzugreifen?

PS.:
Am gemeinsten finde ich daran, dass der Controller nicht sagt was er wirklich für ein Problem hat!
Bitte warten ..
Mitglied: Nagus
06.12.2010 um 10:56 Uhr
Moin,
hm - ich weiß das hilft nicht wirklich, aber ich glaube du solltest alle platten erstmal klonen und dann mit den klonen die weiteren "experimente" durch führen ....

Was gibt denn der Controller für Meldungen sonst aus? Hast Du schon mal ein BIOS update gemacht ... ? Wobei - danach kann es eben auch sein, dass nix mehr geht ...

Gruß
Nagus
Bitte warten ..
Mitglied: SlainteMhath
06.12.2010 um 11:38 Uhr
Moin,

wenn auf dem Raid betriebliche Daten waren => http://www.ontrack.de/ (und auf einen 4 stelligen Betrag vorbereiten)
wenn nicht: Ärgern! und zuhause die finger von RAID 5 lassen

lg,
Slainte
Bitte warten ..
Mitglied: deadron
13.12.2010 um 10:50 Uhr
Ok, ich habe verstanden.

Klonen habe ich schon bei einem anderen RAID probiert vor langer Zeit, geht nicht. und wer weiss was da wieder schief geht.

BIOS Update... soweit mir bekannt ist schon lange keins mehr gekommen, denke aber auch nicht das es was bringt.

Werde es zwangsweise beim REBUILD machen müssen und mich auf die wichtigsten Daten konzentrieren.

Danke euch trotzdem für die Hilfe. ;)

Ist evtl. ein Programm bekannt das bei nicht lesbaren Dateien mit dem Kopieren weiter macht?

Gruß
Bitte warten ..
Mitglied: SlainteMhath
13.12.2010 um 10:53 Uhr
Ist evtl. ein Programm bekannt das bei nicht lesbaren Dateien mit dem Kopieren weiter macht?
xcopy sollte das doch können, oder? Ansonsten nimm robocopy
Bitte warten ..
Ähnliche Inhalte
Google Android
Datenrettung SGS3
Frage von crazy.puppetGoogle Android4 Kommentare

Tach Freunde! Ich habe ein Problem mit einem Samsung Galaxy S3 i9300 Smartphone. Das Startet nicht mehr. Ich habe ...

Festplatten, SSD, Raid

Reboot während des rebuild-Vorgangs?

gelöst Frage von HarryHirsch75Festplatten, SSD, Raid10 Kommentare

Hallo, Mein Raid-5 Verbund habe ich durch eine weitere Festplatte vergrößert. Beim System handelt es sich um einen HP ...

Festplatten, SSD, Raid

HP SmartArray nach Neustart rebuild

gelöst Frage von momaiFestplatten, SSD, Raid2 Kommentare

Hallo, ich habe ein Problem mit meinem SBS2003 Server. Dieser läuft auf einem HP ProLiant ML150G6 mit RAID Controller ...

Windows Server

Raid 5 nach Rebuild nicht verfügbar

gelöst Frage von nettworkerWindows Server3 Kommentare

Hallo zusammen, ich habe bei einem Server 2008 R2 ein Problem. Nachdem eine von 4 Platten aus einem Raid ...

Neue Wissensbeiträge
Windows 10
Zero-Day-Lücke in Microsoft Edge
Information von kgborn vor 1 TagWindows 10

In Microsofts Edge-Browser klafft wohl eine nicht geschlossene (0-Day) Sicherheitslücke im Just In Time Compiler (JIT Compiler) für Javascript. ...

Sicherheit
Microsoft und Skype: Sicherheit
Information von kgborn vor 1 TagSicherheit

Die Tage gab es ja einige Berichte zur Sicherheit des Skype-Updaters. Der Updater von Skype läuft unter dem Konto ...

Datenschutz

Behörden ignorieren Sicherheitsbedenken gegenüber Windows 10

Information von Penny.Cilin vor 2 TagenDatenschutz8 Kommentare

Hallo, passend zum Thema Ablösung LIMUX in München ein Beitrag bei Heise (siehe Link folgend). Behörden ignorieren Sicherheitsbedenken gegenüber ...

Sicherheit
Information Security Hub Munich airport
Information von brammer vor 2 TagenSicherheit

Hallo, Neues Center für Cyber Kriminalität am Münchener Flughafen brammer

Heiß diskutierte Inhalte
DSL, VDSL
Mindestgeschwindigkeiten DSL Telekom
Frage von justlukasDSL, VDSL13 Kommentare

Hallo zusammen, Seit diesem Jahr habe ich Verständnisprobleme mit dem Verhalten der Telekom. Wir haben seit einem Jahr VDSL ...

Switche und Hubs
LANCOM-Switch: Probleme (no link) mit SFP-Modulen?
Frage von THETOBSwitche und Hubs10 Kommentare

Hi zusammen, ich habe folgendes Problem: Und zwar habe ich an einem Standort drei Switche verbaut - LANCOM GS-2326P+, ...

Firewall
RB2011 Firewall Rule eine bestimmte Mac oder IP Adresse nicht zu blockieren
Frage von lightmanFirewall10 Kommentare

Hallo liebes Forum mit ihren Spezialisten. Ich habe meine Firewall so konfiguriert das kein Endgerät ohne meine Speziellen Erlaubnis ...

Humor (lol)
Was könnte man mit einem Server machen? Idee gesucht
Frage von 2SeitenHumor (lol)8 Kommentare

Hey Zusammen Ich habe einen alten HP G2 Rackserver zu Hause rumliegen. 28GB Ram, 1xAMD Prozi mit etwa 2GHz. ...