Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst DCOM 10016 Fehler, kein Eintrag in Komponentendienste

Mitglied: 25431

25431 (Level 1)

08.11.2006, aktualisiert 23.05.2007, 75819 Aufrufe, 13 Kommentare

Hallo,

bekommen auf einem SBS2003 seit einigen Tagen folgende Fehlermeldung. Der Anwendungspool in der zweiten Fehlermeldung ist der vom Project Server 2003. Fehlermeldungen erscheinen bei jedem Anmelden in den Project Server über den Project Web Access (Lokal und Inet).

Wie man sehen kann erscheinen beide Fehlermeldungen zeitgleich.
Was ich bisher versuchen wollte war unter Komponentendienste den Eintrag mit der obigen CLSID Berechtigungen für NT-AUTORITÄT\NETZWERKDIENST zu aktivieren, jedoch finde ich diesen Eintrag nirgends. Ich bin die Liste mit den Komponentendiensten bestimmt 100 mal hoch und runter; ist nicht zu finden.

Weiß jemand Rat?

MfG

_______________________________

Ereignistyp: Fehler
Ereignisquelle: DCOM
Ereigniskategorie: Keine
Ereigniskennung: 10016
Datum: 08.11.2006
Zeit: 19:14:53
Benutzer: NT-AUTORITÄT\NETZWERKDIENST
Computer: Server
Beschreibung:
Durch die Berechtigungseinstellungen (Anwendungsspezifisch) wird der SID (S-1-5-20) für Benutzer NT-AUTORITÄT\NETZWERKDIENST keine Aktivierungberechtigung (Lokal) für die COM-Serveranwendung mit CLSID
{0C0A3666-xxxx-....}
gewährt. Diese Sicherheitsberechtigung kann mit dem Verwaltungsprogramm für Komponentendienste geändert werden.



Ereignistyp: Fehler
Ereignisquelle: Active Server Pages
Ereigniskategorie: Keine
Ereigniskennung: 5
Datum: 08.11.2006
Zeit: 19:14:53
Benutzer: Nicht zutreffend
Computer: Server
Beschreibung:
Fehler: Die Initialisierung des permanenten Vorlagencaches für Anwendungspool "MSPS2003AppPool" ist wegen folgender Fehler fehlgeschlagen: Es konnte kein Cacheunterverzeichnis für den Anwendungspool erstellt werden. Die Daten haben möglicherweise weitere Fehlercodes..
Mitglied: Dani
08.11.2006 um 19:43 Uhr
Hi,
also zu 10016:
Gehe in die Registry (Start => Ausführen => regedit). Danach in das Verzeichnis "HKEY_CLASSES_ROOT\CLSID\0C0A3666-xxxx-...". Dort steht dann ein Name. Diesen solltest du dir gut merken. Danach wieder "Start => Einstellungen => Systemsteuerung => Verwaltung => Komponentendienste.

Dort dann auf "Komponentenliste => Computer => Arbeitsplatz => DCOM-Konfiguration. In der endlosen Liste, muss dein Name aus der Registry auftauchen.


Wenn du den entsprechenden Eintrag gefunden hast, Eintrag markieren, Rechtsklick => Eigenschaften. Dann den Reiter "Sicherheit" anklicken. Dann bei Start- und .... aufanpassen klicken und unter "Bearbeiten" musst du noch den Benutzer "NETZWERKDIENST" hinzufügen (am besten volle Rechte). Danach wieder alles schließen und den Server neustarten...


Gruß
Dani
Bitte warten ..
Mitglied: Dani
08.11.2006 um 19:48 Uhr
Hi,
und nun zu Fehler 5:

Dem Verzeichnis "C:\WINDOWS\Help\iisHelp\common" folgenden Benutzer ("NETZWERKDIENST") zur Sicherheit (Ordner markieren, Rechtsklick, Eigenschaften, Sicherheit). mit Lese- und Ausführrechte hinzufügen.

Dem Verzeichnis "C:\WINDOWS\system32\inetsrv\ASP" folgenden Benutzer ("NETZWERKDIENST") zur Sicherheit (Ordner markieren, Rechtsklick, Eigenschaften, Sicherheit). mit Vollenrechten hinzufügen.

Dem Verzeichnis "C:\WINDOWS\IIS Temporary Compressed Files" folgenden Benutzer ("NETZWERKDIENST") zur Sicherheit (Ordner markieren, Rechtsklick, Eigenschaften, Sicherheit). mit Vollenrechten hinzufügen.


Gruß
Dani
Bitte warten ..
Mitglied: 25431
08.11.2006 um 20:16 Uhr
Hallo Dani

Perfekt!

Habe deine beiden Lösungsvorschläge genau so befolgt und anschließend den Server neu gestartet (ohne Fehlermeldungen). Habe mich anschließend an 2 verschiedenen Rechnern über Project Web Access in den Project Server eingeloggt (ebenfalls ohne Fehlermeldungen).
Ich werde das die nächsten Tage noch beobachten, aber wie es scheint ist das Problem gelöst.

Vielen Dank
Bitte warten ..
Mitglied: Dani
08.11.2006 um 20:19 Uhr
Hi,
ok....dann hoffen wir mal das Beste! Ich hatte die gleichen Probleme (aber ich habe ein paar Wochen gebraucht)! *gg*
Wenn alles in Ordnung ist schreib ne kl. Nachricht und schließe bitte den Thread.


Gruß
Dani
Bitte warten ..
Mitglied: ricardo
22.05.2007 um 00:57 Uhr
Hallo,

nachdem ich den Original-Titel dieses Beitrages las, dachte ich: Hey, eine Lösung für dein Problem, jedoch...

Nachdem ich per Regedit die zur ClassID gehörige Komponente identifiziert habe (Network Connection Manager), konnte und kann ich diese jedoch nicht in der Komponentendienste-konsole finden, nirgends (unter Windows 2003 R2 SP1 Standard). Was macht man dann?

Wie kann ein nicht vorhandener Eintrag periodisch den in diesem Thread besprochenen Fehler produzieren?

Gruß rib
Bitte warten ..
Mitglied: MonsterX
22.05.2007 um 09:53 Uhr
Dani's Ausführung ist zwar gut, aber fehlt ein kleiner Schritt. Hier findest du eine potentielle Lösung:

http://www.admins-tipps.de/Microsoft/Windows_2003_Server/Event-ID_10016 ...
Bitte warten ..
Mitglied: ricardo
23.05.2007 um 23:35 Uhr
Genial, vielen Dank.

Diesen Eintrag gab es dann, war auch bei mir "Netman", und der Fehler scheint 'gone' zu sein

Gruß aus Bremen
Bitte warten ..
Mitglied: x-scips
31.03.2010 um 11:04 Uhr
Hallo,
bei mir bezieht sich der Fehler auf IPBusEnum. Mein Problem ist allerdings, dass ich die Punkte unter dem Reiter "Sicherheit" nicht bearbeiten kann.
Es ist alles grau und eine Auswahl ist nicht möglich. Aneldung ist erfolgt als Domänenadmin.
Eine Idee?
Grüße

PS: Es handelt sich um einen Server 2008 R2
Bitte warten ..
Mitglied: x-scips
31.03.2010 um 11:21 Uhr
Hallo nochmal,

konnte das Problem selbst lösen. Folgende Vorgehensweise:

- den Besitz für den entsprechenden Schlüssel übernehmen
- Berechtigung des Administrators auf Vollzugriff
- Start und Ausführen der Komponentendienste wie unter dem Link von "MonsterX" beschrieben
- nach erfolgter Aktion in der Registry den Administrator bzgl. des Schlüssels wieder entsprechend berechtigen

Grüße
Bitte warten ..
Mitglied: HeyJoe
13.01.2011 um 10:15 Uhr
Hallo, bin hier neu und auf das Forum über´s googeln gestoßen, weil ich bzgl. eines DCOM-Fehlers auf IPBusEnum die Sicherheitsberechtigung ändern wollte, es aber nicht geht, weil die Auswahl „ausgegraut“ ist.
Genau dieses Problem beschreibt das Forumsmitglied x-scips am 31.03.2010 in seinen beiden vorangegangenen Beiträgen.
x-scips hat also die Vorgehensweise beschrieben, allerdings für mich als Laien nicht so, dass ich damit genau was anfangen kann.

Meine Fragen:

- wie und wo übernimmt man genau den Besitz des Schlüssels und welche Einträge muß man genau tätigen?
- Was heißt, nach erfolgter Aktion in der registry den Admin bzgl. des Schlüssel wieder berechtigen? Heißt das, wieder auf den ursprünglichen Zustand zurückändern?

Es wäre schön, wenn mir einer aus dem Forum oder sogar x-scips dazu weiterhelfen könnte.

Nutze Windows 7 / 64-bit

Gruß
HeyJoe
Bitte warten ..
Mitglied: x-scips
27.01.2011 um 17:19 Uhr
Hallo,

folgende Schritte sind über den Registryeditor erforderlich:

- Schlüssel markieren
- In der Menüleiste über BEARBEITEN > BERECHTIGUNGEN...
kann der Besitz des Schlüssels übernommen und die Sicherheitseinstellung geändert und wiederhergestellt werden

Sofern dir die Registry unbekannt ist, solltest du dir jemand holen, der sich dort auskennt - ODER du bist dir zu 100% Sicher, dass die Änderung richtig ist.

Viel Erfolg
Bitte warten ..
Mitglied: HeyJoe
27.01.2011 um 19:08 Uhr
Danke x-scips,

ich werde mal in den nächsten Tagen ein Systemabbild machen und mich dann daran versuchen

Gruß HeyJoe


Hallo x-scips

bekomme es einfach nicht hin. Bin jetzt in die registry gegangen und habe dort bei dem Schlüssel:

HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\(C97FCC79-E628-407D-AE68-A06AD6D8B4D1)

mit Bearbeiten/Berechtigungen dem Administrator die Berechtigung "Vollzugriff" statt "Lesen" gegeben.
Dann in die Komponentendienste (als Admin) auf IPbusEnum, aber es bleibt dort ausgegraut.
Was mache ich falsch?

Gruß HeyJoe
Bitte warten ..
Mitglied: HeyJoe
01.06.2011 um 07:39 Uhr
Hallo x-scips

habe am 31.05.11 über einen anderen Kanal endlich die Lösung bekommen. Hier für alle, die es interessieren könnte:

Unter dem Link

http://www.itexperience.net/2010/10/29/event-10016-the-application-spec ...

ist alles genauestens beschrieben (englisch) und bebildet, danach kann man wunderbar vorgehen und das Problem ist gelöst.

Gruß HeyJoe
Bitte warten ..
Ähnliche Inhalte
Windows 10

Fehler im Runtimebroker DCOM 10016 Rechte fehlen

Frage von AkcentWindows 109 Kommentare

Hallo, auf einem Win10 1709 sind viele DCOM Fehler in der Ereignisanzeige. Nachdem ich im ganzen Netzt sehr viele ...

Exchange Server

Exchange DCOM Fehler

Frage von CloudyExchange Server7 Kommentare

Hallo, Ich habe schon wieder Probleme mit meinem Exchange 2016 (auf einem 2012R2 Standard Server installiert). Dort verabschiedet sich ...

Windows 10

Ständig Fehler Ereignis-Id 10016

Frage von walter23Windows 109 Kommentare

Guten Abend, mir wurde dieses Forum empfohlen und nun versuche ich mein Glück. Ich habe ein neues Notebook und ...

Windows 10

Wie Berechtige ich Komponentendienste richtig, das diese nicht mehr im Eventvwr als Fehler auftauchen

Frage von 131455Windows 104 Kommentare

Hallo, ich habe immer den Runtimebroker Dienst der das Herunterfahren von Windows 10 verzögert. Ich hatte die Schlüssel in ...

Neue Wissensbeiträge
Microsoft

Neuigkeiten zu Server und Office 365 was läuft mit was und was nicht

Tipp von AlFalcone vor 7 StundenMicrosoft

Server Betriebssysteme auf dem die verschiedenen Offices nicht supported sind: • Office 365 ist und wird nicht supported auf Windows ...

Speicherkarten

Neuer Speicherkartentyp - zunächst nur für Huawei-Smartphones (künftig auch für Notebooks u. Tablets?)

Tipp von VGem-e vor 8 StundenSpeicherkarten1 Kommentar

Servus, als ob das "Chaos" i.S. Speicherkarten noch nicht groß genug wäre?! Evtl. kommt dieser neue Kartentyp bald auch ...

Sicherheit

Diverse D-Link-Router durch drei Schwachstellen kompromittierbar

Information von kgborn vor 10 StundenSicherheit

Hat jemand D-Link-Router in Verwendung? Einige Modelle sind sicherheitstechnisch offen wie ein Scheunentor. Äußerst unschöne Sache, aber nichts neues ...

Hardware

100.000 Mikrotik-Router ungefragt von Hacker abgesichert

Information von 7Gizmo7 vor 1 TagHardware1 Kommentar

Hallo zusammen, da hier ja öfters mal von Mikrotik gesprochen wird. Trotz Updates klafft eine Sicherheitslücke in Hundertausenden Mikrotik-Routern. ...

Heiß diskutierte Inhalte
Windows 10
Sysprep Fehler im Log kann nicht starten
Frage von grillinator95Windows 1022 Kommentare

Hallo, kann leider SYSPREP nicht mehr starten, Win10 64bit. Logfile sagt folgendes: 2018-10-17 13:44:56, Info SYSPRP 2018-10-17 13:44:56, Info ...

Sicherheitsgrundlagen
EuGH-Urteil - Internetanschluss für die ganze Familie - Filesharer haften trotzdem
Frage von StefanKittelSicherheitsgrundlagen17 Kommentare

Hallo, In diesem Artikel geht es darum, dass Jemand aus der Familie ein Hörbuch illegal hochgeladen hat. Der Vater ...

Apple
MacBook Pro 2018 mit 8 GB oder 16 GB
Frage von SysAdm81Apple14 Kommentare

Hallo zusammen, ich steh vor der Überlegung mir ein MacBook Pro 13 (2018) zu kaufen. Bzgl. SSD habe ich ...

Outlook & Mail
Outlook schiebt Mails aus Posteingang sofort in den Papierkorb
Frage von hermesOutlook & Mail13 Kommentare

Hallo Outlook Fachleute, wir haben hier das Problem, dass Outlook 2010 alle ankommenden Mails seit zwei Tagen einfach in ...