Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Debian Installation unter VirtualBox - kein Netzwerk

Mitglied: pi314

pi314 (Level 1) - Jetzt verbinden

31.03.2012, aktualisiert 16:36 Uhr, 10330 Aufrufe, 3 Kommentare

Hallo zusammen,

habe in einer VirtualBox ein 64bit-Debian (ohne X-Server) installiert. Die Installation war erfolgreich, soweit läuft auch alles.

Mein Problem ist aber die Netzwerkkonfiguration, so dass Debian ins Internet kann und auch das Hostsystem (Linux Mint Lisa) auf die Maschine kommt.

Als (virtuellen) Adaptertyp in VirtualBox verwende ich einen Intel PRO/1000 MT Desktop (82540EM). Diesen erkennt Debian auch:
01.
root@test01:/#lspci | grep Ether 
02.
00:03.0 Ethernet controller: Intel Corporation 82540EM Gigabit Ethernet Controller (rev 02) 
03.
root@test01:/# 
04.
root@test01:/#lspci -n | grep 00:03 
05.
00:03.0 0200: 8086:100e (rev 02)
Im Verzeichnis /lib/modules/2.6.32-5-amd64 finde ich allerdings nichts, was darauf hindeutet, dass Debian einen Treiber für die VendorID und DeviceID hat:
01.
root@test01:/lib/modules/2.6.32-5-amd64# grep 8086 * | grep 100e 
02.
root@test01:/lib/modules/2.6.32-5-amd64# 

Wie bekomme ich das Netzwerk nun zum Fliegen?
Mitglied: 64748
31.03.2012 um 16:39 Uhr
Hallo pi314,

bitte poste mal die Ausgabe von
lspci -k | grep -iA3 ether
und
ifconfig
Du solltest als Einstellung für das Netzwerk in Virtualbox für diese VM "Bridgemodus" einstellen, dann wird die VM wie jeder andere Rechner in Dein Netzwerk eingebunden.

Zuletzt als ich ein Problem mit einem anderen Linuxgast hatte, hatte der Anschluss die Bezeichnung eth1 anstatt eth0, da hab ich längere Zeit nach einem Fehler gesucht, weil sich das Netzwerk mit "ifconfig eth0 up" nicht starten ließ

Markus
Bitte warten ..
Mitglied: pi314
31.03.2012 um 17:19 Uhr
eth1
Das war die Idee!

Nachdem ich die Einstellung in VirtualBox auf "Netzwerkbrücke" (Name: eth1) gestellt habe, und die Einträge in /etc/network/interfaces von eth0 auf eth1 angepasst habe, schnurrt das Kätzchen

Thx!
Bitte warten ..
Mitglied: mrtux
31.03.2012 um 20:25 Uhr
Hi !

Unter Debian werden die Netdevices über udev verwaltet. Schau in die /etc/udev/rules.d/xx-persistent-net.rules. Dort wird beim Netdevice anstatt eth0 vermutlich eth1 drinstehen und daher kam das Problem. Mit VirtualBox selbst hat das eher nix zu tun, oftmals kann sowas auftreten, wenn man den Typ (Treiber) des Netzwerkadapters in VirtualBox mal testweise ändert und wieder zurückstellt, das würfelt dann anscheinend die Einstellungen durcheinander, zumindest war das bei mir schon mehrmals so und wenn man weiss wo man suchen/hinfassen muss, stellt das normalerweise aber kein Problem dar.

mrtux
Bitte warten ..
Ähnliche Inhalte
Virtualisierung

Installation eines Spiels auf einer VirtualBox-VM

gelöst Frage von honeybeeVirtualisierung6 Kommentare

Hallo, ich versuche gerade, Europa Universalis auf eine VM unter VirtualBox zu installieren. Beim Starten kam diese u. g. ...

Router & Routing

Virtuelles Netzwerk (Virtualbox) - Routingproblem

gelöst Frage von HellgoreRouter & Routing6 Kommentare

Aloah! Ich kämpfe seit zwei Tagen mit einer Aufgabe im Rahmen meiner Ausbildung und finde einfach keine Lösung. Das ...

Netzwerkgrundlagen

Virtualbox Netzwerk einstellungen

Frage von MojoTecNetzwerkgrundlagen18 Kommentare

Hi ;-) , Einfache frage, wie stelle ich Virtualbox richtig ein, dass es als eigener netzwerkteilnehmer erkannt wird, wichtig ...

Debian

Debian Wheezy Postgresql installation

gelöst Frage von Thomas91Debian5 Kommentare

Hallo zusammen, ich habe Debian Wheezy installiert um darauf openz zu installieren. Nun möchte ich für die Software openz ...

Neue Wissensbeiträge
Windows 10

USB Maus und Tastatur versagen Dienst unter Windows 10

Erfahrungsbericht von hardykopff vor 5 StundenWindows 103 Kommentare

Da steht man ziemlich dumm da, wenn der PC sich wegen fehlender USB Tastatur und Maus nicht bedienen lässt. ...

Administrator.de Feedback
Update der Seite: Alles zentriert
Information von Frank vor 8 StundenAdministrator.de Feedback10 Kommentare

Hallo User, die größte Änderung von Release 5.8 ist das Zentrieren der Webseite (auf großen Bildschirmen) und ein "Welcome"-Teaser ...

Humor (lol)

WhatsApp-Nachrichten endlich auch per Bluetooth versendbar

Information von BassFishFox vor 1 TagHumor (lol)4 Kommentare

Genau darauf habe ich gewartet! ;-) Der beliebte Messaging-Dienst WhatsApp erhält eine praktische neue Funktion: Ab dem nächsten Update ...

Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 1 TagGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Heiß diskutierte Inhalte
Server-Hardware
Welche Rolle spielt Design bei Enterprise IT Hardware?
Frage von ApolloXServer-Hardware17 Kommentare

Ich arbeite für einen internationalen Elektronikhersteller in der Forschung und meine Aufgabe ist es, Feedback von Nutzern in Hinsicht ...

Windows Netzwerk
WSUS4 und Windows 10 Updates automatisch installieren
Frage von sammy65Windows Netzwerk15 Kommentare

Hallo miteinander, ich habe mit einen neuen WSUS Server aufgesetzt Server 2016 darauf einen aktuellen WSUS. Grund, wir stellen ...

Speicherkarten
Vergessliche USB-Sticks?
Frage von hanheikSpeicherkarten14 Kommentare

Ich habe in den letzten Tagen 500 USB-Sticks mit Bilddateien bespielt. Obwohl ich die Dateien mit größter Sorgfalt kopiert ...

Switche und Hubs
Cisco SG350X-48 AdminIP in anderes VLAN
Frage von lcer00Switche und Hubs14 Kommentare

Hallo zusammen, ich habe ein Problem mir einem Cisco SG350X-48 bei der Erstinstallation wurde eine IP 192.168.0.254 (Default VLAN ...