Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Debian Squezze DNS Problem

Mitglied: Mr.White

Mr.White (Level 1) - Jetzt verbinden

20.06.2013 um 15:06 Uhr, 1695 Aufrufe, 5 Kommentare

Hallo zusammen,

ich hab ein DNS Problem auf einem Debian Squezze, ich kann eine gewöhnliche IP-Adresse wie z.B. 8.8.8.8 anpingen, bei einem Namen wie www.google.de meckert mir die Maschine und gibt mir die Fehlermeldung ->

ping: unknown host www.google.de


Unter /etc/network/interfaces steht der folgender Eintrag.

auto lo eth0
iface lo inet loopback

iface eth0 inet static

address 192.28.200.182
netmask 255.255.255.0
nameserver 8.8.8.8
broadcast 192.28.200.255
gateway 192.28.200.1
network 192.28.200.0


Unter /etc/resolv.conf steht die folgende Meldung.

  1. Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
  2. DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN


Habe erst vor kurzem diese Maschine (ist eigentlich eine physische Maschine) über dem VMware Converter auf eine virtuelle Maschine (ESXi) geklont.

Die Subnetze passen selbstverständlich nicht mehr, weil die ursprüngliche Maschine aus dem Netz 192.28.230..... stammt. Die "neue" IP habe ich dementsprechend angepasst.


Habe ich evtl. irgend etwas übersehen, ich habe keine andere Idee mehr.

Über Anregungen bedanke ich mich im voraus und wünsche euch einen schönen sonnigen Donnerstag.


LG

Mr.White
Mitglied: Nordichammer
20.06.2013, aktualisiert um 15:34 Uhr
Hallo

trag doch mal von hand in die /etc/resolv.conf "nameserver 8.8.8.8" und speicher diese und probier es danach noch mal.

Guß

Nordichammer
Bitte warten ..
Mitglied: Mr.White
20.06.2013 um 15:41 Uhr
Hallo Nordichammer,

vielen Dank für dein Beitrag. Das hat super funktioniert! Tausend Dank.

Aber durch die Meldung habe ich abschrecken lassen, kannst du mir vielleicht kurz verraten wieso ich eigenhändig in die resolv.conf reinschreiben kann ohne das sich der Eintrag nachher löscht?


Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN


Vielen Dank für deine Hilfe

LG

Mr.White
Bitte warten ..
Mitglied: Nordichammer
20.06.2013 um 16:01 Uhr
Hallo,

schön dass ich dir weiterhelfen konnte, die Einträge in der resolv.conf werden durch die eingetragenen Nameserver in der /etc/network/interfaces bei Systemstart also auch bei bei interface neustart/reload erzeugt. Stand bei Start des Systems/interface nichts in der /etc/network/interfaces kann auch nichts in die resolv.conf geschrieben werden.

MFG
Bitte warten ..
Mitglied: Lochkartenstanzer
20.06.2013 um 18:02 Uhr
Zitat von Mr.White:
Habe erst vor kurzem diese Maschine (ist eigentlich eine physische Maschine) über dem VMware Converter auf eine virtuelle
Maschine (ESXi) geklont.

Schau mal nach,. ob das LAN-interface imemr noch eth0 ist. Bei "Hardware-Wechsel" bekommt die LAN-Schnittstelle einen neunen Namen und zieht sich die Adresse per DHCP. dann passen ggf die Einträge nicht mehr. ggf /etc7network7interfaces anpassen und nach einem reboot sollte alles wieder gut sein.

manuelle Änderungen an der resolv.conf überleben normalerweise den reboot nicht.

lks
Bitte warten ..
Mitglied: Mr.White
25.06.2013 um 10:25 Uhr
Zitat von Lochkartenstanzer:
> Zitat von Mr.White:
> ----
> Habe erst vor kurzem diese Maschine (ist eigentlich eine physische Maschine) über dem VMware Converter auf eine
virtuelle
> Maschine (ESXi) geklont.

Schau mal nach,. ob das LAN-interface imemr noch eth0 ist. Bei "Hardware-Wechsel" bekommt die LAN-Schnittstelle einen
neunen Namen und zieht sich die Adresse per DHCP. dann passen ggf die Einträge nicht mehr. ggf /etc7network7interfaces
anpassen und nach einem reboot sollte alles wieder gut sein.

manuelle Änderungen an der resolv.conf überleben normalerweise den reboot nicht.

lks

Moin,

das stimmt spätestens nach dem reboot war der Eintrag nicht mehr drin.

Vielen Dank für die Info

LG

Mr.White
Bitte warten ..
Ähnliche Inhalte
Debian
Debian Jessie - DNS-Problem
gelöst Frage von FA-jkaDebian2 Kommentare

Mein Jessie ärgert mich: Warum kann ich den Domaincontroller (dc.ia.local / 10.10.10.1) nicht über seinen voll qualifizierten Namen anpingen? ...

Ubuntu

Problem mit MailServer unter Debian - Postfix, Dovecot

Frage von Richard8Ubuntu4 Kommentare

Guten Tag, leider ist es mir nicht möglich mit meinem neu aufgesetztem MailServer welcher aktuell auf meinem Debian Jessie ...

Linux Netzwerk

Debian Iptables kein Ping und DNS nach außen möglich

gelöst Frage von ZuendappLinux Netzwerk5 Kommentare

Hallo Zusammen, ich habe ein kleines Problem mit meinem Debian Rechner/Server und den iptables. Da ich mir aus dem ...

DNS

DNS Problem im VLAN

Frage von momaiDNS7 Kommentare

Hallo, ich habe ein kleines DNS Problem im VLAN. Folgende Konstellation. Das DNS sollte eigentlich der RVS4000 machen unter ...

Neue Wissensbeiträge
Humor (lol)
IoT-Gefahr: Smartes Aquarium leckt!
Information von Lochkartenstanzer vor 56 MinutenHumor (lol)

Moin, Die IoT-Manie hat weitere Opfer gefunden. Ein Casino-Leck durch ein smartes Aquarium: Allerdings haben sie kein Wasser, sondern ...

Router & Routing

Olle Fritzbox 7270 mit VPN und SIP-Telefonie hinter O2 Homebox 6641 als "Modem"

Erfahrungsbericht von the-buccaneer vor 9 StundenRouter & Routing3 Kommentare

Nun war es soweit: Auch O2 hat mich mit VOIP zwangsbeglückt. Heute am Privatanschluss, in 2 Wochen ist das ...

Sicherheit

Ungepatchte Remote Code Execution-Lücke in LG NAS

Information von kgborn vor 22 StundenSicherheit

Nutzt wer LG NAS-Einheiten? In den NAS-Einheiten der LG Network Storage-Einheiten gibt es eine sehr unschöne Schwachstelle, die einen ...

Windows Update

Neue Version KB4099950 NIC Einstellungen gehen verloren

Information von sabines vor 1 TagWindows Update2 Kommentare

Es ist eine neue Version des KB4099950 verfügbar, die das Problem mit den verlorenen Netzwerkeinstellungen lösen soll. Das Datum ...

Heiß diskutierte Inhalte
Festplatten, SSD, Raid
Server SSD: NVMe PCIe 3.0 RAID?
Frage von bouneeFestplatten, SSD, Raid15 Kommentare

Hallo liebe Admins, mir stellt sich gerade die Frage, ob ein neuer Server mit SSD NVMe PCIe 3.0 Sinn ...

Sonstige Systeme
Wie Normenkataloge im Unternehmen bereit stellen?
Frage von MuzzepuckelSonstige Systeme14 Kommentare

Hallo Kollegen, ich lese schon lange hier mit, nun mein ersrer Beitrag, bzw. Frage. :-) Wir benötigen für unsere ...

Sicherheit
Verbindliche Zustellung per E-Mail?
Frage von ahussainSicherheit14 Kommentare

Hallo allerseits, ein Kunde von mir nutzt intensiv Fax. Hauptgrund: zusammen mit einer Empfangsbestätigung ist eine verbindliche Zustellung gewährleistet. ...

LAN, WAN, Wireless
OpenVPN Client Fehlermeldungen
Frage von chris84LAN, WAN, Wireless14 Kommentare

Hallo Zusammen, wir nutzen seit kurzem einen neuen Router und den OpenVPN Client. Die VPN Verbindung klappt; allerdings kommen ...