Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Debian v.6.0.4 (Squeeze) Webserver mit Apache2, Adressbereich geändert und seit dem Ist die Homepage nicht mehr erreichbar. Warum?

Mitglied: Sierjoerg

Sierjoerg (Level 1) - Jetzt verbinden

05.04.2012 um 08:00 Uhr, 4601 Aufrufe, 7 Kommentare

Ich wollte meinen Webserver einfach nur ins Intranet einbinden, damit ich auch an anderen Rechnern zugriff auf die Homepage habe, um z.B. meinem Chef die Fortschritte an der Homepage präsentieren kann.

Hallo liebe Administratorinen und Administratoren,
folgendes Problem beschäftigt mich seit 2 Tagen. Ich habe die Aufgabe für unsere Tochterfirma eine Homepage nach vorbild unserer eigenen Homepage zu erstellen. Also habe ich mir eine Virtuellen Maschine (vmware) mit Debian v.6.0.4 eingerichtet.
Darauf habe ich mir einen Webserver mit Apache2 eingerichtet, Php5 und Mysql für die Datenbank eingerichtet.

Anfangs habe ich den Webserver auserhalb des Firmennetzes eingerichtet. Das bedeutet ich habe eine IP-Adresse auserhalb unseres IP Adressbereichs verwendet. Da ich in meinem Rechner zwei NIC's habe konnte ich mir eine von den beiden für das andere Netz konfigurieren. Das einrichten und drauf zugreifen auf die Homepage war auch Anfangs kein Problem, bis ich den Webserver in unseren Firmennetz sprich in unseren Adressbereich einfügen wollte. Nach dem Ich die IP geändert hatte, konnte ich auf einmal nur noch auf die Startseite meiner Homepage drauf zugreifen. Zudem wurde die Seite nicht richtig dargestellt. Es fehlen jegliche art von Logos Farblichen Hintergründen, eingerichtete Menüleisten usw. Wenn ich z.B auf einen anderen Bereich klicken will, sagen wir Impressum, bekomme ich die Meldung vom Server, das der Zugriff auf die angeforderte URL nicht erfolgreich war: Grund die Verbindung schlug fehl. Das interessante daran ist, er will die alte IP Adresse für den Zugriff auf die Seite nutzen. Aufruf der Hompage lief bis jetzt nur über die IP!
Darauf hin habe ich erst mal den Verlauf und den Cache meines Browsers gelöscht. Hat aber nicht geholfen. Also bin ich mal an einen anderen Rechner gegangen und habe versucht dort die Homepage aufzurufen. Aber auch da versucht der Browser eine Verbindung zur alten IP Adresse aufzunehmen.
Leider kenne ich mich in Linux nicht ganz so gut aus um das Problem auch nur irgendwie einzugrenzen. Für mich sieht das so aus, als würde irgendwo, in irgend einer Datei stehen, dass die Seiten meiner Homepage über diese Adresse erreichbar sind. Obwohl die Netzwerkkarte in einen anderen Adressbereich gebracht worden ist.

Ich hoffe ihr könnt mir helfen.
Falls ihr noch infos benötigt bitte fragen. Ich versuch mein bestes eure Fragen zu beantworten.

MFG Sierjörg
Mitglied: it-frosch
05.04.2012 um 08:10 Uhr
Hallo Sierjörg,

ich vermute mal das du ein CMS verwendest. Hast du darin mal die Einstellungen geprüft.
Es schaut ja so aus das die Pfade für bestimmte Inhalte die alte IP enthalten. Also würde ich da ansetzen.
Wenn du schreibst mit welchem CMS du arbeitest, gibt es hier bestimmt einen Admin der dir aus dem Hut sagen kann wo die Einstellung ist.

grüße vom it-frosch
Bitte warten ..
Mitglied: Sierjoerg
05.04.2012 um 08:23 Uhr
Ich schätze du meinst Mit CMS so was wie Websitebaker oder? Was zu gleich auch die Antwort dieser Frage ist .
Bitte warten ..
Mitglied: SlainteMhath
05.04.2012 um 08:58 Uhr
Moin,

sieht für mich so aus, als wäre das Problem in deinem Sourcecode zu suchen. Durchsuche doch einfach mal all deine PHP und Config-Dateien nach der alten IP. Oder hast du bei Apache rewrites, redirects oder aliases eingetragen?

lg,
Slainte
Bitte warten ..
Mitglied: Sierjoerg
05.04.2012 um 09:28 Uhr
Moin Slainte,
in Apache habe ich keinerlei der artiger Einstellungen vorgenommen. Und was dem Sourcecode angeht, der stammt ja von Websitebaker, und dem Template von unserer Firmen Homepage. Den habe ich nur leicht in sachen anderes Logo und andere Sidebar Einträge geändert.
Bitte warten ..
Mitglied: Sierjoerg
05.04.2012 um 09:31 Uhr
Hallo noch mal,
ich habe mir gerade ein bischen Quellcode angeschaut und siehe da, gleich am Anfang steht die alte IP Adresse.
Bitte warten ..
Mitglied: Sierjoerg
05.04.2012 um 10:02 Uhr
So Problem dank Slainte Hinweis gelöst. Ich darf dann mal eben die Lösung präsentieren.

Die Lösung steckt inder Config.php vom Websitebacker. Hier der Quellcode:

<?php

define('DB_TYPE', 'mysql');
define('DB_HOST', 'localhost');
define('DB_Name','Websitebaker');
define('DB_USERNAME', 'rootr');
define('DB_PASSWORD', 'password');
define('DB_NAME', 'name');
define('TABLE_PREFIX', '');

define('WB_PATH', dirname(__FILE__));
define('WB_URL', 'http://192.xxx.xxx.241/wservice/wb'");
define('ADMIN_PATH', WB_PATH.'/admin');
define('ADMIN_URL',WB_URL.'/admin');

require_once(WB_PATH.'/framework/initialize.php');

?>
Wenn man jetzt den IP Adressbereich seines Webservers ändert, muss man auch die Config.php dem entsprechend an der stell WB_URL ändern.

Ich bedanke mich bei allen, die so schnell auf meine Frage geantwortet haben und wünsche euch frohe Ostern.
MFG Sierjörg
Bitte warten ..
Mitglied: it-frosch
05.04.2012 um 10:50 Uhr
Hallo Sierjörg,

noch zur Info. ( http://www.websitebaker2.org/de/hilfe/entwicklerhandbuch/variablen-und- ... )

dir auch schöne Ostern.

grüße vom it-frosch
Bitte warten ..
Ähnliche Inhalte
Apache Server

Debian CPU Auslastung durch Apache2 sehr hoch

gelöst Frage von zeroblue2005Apache Server12 Kommentare

Hallo Zusammen, ich habe eine VM Debian 7.11 x32 mit einem Apache2 am laufen. Jetzt stelle ich fest, dass ...

LAN, WAN, Wireless

Webserver über das eigene Netzwerk nicht erreichbar

gelöst Frage von frilooLAN, WAN, Wireless18 Kommentare

Hallo, ich habe einen kleinen Webserver im Internet gefunden, mit dem ich IN meinem Netzwerk arbeiten möchte Ich möchte ...

Server

Plesk Webserver teilweise nicht Erreichbar

Frage von JoRu1407Server3 Kommentare

Liebe Community! Ich habe ein Problem mit meinem bei Host Europe angemieteten vServer samt Plesk: Leider sind alle Internetseiten ...

Apache Server

htaccess Problem mit mod rewrite (apache2, debian)

gelöst Frage von janek26Apache Server1 Kommentar

Hallo Community, ich habe ein problem mit meinem Webserver. Irgendwie ließt er die .htaccess nicht richtig ein. manche links ...

Neue Wissensbeiträge
Windows 10

USB Maus und Tastatur versagen Dienst unter Windows 10

Erfahrungsbericht von hardykopff vor 1 TagWindows 105 Kommentare

Da steht man ziemlich dumm da, wenn der PC sich wegen fehlender USB Tastatur und Maus nicht bedienen lässt. ...

Administrator.de Feedback
Update der Seite: Alles zentriert
Information von Frank vor 1 TagAdministrator.de Feedback18 Kommentare

Hallo User, die größte Änderung von Release 5.8 ist das Zentrieren der Webseite (auf großen Bildschirmen) und ein "Welcome"-Teaser ...

Humor (lol)

WhatsApp-Nachrichten endlich auch per Bluetooth versendbar

Information von BassFishFox vor 2 TagenHumor (lol)4 Kommentare

Genau darauf habe ich gewartet! ;-) Der beliebte Messaging-Dienst WhatsApp erhält eine praktische neue Funktion: Ab dem nächsten Update ...

Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 2 TagenGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Heiß diskutierte Inhalte
Windows Netzwerk
WSUS4 und Windows 10 Updates automatisch installieren
Frage von sammy65Windows Netzwerk15 Kommentare

Hallo miteinander, ich habe mit einen neuen WSUS Server aufgesetzt Server 2016 darauf einen aktuellen WSUS. Grund, wir stellen ...

Speicherkarten
Vergessliche USB-Sticks?
Frage von hanheikSpeicherkarten14 Kommentare

Ich habe in den letzten Tagen 500 USB-Sticks mit Bilddateien bespielt. Obwohl ich die Dateien mit größter Sorgfalt kopiert ...

Hyper-V
Hyper-V mit altem XEON-Server. Was ist falsch?
Frage von LollipopHyper-V11 Kommentare

Hallo Bin etwas frustriert. Kleinbetrieb, ca. 15 PC's, 2 Stk. Server mit einigen virtuellen PC's für Fernwartung, VaultServer für ...

Windows Server
NTFS Berechtigungen Ordnerstruktur
Frage von hukahu23489Windows Server11 Kommentare

Hallo, ich bin seit kurzem in einer neuen IT-Abteilung und bin über das Berechtigungskonzept des Unternehmens sehr schockiert. Ich ...