Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Debin 5 Lenny Kernel 2.6.26-2-amd64 mit GA-D525TUD XServer startet nicht

Mitglied: Shamaz

Shamaz (Level 1) - Jetzt verbinden

28.10.2010 um 18:18 Uhr, 3208 Aufrufe, 2 Kommentare

Ich bin jetzt nicht mehr soo der Anfänger, jedoch kenne auch ich nicht jeden Befehl und weiss wo sich alle relevanten Dateien befinden, aber wenn man es mir einfach erklärt, werde ich es schon verstehen.
Damit ihr auch wisst um welches System es sich handelt hier eine Zusammenfassung:
Motherboard: Gigabyte GA-D525TUD
OS: Debin 5.0.6 lenny mit Kernel 2.6.26-2-amd64 und Gnome Oberfläche

So nun zum eigentlichen Problem:

Ich wollte mir die Desktopumgebung Gnome auf mehr als 800x600 anzeigen lassen.
Jedoch wird mir nichts höheres angeboten, was auf einem 21 Zoll Monitor (Manual hier )ziemlich körnig ist.
Somit habe ich versucht die passenden Einträge in die /etc/X11/xorg.conf zu machen. Habe dann erst nach mehreren Versuchen festgestellt, das 1280x1024 nur mit 16 Bit Farbtiefe überhaut geht. Gemerkt habe ich das daran, das überhaut der Loginscreen kam. Jetzt ist es aber so, das ich mich nicht mit meinem normalen User anmelden kann. Nach der Eingabe von Benutzername und Passwort (komischerweise mit Englischem Tastaturlayout) flimmert der Bildschirm und ich bin wieder beim Login.

Mache ich jedoch folgendes:
STRG+ALT+F1-> Login als root
dann invoke-rc.d gdm stop gefolgt von startx
bin ich sogar als root in der grafischen Oberfläche angemeldet, was ja sonnst nicht möglich ist und das auch in 1280x1024 Auflösung

Um bis hier hin zu kommen habe ich schon diverses versucht:

Original xorg.conf um Einträge wie in den Sectionen "Monito" und "Screen" erweitert
01.
 Section "Monitor" 
02.
     Option "PreferredMode" "1280x1024" 
03.
     HorizSync	30.0 - 107.0 
04.
    VertRefresh	50.0 - 160.0 
05.
    Option		"dpms" 
06.
    Modeline "1280x1024@85"  159.36  1280 1376 1512 1744  1024 1025 1028 1075 
07.
 EndSection 
08.
 
09.
 Section "Screen" 
10.
    Identifier	"Default Screen" 
11.
    Monitor		"Configured Monitor" 
12.
    DefaultDepth	16 
13.
    SubSection "Display" 
14.
             Depth	16 
15.
             Modes	"1280x1024@85" "800x600" 
16.
 EndSubSection 
17.
 EndSection
Die Modeline habe ich mir mit dem Befehl
01.
gtf 1280 1024 85
erzeugen lassen

Was aber dazu geführt hat, das der Bildschirm nur noch schwarz blieb. Deshalb habe ich gdm wieder gestoppt mit invoke-rc.d gdm stop und mir mit
X -configure
eine neue xorg.conf erstellen lassen. In diesem Dummy habe ich dann kleine Anpassungen gemacht und nach /etc/X11 verschoben und umbenannt. diese sieht nun so aus:
01.
Section "ServerLayout" 
02.
	Identifier     "X.org Configured" 
03.
	Screen      0  "Screen0" 0 0 
04.
	InputDevice    "Mouse0" "CorePointer" 
05.
	InputDevice    "Keyboard0" "CoreKeyboard" 
06.
EndSection 
07.
 
08.
Section "Files" 
09.
	RgbPath      "/etc/X11/rgb" 
10.
	ModulePath   "/usr/lib/xorg/modules" 
11.
	FontPath     "/usr/share/fonts/X11/misc" 
12.
	FontPath     "/usr/share/fonts/X11/cyrillic" 
13.
	FontPath     "/usr/share/fonts/X11/100dpi/:unscaled" 
14.
	FontPath     "/usr/share/fonts/X11/75dpi/:unscaled" 
15.
	FontPath     "/usr/share/fonts/X11/Type1" 
16.
	FontPath     "/usr/share/fonts/X11/100dpi" 
17.
	FontPath     "/usr/share/fonts/X11/75dpi" 
18.
	FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType" 
19.
EndSection 
20.
 
21.
Section "Module" 
22.
	Load  "record" 
23.
	Load  "extmod" 
24.
	Load  "dri" 
25.
	Load  "glx" 
26.
	Load  "xtrap" 
27.
	Load  "GLcore" 
28.
	Load  "dbe" 
29.
EndSection 
30.
 
31.
Section "InputDevice" 
32.
	Identifier  "Keyboard0" 
33.
	Driver      "kbd" 
34.
EndSection 
35.
 
36.
Section "InputDevice" 
37.
	Identifier  "Mouse0" 
38.
	Driver      "mouse" 
39.
	Option	    "Protocol" "auto" 
40.
	Option	    "Device" "/dev/input/mice" 
41.
	Option	    "ZAxisMapping" "4 5 6 7" 
42.
EndSection 
43.
 
44.
Section "Monitor" 
45.
	Identifier   "Monitor0" 
46.
	VendorName   "Monitor Vendor" 
47.
	ModelName    "Monitor Model" 
48.
EndSection 
49.
 
50.
Section "Device" 
51.
        ### Available Driver options are:- 
52.
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False", 
53.
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz" 
54.
        ### [arg]: arg optional 
55.
        #Option     "ShadowFB"           	# [<bool>] 
56.
        #Option     "DefaultRefresh"     	# [<bool>] 
57.
        #Option     "ModeSetClearScreen" 	# [<bool>] 
58.
	Identifier  "Card0" 
59.
	Driver      "vesa" 
60.
	VendorName  "Intel Corporation" 
61.
	BoardName   "Unknown Board" 
62.
	BusID       "PCI:0:2:0" 
63.
EndSection 
64.
 
65.
Section "Screen" 
66.
	Identifier "Screen0" 
67.
	Device     "Card0" 
68.
	Monitor    "Monitor0" 
69.
	SubSection "Display" 
70.
		Viewport   0 0 
71.
		Depth     1 
72.
	EndSubSection 
73.
	SubSection "Display" 
74.
		Viewport   0 0 
75.
		Depth     4 
76.
	EndSubSection 
77.
	SubSection "Display" 
78.
		Viewport   0 0 
79.
		Depth     8 
80.
	EndSubSection 
81.
	SubSection "Display" 
82.
		Viewport   0 0 
83.
		Depth     15 
84.
	EndSubSection 
85.
	SubSection "Display" 
86.
		Viewport   0 0 
87.
		Depth     16 
88.
		Modes 	 "1024x768" "800x600" 
89.
	EndSubSection 
90.
	SubSection "Display" 
91.
		Viewport   0 0 
92.
		Depth  	24 
93.
	EndSubSection 
94.
EndSection
Das ist nun auch die aktuelle Konfig, bei der oben beschriebenes Verhalten zu beobachten ist.
Zusammengefasst:
Anmeldung mit normalen User nicht möglich, nur mit Englischem Tastaturlayout
In Konsole wechseln -> als root anmelden -> gdm stoppen mit invoke-rc.d gdm stop -> XServer starten mit startx
Dann als root mit der richtigen 1280x1024 Auflösung alles möglich in Gnome

Was ich jetzt brauche ist eine Lösung damit ich mich auch als normaler User einfach anmelden kann und das bei einer Auflösung von 1280x1024

So schon mal danke im Voraus

Mfg Shamaz
Mitglied: Pago159
29.10.2010 um 08:31 Uhr

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
EndSection


Hiermit könntest du schonmal dein Tastaturlayout auf Deutsch umstellen:

Section "InputDevice"

Identifier "Keyboard0"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "de"

EndSection

Das Flimmern kann ich mir gerade nicht erklären,
woran das hängen könnte.
Hast du nicht deine Orginale Xorg.conf noch als Sicherung irgendwo liegen?

Lg Grapper
Bitte warten ..
Mitglied: Shamaz
01.11.2010 um 22:31 Uhr
danke für deine Antwort, jedoch habe ich es noch weiter probiert und bin zu dem schluss gekommen, das ich es nicht hin bekomme. Habe mich jetzt dafür entschieden Ubuntu Server zu installieren und da dann gnome und so nen paar andere Sachen nach zu installieren.

Danke aber trotzdem.

Mfg Shamaz
Bitte warten ..
Ähnliche Inhalte
CPU, RAM, Mainboards

Gigabyte GA-H55M-UD2H auf 2x4 GB aufrüsten und dann startet Windows nicht mehr

Frage von KaucherCPU, RAM, Mainboards4 Kommentare

Hallo Ich habe 4 Rechner mit Mainboard Gigabyte GA-H55M-UD2H Rev 1.3 BIOS F11 CPU Intel i3 550 Speicher 2x ...

Ubuntu

Apache 2 startet nicht mehr

gelöst Frage von Hector-UserUbuntu2 Kommentare

Eingabe: /etc/init.d/apache2 start Fehlermeldung: Starting apache2 (via systemctl): apache2.serviceJob for apache2.service failed. See "systemctl status apache2.service" and "journalctl -xe" ...

Festplatten, SSD, Raid

Raidcontrollersoftware für GA-H87M-D3H

gelöst Frage von CharlyXLFestplatten, SSD, Raid6 Kommentare

Hallo zusammen, ich suche nach einer Software um vom Windows aus, mein Raid zu kontrollieren. Leider finde ich nicht ...

Assembler

Kernel programmieren.

Frage von TatonitAssembler2 Kommentare

Um den Kernel zu programmieren, muss man die "komplette" References können ? Würden also normale Tutorials ausreichen bzw. auch ...

Neue Wissensbeiträge
Humor (lol)

WhatsApp-Nachrichten endlich auch per Bluetooth versendbar

Information von BassFishFox vor 8 StundenHumor (lol)1 Kommentar

Genau darauf habe ich gewartet! ;-) Der beliebte Messaging-Dienst WhatsApp erhält eine praktische neue Funktion: Ab dem nächsten Update ...

Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 20 StundenGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Sicherheit

Intel gibt neue Spectre V2-Microcode-Updates frei (20.02.2018)

Information von kgborn vor 21 StundenSicherheit

Intel hat zum 20. Februar 2018 weitere Microcode-Updates für OEMs freigegeben, um Systeme mit neueren Prozessoren gegen die Spectre ...

Microsoft
ARD-Doku - Das Microsoft Dilemma
Tipp von Knorkator vor 1 TagMicrosoft3 Kommentare

Hallo zusammen, vor einigen Tagen lief in der ARD u.a. Reportage. Das Youtube Video dazu dürfte länger verfügbar sein. ...

Heiß diskutierte Inhalte
Windows Server
AD DS findet Domäne nicht, behebbar?
Frage von schapitzWindows Server40 Kommentare

Guten Tag, ich habe bei einem Kunden ein Problem mit den AD DS. Umgebung ist folgende: Windows Server 2016 ...

Router & Routing
LANCOM VPN CLIENT einrichten
Frage von Finchen961988Router & Routing27 Kommentare

Hallo, ich habe ein Problem und hoffe ihr könnt mir helfen, wir haben einen Kunden der hat einen Speedport ...

Router & Routing
ISC DHCP 2 Subnetze
gelöst Frage von janosch12Router & Routing19 Kommentare

Hallo, ich betreibe bei mir im Netzwerk einen ISC DHCP Server auf Debian, der DHCP verwaltet aktuell ein /24 ...

Switche und Hubs
Cisco SG350X-48 AdminIP in anderes VLAN
Frage von lcer00Switche und Hubs14 Kommentare

Hallo zusammen, ich habe ein Problem mir einem Cisco SG350X-48 bei der Erstinstallation wurde eine IP 192.168.0.254 (Default VLAN ...