Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

DHCP und Catalyst2960: 54 Sekunden bis zur IP-Adresse :(

Mitglied: Ikarisan

Ikarisan (Level 1) - Jetzt verbinden

23.03.2007, aktualisiert 10.04.2007, 4181 Aufrufe, 6 Kommentare

Ein neu angeschlossener Client bekommt erst nach mind. 54 Sekunden eine IP-Adresse.....

Hallo!

Ich habe ein ganz seltsames Problem. Und zwar habe ich hier ein Netzwerk mit einigen W2k3 Servern. Und auf zweien läuft ein DHCP-Server. Ein primärer und ein sekundärer. Die Server wie auch alle Client hängen an Cisco Catalyst Switches der 2960er Reihe. Und eigentlich immer schon tritt folgendes Problem auf:

Wenn ich einen Client an einen Switchport hänge und dieser sich dann die IP-Adresse vom DHCP Server holen will funktioniert das erst nach ca. 54 Sekunden. Es wird immer wieder ein "DHCP DISCOVER" gesendet aber es erfolgt keine Antwort. Dies ist unter Windows und Linux so.
Hat der Client nach diesen 54 Sekunden endlich eine IP-Adresse bekommen dauert das Anfordern einer neuen (nach einem Release) maximal 4 Sekunden. Aber sobald ich das Netzwerkkabel für 5 Sekunden ausstecke und wieder anschließe muss ich wieder knapp eine Minute warten.

Interessant dabei ist folgendes. Hänge ich an den Port des Catalyst einen weiteren kleinen Switch oder einen Hub und schließe an diesen dann den Client an bekommt dieser innerhalb von max. 4 Sekunden seine IP-Adresse!

Scheinbar liegt es am Catalyst der erst nach über 50 Sekunden die Anfragen des Clients an den Server weiterleitet. Und wenn an dem Port schon ein Switch/Hub hängt ist die "Weiterleitung" der Pakete halt schon aktiv bzw. der Switchport freigeschaltet.
Leider habe ich keine Ahnung ob man da bei dem Switch was konfigurieren kann. Und vor allem..... WAS müsste ich konfigurieren?

Unser Problem ist nämlich das Windows immer noch keine IP-Adresse bekommen hat wenn der User sich anmeldet und demnach auch die ganzen Netzlaufwerke nicht eingebunden werden. Die Benutzer müssen sich dann immer wieder abmelden, zwei Minuten warten und wieder neu anmelden. Das ist ziemlich nervig.

Hat irgendjemand Erfahrungen mit der 2960er Reihe und kann mir einen Tip geben?

Vielen Dank!!!!

Gruß
Thorsten
Mitglied: Dani
23.03.2007 um 20:30 Uhr
G' Abend,
wir haben in einem Testteillabor auch einen Switch stehen. Dort dauert es auch ca 1 Min. bis DHCP Request erfolgreich war. Lösungen => Keine. Somit habe ich natürlich auch Interesse.


Grüße
Dani
Bitte warten ..
Mitglied: DerSchorsch
23.03.2007 um 21:05 Uhr
Hallo,

ist bei Cisco normal. Diese Switches kann man leider nicht einfach so hinstellen, sondern man muss sie auch konfigurieren.
Verantwortlich für dein Problem ist das Spanning Tree Protokoll. Damit versucht der Switch die Netzwerktopologie des Netzwerkes zu erkennen und vor allem Verkabelungsfehler, die eine Schleife erzeugen, zu ermitteln.

Die Lösung ist recht einfach:
Ports, an denen ein Host hängt, schaltest du auf "spanning-tree portfast". Dann schaltet er fast sofort ein. Die Ports, an denen andere Switches/Hubs hängen, solltest du lassen.

Kannst du über die Konsole oder das Webinterface (falls er bereits eine IP hat) konfigurieren.

Das Handbuch zum 2960 findest du hier:
http://www.cisco.com/en/US/products/ps6406/products_configuration_guide ...

Gruß,
Schorsch
Bitte warten ..
Mitglied: Dani
26.03.2007 um 07:50 Uhr
G' Morgen,
wunderbar....geht jetzt wirklich zügig! Dauert jetzt max. 10 Sekunden.


Grüße
Dani
Bitte warten ..
Mitglied: Ikarisan
30.03.2007 um 18:57 Uhr
Vielen Dank!!
Habe das eben mal ausprobiert und es funktioniert wirklich.
Jetzt sinds nur noch 4 Sekunden bis zur IP-Adresse!!

Wie haben hier auch noch zwei 2948G und einen 2980G laufen auf denen das auch noch geändert werden müsste. Da läuft aber CatOS 8.x bzw 6.x drauf. Gibt es da auch so was wie einen "interfaces range" Befehl? Alle 48 bzw. 80 Port manuell umzustellen ist nämlich eine unglaublich zeitaufwändige Angelegenheit.

Kann man das CatOS nicht einfach durch IOS12.x ersetzen?

Gruß
Thorsten
Bitte warten ..
Mitglied: DerSchorsch
30.03.2007 um 21:06 Uhr
Hallo,

Ich bezweifle, dass man CatOS durch IOS ersetzen kann, aber probier es mal mit:
"set spantree portfast 0/1-48 enable"
Damit müsste man eigentlich alle Ports eines Moduls auf einen Schlag umstellen können.

Ansonsten einen Azubi oder eine Sekretärin schnappen und "delegieren"

Grüße,
Schorsch
Bitte warten ..
Mitglied: Ikarisan
10.04.2007 um 09:25 Uhr
Danke!

Ich werde das mal ausprobieren. Leider bin ich bin ich momentan krank, aber ich werde mal per Mail "delegieren" :D
Bitte warten ..
Ähnliche Inhalte
Peripheriegeräte

IP Telefon bekommt über DHCP keine Adresse

gelöst Frage von a.grothePeripheriegeräte13 Kommentare

Hallo zusammen, ich habe hier ein Problem, mit IP Telefonen: Wir nutzen hier VLANs. z.b. VLAN 3 für Server ...

Windows Server

IP Adressen im DHCP Bereich werden zu wenig

Frage von shooanWindows Server5 Kommentare

Hallo Leute, ich habe ein Problem mit den DHCP Adressen, diese werden mir bald wohl ausgehen. Wenn wir W-LAN ...

LAN, WAN, Wireless

IP Adressen in DMZ von DHCP in LAN

gelöst Frage von 118080LAN, WAN, Wireless9 Kommentare

Moin :-) Ich spiele momentan mit dem Gedanken eine DMZ einzurichten. Jetzt habe ich eine ganz grundlegende Frage. Ich ...

Netzwerkmanagement

DHCP Mac Adresse einer IP zuweisen

Frage von vikozoNetzwerkmanagement8 Kommentare

guten Tag in meinem DHCP Server weise ich diverse MAC Adressen diversen IP Ranges zu. Was soweit auch klappt. ...

Neue Wissensbeiträge
Humor (lol)
IoT-Gefahr: Smartes Aquarium leckt!
Information von Lochkartenstanzer vor 4 StundenHumor (lol)3 Kommentare

Moin, Die IoT-Manie hat weitere Opfer gefunden. Ein Casino-Leck durch ein smartes Aquarium: Allerdings haben sie kein Wasser, sondern ...

Router & Routing

Olle Fritzbox 7270 mit VPN und SIP-Telefonie hinter O2 Homebox 6641 als "Modem"

Erfahrungsbericht von the-buccaneer vor 13 StundenRouter & Routing3 Kommentare

Nun war es soweit: Auch O2 hat mich mit VOIP zwangsbeglückt. Heute am Privatanschluss, in 2 Wochen ist das ...

Sicherheit

Ungepatchte Remote Code Execution-Lücke in LG NAS

Information von kgborn vor 1 TagSicherheit

Nutzt wer LG NAS-Einheiten? In den NAS-Einheiten der LG Network Storage-Einheiten gibt es eine sehr unschöne Schwachstelle, die einen ...

Windows Update

Neue Version KB4099950 NIC Einstellungen gehen verloren

Information von sabines vor 1 TagWindows Update2 Kommentare

Es ist eine neue Version des KB4099950 verfügbar, die das Problem mit den verlorenen Netzwerkeinstellungen lösen soll. Das Datum ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
OpenVPN Client Fehlermeldungen
Frage von chris84LAN, WAN, Wireless15 Kommentare

Hallo Zusammen, wir nutzen seit kurzem einen neuen Router und den OpenVPN Client. Die VPN Verbindung klappt; allerdings kommen ...

Sonstige Systeme
Wie Normenkataloge im Unternehmen bereit stellen?
Frage von MuzzepuckelSonstige Systeme14 Kommentare

Hallo Kollegen, ich lese schon lange hier mit, nun mein ersrer Beitrag, bzw. Frage. :-) Wir benötigen für unsere ...

Sicherheit
Verbindliche Zustellung per E-Mail?
Frage von ahussainSicherheit14 Kommentare

Hallo allerseits, ein Kunde von mir nutzt intensiv Fax. Hauptgrund: zusammen mit einer Empfangsbestätigung ist eine verbindliche Zustellung gewährleistet. ...

SAN, NAS, DAS
Entscheidung SAN Dell oder HP
Frage von VincorSAN, NAS, DAS13 Kommentare

Hallo, wir wollen uns für unsere Hyper V Umgebung eine neue SAN Anschaffen. Es laufen 30 VM's darunter, DC; ...