Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

DNS Problem bei Backbone und Intranet

Mitglied: leuaner

leuaner (Level 1) - Jetzt verbinden

22.02.2008, aktualisiert 26.02.2008, 3289 Aufrufe, 2 Kommentare

Wie muss der DNS-Server richtig konfiguriert werden bei Verwendung eines
LANs und eines Backbones?

Hallo,

Wir haben ein Problem, welches schon seit einiger Zeit für Probleme im Netz sorgt:

Wir haben ein LAN mit dem IP-Range 10.x.x.x
An diesem LAN hängen unsere Clients und Server (auch Terminalserver).
Ein Server (DC) ist dabei Domainencontroller, DNS-Server und WINS-Server in einem.
Es gibt auch noch einen zweiten Server mit gleicher Funktionalität, der ebenfalls
die drei Funktionen beinhaltet und als Backup dient.

Nun hat das LAN nur 100 MBit, daher haben wir auch noch ein Backbone mit
dem IP-Range 192.168.6.x, welches NUR die Server alle über eine zweite
Netzwerkkarte mittels eines Switches verbindet, dieses Netz hat 1 GBit.

Auf dem DNS-Server haben wir 2 Forward-Lookupzonen eingerichtet:

firma.de:
Router 10.0.0.1
DC1 10.0.0.2
DC2 10.0.0.3
TS1 10.0.0.4
TS2 10.0.0.5
AnwSrv 10.0.0.6
Client1 10.0.0.7
Client2 10.0.0.8
usw.

giga.firma.de:
DC1 192.168.6.2
DC2 192.168.6.3
TS1 192.168.6.4
TS2 192.168.6.5
AnwSrv 192.168.6.6

Die Server stehen also in beiden Zonen mit gleichem Namen aber unterschiedlichen
IPs drin. Die Eintragungen im WINS-Server sind analog.

Ziel ist es, dass die Clients bei DNS/WINS-Anfragen eine Antwort aus Ihrem
Range bekommen sollen (10.x), während die Server auf die gleichen Anfragen
eine Antwort 192.168.6.x bekommen sollen.

Möchte ein Client also auf den TS1, dann sollte der DNS-Server 10.0.0.4 zurückliefern.
Möchte der TS1 aber auf den AnwSrv, dann sollte die Antwort 192.168.6.6 lauten.

Das Problem ist nun, dass auf Client-Anfragen manchmal eine Antwort aus der
192.168.6.x- Bereich geliefert wird, die dann vom Client aus nicht erreichbar ist.


Frage: Wie löst man dieses Problem? Wie müssten die Zonen auf dem DNS-Server
eingerichtet werden? Wie müssten die IP-Einstellungen der Netzwerkkarten der
Clients, der Server zum LAN hin und der Server zum Backbone hin konfiguriert werden?
Können die gleichen Namen in beiden Zonen überhaupt verwendet werden oder
müssen die Server zum Giganetz hin andere Namen haben?

Gruß,
Leuaner
Mitglied: leuaner
22.02.2008 um 10:59 Uhr
Ich wollte noch was anfügen:

Ich habe mal von einem Client aus nslookup aufgerufen.
Bei der Abfrage von TS1 bekomme ich: 10.0.0.4, 192.168.6.4
Bei der Abfrage von TS1.giga.firma.de bekomme ich: 192.168.6.4
Bei der Abfrage von TS1.firma.de bekomme ich: 10.0.0.4, 192.168.6.4

Vor allem die letzte Abfrage wundert mich, warum wird mir hier auch die
Giganetz-IP zurückgeliefert? Was müsste ich ändern, damit man nur
die IP 10.0.0.4 bei der Abfrage vom Client aus bekommt?
Bitte warten ..
Mitglied: user01
26.02.2008 um 14:57 Uhr
So ich bin mir nicht sicher wie man das eigentlich konfigurieren sollte aber ich denke du hast in jedem Server nur 1 Netzwerkkarte? und die Server sind eigentlich auch in der AD Domäne firma.de - welches wir hier böserweise verwenden.

Auf dem Server bei den eigenschaften der Lan Verbindung - TPC/IP - Erweitert - DNS ist unten ein hacken gesetzt - Adressen dieser verbindung im DNS registrieren.

Tja so kommen denke ich die adressen auch in die forward lookup zone firma.de und werden dann zurückgegeben.

wenn das so ist sollten sie auch in der entsprechenden zone im dns eingetragen sein - also einfach 2 A Records für den jeweiligen server unter firma.de und 1 A Record unter giga.firma.de

LG, Thomas
Bitte warten ..
Ähnliche Inhalte
Windows Netzwerk

Problem beim aufrufen von Intranet Seiten

gelöst Frage von dwestermannWindows Netzwerk30 Kommentare

Hallo Kollegen, ich habe heute ein kleines Problem. Und zwar hat eine Kollegin schon seid längerer Zeit sporadisch Probleme ...

DNS

Subdomain für Intranet Webserver oder DNS Eintrag - Umsetzung?

gelöst Frage von derinderinderinDNS4 Kommentare

Hallo Zusammen, Wir haben im Intranet einen Webserver. Beispiel 192.168.1.20 Diesen kann ich natürlich über den Webbrowser erreichen. Auf ...

DNS

DNS Problem im VLAN

Frage von momaiDNS7 Kommentare

Hallo, ich habe ein kleines DNS Problem im VLAN. Folgende Konstellation. Das DNS sollte eigentlich der RVS4000 machen unter ...

DNS

Eigenartiges DNS-Problem

gelöst Frage von keine-ahnungDNS5 Kommentare

Moin, komische Dinge passieren bei mir :-) Folgendes setup: Heimnetzwerk > Arbeitsgruppe > Router Fritzbox 6842 (aktuelle firmware) > ...

Neue Wissensbeiträge
Backup

2016 - Restore mit WBAdmin - iSCSI Device als Sicherungsziel

Erfahrungsbericht von Henere vor 2 TagenBackup1 Kommentar

Servus zusammen, was mich eben einige graue Haare gekostet hat Server 2016. Ich habe meinem Server eine weitere M2 ...

Humor (lol)
(Part num your Hacked phone. +XX XXXXXX5200)
Erfahrungsbericht von Henere vor 4 TagenHumor (lol)10 Kommentare

Mein Handy hat aber ne ganz andere Endnummer. Muss ich mir jetzt Sorgen machen ? :-) Vielleicht betrifft es ...

Exchange Server

Letztes Update für Exchange 2016 CU9 war in gewisser Weise destruktiv

Erfahrungsbericht von DerWoWusste vor 4 TagenExchange Server9 Kommentare

Kurzer Erfahrungsbericht zu Exchange2016-KB4340731-x64 Der Exchangeserver hat wie gewöhnlich versucht, es in der Nacht automatisch zu installieren - abgesehen ...

Erkennung und -Abwehr

Neue Sicherheitslücke Foreshadow (L1TF) gefährdet fast alle Intel-Prozessoren

Information von Frank vor 5 TagenErkennung und -Abwehr3 Kommentare

Eine neue Sicherheitslücke, genannt Foreshadow (alias L1TF) wurde auf der Usenix Security 18 von einem Team internationaler Experten veröffentlicht. ...

Heiß diskutierte Inhalte
E-Mail
Deutsche e-Mail Adresse auf iPhone in Katar. Nur Probleme
gelöst Frage von vanTastE-Mail32 Kommentare

Moin, ich habe hier in Deutschland auf einem Exchange 2013 eine e-Mail Adresse (name@domain.de) für einen Kollegen in Katar ...

Windows Server
Domäne beitreten nicht möglich, unter VMWare windows Server 2016 Core
Frage von AmanuelWindows Server19 Kommentare

Ich habe auf meinem Mac unter VMWare Windows Server 2016 Core und Windows Server 2016 Desktopversion installiert. Beide Systeme ...

Windows Server
Server verliert Dateien und Ordner
gelöst Frage von routeserverWindows Server18 Kommentare

Hallo Freunde, ich habe hier ein Problem, das mich an meine Grenzen treibt und ich würde gerne wissen, ob ...

Windows Tools
User Self Service und Client Management
Frage von OrkansonWindows Tools14 Kommentare

Hallo zusammen, ich hab ein paar verschiedene Fragen: 1. Was benutzt ihr um Software im Unternehmen zu verteilen? 2. ...