Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Excel-SUMMEWENN mit bedingter Multiplikation

Mitglied: immobrauch

immobrauch (Level 1) - Jetzt verbinden

10.01.2010 um 11:11 Uhr, 18342 Aufrufe, 4 Kommentare

Excel 2003 SP3

Hallo zusammen,

ich möchte den aktuellen Warenbestandswert EK-Netto auf einem separaten
Sheet auslesen.

In der Tabelle gibt es u. a. 2 Blätter "Hardware" und "Auswertung". Die
gesuchte Formel soll in "Auswertung" stehen und Berechnungen aus "Hardware"
durchführen.

X:X in "Hardware" zeigt den aktuellen Warenbestand (Stückzahl)
AB:AB in "Hardware" zeigt den EK-Netto/Stück

Formel A

=SUMMEWENN(Hardware!X:X;">0";Hardware!AB:AB)

summiert mir richtig die Spalte AB:AB in "Hardware", ohne allerdings den
EK-Netto/Stück mit dem Warenbestand in X:X zu multiplizieren.

Formel B

=WENN(Hardware!X:X>0; Hardware!X:X*Hardware!AB:AB) multipliziert zwar,
allerdings immer nur Zeile für Zeile.

In Formel B taucht der Artikel XYZ nur 1x auf. Wenn der Warenwert/EK € 20,00
ist, werden auch nur die € 20,00 berechnet. Habe ich den Artikel 3x im Laden,
muss hier aber mit € 60,00 gerechnet werden, also mit 3 multipliziert werden.

Ich möchte nun Formel A so anpassen, dass mir mehrfach vorhandene Waren in
der Gesamtsumme wie in Formel B berücksichtigt.


Wer weiß hierzu Rat?

--
Immo Brauch
Mitglied: bastla
10.01.2010 um 13:56 Uhr
Hallo immobrauch!

Dazu benötigst Du die folgende Array-Formel:
{=SUMME(WENN(Hardware!X:X>0; Hardware!X:X*Hardware!AB:AB;0))}
Die geschwungenen Klammern "{" und "}" an Beginn und Ende der Formel sind dabei nicht einzugeben, sondern werden von Excel zur Kennzeichnung der Formel als "Array-Formel" gesetzt. Die Eingabe muss (auch nach jeder Bearbeitung / Änderung der Formel) mit der Tastenkombination "Strg + Umsch + Eingabe" abgeschlossen werden.

Anmerkung: Soferne es keine negativen Mengen zu berücksichtigen gibt, könnte das "WENN" auch entfallen (die Multiplikation mit der Menge 0 führt automatisch auch zu einem Wert 0):
{=SUMME(Hardware!X:X*Hardware!AB:AB)}
Grüße
bastla
Bitte warten ..
Mitglied: immobrauch
10.01.2010 um 18:48 Uhr
Hallo Bastla,

das Ergebnis = #ZAHL!

Ich habs mittlerweile gelöst mit SUMMENPRODUKT, wobei ich in XL 2003 keine ganzen Spalten AB:AB, sondern nur Bereiche AB2:AB5000 eingeben kann.

Deine Lösung wäre komfortabler, da sie nicht mehr angepasst werden muss, funktioniert bei mir aber leider nicht.

Mit der Tastenkombination "Strg + Umsch + Eingabe" habe ich abgeschlossen und die geschweiften Klammern auch weggelassen.

Immo Brauch
Bitte warten ..
Mitglied: bastla
10.01.2010 um 20:09 Uhr
Hallo immobrauch!

Sorry - hatte mal wieder vergessen, dass auch für die Array-Formel die Angabe der gesamten Spalten nicht funktioniert (womit auch der vermeintliche Vorteil sich schon wieder erledigt hätte) ...

Mit
{=SUMME(Hardware!X2:X500*Hardware!AB2:AB5000)}
sollte es geklappt haben, wobei allerdings für die Version ohne "WENN()" tatsächlich "SUMMENPRODUKT()" die bessere Alternative darstellt. Für den Fall, dass tatsächlich einmal eine Bedingung erforderlich wäre, könntest Du aber die erste "Array"-Version von oben verwenden.

Grüße
bastla
Bitte warten ..
Mitglied: immobrauch
10.01.2010 um 20:18 Uhr
Hallo Bastla,

funktioniert! *freu* Merci vielmals.

Immo Brauch
Bitte warten ..
Ähnliche Inhalte
Microsoft Office
Bedingte Formatierung in Excel 2016
gelöst Frage von DarkMoonMicrosoft Office8 Kommentare

Hallo zusammen, ich scheitere zur Zeit an der Bedingten Formatierung in Excel. Es soll, wenn ich in der "Ja" ...

Microsoft Office
Bedingte Formatierung in Excel 2010
gelöst Frage von killtecMicrosoft Office10 Kommentare

Hallo, ich möchte in Excel 2010 eine Bedingte Formatierung anlegen, die etwas komplexer ist. Ich habe einen Wert z.B. ...

Microsoft Office
Excel bedingte Formatierung
Frage von 103148Microsoft Office3 Kommentare

Hallo, ich berechne das Alter von Computern aus dem Liefer Datum ( K181 ) K181 L181 M181 28.02.2013 3 Alter: 1 ...

Microsoft Office

Bedingte Formatierung in Excel für verschiedene Dezimalstellen

gelöst Frage von wingetMicrosoft Office6 Kommentare

Hallo zusammen, ich suche die Möglichkeit durch "Bedingte Formatierung" in Excel verschiedene Dezimalstellen durch verschiedene Farben (die Zelle soll ...

Neue Wissensbeiträge
Sicherheit
Sicherheitsrisiko: Die Krux mit 7-Zip
Information von kgborn vor 2 StundenSicherheit

Bei vielen Anwendern ist das Tool 7-Zip zum Entpacken von Archivdateien im Einsatz. Die Software ist kostenlos und steht ...

Internet

Datendealing im WWW Tracking Methoden immer brutaler

Information von sabines vor 12 StundenInternet

Interessanter Artikel zum Thema Tracking im WWW und die immer "besseren" Methoden des Trackings. Professor Arvind Narayanan (Princeton-Universität) betreibt ...

Erkennung und -Abwehr

Ups: Einfaches Nullzeichen hebelte den Anti-Malware-Schutzt in Windows 10 aus

Information von kgborn vor 1 TagErkennung und -Abwehr

Windows 10 ist das sicherste Windows aller Zeiten, wie Microsoft betont. Insidern ist aber klar, das es da Lücken, ...

Windows 10

Windows 10 on ARM: von Microsoft entfernte Info - Klartext, was nicht geht

Information von kgborn vor 1 TagWindows 10

Windows 10 on ARM ist ja eine neue Variante, die Microsoft im Verbund mit Geräteherstellern am Markt etablieren will. ...

Heiß diskutierte Inhalte
Server
Route-Befehl Unterstützung (unter CMD)
gelöst Frage von FKRR56Server36 Kommentare

Guten Tag , i.M. habe ich Probleme über den CMD-Route-Befehl ein Routing auf einen entfernten Server zuzulassen. Der Server ...

Windows 10
Windows 10 (1709) Tastur und Maus wieder einschalten?
Frage von LochkartenstanzerWindows 1028 Kommentare

Moin, Ich habe von einem Kunden einen Win10-Rechner bekommen, bei dem weder Tastatur noch Maus geht. Die Hardware funktioniert ...

Microsoft
TV-Tipp: Das Microsoft-Dilemma
Information von kgbornMicrosoft17 Kommentare

Aktuell gibt es in Behörden und in Firmen eine fatale Abhängigkeit von Microsoft und dessen Produkten. Planlos agieren die ...

Webbrowser
Welcher Browser ist der Beste?
Frage von justtinWebbrowser15 Kommentare

Hallo Leute Ich habe eine interessante Frage. Mich wurde mal interessieren welcher Browser ist eure meinung nach der beste? ...