Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Excelabfrage vergleich von werten über mehrer zeilen ob die werte dort auftauchen

Mitglied: chakakan

chakakan (Level 1) - Jetzt verbinden

10.12.2010, aktualisiert 14:16 Uhr, 10974 Aufrufe, 4 Kommentare

Hallo ExcelCracks,

ich hänge grad an einem, für mich, sehr großen Problem.

Auszug aus der Tabelle, das sind Vorwahlen (siehe Bild )
f82255521d1d83f65698b9e6199c9d15 - Klicke auf das Bild, um es zu vergrößern

Nun zu meinem Problem.

Ich möchte das mir excel Spalte für Spalte vergleicht. 1 Spalte mit 2,3,4,5, ... dann 2 Spalte mit 1,3,4,5,.... dann 3 Spalte mit 1,2,4,5,6.. .....
und mir markiert ob ein wert aus spalte 1 in spalte 2, 3,4,5, .... -für jede spalte dann entsprechend- doppelt ist.

Ist sowas möglich ??

Danke schon mal für den eingesetzten Hirnschmalz ^^


Gruß Chaka
Mitglied: Biber
10.12.2010 um 18:23 Uhr
Moin chakakan,

Rückfragen:
? Was stellst du dir unter einer Markierung vor? Alle Werte in Rot, die nicht unique je Zeile sind?
? Würdest du wirklich so wie oben beschrieben vorgehen wollen..
Ich möchte das mir excel Spalte für Spalte vergleicht. 1 Spalte mit 2,3,4,5, ... dann 2 Spalte mit 1,3,4,5,.... dann 3 Spalte mit 1,2,4,5,6..
... beispielsweise wenn du den Job von Excel hättest?
Ich meine, Excel hat nur Funktionen, die Strategie solltest du schon planen..

Teilantwort:
Ist sowas möglich ??
Ich denke ja.
Aber wozu werden Beiträge immer mit solchen Kasperfüllseln angereichert?
Hattest du schon mal so eine Teilfrage in der Führerscheinprüfung oder der Matheklausur?
Wenn ja, wieviel Punkte brachte die richtige Antwort?

Grüße
Biber
Bitte warten ..
Mitglied: mathe172
10.12.2010 um 18:30 Uhr
Edit: Gelöscht, da ich Beitrag über mir nicht sah
P.S.:Könnte ich den Beitrag auch ganz löschen?
Bitte warten ..
Mitglied: mathe172
10.12.2010 um 18:56 Uhr
Hallo chakakan!

Ich hab jetzt mal eine Möglichkeit:
01.
"=WENN(ZÄHLENWENN(Suchbereich;"=" & Zu_überprüfende_Zelle)-ZÄHLENWENN(Spalte;"=" & Zu_überprüfende_Zelle)>0;"Vorhanden";"Nicht Vorhanden")"
Diese Formel in irgend eine LEERE Zelle (z.B. an die gleiche Stelle im zweiten Blatt, dann aber "TABELLENAME!" VOR DIE ENTSPRECHENDEN BEZÜGE SETZEN), und abändern
Um z.B. die Zelle A1 überprüft werden soll, dann sollte die Formel so aussehen:
01.
=WENN(ZÄHLENWENN($A:$J;"=" & A3)-ZÄHLENWENN(A:A;"=" & A3)>0;"Vorhanden";"Nicht Vorhanden")
Strategie: Zähle alle Wertvorkommen, und ziehe eigene Spalte ab.
Diese Formel könnte man dann "rüber-" und "runterziehen". So erhält man eine zweite Tabelle, in der man für jede Zelle sieht, ob der Wert in einer anderen Spalte steht.
Nun kan man in der Zeile über der Ersten Tabelle folgende Formel einsetzen:
01.
"=Wenn(Zählenwenn(Spalte_in_Zweittabelle;"Vorhanden")>0;"Doppelt";"Nicht doppelt")"
Umgeändert auf die Zelle A2, und die Zweittabelle im zweiten Arbeitsblatt an derselben Stelle steht:
01.
=Wenn(Zählenwenn(Tabelle2!A:A;"Vorhanden")>0;"Doppelt";"Nicht doppelt")
Diese Zeile kann man nun "bedingt Formatieren"

Mathe172
Bitte warten ..
Mitglied: Biber
11.12.2010 um 01:00 Uhr
Moin Mathe172,

jepp, auch ein gut nachvollziehbarer Ansatz.

Ich würde, da ich so meine Befürchtungen bezüglich der Anzahl der Zeilen habe, etwas vorsichtiger herangehen.

Was auch ein guter alter Ein-Kern-Prozessor noch flott schafft bei ein paar tausend Zeilen ist doch,
bei bekanntermaßen "nur" 9 Spalten eben mal festzustellen, wie viele unterschiedliche Werte in den 9 Spalten sind.
Sind es 9 -> habe ich keine Dubletten und mein Prozessor somit nothing more to do.
Nur bei Zeilen, die weniger unterschiedliche Werte haben, kann ich dann (wenn die biooptische Analyse nicht ausreicht) dann meinetwegen mit Formeln und bedingter Formatierung und Clonetabelle auch für PISA-Abiturienten erkennbar aufbrezeln.

Die Ermittlung der Unterschiedlichen Werte meinetwegen in einer Hilfsspalte rechts neben den Daten ist nix als Mathe 6. Klasse (oder heisst es in der 6.Klasse noch "Rechnen"?):
{=SUMME(1/ZÄHLENWENN(A3:J3;A3:J3))}
als Matrixformel z.B. in Zelle L3 eingeben OHNE geschweifte Klammern mit Strg-Shift-Enter und runterziehkopieren.

Ist ja nichts weiter als der die Summe der Kehrwerte der Vorkommnisse der Werte.
Handlungsbedarf nur wenn ungleich 9.

Ohne Matrixformel-Eingabehandgriffe:
=SUMME((HÄUFIGKEIT(3:3;3:3)>0)*1)

..wieder in Zelle L3 zur Berechnung der Zeile 3 und abwärtsdraggen.

Grüße
Biber

P.S. @mathe172
Deinen ersten (zurückgezogenen) Kommentar kannst du nicht selbst löschen. Muss ein netter Moderator machen oder ersatzweise ich.
Bitte warten ..
Ähnliche Inhalte
Microsoft Office

Excel: Wert aus mehreren Zeilen vergleichen

gelöst Frage von NicolaasMicrosoft Office2 Kommentare

Hallo zusammen, ich würde mir gerne eine Auswertung mit Excel erstellen. Ich habe leider gerade keine Idee mit welcher ...

Microsoft Office

Wert aus einer Spalte mit Werten in einer Spalten vergleiche, wenn Wert vorhanden, dann Wert aus der dritten Spalte in der selben Zeile ausgeben, verschiedene Tabellenblätter

gelöst Frage von DevilioMicrosoft Office5 Kommentare

Hallo Zusammen, ich habe folgendes Problem und finde keine Lösung. Ich habe 2 Tabellenblätter mit folgenden Daten: Tabelle 1: ...

Microsoft Office

Excel Werte vergleichen

Frage von 103148Microsoft Office5 Kommentare

Hallo, ich habe eine Liste ( ca. 200 Einträge ) mit Kistengröße wie folgt: Länge, Breite, Höhe daneben wird ...

Batch & Shell

Powershell: Wert aus Registry auslesen und mit vorhandenem Wert vergleichen

gelöst Frage von BrowserlauserBatch & Shell5 Kommentare

Hallo, ich stehe vor folgendem Problem: Ich möchte per Powershell aus der Registry einen bestimmten Wert auslesen. Beispiel: in ...

Neue Wissensbeiträge
Humor (lol)

WhatsApp-Nachrichten endlich auch per Bluetooth versendbar

Information von BassFishFox vor 8 StundenHumor (lol)1 Kommentar

Genau darauf habe ich gewartet! ;-) Der beliebte Messaging-Dienst WhatsApp erhält eine praktische neue Funktion: Ab dem nächsten Update ...

Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 20 StundenGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Sicherheit

Intel gibt neue Spectre V2-Microcode-Updates frei (20.02.2018)

Information von kgborn vor 21 StundenSicherheit

Intel hat zum 20. Februar 2018 weitere Microcode-Updates für OEMs freigegeben, um Systeme mit neueren Prozessoren gegen die Spectre ...

Microsoft
ARD-Doku - Das Microsoft Dilemma
Tipp von Knorkator vor 1 TagMicrosoft3 Kommentare

Hallo zusammen, vor einigen Tagen lief in der ARD u.a. Reportage. Das Youtube Video dazu dürfte länger verfügbar sein. ...

Heiß diskutierte Inhalte
Windows Server
AD DS findet Domäne nicht, behebbar?
Frage von schapitzWindows Server40 Kommentare

Guten Tag, ich habe bei einem Kunden ein Problem mit den AD DS. Umgebung ist folgende: Windows Server 2016 ...

Router & Routing
LANCOM VPN CLIENT einrichten
Frage von Finchen961988Router & Routing27 Kommentare

Hallo, ich habe ein Problem und hoffe ihr könnt mir helfen, wir haben einen Kunden der hat einen Speedport ...

Router & Routing
ISC DHCP 2 Subnetze
gelöst Frage von janosch12Router & Routing19 Kommentare

Hallo, ich betreibe bei mir im Netzwerk einen ISC DHCP Server auf Debian, der DHCP verwaltet aktuell ein /24 ...

Switche und Hubs
Cisco SG350X-48 AdminIP in anderes VLAN
Frage von lcer00Switche und Hubs14 Kommentare

Hallo zusammen, ich habe ein Problem mir einem Cisco SG350X-48 bei der Erstinstallation wurde eine IP 192.168.0.254 (Default VLAN ...