Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Exchange 2007 ActiveSync Server einrichten

Mitglied: Ghostraider

Ghostraider (Level 1) - Jetzt verbinden

26.02.2010, aktualisiert 01.03.2010, 16900 Aufrufe, 11 Kommentare

Hallo Leute,

ich versuche jetzt schon seit einigen Wochen verzweifelt meinen Exchange 2007 so zu konfigurieren das sich mein MDA (HTC HD2 WM6.5) per UMTS/GRPS mit dem Exchange verbindet und Mails/Kontakte/Kalender syncht.
Meine Umgebung sieht so aus:

Windows Server 2008 SP2
-AD mit Domäne
-DHCP
-DNS
-IIS
-Zertifikatstelle

Exchange 2007 SP2
-Mails werden von POP3 Konten abgeholt und dann lokal verteilt.

Bisher läuft alles so wie Ich möchte, habe eine Domäne mit 3 Clients, auf allen läuft Outlook mit anbindung an den Exchange.
Von Unterwegs kann Ich über OWA auch auf die Mails zugreifen, funktioniert auch Problemlos.

Ich möchte jetzt aber noch das der MDA sich auch auf den Server verbindet und die Mails etc. dann synchronisiert.
Hab schon etliche HowTo von MSXFAQ.DE durch probiert. Bisher war alles erfolglos.

Der aktuelle Stand ist der das Ich weder mit noch ohne SSL den MDA synchronisieren kann.
Wenn Ich das versuche (mit SSL) erhalten Ich den Fehlercode: 0x80072F17 auf dem MDA.
Ich weiß im moment einfach nicht wo und wie Ich weiter machen soll.
Muss man den den Exchange 2007 konfigurieren damit er überhaupt ActiveSync fähig wird ? Mein Benutzer hat bereits im Exchange die Berechtigung bekommen um AS zu machen.
Aber muss man da sonst noch was machen?

Ich hoffe Ihr könnt mir helfen, den langsam bin Ich wirklich am verzweifeln und sehe wohl vor lauter Bäumen den Wald nicht mehr.

Gruß Torsten
Mitglied: 16409
26.02.2010 um 21:21 Uhr
Der Fehlercode 0x80072F17 besagt das es ein Problem mit dem Zertifikat gibt. Da es sich bei die vermutlich um ein self signed ertifikat handelt musst du das Zertifizierungsstellenzertifikat erst auf deinem MDA installieren.

Was passiert, wenn du testweise versuchst dich ohne SSL mit AS zu verbinden? Welcher Fehler kommt dann?
Bitte warten ..
Mitglied: Ghostraider
26.02.2010 um 21:48 Uhr
Hi,

richtig es ist ein self Signed Zertifikat das Ich erstelle habe. Hab auch schon versucht das Root-CA auf dem MDA zu Installieren, dieser verweigert aber immer die Installation.
Wenn Ich ohne SSL versuche zu Syncen dann meldet der MDA (Fehlercode hab Ich grade nicht zu Hand) das es Verbindungsproblem gab und Ich es zu einem späteren Zeitpunkt noch mal versuchen soll.
Ich kann aber ausschließen das es sich um ein Verbindungsproblem handelt den egal wann und wo (WLAN / UMTS / Edge) es funktioniert nicht.

Deshalb gehe Ich auch davon aus das noch etwas grundlegendes an meiner Konfiguration nicht stimmt.
Es wird vermutlich auch nicht funktionieren wenn Ich das Zertifikat Installiert bekomme. Ich denke Ich muss am Exchange oder am IIS noch irgend etwas konfigurieren bzw. einrichten.
Bitte warten ..
Mitglied: Alforno
27.02.2010 um 08:57 Uhr
Hallo Torsten,

ich kenne mich mit ActiveSync zwar nicht aus, aber mal so ins Blaue hinein.

Wie sieht es denn mit den Ports aus?
443 müsste ja sicherlich auf den Server weitergeleitet werden.
Welche Ports sind denn offen? OWA funktioniert ja.

Hast du mal probiert, dass Ganze im LAN zu testen?

MfG
Alforno
Bitte warten ..
Mitglied: 16409
27.02.2010 um 12:15 Uhr
Nach einer Standardinstallation und wenn du dem User die Berechtigung erteilt hast Active Sync zu nutzen, musst du in der Regel nichts mehr nach konfigurieren. EineVerbindung via HTTP sollte dann gehen. Bei HTTPS musst du wie gesagt erst das Zertifizierungsstellenzertifikat installieren.
Wie ist denn dein Exchangesystem aufgebaut. Alles auf einem Server, oder verschiedene? Hast du einen ISA Server vor dem Exchange oder sprichst du direkt den Client Access Server an?

Die Fehlermeldung bei HTTP könnte helfen, denn es gibt verschiedene Gründe für Verbindungsprobleme. und welches MDA nutzt du?
Bitte warten ..
Mitglied: Ghostraider
27.02.2010 um 16:17 Uhr
Hi Leute,

Ich hab gute Nachrichte *gg*
Hab seit Donnerstag ja meine HTC HD2. Nach dem Ich dann gestern Abend alles soweit eingerichtet hatte, dachte Ich probier Ichs halt nochmal.
Hab mir aber keine große Hoffnugn gemacht den mit dem alten Diamond II ging es nicht. Also warum sollte es mit dem HD2 gehen der hat ja die selbe Software, würde also garkein Sinn machen.

Hab dann das Root Zertifikat auf dem Handy Installiert, die Serververbindung konfiguriert und auf Synchronisieren geklickt.
Und auf einmal hat er angezeigt "Downloading". Naja Ich dachte vlt. ist die Status anzeige fehlerhat. Als er dann aber anzeigte "Mails 0/45" war Ich doch etwas verwirrt.
Der HD2 hat dann also tatsächlich die Mails vom Exchange abgerufen. Zu diesem Zeitpunkt war Ich über WLAN direkt im Netz. Ich hab dann das WLAN ausgeschaltet und noch mal Synchronisiert, das ging auch.
Ab da war Ich dann komplett verwirrt :D

Es sieht jetzt im moment so aus, das Ich manuell Synchronisieren kann, Mails, Kalender, Kontakte, Aufgaben, geht ohne Probleme. Aber der Push Service funktioniert nicht. Ich hab im Zeitplan eingestellt das in der Hauptzeit (Mo-So 8.00Uhr - 20Uhr) bei Elementeingang Synchronisiert werden soll. Das müsste ja dann bedeuten wenn auf dem Exchange eine neue eMail eingeht, das Ich die dann auf das Handy gepusht bekomme. Im Handy ist die Verbindung übrigens als SSL Verbindung eingerichtet. Ohne SSL hab Ich bis jetzt noch nicht versucht.

Ich denke aber das geht nicht weil er mir im Statusbericht noch immer anzeigt das es einen Zertifikatsfehler gibt:

Ergebnis:
Das Sicherheitszertifikat auf dem Server ist ungültig. Bitten Sie den Exchange-Server-Administrator oder Ihren Internetdienstanbieter, ein gültiges Sicherheitszertifikat auf dem Server zu installieren. Unterstützungscode: 0x80072F06.

Ich hab mit Hilfe dieser Anleitung (http://www.msxfaq.de/howto/e2k7ssl.htm) das Zertifikat für den Exchange erstellt, und das scheint auch funktioniert zu haben.

@16409:
Also bei mir läuft alles auf einem Server. Einen ISA Server habe Ich nicht im einsatz, es geht direktauf den Client Access Server.
MDA ist ein HTC HD2 mit T-Mobile Branding.

@Alforno:
443TCP ist auf den Exchange Server geforwardet.
OWA Funktioniert ohne Probleme ja, außer das der IE auch meldet das es kein Vertrauenswürdiges Zertifikat ist, da es ja aber ein SelfSigned Zertifikat ist wird sich das wohl nicht vermeiden lassen.

Wenn es jetzt noch funktionieren würde das Ich die Mails gepusht bekomme dann bin Ich richtig Glücklich. Vielleicht bekommen wir das ja noch hin, wäre ein super Geburtstagsgeschenk, den am Montag hab Ich Geburtstag *gg*

Gruß Torsten
Bitte warten ..
Mitglied: 16409
28.02.2010 um 10:54 Uhr
Hallo Torsten,

das Problem mit dem Diamon II kenn ich. Das ist das einzige MDA, welches ich auch mit meinem Active Sync nicht verbunden bekomme.

Hast du die Push Funktion auch im WLAN getestet? Ich habe neben 443 noch weitere Ports weitergeleitet. Hier http://support.microsoft.com/kb/259369 mal eine Auflistung von MS über AS Ports.
Bitte warten ..
Mitglied: Ghostraider
01.03.2010 um 12:49 Uhr
Hi uemmel,

danke für den Link die Ports hab Ich alle mal freigegeben.
Ja die Push funktion hab Ich auch über WLAN getestet, hat allerdings auch nicht funktioniert.

Ich hab jetzt aber ein ganz anderes Problem.
Seit gestern mittag synchronisiert er nicht mehr. Der MDA meldet das nicht genug Speicher frei ist.

Ergebnis:
Nicht genügend Speicher auf dem Gerät vorhanden. Beenden Sie alle zurzeit ausgeführten Programm um Speicher freizugeben, oder starten Sie das Gerät neu.
Unterstüzungscode: 0x8007000E

Ich versteh nicht wie der MDA auf diese Meldung kommt. Ich hab aktuell 190MB freien RAM und 75MB freie Speicher um Anwendungen zu Installieren.
Das sollte doch mehr als genug sein. Hab auch schon mehrer Softresets gemacht und mit CleanRAM den Speicher aufgeräumt. Hat aber leider alles nichts gebracht.

Im Netz haben Ich einen Hinweiß gefunden das es an einen Termin liegen kann der zu viele Teilnehmer hat, oder an einer eMail mit großem Anhang.
Ich hab dann mal eingestellt das er nur Aufgaben Synchronisieren soll. Das wären aktuell 3 Stück. Das macht er aber auch nicht.

Von daher gehe Ich davon aus das es nichts mit dem Speicher zu tun hat. Sondern das irgend etwas anderes faul ist.

EDIT:
Noch als kleiner Hinweiß. Mir ist grade eingefallen. Das letzte mal als Ich Synchronisiert habe, hab Ich eine 1,2MB große eMail verschickt. (Erfolgreich)
Vermutlich hängt diese eMail noch irgendwo im System. Den seit die Mail raus ist geht nichts mehr. Ich hab aber schon mehrfach die Mails auf dem PDA gelöscht.

Torsten
Bitte warten ..
Mitglied: Ghostraider
01.03.2010 um 16:31 Uhr
Ich nochmal.
Hab jetzt einen Hardreset durchgeführt. Jetzt funktioniert das Synchronisieren wieder.
Allerdings immer noch mit dem alten Fehler das ein Zertifikat auf dem Exchange Server nicht stimmt.
Kann man den das Zertifikat auf dem Exchange irgendwie überprüfen ob es stimmt?

Push Funktion geht übrigens immer noch nicht.
Bitte warten ..
Mitglied: 16409
01.03.2010 um 20:52 Uhr
Welches Zertifikat stimmt auf dem Server nicht?

Versuch das mal http://www.msexchangefaq.de/mobil/eas.htm den activeSync Tester.
Bitte warten ..
Mitglied: Ghostraider
02.03.2010 um 12:17 Uhr
Hi uemmel,

hab den ActiveSync Tester mal laufen lassen. Hier das Ergebniss:

Testing xxx.dyndns.info (SSL, On LAN):

Communications:
Doing DNS lookup on xxx.dyndns.info OK (84.159.xxx.xxx)
Testing TCP to 84.159.xxx.xxx port 443 ... OK
SSL Certificate:
Receiving ................................ OK
Ensuring not Self-Signed ................. OK
Verifying certificate .................... FAIL
ActiveSync:
Checking for application ................. OK
Checking version ......................... OK (8.2)
Checking protocols ....................... OK (1.0,2.0,2.1,2.5,12.0,12.1)
User Permissions:
Checking "Home/Torsten" .................. FAIL

Was mich wundert, das er sagt das mein Benutzer falsch wäre.
Ich habe nur zwei Benutzer auf dem Exhcange und im AD. Einmal der Administrator und dann noch mein Benutzer.

Ich habe zusätzlich noch den Exchange Connectivity Test von Microsoft gemacht:


Testing Exchange ActiveSync
Exchange ActiveSync test Failed

Test Steps

Attempting to resolve the host name XXX.dyndns.info in DNS.
Host successfully resolved

Additional Details
IP(s) returned: 84.159.XXX.XXX
Testing TCP Port 443 on host XXX.dyndns.info to ensure it is listening and open.
The port was opened successfully.
Testing SSL Certificate for validity.
The SSL Certificate failed one or more certificate validation checks.

Test Steps

Validating certificate name
Successfully validated the certificate name

Additional Details
Found hostname flynetwork.dyndns.info in Certificate Subject Common name
Validating certificate trust for Windows Mobile Devices
Certificate trust validation failed

Additional Details
Certificate chain could not be built. You may be missing required intermediate certificates, See KB 927465 for more details.

Gruß Torsten
Bitte warten ..
Mitglied: Ghostraider
07.03.2010 um 23:39 Uhr
Hi,

das mit den Zertifikaten klappt immer noch nicht.
Ich hab in zwischen das Exchange Zerfifikat komplett neu erstell hat auch nichts gebracht.

Mittler weile ist es mir auch egal. Mich nervt nur das der Push Service nicht funktioniert. Gibt es da irgendwelche Lösungsansätze um dem fehler evtl. auf die spur zu kommen?

Dann wäre Ich nämlich schon glücklich.

MFG Torsten
Bitte warten ..
Ähnliche Inhalte
Exchange Server
Exchange Server 2013 + ActiveSync
Frage von Joannis71Exchange Server3 Kommentare

Hallo, wir haben einen Exchange Server 2013 und möchten ActiveSync für die Handys einrichten. Der Exchange Server soll nicht ...

Exchange Server

Problem mit ActiveSync Exchange Server 2003

Frage von addamainExchange Server

Hallo zusammen, ich habe ein Problem mit ActiveSync auf einem Exchange 2003. Das Problem ist folgendes: Android Handys funktionieren ...

Exchange Server

Wie Exchange ActiveSync ohne Zertifikat

gelöst Frage von 118041Exchange Server3 Kommentare

Ich versuche eine Verbindung vom Smartphone (Android 4.3) zu unsrem Exchange-Server herzustellen. Ein Zertifikat soll dabei NICHT verwendet werden. ...

Exchange Server

Exchange ActiveSync Android Synchronisierungsrechte

Frage von Marcel93Exchange Server

Hallo, folgendes Problem. Vorheriges Handy war ein iPhone wo die Mails per Exchange geladen wurden. Hat alles wunderbar geklappt. ...

Neue Wissensbeiträge
iOS
Updates für Iphone und Co
Information von sabines vor 3 MinuteniOS

Gestern abend ist iOS 11.3.1 erschienen, ein kleineres Update, dass einige Lücken schließt und "Lahmlegen" nach einem Display Tausch ...

Windows 7

Windows 7 - Server 2008 R2: Exploit für Total Meltdown verfügbar

Information von kgborn vor 1 TagWindows 7

Kleine Information für Administratoren, die für die Updates von Windows 7 SP1 und Windows Server 2008 R2 SP1 verantwortlich ...

Sicherheit

Zero Day-Schwachstelle im Internet Explorer - wird von APT bereits ausgenutzt

Information von kgborn vor 1 TagSicherheit

Im Kernel des Internet Explorer scheint es eine Zero Day-Lücke zu geben, die von staatlichen Akteuren (APT) im Rahmen ...

Microsoft
Folder Security Viewer-Lizenzen zu gewinnen
Information von kgborn vor 1 TagMicrosoft

Ich nehme das Thema mal in Absprache mit Frank hier auf, da es für den einen oder anderen Administrator ...

Heiß diskutierte Inhalte
C und C++
Frage1 C Programmierung-Makefile Frage2 PHP-Programmierung HTTP-Fehler 404
Frage von KatalinaC und C++27 Kommentare

Hallo, ich habe 2 Fragen, die nichts miteinander zu tun haben aber mit denen ich mich gerade beschäftige: 1. ...

Linux
Linux Server oder Windows Server - lohnt eine Umstellung auf Linux und ebenso basierende SW bei einer langfristigen Planung?
Frage von motus5Linux27 Kommentare

Wir brauchen bei uns einen neuen Server. Dieser wird als Fileserver, Domäne Controller sowie Exchange Server verwendet. Wir versuchen ...

LAN, WAN, Wireless
Watchguard T15 VPN Einrichtung
gelöst Frage von thomasjayLAN, WAN, Wireless22 Kommentare

Hallo zusammen, wir möchten gerne über unsere Watchguard T15 einen VPN-Tunnel (Mobile VPN with IPSec) einrichten! Als Client nutzen ...

DSL, VDSL
ISP Wechsel auf Vodefone Koax, Gebäudeverkabelung nur per Cat 7
gelöst Frage von wusa88DSL, VDSL19 Kommentare

Hallo Zusammen, ich bin momentan bei Mnet als Glasfaser Kunde und möchte Preis/Leistungs-Technisch zu Kabel Deutschland / Vodafone wechseln. ...