Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Exchange 2007 nimmt für bestimmte Domäne falschen MX-Record

Mitglied: DGI-SysAdm

DGI-SysAdm (Level 1) - Jetzt verbinden

11.12.2014 um 11:45 Uhr, 911 Aufrufe, 4 Kommentare

Liebe Gemeinde

Nun bin ich mit meinem Latein am Ende ...

Sachverhalt:
mail an "info@spezialdomain.de" (und nur hier gibt es Probleme) wird an den falschen MX-Record zugestellt

Details:
spezialdomain.de hat zwei MX-Einträge, einem mit Prio10 "mx10" und einem mit Prio20 "mx20" - wobei der der "mx20" nicht funktioniert (Mails verschwinden ins Nirwana - das ist aber nicht Thema der Frage!)
Beim Sender einer Mail müsste nun der Exchange die mx-Records der "sezialdomain.de" abfragen, den "mx10" prüfen, sehen dass er erreichbar ist und ihm die Mail zustellen.
Denkste ! Er beharrt auf dem "mx20".
Die Auflösung der MX-Record direkt auf dem Exchange ist "schön" ...
Der Exchange hat keine differenzierten SendeConnectoren o.ä. !

Was sich schon versucht habe:
- ipconfig /flushdns auf dem Exchange
- Zone für "spezialdomain.de" auf unserem DNS angelegt und dort den "mx10" als MX-Record eingetragen (Exchange löst "spezialdomain.de" auch wunderbar über unseren Server auf und sieht auch den (nun einzelnen) MX-Record "mx10")

Was ich nicht kann ...
... den Exchange mal kurz durchbooten (jedenfalls nicht tagsüber)


Nun bin ich mal auf zündende Ideen gespannt ...
Robert

Mitglied: DGI-SysAdm
11.12.2014 um 12:41 Uhr
Hat sich zeitlich erstmal entschärft - der Admin der anderen Seite hat nach über 24h seinen zweiten MX-Eintrag korrigiert (oder das Forwarding freigeschaltet) ...

Trotzdem sendet unser Exchange immer noch über den niedrig priorisierten zweiten MX ... werde heute Nacht die Kiste mal neu starten ...
Bitte warten ..
Mitglied: AndiEoh
11.12.2014 um 13:04 Uhr
Hallo,

hast du schon geprüft ob der erste MX auch zeitnah antwortet und E-Mails annimmt? Die meisten MTA haben eine Liste mit kürzlich nicht erreichbaren Gegenstellen die sie falls Alternative vorhanden überspringen. Greylisting auf dem ersten MX führt übrigens oft zu solch einem Verhalten.

Gruß

Andi
Bitte warten ..
Mitglied: DGI-SysAdm
11.12.2014 um 15:29 Uhr
Hi Andi,

ja habe ich schon geprüft. Habe mich sogar direkt auf die beiden MX'e gesetzt (Telnet auf 25) und dort "plain" eine Mail gesendet, auf dem mx10 ging sie durch, auf dem mx20 nicht. Beide reagieren prompt auf Port 25 und auch Ping.

Hat Exchange einen eigenen DNS-Cache - und wenn ja, wie kann man den löschen

Naja, der Abend (und somit der Reboot) naht

Danke,
Robert
Bitte warten ..
Mitglied: AndiEoh
11.12.2014 um 19:14 Uhr
Meines Wissen nach wird auch auf dem Server der DNS Client Dienst verwendet welcher auch einen Cache verwaltet. Aber die Liste für fehlgeschlagene Port 25 Connections dürfte im Exchange stecken...

Viel Glück

Andi
Bitte warten ..
Ähnliche Inhalte
DNS

Versändnisfrage zu MX Records im DNS

gelöst Frage von Poba88DNS12 Kommentare

Hallo zusammen Nehmen wir an wir haben folgendes Beispiel: nslookup mx.meindomain.de -> zeigt die IP Adresse meines Mail Servers ...

Exchange Server

Office 365 - MX Record

gelöst Frage von 109424Exchange Server4 Kommentare

Hallo zusammen, ich stehe vor einem Problem bei dem mir einfach keine geeignete Lösung einfallen will. Ich hoffe ihr ...

Exchange Server

Exchange Mail Empfang über MX Record und Versand über SmartHost

gelöst Frage von manuelwExchange Server24 Kommentare

Hallo ich beschäftige mich gerade mit MS Exchange und hätte dazu eine Frage. Ich würde meine E-Mails gerne über ...

DNS

MX Record wird in der Zonedatei nicht übernommen, hilfe!

gelöst Frage von Poba88DNS5 Kommentare

Hallo zusammen, unten seht ihr meine Zonedatei. Ich habe gestern meinen MX Record geändert, jedoch scheint er die Änderung ...

Neue Wissensbeiträge
Sicherheit

Ungepatchte Remote Code Execution-Lücke in LG NAS

Information von kgborn vor 1 StundeSicherheit

Nutzt wer LG NAS-Einheiten? In den NAS-Einheiten der LG Network Storage-Einheiten gibt es eine sehr unschöne Schwachstelle, die einen ...

Windows Update

Neue Version KB4099950 NIC Einstellungen gehen verloren

Information von sabines vor 6 StundenWindows Update2 Kommentare

Es ist eine neue Version des KB4099950 verfügbar, die das Problem mit den verlorenen Netzwerkeinstellungen lösen soll. Das Datum ...

Microsoft Office

MS Office 2019 ohne OneNote - OneNote App speichert nur in Cloud

Information von Deepsys vor 17 StundenMicrosoft Office2 Kommentare

Microsoft zeigt deutlich wohin alles bei Ihnen geht, OneNote 2019 wird es nicht mehr geben, und die Windows 10 ...

Humor (lol)

Warum man sein Gast-WLAN nicht beliebig nennen sollte

Erfahrungsbericht von Henere vor 1 TagHumor (lol)5 Kommentare

Servus, mal was aus dem Alltag. Zu Hause. Eigentlich wollte ich nur einen weiteren WLAN-AP ins Netz bringen, damit ...

Heiß diskutierte Inhalte
Windows Netzwerk
LAN nur 10MB pro s trotz gb lan
Frage von tsunamiWindows Netzwerk21 Kommentare

Hallo zusammen, ich brauche mal wieder einen Anstoß in die richtige Richtung. Ich habe einen Windows 10 pc mit ...

Festplatten, SSD, Raid
Server SSD: NVMe PCIe 3.0 RAID?
Frage von bouneeFestplatten, SSD, Raid15 Kommentare

Hallo liebe Admins, mir stellt sich gerade die Frage, ob ein neuer Server mit SSD NVMe PCIe 3.0 Sinn ...

Windows 10
Windows 10 Startmenü-Einstellungen Systemweit festlegen
Frage von flotautWindows 1013 Kommentare

Guten Morgen liebe Admins, wir möchten bei uns am Lehrstuhl demnächst auf Windows 10 umsteigen. Wir installieren unsere PC's ...

Netzwerke
Gateway in Switches, Druckern ect eintragen oder nicht
Frage von JodelknutNetzwerke12 Kommentare

Hi, bisher habe ich immer das Gateway überall wo es verlangt oder eintragbar war auch eingetragen. Mein neuer Kollege ...