Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Exchange 2007: Shared Namespace geht nicht

Mitglied: lasseboo

lasseboo (Level 1) - Jetzt verbinden

20.01.2015 um 09:57 Uhr, 920 Aufrufe, 1 Kommentar

Hallo, Forum,

an einem Exchange 2007 auf SBS 2008 hatten wir bisher die Domain unser-exchange.de lokal im LAN betrieben. Smarthost / MXer im Internet (Postfix) nimmt die Mails aus dem WAN für unser-exchange.de an, von dort ruft der Exchange / SBS mit dem integrierten POP-Connector ab.

So weit, so gut. Nun ist aber ein Standort mit einem Teil der Benutzer aus dem AD DS (respektive der SBS-Console) abgetrennt worden.

user.hier@unser-exchange.de bleibt also bei uns.
user.dort@unser-exchange.de wird auf dem neuen MTA am anderen Standort betrieben.

Dummerweise unter derselben Domain, was ja dank Shared Namespace kein Problem sein sollte.

Also habe ich:

a) zuerst die vorhandene Domain unser-exchange.de auf dem lokalen Exchange von Authoritative auf InternalRelay gesetzt:

Set-AcceptedDomain unser-exchange.de -DomainType InternalRelay

b) den Sendeconnector für die Domain gesetzt:

New-SendConnector -Name "Internal Relay" -Internet -AddressSpace unser-exchange.de -SmartHosts mx.extern.de

c) den AddressBook-Lookup deaktiviert:

Set-AcceptedDomain unser-exchange.de -AddressBookEnabled $false

d) Schliesslich noch über die Exchange Verwaltungskonsole = Anti-Spam das Recipient filtering abgeschaltet.

e) user.dort@unser-exchange.de auf unserem Exchange gelöscht


Schicke ich jetzt über unseren Exchange eine Mail von user.hier@unser-exchange.de an user.dort@unser-exchange.de, sollten diese an den SendConnector zugestellt werden, weil ich user.dort@unser-exchange.de ja bei un. Klappt nur leider nicht ... d.h. es klappt, aber nur für Adressen, die es vorher nicht im lokalen SBS / Exchange gab.

a) Schreibe ich also an eine alte (gelöschte) Emailadresse, bekomme ich einen NDR vom lokalen Exchange.
b) Schreibe ich an eine Phantasie-Adresse (gibts.nicht@unser-exchange.de), bekomme ich einen NDR vom MX/Smarthost (Postfix) - also funktioniert der Sende-Connector.
c) Erstelle ich auf dem Postfix-MXer/Smarthost eine neue Emailadresse neuer.user@unser-exchange.de, wird diese Mail zugestellt.

Ich habe alle Adressen gecheckt, in der Exchange-Verwaltungskonsole und im ADDS nachgesehen - aber es gibt user.dort@unser-exchange.de nirgends mehr auf unserem Exchange. trotzdem erhalte ich beim Versuch, eine Mail an user.dort@unser-exchange.de zusenden, einen NDR von unserem lokalen Exchange.

Ich habe den SendConnector gelöscht und neu angelegt mit etwas anderer Syntax:

New-SendConnector -Name "Internal Relay" -Custom -AddressSpaces unser-exchange.de -SmartHosts mx.extern.de -SourceTransportServers exchange-local

- aber meines Erachtens ist das nicht das Problem, das Relayen an (neu) unbekannte Adressen funktioniert ja.

Ich habe gestern abend den Exchange neugestartet in der Hoffnung, dass es das behebt, aber das war es auch nicht

Habe ich etwas übersehen? Einen Verständnisfehler gemacht?

Vielleicht hat ja jemand eine gute Idee ...

Vielen Dank im Voraus!


MfG

lasseboo
Mitglied: lasseboo
30.01.2015 um 09:20 Uhr
Hallo zusammen,

ich antworte mir jetzt mal selber ;)

Hier die Schritte, wie es dann letztlich ablief:

1) Domain von Authoritative auf InternalRelay gesetzt:

Set-AcceptedDomain unser-exchange.de -DomainType InternalRelay

bzw (laut Microsoft)

New-AcceptedDomain -Name "unser-exchange.de" -DomainName unser-exchange.de -DomainType InternalRelay

2) externen Sendeconnector erstellt bzw. zugewiesen:

New-SendConnector -Name "Internal Relay" -Internet -AddressSpace unser-exchange.de -DNSRoutingEnabled $false -SmartHosts mx.extern.de-SmartHostAuthMechanism ExternalAuthoritative -MaxMessageSize 20MB

bzw (laut Microsoft)

New-SendConnector -Name "Internal Relay" -Custom -AddressSpaces unser-exchange.de -SmartHosts mx.extern.de -SourceTransportServers ex2007.mycompany.local

3) Da die Domain am Hauptstandort bereits angelegt war, ist die Adressbuch-Abfrage standardmässig aktiviert. Deswegen diese Abfrage für die entsprechende Domain abschalten:

Get-AcceptedDomain | select name,domaintype,addressbookenabled

Set-AcceptedDomain unser-exchange.de -AddressBookEnabled $false

4) Schliesslich noch Recipient filtering abschalten:

= Exchange Verwaltungskonsole = Anti-Spam

5) Dann diese Schritte in der Exchange-Shell ausgeführt:

Get-EmailAddressPolicy | Update-EmailAddressPolicy
Get-AddressList | Update-AddressList
Get-GlobalAddressList | Update-GlobalAddressList

get-mailbox | set-mailbox -applymandantoryproperties

6) Jetzt funktionierte der Versand von einem NEU angelegten Outlook-Konto aus (bzw. einem PC mit neuem Profil, der nicht durch eine "alte" Autovervollständigung per NK2 bzw. vorgeschlagener Kontakte "belastet" war:

a) Mail an user.hier wurde am alten Standort zugestellt
b) Mail an user.dort ging problemlos an den User am neuen Standort (mit neuem Exchange) raus

7) An den "alten" PCs bzw. deren Konten muss man nun entweder

a) die "falschen" Adressen aus den Vorschlägen manuell entfernen - das hat nur manchmal geholfen, bei ca. 20 PCs, es lebe die Berechenbarkeit von IT-Systemen ;)

b) die alte Autovervollständigung komplett zu löschen hätte vermutlich auch geholfen

c) wenn ein neuer User user.dort vom neuen Exchange am abgetrennten Standort übrigens eine Mail an die "alten" User am lokalen Standort hier schickt und beantwortet wird, geht diese auch zum abgetrennten Exchange.

Letztlich muss man wohl entweder diesen berüchtigten X.500-Proxy anlegen (den ich aber bisher noch nicht begriffen habe - macht man das für die verschobenen User oder global für einen Bereich?), oder die alten Outlook-Konten manuell abklappern.

So hat es bei uns geklappt, alle Aussagen ohne Gewähr, alles war sehr mühselig - aber wer eine bessere (funktionierende und nachvollziehbare!) Lösung hat, soll sie hier posten, ich lerne gerne dazu!


Schöne Grüße

Lasseboo
Bitte warten ..
Ähnliche Inhalte
Exchange Server

Shared Namespace und Standortwechsel eines Benutzers

Frage von HampekExchange Server17 Kommentare

Hallo zusammen, bitte um Hilfe bei folgendem Szenario. Wir haben zwei Standorte mit jeweils einem SBS2011 inkl. Exchange. Beide ...

Firewall

Sophos UTM 9.x wie SMTP Shared Namespace definieren?

Frage von mipo64Firewall

Hallo zusammen, ich bin gerade dabei auf einer Testinstallation eines Exchange 2013 einen Shared Namespace für eine Domain einzurichten. ...

Exchange Server

Exchange 2010 Shared Mailbox und "senden als"

Frage von MarzaruExchange Server5 Kommentare

Hallo liebe Community, ich habe eine Frage zur Benutzung von mehreren Mailfächern und der Funktion "senden als". Wir haben ...

Exchange Server

Shared Mailbox Exchange - Berechtigung Gruppe

Frage von fabio84Exchange Server1 Kommentar

Hallo Admins, kurze Frage Ziel ist es einer Gruppe Zugriffsrechte auf einen Kalender einer SharedMailbox zu geben. Ich habe ...

Neue Wissensbeiträge
Humor (lol)

WhatsApp-Nachrichten endlich auch per Bluetooth versendbar

Information von BassFishFox vor 2 StundenHumor (lol)1 Kommentar

Genau darauf habe ich gewartet! ;-) Der beliebte Messaging-Dienst WhatsApp erhält eine praktische neue Funktion: Ab dem nächsten Update ...

Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 14 StundenGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Sicherheit

Intel gibt neue Spectre V2-Microcode-Updates frei (20.02.2018)

Information von kgborn vor 15 StundenSicherheit

Intel hat zum 20. Februar 2018 weitere Microcode-Updates für OEMs freigegeben, um Systeme mit neueren Prozessoren gegen die Spectre ...

Microsoft
ARD-Doku - Das Microsoft Dilemma
Tipp von Knorkator vor 18 StundenMicrosoft3 Kommentare

Hallo zusammen, vor einigen Tagen lief in der ARD u.a. Reportage. Das Youtube Video dazu dürfte länger verfügbar sein. ...

Heiß diskutierte Inhalte
Windows Server
AD DS findet Domäne nicht, behebbar?
Frage von schapitzWindows Server40 Kommentare

Guten Tag, ich habe bei einem Kunden ein Problem mit den AD DS. Umgebung ist folgende: Windows Server 2016 ...

Router & Routing
LANCOM VPN CLIENT einrichten
Frage von Finchen961988Router & Routing27 Kommentare

Hallo, ich habe ein Problem und hoffe ihr könnt mir helfen, wir haben einen Kunden der hat einen Speedport ...

Router & Routing
ISC DHCP 2 Subnetze
gelöst Frage von janosch12Router & Routing19 Kommentare

Hallo, ich betreibe bei mir im Netzwerk einen ISC DHCP Server auf Debian, der DHCP verwaltet aktuell ein /24 ...

Switche und Hubs
Cisco SG350X-48 AdminIP in anderes VLAN
Frage von lcer00Switche und Hubs14 Kommentare

Hallo zusammen, ich habe ein Problem mir einem Cisco SG350X-48 bei der Erstinstallation wurde eine IP 192.168.0.254 (Default VLAN ...