Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Exchange 2007 Transportdienst startet nicht, auch nach Löschen vom Queue-Verzeichnis

Mitglied: onkeldata

onkeldata (Level 1) - Jetzt verbinden

06.11.2014 um 02:19 Uhr, 2349 Aufrufe, 7 Kommentare

Guten Tag,

Nach hartem Ausschalten kann der Exchangeserver keine Nachrichten mehr übermitteln, Der Transportdienst lasst sich nicht starten. Zuerst mahnte er das Fehlen bestimmter Trnxxxxx.log an, jetzt, nachdem ich das Queue-Verzeichnis geplättet habe, erstellt er zwar Teile der Daten neu, aber (aus Ereignisanzeige, Fehlerquelle MSExchangetransport, Fehlernummer 17005):

Transportvorgang für Maildatenbank: Die Datenbank konnte nicht geöffnet werden, weil eine Protokolldatei fehlt oder fehlerhaft ist. Der Microsoft Exchange-Transportdienst wird beendet. Möglicherweise ist eine manuelle Wiederherstellung oder Reparatur der Datenbank erforderlich. Die Ausnahme ist Microsoft.Exchange.Isam.IsamDatabaseDirtyShutdownException: Database was not shutdown cleanly. Recovery must first be run to properly complete database operations for the previous shutdown. (-550)
bei Microsoft.Exchange.Isam.?A0x4cb6fe23.HandleError(Int32 err)
bei Microsoft.Exchange.Isam.?A0x4cb6fe23.CallW(Int32 errFn)
bei Microsoft.Exchange.Isam.Interop.MJetAttachDatabase(MJET_SESID sesid, String file, MJET_GRBIT grbit)
bei Microsoft.Exchange.Isam.Interop.MJetAttachDatabase(MJET_SESID sesid, String file)
bei Microsoft.Exchange.Transport.Storage.DataSource.OpenDatabase().


Eine mail.que existiert nicht. Eine tmp.edb existiert nicht. Wird das Queue-Verzeichnis gelöscht, legt er es beim Startversuch brav an, um dann zu scheitern.

In meiner Verzweiflung habe ich den Exchangeserver schon aus dem Backup als Anwendung wiederhergestellt. Mit keinem Erfolg.

Was nun?!

Gruss,

der onkel
Mitglied: Criemo
06.11.2014 um 08:21 Uhr
Hallo Onkel,
dann wirst du wohl oder Übel eine Datenbankrettung bzw. repair machen müssen, da sich sich deine Datenbank im Dirty shutdown befindet.

Exchange Datenbankrettung:


Zustandüberprüfen:
Eseutil /mh
Wenn bei Konsistenz „Dirty shut down“ steht, Recovery Mode starten

1.
Ins Log Verzeichnis gehen schauen wie die log Datei *.chk heißt (meistens E00.chk kann aber abweichen)

2.
*.chk datei löschen und versuchen die Datenbank wieder bereit zu stellen, je nach wie viele logs da sind kann das ne stunde dann dauern, wenn das nicht funktionieren sollte…


1.
Folgenden befehl im CMD ausführen:


Eseutil /r e00 /de:\EXchangeDB\DB3.edb /lc:\exlog\sg3\ /a /i


passer entsprechende Datenbanknamen an

1.
Wenn das nicht hilft muss ein Repair durchgeführt werden:


Eseutil /p e:\exchangedb\db3.edb


Bei einem repair kann der Vorgang „Deleting unicode fixup table“ bis zu 16 Stunden dauern, pro Datenbank


Greetz
Criemo
Bitte warten ..
Mitglied: Criemo
06.11.2014 um 08:22 Uhr
nach dem Repair kannste dann die Datenbank bereitstellen und den Transportdienst erneut starten!
Bitte warten ..
Mitglied: onkeldata
06.11.2014 um 08:37 Uhr
Hallo,

Der Informations-Speicher startet und steht zur Verfügung. Benutzer können auf Ihr Postfach zugreifen. Aber ich kann ja mal trotzdem einen eseutil /MH darauf loslassen... So wirklich glaube ich aber nicht, das es daher kommt.

Gruss, der Onkel
Bitte warten ..
Mitglied: Criemo
06.11.2014 um 08:48 Uhr
Das hat damit nichts zu tun.

es steht eindeutig da....


Database was not shutdown cleanly. Recovery must first be run to properly complete database operations for the previous shutdown. (-550)
Bitte warten ..
Mitglied: onkeldata
06.11.2014 um 10:22 Uhr
Servus,

nun ist es so - und das ohne Deinen Willen zur Hilfe irgendwie kränken zu wollen - dass die Datenbank des Exchange, in der die Postfächer sind, nichts, aber auch gar nichts mit dem Transportdienst an sich zu tun hat. Dennoch habe ich es geprüft, sie zeigt einen Clean Shutdown.

Der Transportdienst verwendet eine eigene Mail.que, die im Moment nicht existiert, und eine tmp.edb, die ebenfalls im Moment nicht existiert. Beide sollte er bei Start des Dienstes selbstständig anlegen, wenn diese fehlen. Das tut er nicht, und plus extra er findet eine unsaubere Datenbank. Ich habe auch den Pfad zur Queue in der .config geprüft, der stimmt.

Weitere Ideen - ich habe nämlich keine?!

Gruss, der Onkel
Bitte warten ..
Mitglied: Criemo
LÖSUNG 06.11.2014, aktualisiert um 11:15 Uhr
HI,

Das ist ja super dass du das gemacht hast,
meine frage ist hast du das auch für die Transportdatenbank (mail.que) gemacht?
wäre ja sinnvoll?!

http://technet.microsoft.com/de-de/library/aa998231(v=exchg.80).aspx

http://exchangeserverpro.com/event-id-454-and-17003-a-corrupt-sender-re ...


Gruß
Criemo
Bitte warten ..
Mitglied: onkeldata
06.11.2014 um 11:14 Uhr
Wie ich bereits schrieb, war die mail.que nicht vorhanden, und wurde auch nicht angelegt.

Sonst hätte ich die herzlich gerne geprüft.

Aaaaber, ich habe das Ding jetzt gelöst. ich habe einen neuen Pfad in der Edgetransport Config angelegt, und siehe da, dort wurde dann alles ordnungsgemäss erstellt und lief.

Was war das Problem? Die Rechte im Verzeichnis stimmten, es wurden Dateien (die Logs) angelegt (deshalb war wohl auch das Dateisystem selber intakt), usw.

Für das nächste Mal nehme ich mit: wenn eine automatische Funktion nicht tut, was sie soll, sag ihr, sie soll es woanders tun :/

Fertig,

der Onkel
Bitte warten ..
Ähnliche Inhalte
Exchange Server
Mails aus Submission Queue löschen
Frage von BradockExchange Server1 Kommentar

Hallo zusammen ich habe 3 Mails die in einer meiner Submission Queues hängen. Diese würde ich gerne löschen da ...

Exchange Server

Exchange 2013 Transportdienst beendet sich

gelöst Frage von clSchakExchange Server15 Kommentare

Hallo Zusammen wir haben aktuell, seit heute morgen, das Problem, dass sich der Transportdienst in einem Rhythmus von 10-20 ...

Exchange Server

EXCHANGE 2016 Installationabbruch bei Postfachrolle Transportdienst

Frage von NaumannExchange Server

Hallo liebe Gemeinde, bei der Installation von EXCHANGE 2016 ist folgender Fehler aufgetreten: Fehler: Der folgende Fehler wurde generiert, ...

Windows Server

Verzeichnis lässt sich nicht löschen

Frage von BPeterWindows Server7 Kommentare

Hallo, ein Mitarbeiter hat auf einem Windows 2003 Fileserver ein Ordner von einem USB-Stick kopiert, den ich jetzt nicht ...

Neue Wissensbeiträge
Internet

Datendealing im WWW Tracking Methoden immer brutaler

Information von sabines vor 1 StundeInternet

Interessanter Artikel zum Thema Tracking im WWW und die immer "besseren" Methoden des Trackings. Professor Arvind Narayanan (Princeton-Universität) betreibt ...

Erkennung und -Abwehr

Ups: Einfaches Nullzeichen hebelte den Anti-Malware-Schutzt in Windows 10 aus

Information von kgborn vor 13 StundenErkennung und -Abwehr

Windows 10 ist das sicherste Windows aller Zeiten, wie Microsoft betont. Insidern ist aber klar, das es da Lücken, ...

Windows 10

Windows 10 on ARM: von Microsoft entfernte Info - Klartext, was nicht geht

Information von kgborn vor 15 StundenWindows 10

Windows 10 on ARM ist ja eine neue Variante, die Microsoft im Verbund mit Geräteherstellern am Markt etablieren will. ...

Microsoft
TV-Tipp: Das Microsoft-Dilemma
Information von kgborn vor 15 StundenMicrosoft9 Kommentare

Aktuell gibt es in Behörden und in Firmen eine fatale Abhängigkeit von Microsoft und dessen Produkten. Planlos agieren die ...

Heiß diskutierte Inhalte
Windows 10
Windows 10 (1709) Tastur und Maus wieder einschalten?
Frage von LochkartenstanzerWindows 1026 Kommentare

Moin, Ich habe von einem Kunden einen Win10-Rechner bekommen, bei dem weder Tastatur noch Maus geht. Die Hardware funktioniert ...

Firewall
RB2011 Firewall Rule eine bestimmte Mac oder IP Adresse nicht zu blockieren
Frage von lightmanFirewall15 Kommentare

Hallo liebes Forum mit ihren Spezialisten. Ich habe meine Firewall so konfiguriert das kein Endgerät ohne meine Speziellen Erlaubnis ...

Server
Route-Befehl Unterstützung (unter CMD)
gelöst Frage von FKRR56Server15 Kommentare

Guten Tag , i.M. habe ich Probleme über den CMD-Route-Befehl ein Routing auf einen entfernten Server zuzulassen. Der Server ...

Humor (lol)
Was könnte man mit einem Server machen? Idee gesucht
Frage von 2SeitenHumor (lol)15 Kommentare

Hey Zusammen Ich habe einen alten HP G2 Rackserver zu Hause rumliegen. 28GB Ram, 1xAMD Prozi mit etwa 2GHz. ...