Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Exchange 2010 mehrere Smarthosts nach Absender

Mitglied: Terminatorthree

Terminatorthree (Level 1) - Jetzt verbinden

27.02.2010, aktualisiert 17:59 Uhr, 12838 Aufrufe, 9 Kommentare

Hallo liebe Administrator.de Community, ich möchte in Exchange die Mails über verschiedene Smarthosts leiten, je nach Absender.

Mich quält seit einigen Tagen dieses Problem. Ich habe hier einige wenige User deren Mails sowie Kontakte und Termine auf dem Exchange verwaltet werden. Die Mails werden von Freemailern abgeholt und dann an die Postfächer zugestellt. Dies funktioniert auch. Das Problem stellt sich für mich nun beim Versenden der Mails. Die Mails müssen je nach User wieder über den Smarthost versendet werden. Wie kann ich nun erreichen das die Mails je nach Absender über bestimmte Smarthosts gesendet werden? Wie gesagt nach dem Absender nicht nach Empfängerdomain.

Es wäre super wenn ihr mir auch diesmal wieder helfen könntet.

Es kann auch zusätzliche Software eingesetzt werden, jedoch ist wie immer kein Geld vorhanden um neue Software zu kaufen also kommt nur Freeware in Frage (wenn sich das nicht mit Exchange Mitteln lösen lässt).

Mit freundlichen Grüßen

Terminatorthree
Mitglied: filippg
27.02.2010 um 22:08 Uhr
Hallo,

das ist so im Exchange nicht vorgesehen.
Der Workaround unter Ex 2003 (von dem du also schauen kannst, ob der in 2007 immer noch geht) war das Setzen von Berechtigungen auf dem Send-Connector. Lege für jeden Nutzer einen Connector an, denn nur er nutzen darf. Exchange sucht dann für jeden den geeigneten raus... Aber Freude macht man sich damit nicht.

Gruß

Filipp
Bitte warten ..
Mitglied: Terminatorthree
27.02.2010 um 22:16 Uhr
Danke die Idee hatte ich auch schon so in der Art. Aber wie setzt man denn Berechtigungen auf einen Send-Connector?
Ich habe inzwischen auch das hier noch als Tipp bekommen: http://blogs.technet.com/appssrv/archive/2009/08/26/how-to-control-rout ...
Bitte warten ..
Mitglied: Stephan.Betken
28.02.2010 um 00:51 Uhr
Hallo,

leider besteht die Möglichkeit, dies über Berechtigungen zu lösen, nicht mehr.

Terminatorthree hat aber in einem anderen Forum ein paar Lösungsvorschläge für eine Eigenbau- und eine kostenpflichtige Lösung bekommen. (siehe http://www.mcseboard.de/ms-exchange-forum-80/exchange-2010-mehrere-smar ... )

http://blogs.technet.com/appssrv/archive/2009/08/26/how-to-control-rout ...
Bitte warten ..
Mitglied: Terminatorthree
28.02.2010 um 10:25 Uhr
Hmm ok,
erstmal danke für die Info das es so nicht mehr geht. Dann brauch ich nicht mehr nach einem Berechtigungsschalter suchen.
Die Eigenbaulösung werde ich mir noch genauer ansehen (müssen). Leider startete gestern nach einem kurzen Test der Exchange Transport Dienst nicht mehr da der Assembly Path (der ja vorher importiert wurde) nicht mehr gefunden wurde. Hat jemand vielleicht eine Idee woran das liegen kann? Sobald ich zu komme werde ich auch noch ein wenig weiter probieren.

Vielen Dank bis hierhin für die Antworten
MfG Terminatorthree
Bitte warten ..
Mitglied: Stephan.Betken
28.02.2010 um 10:38 Uhr
Hi,

ich würde auch zu der bereits vorgeschlagenen Firmendomain tendieren, an die die vorhandenen E-Mail-Adressen weitergeleitet werden.
Die Alternative zur Eigenbaulösung ist für andere vielleicht auch interessant. https://solutionfinder.microsoft.com/Solutions/SolutionDetailsView.aspx? ...

Bekommst du denn eine Fehlermeldung?

Beste Grüße
Stephan
Bitte warten ..
Mitglied: Terminatorthree
28.02.2010 um 10:49 Uhr
Ja im EventViewer erhalte ich die Meldung: "AssemblyPath not found"
EDIT:
Microsoft Exchange couldn't start transport agents. The Microsoft Exchange Transport service will be stopped. Exception details: Failed to create type 'RoutingAgentOverride.SampleRoutingAgentFactory' from assembly 'E:\Share\Dlls\ClassLibrary1.dll' due to error 'Invalid agent assembly path.'. : Microsoft.Exchange.Data.ExchangeConfigurationException: Failed to create type 'RoutingAgentOverride.SampleRoutingAgentFactory' from assembly 'E:\Share\Dlls\ClassLibrary1.dll' due to error 'Invalid agent assembly path.'. ---> System.ArgumentException: Invalid agent assembly path.
--- End of inner exception stack trace ---
at Microsoft.Exchange.Data.Transport.Internal.MExRuntime.FactoryTable.CreateAgentFactory(AgentInfo agentInfo)
at Microsoft.Exchange.Data.Transport.Internal.MExRuntime.FactoryTable..ctor(IEnumerable agents)
at Microsoft.Exchange.Data.Transport.Internal.MExRuntime.RuntimeSettings..ctor(MExConfiguration config, String agentGroup)
at Microsoft.Exchange.Data.Transport.Internal.MExRuntime.MExRuntime.Initialize(String configFile, String agentGroup, Boolean isBridgeHead, String installPath)
at Microsoft.Exchange.Transport.Categorizer.MExEvents.Initialize(String configFilePath)
at Microsoft.Exchange.Transport.Components.CategorizerMExRuntimeLoader.Load()
Bitte warten ..
Mitglied: osterhase09
01.03.2010 um 16:59 Uhr
Alternativ könnte man auch einen SMTP-Relay-Server nutzen wie bspw. www.authsmtp.com
Ist aber auch nicht die eleganteste Lösung im Hinblick auf SPAM-Filter bei den Mail-Empfängern. Privat habe ich das seit etwa einem Jahr im Einsatz - es verirren sich nur recht wenige Mails in den Filtern von GMX und Co... Aber es ist definitiv nicht fehlerfrei.
Bitte warten ..
Mitglied: Stephan.Betken
01.03.2010 um 17:03 Uhr
details: Failed to create type 'RoutingAgentOverride.SampleRoutingAgentFactory' from assembly
'E:\Share\Dlls\ClassLibrary1.dll' due to error 'Invalid agent assembly path.'. :

Hört sich gerade nach dem falschen Pfad an (oder einer defekten DLL).
Bitte warten ..
Mitglied: Terminatorthree
01.03.2010 um 17:21 Uhr
Hallo ihr Lieben,
es tut mir Leid das ich mich erst jetzt wieder melden kann. Ich habe die Sache noch einmal von vorbe gemacht und nun geht es komischerweise. Woran es gelegen hat kann ich leider nict mehr nachvollziehen, der Pfad hat jedoch definitiv gestimmt. Dementsprechend markiere ich diesen Beitrag hier als gelöst, ich habe ja eine Lösung bekommen habe.

Ich danke euch allen für eure Hilfe.

MfG
Terminatorthree
Bitte warten ..
Ähnliche Inhalte
Exchange Server

Exchange 2010 (SBS) nur noch als Smarthost nutzen?

Frage von gagaguExchange Server9 Kommentare

Hallo, wir haben einen SBS 2011 mit einem Exchange 2010 im Einsatz den wir gerade duch einen Exteren Anbieter ...

Exchange Server

Exchange 2010 Server Fehler bei Änderung der Authentifizierung aller Absender

Frage von stefan2k10Exchange Server1 Kommentar

Hallo, habe folgendes Problem. Ich würde gerne auf unserem Exchange 2010 eine Vertreilergruppe einricht, die auch von aussen erreichbar ...

E-Mail

Exchange mit Smarthost und SPF

Frage von der-suchendeE-Mail6 Kommentare

Hallo Wissende, ich habe ein generelles Problem mit meinem Exchange, dem Senden via Smarthost, dem genutzten Relayserver und dem ...

Exchange Server

Exchange Server ausgehender Smarthost mehrere Domains

gelöst Frage von icegetExchange Server3 Kommentare

Hallo liebe Community, in meinem Exchange Server befinden sich drei Domains (domain1.com, domain2.com & domain3.com). Aktuell sende ich die ...

Neue Wissensbeiträge
Humor (lol)
IoT-Gefahr: Smartes Aquarium leckt!
Information von Lochkartenstanzer vor 2 TagenHumor (lol)3 Kommentare

Moin, Die IoT-Manie hat weitere Opfer gefunden. Ein Casino-Leck durch ein smartes Aquarium: Allerdings haben sie kein Wasser, sondern ...

Router & Routing

Alte Fritzbox 7270 mit VPN und SIP-Telefonie hinter O2 Homebox 6641 als "Modem"

Erfahrungsbericht von the-buccaneer vor 2 TagenRouter & Routing3 Kommentare

Nun war es soweit: Auch O2 hat mich mit VOIP zwangsbeglückt. Heute am Privatanschluss, in 2 Wochen ist das ...

Sicherheit

Ungepatchte Remote Code Execution-Lücke in LG NAS

Information von kgborn vor 2 TagenSicherheit

Nutzt wer LG NAS-Einheiten? In den NAS-Einheiten der LG Network Storage-Einheiten gibt es eine sehr unschöne Schwachstelle, die einen ...

Windows Update

Neue Version KB4099950 NIC Einstellungen gehen verloren

Information von sabines vor 3 TagenWindows Update2 Kommentare

Es ist eine neue Version des KB4099950 verfügbar, die das Problem mit den verlorenen Netzwerkeinstellungen lösen soll. Das Datum ...

Heiß diskutierte Inhalte
Netzwerkmanagement
Netzwerkmanagment im Haus mit Switch, Panel und pfsense
gelöst Frage von CorraggiounoNetzwerkmanagement14 Kommentare

hi zusammen, wir sind gerade dabei das ganze Haus bzw. die einzelnen Zimmer mit netzwerkdosen zu versorgen. Vom Keller ...

Linux Netzwerk
Raspberry Pi 3: WLAN Power save deaktivieren
Frage von nordie92Linux Netzwerk14 Kommentare

Moin moin, mein Raspberry Pi 3 Model B benötigt eine dauerhaft aktive WLAN-Verbindung. Leider bricht die WLAN-Verbindung nach einigen ...

Google Android
Empfehlung: Android Ortungsapp
gelöst Frage von certifiedit.netGoogle Android13 Kommentare

Guten Morgen, grundsätzlich vorweg, ich wollte mich eben schlau machen, bzgl einer Ortungsapp, welche Androidbasiert einem anderen Androidsmartphone mitteilt, ...

Vmware
Server 2008 r2 vmware terminalserver
Frage von MasterCVmware12 Kommentare

Guten Abend zusammen, ich hoffe , dass einer von euch mir weiterhelfen kann ,bei meinem kack Problem ! Ist ...