Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Exchange SMTP Mail FROM in Telnet

Mitglied: Goofie

Goofie (Level 1) - Jetzt verbinden

23.03.2008, aktualisiert 25.03.2008, 7607 Aufrufe, 4 Kommentare

Das versenden von Mails via Telnet und Exchange funktioniert nur, wenn bei MAIL FROM: <myname@domain.com> verwendet wird. MAIL FROM: myname <myname@domain.com> funktioniert nicht!

Hi,

ich versuche verzweifelt rauszubekommen, warum mein Exchange per Telnet einfach nur E-Mails mit Absender-Mail-Adresse verschickt und ich keinen Absendername anfügen kann.

Wenn ich per Telnet auf den Server verbinde und
MAIL FROM: <myname@domain.com>
ausführe, dann funktioniert alles.
Will ich jedoch einen Absendername hinzufügen (MAIL FROM: myname <myname@domain.com>)
und nicht nur eine Absender-Mail-Adresse, dann meckert Exchange: 501 5.5.4 Invalid arguments.

Per Outlook Express kann ich jedoch auch einen beliebitgen Absendernamen eingeben und die Mails kommen korrekt an.

Wahrscheinlich ist die Eingabe-form falsch... kann mir jemand helfen???

Gruß

Ben
Mitglied: filippg
23.03.2008 um 17:13 Uhr
Hallo,

beim Mailversand per SMTP taucht der Absender zweimal auf: einmal im "MAIL FROM:"-SMTP-Befehl, und einmal im Message-Header. Der Message-Header wird im "DATA"-Teil übertragen. Der Mailserver wertet diese Header gar nicht aus (gut, zum Spamschutz wird das mittlerweile schon gemacht, ist eigentlich aber nicht vorgesehen). Und die Angabe des Absendernamens kann nur in den Message-Headern im DATA-Teil gemacht werden, nicht im MAIL FROM-Befehl.

Gruß

Filipp
Bitte warten ..
Mitglied: Goofie
24.03.2008 um 14:54 Uhr
@filippg: Danke für den Hinweis...
Ich versuche allerdings per PHP mit dem mail()-Befehl eine E-Mail zu versenden.
wie ich bereits erläutert habe, funktioniert dies nur, wenn ich als absender eine e-mail-adresse festlege...

mit:
$headers.="From: \"$fromname\" <$from>\r\n";
wird keine E-Mail versandt... ich bin hier etwas fündig geworden, aber der bugfix zeigt keine wirkung:

The fix is in Microsoft Article ID 291828 ( http://support.microsoft.com/?id=291828 ). Even though the "bug" workaround is for IIS 6.0 on Exchange 2003 communicating with a UNIX server, THIS SOLVES THE PROBLEM. Just skip down to the last section for Exchange 2003 and follow the instructions to modify the IIS 6 MetaBase with the MetaBase Explorer found in the IIS 6 Resource Kit.
Bitte warten ..
Mitglied: filippg
24.03.2008 um 15:33 Uhr
Hallo,

von PHP hattest du leider kein Wort geschrieben.
Und der Patch den du verlinkt hast bezieht sich auf einen komplett anderen Fehler.

Gruß

Filipp
Bitte warten ..
Mitglied: Goofie
25.03.2008 um 13:07 Uhr
Habs hinbekommen...

das Problem lag an folgendem: die in der PHP.ini kein Absender angegeben war, hat die Mail-funktion als Absender die im Header angegebene Adresse verwendet und zwar mit Absendername <E-Mail-adresse>, was Exchange aber so nicht annimmt.

Meine neue Mail-Funktion in PHP ändert also erst die Absenderadresse in der PHP.ini, im Header kann dann trotzdem Absendername <E-Mail-Adresse> verwendet werden.
Bitte warten ..
Ähnliche Inhalte
E-Mail

Frage SMTP Dialog via Telnet:25 mit Hoster

Frage von Various5E-Mail5 Kommentare

Schönen guten Tag Community Ein Kunde hat mich Heute angerufen und sich über SPAM Mails beklagt mit Viren Inhalt. ...

Exchange Server

Exchange nicht alle mails kommen rein 550 smtp

Frage von windows10Exchange Server2 Kommentare

Hallo Forum Habe aus versehen den Default Connector von unserem Exchange gelöscht :( habe ihn danach neu erstellt leider ...

Exchange Server

Mails über SMTP abrufen

Frage von Philbo69Exchange Server14 Kommentare

Hallo, einer unserer neuen Kunden hat einen Microsoft Exchange 2003 ( Ja ich weiß Exchange 2003 ist alt und ...

Exchange Server

Exchange SMTP-Zugang in CRM

gelöst Frage von 118080Exchange Server11 Kommentare

Hi! Ich bin gerade dabei in neues CRM einzuführen, und ich kann direkt aus diesem CRM raus Mails versenden, ...

Neue Wissensbeiträge
Hardware

100.000 Mikrotik-Router ungefragt von Hacker abgesichert

Information von 7Gizmo7 vor 13 StundenHardware1 Kommentar

Hallo zusammen, da hier ja öfters mal von Mikrotik gesprochen wird. Trotz Updates klafft eine Sicherheitslücke in Hundertausenden Mikrotik-Routern. ...

Sicherheit

Oracle gibt kritische Updates für diverse Produkte frei (16. Oktober 2018)

Information von kgborn vor 1 TagSicherheit

Oracle hat zum 16. Oktober 2018 eine ganze Reihe an kritischen Updates für seine Produkte freigegeben. Eine Kurzübersicht mit ...

Windows 10
FYI: Fristen beim Windows 10 Downgrade-Recht
Information von kgborn vor 1 TagWindows 101 Kommentar

Möglicherweise ist das bei euch bekannt - ich habe es gerade aus einem Newsletter eines OEMs herausgefischt. Beim Downgrade-Recht ...

CMS
Freie Wähler Bayern MySQL PW online
Information von sabines vor 1 TagCMS6 Kommentare

Die Typo3 Installation der Freien Wähler Bayern scheint wohl längere Zeit nicht mehr angefasst und/oder fehlkonfiguriert zu sein. Nach ...

Heiß diskutierte Inhalte
Windows 10
Sysprep Fehler im Log kann nicht starten
Frage von grillinator95Windows 1022 Kommentare

Hallo, kann leider SYSPREP nicht mehr starten, Win10 64bit. Logfile sagt folgendes: 2018-10-17 13:44:56, Info SYSPRP 2018-10-17 13:44:56, Info ...

Internet
Ist diese URL denkbar (Syntax)?
gelöst Frage von departure69Internet17 Kommentare

Hallo. Der Sohn eines Arbeitskollegen hat im Gymnasium EDV-Unterricht. Leider hat er in der letzten Klassenarbeit einen Fünfer geschrieben. ...

Exchange Server
Outlook Anywhere - Anmeldefenster muss mit Domain gefüllt werden
Frage von leon123Exchange Server16 Kommentare

Hallo zusammen, ich habe relativ erfolgreich einen Exchange 2016 aufgesetzt, sowie ein SAN-Zertifikat eingespielt und Outlook Anywhere aktiviert. Beim ...

Debian
Linux debian 9 Installation
Frage von Green14Debian15 Kommentare

Hallo zusammen, ich habe mich ein wenig mit Debian auseinandergesetzt und möchte mir eine Standard-Installation als Grundlage für andere ...