Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Externe Verbindung mit VNC über Speedport W700V

Mitglied: Momo

Momo (Level 1) - Jetzt verbinden

17.02.2007, aktualisiert 26.02.2007, 17012 Aufrufe, 13 Kommentare

Hallo große Meister der IT-Kunst,

mein Bruder hat zuhause einen Win2000 PC mit nem VNC-Server drauf. Die Internetverbindung betreibt er mit dem Router der Teletubbies "Speedport W700V".

Nun habe ich mal unter dem Menüpunkt Netzwerk --> Nat & Ports den Port 5900 für die VNC-Verbindung freigeschaltet.

Bei mir zuhause habe ich ne Linux-Kiste "OpenSuse 10.2" mit einer aktiven Firewall in der ich aber den Port 5900 ebenfalls freigeschaltet habe. Ich betreibe mein Internet mit dem Router "SMC2804 WBR". Ein super Ding, habe ich schon seit einigen Jahren, ist auf den neuesten Stand per update gebracht und funktioniert sehr gut. Darauf habe ich ebenfalls unter "Nat-->special applications" den Port 5900 für TCP und UDP freigeschaltet.

Allerdings bekomme ich mit meinem VNC-Viewer keine Verbindung zum VNC-Server meines Bruders. Natürlich funktioniert es netzintern, jedoch komme ich nur bis zu dem Router meines Bruders und nicht weiter.
Anpingen kann ich den PC meines Bruders einwandfrei.

Kennt jemand den "Speedport W700V" und kann mir sagen was ich da falsch mache?

Ich bin für jeden Tip und Hinweis sehr sehr dankbar!

Viele Grüße

derNichtsWissende
Mitglied: aqui
17.02.2007 um 15:12 Uhr
Außer 5900, sind es noch die Port 5800 und 5500. Portforward sagt dies anhand eines Beispiels für deinen Router !
http://www.portforward.com/english/routers/port_forwarding/SMC/2804WBR/ ...

Das VNC FAQ betätigt das....
http://faq.gotomyvnc.com/fom-serve/cache/52.html
Bitte warten ..
Mitglied: Momo
18.02.2007 um 02:20 Uhr
Vielen Dank für die schnelle Antwort!
Leider habe ich den T-Online Router "SpeedPort W 700V" auf der Seite nicht gefunden.
Hast du vielleicht auch nähere Informationen zu dem SpeedPort W 700V und kannst du mir auch sage wie ich diesen einstelle? Denn dazu habe ich im INternet leider bisher noch nichts gefunden.
Bitte warten ..
Mitglied: aqui
19.02.2007 um 14:35 Uhr
Das mitgelieferte Handbuch, oder falls du es nicht haben solltest findest du es hier:

http://www.t-com.de/dlp/eki/downloads/Speedport/bedanl_speedport_w700v_ ...

beschreibt das einfach und auch für Laien verständlich auf den Seiten 82 und folgende. Da ist alles Schritt für Schritt erklärt !!
Eingestellt wird das über den Menüpunkt Netzwerk dann NAT & Portregeln... den Rest erklärt das Handbuch !!
Bitte warten ..
Mitglied: Momo
19.02.2007 um 15:26 Uhr
Obwohl ich die Portweiterleitung auf dem Speedport W700V eingerichtet habe und die Ports 5500-5900 alle freigeschaltet habe, bekomme ich dennoch mit meinem VNC-Viewer keine Verbindung zum Server. Nach einer Weile kommt die Meldung, dass der Server nicht gefunden werden konnte.

Ist schon etwas seltsam.

Es gibt noch die Möglichkeit des Port-Triggering. Die habe ich noch nicht ausprobiert. Vielleicht klappts ja damit. Mal sehn. Eigentlich habe ich es immer ohne dieses Triggering geschafft eine Verbindung ins Internet mit einem VNC-Server aufzubauen.

Naja...ich probiers mal.

Besten Dank für deine Mühe!

Viele Grüße
DerNichtswissende
Bitte warten ..
Mitglied: Momo
19.02.2007 um 15:26 Uhr
Obwohl ich die Portweiterleitung auf dem Speedport W700V eingerichtet habe und die Ports 5500-5900 alle freigeschaltet habe, bekomme ich dennoch mit meinem VNC-Viewer keine Verbindung zum Server. Nach einer Weile kommt die Meldung, dass der Server nicht gefunden werden konnte.

Ist schon etwas seltsam.

Es gibt noch die Möglichkeit des Port-Triggering. Die habe ich noch nicht ausprobiert. Vielleicht klappts ja damit. Mal sehn. Eigentlich habe ich es immer ohne dieses Triggering geschafft eine Verbindung ins Internet mit einem VNC-Server aufzubauen.

Naja...ich probiers mal.

Besten Dank für deine Mühe!

Viele Grüße
DerNichtswissende
Bitte warten ..
Mitglied: aqui
19.02.2007 um 17:51 Uhr
Denk dran das du diese Portweiterleitung von externen Rechnern auch wirklich nur extern ausprobieren kannst. Es geht nicht wenn du von einem internen PC einfach die externe IP Adresse des Routers versuchst zu verbinden !
Das du natürlich zum Verbindungsaufbau mit VNC auf dem externen Rechner die IP Adresse des WAN/DSL Interfaces des Speeport als Ziel angeben musst und nicht die des PCs im lokalen LANs sollte klar sein !!! Welche Adresse du dort hast kannst du z.B. sehen mit http://www.wieistmeineip.de/

Ob überhaupt Packete vom Router ankommen kannst du ganz einfach sehen indem du mal einen Packet Sniffer auf diesem Server wie den Wireshark (www.wireshark.org) installierst.
Sofern du dich mit dem Bediener des externen Rechners per Telefon o.ä. abstimmst, wann der eine Session aufbauen will und sie dann startet, dann müsstest du sofort eingehende TCP Packete mit der Serverziel IP Adresse auf dem VNC Port im Sniffer sehen.
Siehst du keine, forwardet der Speedport einfach nichts und das Problem liegt noch irgendwo in der Einrichtung des Routers.... !
Bitte warten ..
Mitglied: Momo
20.02.2007 um 22:17 Uhr
Eigentlich dachte ich immer, dass ich mich mit den Dingern und überhaupt mit PCs auskenne aber dieses blöde Problemchen kann ich dennoch nicht lösen.

Das ich die ip-Addresse des Speedport ausserhalb des Netzwerkes, in dem sich der SpeedPort befindet, im VNC-Viewer eingeben muß ist mir durchaus bewusst. Andernfalls kriegt es der Router nicht geschnallt.

Mein Bruder und ich wohnen einige Meter von einander entfernt. Um die IP-Adresse des Speedport immer herauszufinden habe ich auf dem PC meines Bruder einen DynDNS-Updater installiert. Das funktioniert auch alles. Wenn ich z.B. für den Port 80 eine Weiterleitung einrichte, dann schnallt es der Speedport und leitet einfach zum Webserver weiter.

Wenn ich aber die Ports im NAT "5500-5900" für TCP und "5500-5900" für UDP einrichte und den VNC-Server als Dienst laufen lasse und sogar den VNC-Listener starte, dann bekomme ich dennoch keine Verbindung zum VNC-Server.

Ich bin schon total am verzweifeln.

Mit diversen anderen Routern habe ich dies schon ausprobiert und es hat immer funktioniert aber mit diesem blöden Router geht es einfach nicht. Ich weiß einfach nicht mehr weiter!
Bitte warten ..
Mitglied: aqui
21.02.2007 um 13:02 Uhr
Hoffen wir mal das du die Port Weiterleitung auch auf der VNC Serverseite gemacht hast sofern der auch hinter einem NAT Router liegt. Das ist wichtig !!! Die Clientseite nicht !
Bitte warten ..
Mitglied: Momo
22.02.2007 um 20:42 Uhr
Gerade auf der VNC-Serverseite habe ich die Portweiterleitung im NAT eingerichtet.
Auf der VNC-Viewerseite habe ich die Ports nur deshalb freigeschaltet, um Probleme auf meiner Seite in jedem Fall auszuschliessen.

Dieses Wochenende werde ich es nochmals probieren.

Ich verstehe es einfach nicht!
Bitte warten ..
Mitglied: aqui
22.02.2007 um 22:45 Uhr
Das ist auch nicht zu verstehen, denn es ist wahrscheinlich ein Problem des Routers, das der kein richtiges Portforwarding ausführt (Bug ?)
Um da sicherzugehen kannst du parallel mal den Wireshark (www.wireshark.org) auf dem VNC Server laufen lassen um zu sehen ob überhaupt vom Router geforwardete VNC Packete für die IP Adresse eingehen.
Tun sie das nicht trotz sauber konfiguriertem Port Forwarding (das ist immer die Voraussetzung !!) dann hat der Router einen Bug.
Sicherheitshalber solltest du ihm vor dem Testen nochmal das neueste Firmware Image verpassen !
Das gibts hier:
http://www.t-com.de/dlp/eki/downloads/Speedport/Speedport_W700V/fw_spee ...
die Anleitung dazu:
http://www.t-com.de/dlp/eki/downloads/Speedport/Speedport_W700V/update_ ...
Ansonsten einen anständigen Router verwenden der das sauber kann
Bitte warten ..
Mitglied: Momo
22.02.2007 um 23:00 Uhr
das ist echt klasse von dir.
Herzlichen Dank für diese riesige Mühe.

Ich werde mir das alles mal am Samstag zu Gemüte führen.
Das muß einfach funktionieren.

Besten Dank nochmals!

Ich melde mich dann am Samstag. Hoffe das ich nach dem update weiterkomme.

Wünsche dir noch ne angenehme Nacht!

Bis Samstag!
Bitte warten ..
Mitglied: Momo
26.02.2007 um 00:35 Uhr
hi!

Es klappt nun. Ich kann endlich auf den VNC-Server zugreifen.
Es lag nicht am Portforwarding sondern am VNC-Server.
Der VNC-Server hat keine bestimmten Ports akzeptiert. Als ich den VNC-Server jedoch so konfiguriert habe das er alle Ports akzeptieren soll, hat es plötzlich funktioniert und ich konnte mich am Rechner einloggen.

Was ich immernoch nicht verstehe ist folgendes:

Über die MS-Dos Konsole kann ich mich per ftp auf meinem NAS vom PC meines Bruders einloggen. Allerdings geht es nicht über den Windows-Explorer des PC's meines Bruders.

Woran könnte das liegen?
Bitte warten ..
Mitglied: aqui
26.02.2007 um 23:56 Uhr
Wahrscheinlich nutzt der Explorer eine active FTP Verbindung als Client. Um über NAT zu gehen benötigst du aber einen passive FTP Client. Was das ist kannst du hier nachlesen:
http://slacksite.com/other/ftp.html
Wie man den Explorer auf passive Mode stellt siehst du hier:
http://compnetworking.about.com/cs/novellgroupwise/ht/setpassiveftpie.h ...
Bitte warten ..
Ähnliche Inhalte
Windows Tools
VNC Verbindung als Autostart festlegen
Frage von dgrebnerWindows Tools7 Kommentare

Hallo ich möchte gerne erreichen, dass ein PC eine VNC Verbindung über Tight VNC automatisch aufbaut. Der PC loggt ...

Monitoring
VNC Verbindung Parameter Scaling
Frage von sschultewolterMonitoring1 Kommentar

Hallo, ich habe diverse VNC Verbindungen, die standardmäßig sehr klein sind. Diese skaliere ich auf 150%. Danach speichere ich ...

Router & Routing
VPN in Verbindung mit Speedport LTE II
gelöst Frage von cschenkRouter & Routing2 Kommentare

Hallo, meine Frage muss ihren Laptop per VPN mit dem dem Firmennetz verbinden und ich kämpfe hier mit der ...

Router & Routing

Repeater an Router Koppeln ich verzweifele noch... Fritz box und Speedport W700V

Frage von A4-RazerRouter & Routing18 Kommentare

Hey Leute ich hoffe Ihr könnt mir helfen. Ich habe ein Speedport W700v als Router mit der IP 192.168.2.1 ...

Neue Wissensbeiträge
iOS
IOS 11.2.6 verfügbar
Information von sabines vor 2 StundeniOS

Mit dem Update soll der Bug behoben werden, bei dem eine bestimmte Zeichenkette IOS zum Absturz gebracht hat.

Sicherheit
Sicherheitsrisiko: Die Krux mit 7-Zip
Information von kgborn vor 16 StundenSicherheit

Bei vielen Anwendern ist das Tool 7-Zip zum Entpacken von Archivdateien im Einsatz. Die Software ist kostenlos und steht ...

Internet

Datendealing im WWW Tracking Methoden immer brutaler

Information von sabines vor 1 TagInternet

Interessanter Artikel zum Thema Tracking im WWW und die immer "besseren" Methoden des Trackings. Professor Arvind Narayanan (Princeton-Universität) betreibt ...

Erkennung und -Abwehr

Ups: Einfaches Nullzeichen hebelte den Anti-Malware-Schutzt in Windows 10 aus

Information von kgborn vor 1 TagErkennung und -Abwehr

Windows 10 ist das sicherste Windows aller Zeiten, wie Microsoft betont. Insidern ist aber klar, das es da Lücken, ...

Heiß diskutierte Inhalte
Server
Route-Befehl Unterstützung (unter CMD)
gelöst Frage von FKRR56Server38 Kommentare

Guten Tag , i.M. habe ich Probleme über den CMD-Route-Befehl ein Routing auf einen entfernten Server zuzulassen. Der Server ...

Windows 10
Windows 10 (1709) Tastur und Maus wieder einschalten?
Frage von LochkartenstanzerWindows 1028 Kommentare

Moin, Ich habe von einem Kunden einen Win10-Rechner bekommen, bei dem weder Tastatur noch Maus geht. Die Hardware funktioniert ...

Microsoft
TV-Tipp: Das Microsoft-Dilemma
Information von kgbornMicrosoft17 Kommentare

Aktuell gibt es in Behörden und in Firmen eine fatale Abhängigkeit von Microsoft und dessen Produkten. Planlos agieren die ...

LAN, WAN, Wireless
VPN Cisco ASA5505 PaloAlto PA-200
gelöst Frage von YannoschLAN, WAN, Wireless15 Kommentare

Hallo zusammen, ich würde gerne ein Site-to-Site VPN zwischen den beiden Standorten aufbauen. PaloAlto PA200 Internetanschluss Deutsche Telekom GK ...