Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Fehler: %%a ist syntaktisch an dieser Stelle nicht verarbeitbar

Mitglied: fugu

fugu (Level 2) - Jetzt verbinden

15.09.2006, aktualisiert 16.09.2006, 26045 Aufrufe, 7 Kommentare

Moinz @Batchler

Ich habe hier 2 Server, die per M$-Backup je auf eine lokal angeschlossene USB-HDD sichern.
In der Buchhaltung haben wir einen Verantwortlichen "gefunden", der nun täglich die Bänder vom neu angeschafften REV Drive wechseln soll. Hierfür steht auch eingens eine XPProf-Dose bereit, woran das REV angeschlossen ist.

Ich möchte nun:
  • Die jeweils aktuellste *.bkf von den beiden USB-HDD auf die lokale HDD der XP-Dose holen.
  • Die *.bkf auf das REV schreiben

Soweit so gut...

01.
@ECHO OFF 
02.
 
03.
CD /D D:\Backup 
04.
DEL /S /Q *.* 
05.
 
06.
NET USE X: \\srv01\DASI_SRV01 
07.
NET USE Y: \\srv02\DASI_SRV02 
08.
 
09.
CD X:\ 
10.
FOR /F "skip=1 tokens=*" %%a IN ('DIR /O /B X:') DO ( 
11.
  XCOPY "%%a" D:\Backup /I /C /E /Q /Y 
12.
13.
 
14.
CD Y:\ 
15.
FOR /F "skip=1 tokens=*" %%a IN ('DIR /O /B Y:') DO ( 
16.
  XCOPY "%%a" D:\Backup /I /C /E /Q /Y 
17.
18.
 
19.
"C:\Programme\Iomega\REV System Software\ImDrvCli.exe" /Drive=R: /Format 
20.
XCOPY D:\Backup\*.* R:\ /I /C /E /Q /Y 
21.
"C:\Programme\Iomega\REV System Software\ImDrvCli.exe" /Drive=R: /Eject 
22.
 
23.
NET USE X: /D /Y 
24.
NET USE Y: /D /Y
Leider bricht die FOR-Schleife mit der Meldung "%%a" ist syntaktisch an dieser Stelle nicht verarbeitbar. ab - und ich hab keine Idee, wo mein Fehler ist.

Thx for help, Fugu
Mitglied: hoschen
15.09.2006 um 13:37 Uhr
mach das mal so:

01.
@ECHO OFF 
02.
 
03.
CD /D D:\Backup 
04.
DEL /S /Q *.* 
05.
 
06.
NET USE X: \\srv01\DASI_SRV01 
07.
NET USE Y: \\srv02\DASI_SRV02 
08.
 
09.
CD X: 
10.
FOR /F "skip=1 tokens=*" %%a IN ('DIR /O /B X:') DO ( 
11.
  XCOPY "%%a" D:\Backup /I /C /E /Q /Y 
12.
13.
 
14.
CD Y: 
15.
FOR /F "skip=1 tokens=*" %%a IN ('DIR /O /B Y:') DO ( 
16.
  XCOPY "%%a" D:\Backup /I /C /E /Q /Y 
17.
18.
 
19.
"C:\Programme\Iomega\REV System Software\ImDrvCli.exe" /Drive=R: /Format 
20.
XCOPY D:\Backup\*.* R:\ /I /C /E /Q /Y 
21.
"C:\Programme\Iomega\REV System Software\ImDrvCli.exe" /Drive=R: /Eject 
22.
 
23.
NET USE X: /D /Y 
24.
NET USE Y: /D /Y
Bitte warten ..
Mitglied: fugu
15.09.2006 um 13:43 Uhr
sorry, hatte ich vergessen zu erwähnen...
die Variante hatte ich schon
Bitte warten ..
Mitglied: hoschen
15.09.2006 um 14:17 Uhr
machst du mal diesen Versuch?

01.
@ECHO OFF 
02.
 
03.
NET USE X: \\srv01\DASI_SRV01 
04.
NET USE Y: \\srv02\DASI_SRV02 
05.
 
06.
CD X: 
07.
FOR /F "skip=1 tokens=*" %%a IN ('DIR /O /B X:') DO ( 
08.
  echo %%a 
09.
)
Es sollte dann der Inhalt von X: aufgelistet werden!
Bitte warten ..
Mitglied: fugu
15.09.2006 um 14:22 Uhr
auch das hab ich schon versucht...
gleiche Fehlermeldung!

Den Laufwerkswechsel habe ich natürlich nicht mit
01.
CD X:
gemacht, sondern mit
01.
X: 
02.
 
03.
bzw. 
04.
 
05.
CD /D X:
Fugu
Bitte warten ..
Mitglied: geTuemII
15.09.2006 um 18:12 Uhr
Hallo Fugu,

vor die Commands gehört ein @ (@xcopy) und den Laufwerkswechsel mach mal besser mit pushd @pushd x:

[EDIT]
%%a gehört übrigens nicht in Anführungszeichen, aber das war dir sicher schon aufgefallen.
[/EDIT]

HTH geTuemII
Bitte warten ..
Mitglied: fugu
16.09.2006 um 08:39 Uhr
Danke geTuemII,

leider fruchtet das ebenfalls nix... auch dann nicht, wenn ich mich vorher manuell zu LW Y:\ wechsle. Und die Sicherungsdateien sind auch da, wo sie sein sollten.

01.
Y:\>dir /b 
02.
srv02---2006-09-15.bkf 
03.
srv02---2006-09-14.bkf 
04.
srv02---2006-09-13.bkf 
05.
srv02---2006-09-12.bkf 
06.
srv02---2006-09-11.bkf 
07.
 
08.
---- 
09.
 
10.
Y:\>FOR /F "skip=1 tokens=*" %%a IN ('DIR /O /B Y:') DO ( @XCOPY %%a D:\Backup /I /C /E /Q /Y ) 
11.
"%%a" ist syntaktisch an dieser Stelle nicht verarbeitbar.
Bitte warten ..
Mitglied: hoschen
16.09.2006 um 13:41 Uhr
dieser Befehl funktioniert nur in einer Batch-Datei!

01.
FOR /F "skip=1 tokens=*" %%a IN ('DIR /O /B Y:') DO ( @XCOPY %%a D:\Backup /I /C /E /Q /Y )
an der Kommandozeile (in einem Dos-Fenster) nur einmal % nicht %%

also:

Diesen Code in eine b-up.cmd und dann diesen Befehl "b-up.cmd" aufrufen.

01.
@echo off 
02.
 
03.
FOR /F "skip=1 tokens=*" %%a IN ('DIR /O /B Y:') DO XCOPY %%a D:\Backup /I /C /E /Q /Y
Bitte warten ..
Ähnliche Inhalte
Batch & Shell

"goto" kann syntaktisch an dieser Stelle nicht verarbeitet werden

gelöst Frage von Y4nn1ckBatch & Shell14 Kommentare

Morgen, ich schreibe gerade an einem Zufallsgenerator für die Klasse, also an einem, der auswählt, wer dran kommt. Ich ...

Batch & Shell

"C.E.O." kann syntaktisch an dieser Stelle nicht verarbeitet werden

gelöst Frage von HeacienBatch & Shell2 Kommentare

Ich bin gerade dabi die Smartphone App 'Don't get fired!' in Batch als abgewandte Version nachzuschreiben. Da die Formatierung ...

Batch & Shell

Batch "goto kann syntaktisch an dieser Stelle nicht verarbeitet werden"

Frage von admadmBatch & Shell1 Kommentar

Ich habe hier eine Batch die aus einem Programm heraus aufgerufen wird, leider funktioniert diese nicht. Ich erhalte den ...

Batch & Shell

Syntaktischer Fehler im Batch File das die Farben von CMD ändern soll

gelöst Frage von MaxappemannBatch & Shell2 Kommentare

Hallo liebe Community wir haben hier ein kleines Problem. Wir versuchen mit einem Batch File statt color 0A schreiben ...

Neue Wissensbeiträge
Microsoft
Shadow Defender
Tipp von Hyrule vor 7 StundenMicrosoft

Ich denke viele kennen es: Ein Update oder ein neues Programm und vieles funktioniert nicht mehr wie gewünscht. Die ...

Microsoft
Microsoft verarztet 50 Sicherheitslücken
Tipp von Hyrule vor 4 TagenMicrosoft

Microsoft verarztet mal wieder ein "paar" Sicherheitslücken in ihren Produkten: Und mal wieder Remote Code Execution und der abartige ...

Sicherheit

Prüfskript gegen Spectre und Co. wurde erweitert

Tipp von DerWoWusste vor 5 TagenSicherheit

Moin. Get-SpeculationControlSettings sagt sicherlich den meisten etwas. Mit den neuen Spectrevarianten muss man nun weitere Schritte machen, um zu ...

LAN, WAN, Wireless

IPhone und iPad scheinen Verbindungsprobleme mit Unifi v5.7.23 und 802.11r (schnelles Roaming) zu haben

Erfahrungsbericht von StefanKittel vor 8 TagenLAN, WAN, Wireless4 Kommentare

Hallo, vielleicht hilft dieser recht kurze Bericht doch den Einen oder Anderen. Ausgangspunkt Ein Kunde von mir setzt einen ...

Heiß diskutierte Inhalte
Hyper-V
Hyper V startet nicht wenn eine Offline geschaltene HD integriert wird
Frage von DieAzubinneHyper-V11 Kommentare

Hallö, bei einem PC der mit Windows 10 Pro installiert ist habe ich das Problem, dass der Virtuelle PC ...

CPU, RAM, Mainboards
ASUS P5W DELUXE startet nur manchmal und nur mit 2 GraKas
Frage von Windows10GegnerCPU, RAM, Mainboards10 Kommentare

Hallo, ich habe das o.g. Motherboard erhalten. Egal ob C2D 8400, Pentium D 945 oder P4 670, das teil ...

Virtualisierung
Virtuelle Maschinen langsam unabhängig vom Hypervisor
gelöst Frage von HyruleVirtualisierung8 Kommentare

Hallo, ich möchte gerne zwei bis drei virtuelle Maschinen virtualisieren, darauf sollen jeweils Windows 10 und diverse etwas größere ...

Rechtliche Fragen
Vorlage "private Nutzung dienstlicher Mobiltelefone"
Frage von linos2Rechtliche Fragen8 Kommentare

Hallo zusammen, ich bin auf der Suche nach einer Vorlage für die private Nutzung von dienstlichen Mobiltelefonen. Unsere Firma ...