Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Fehler bei Serversicherung Server 2012r2

Mitglied: sk7519

sk7519 (Level 1) - Jetzt verbinden

12.12.2014, aktualisiert 21:24 Uhr, 6461 Aufrufe, 12 Kommentare

Hallo zusammen,

ich habe hier einen Server 2012r2 Standard Server mit zwei Virtuellen Maschinen (Terminal Server und Domain Controler).
Die Sicherung habe ich auf dem Host erstellt, leider bringt er mir nun noch einen Fehler beim Backup.

Hier mal das Log von der Sicherung:

Fehler des Writers
Writer-ID: "{66841CD4-6DED-4F4B-8F17-FD23F8DDC3DE}"
Instanz-ID: "{31808F25-1C98-4B63-8899-0AA63965F0EE}"
Name des Writers: "Microsoft Hyper-V VSS Writer"
Status des Writers: "5"
Fehlerergebnis: "80042336"
Anwendungsergebnis: "80004005"
Anwendungsmeldung: "(null)"
Komponente: "CC87C389-21A0-47BB-8B7F-9E533B272505"
Logischer Pfad: "(null)"
Komponentenergebnis: "800423F0"
Komponentenmeldung: Für den virtuellen Computer "RDS01" konnte kein Sicherungsprüfpunkt erstellt werden: Der Schattenkopiesatz enthält nur eine Teilmenge der Volumes, die für eine ordnungsgemäße Sicherung der ausgewählten Komponenten des Generators notwendig sind. (0x800423F0). (ID des virtuellen Computers: CC87C389-21A0-47BB-8B7F-9E533B272505)
Dateiangabe: "V:\Hyper-V\Virtual Machines\\CC87C389-21A0-47BB-8B7F-9E533B272505.xml", rekursiv: "0"
Dateiangabe: "V:\Hyper-V\Virtual Hard Disks\\DATEN.vhdx", rekursiv: "0"
Dateiangabe: "V:\Hyper-V\Virtual Hard Disks\\RDS01.vhdx", rekursiv: "0"
Dateiangabe: "V:\Hyper-V\Virtual Hard Disks\\SQLDATA.vhdx", rekursiv: "0"
Dateiangabe: "V:\Hyper-V\Virtual Hard Disks\\SQLLOG.vhdx", rekursiv: "0"
Dateiangabe: "V:\Hyper-V\Snapshots\4D3C0357-2717-4AE7-8034-FC23CEBB2030.xml", rekursiv: "0"
Dateiangabe: "V:\Hyper-V\Virtual Hard Disks\DATEN-AutoRecovery.avhdx", rekursiv: "0"
Dateiangabe: "V:\Hyper-V\Virtual Hard Disks\RDS01-AutoRecovery.avhdx", rekursiv: "0"
Dateiangabe: "V:\Hyper-V\Virtual Hard Disks\SQLDATA-AutoRecovery.avhdx", rekursiv: "0"
Dateiangabe: "V:\Hyper-V\Virtual Hard Disks\SQLLOG-AutoRecovery.avhdx", rekursiv: "0"
*-----------------------------*


Anwendungssicherung
Writer-ID: "{66841CD4-6DED-4F4B-8F17-FD23F8DDC3DE}"
Komponente: "CC87C389-21A0-47BB-8B7F-9E533B272505"
Beschreibung : Online\RDS01
Logischer Pfad: ""
Fehler : 80780175
Fehlermeldung : Eine Komponente wurde bei der Schattenkopie des Volumes übersprungen.

Detaillierter Fehler : 800423F0
Detaillierte Fehlermeldung : Der Schattenkopiesatz enthält nur eine Teilmenge der
Volumes, die für eine ordnungsgemäße Sicherung der ausgewählten
Komponenten des Generators notwendig sind.



*-----------------------------*


Wo klemmts da noch?
Mitglied: 114757
12.12.2014, aktualisiert um 21:23 Uhr
Moin,
meistens liegt das an nicht genügend freiem Speicher auf den Partitionen im Gast. Achtung dazu zählen auch Bootpartitionen für die Microsoft eine Mindestmenge an freiem Speicher erwartet:
https://www.administrator.de/forum/server-sicherung-unter-server-2012-fe ...

Für allgemeines Troubleshooting bei wbadmin-Backups siehe unbedingt folgende Seite:
http://technet.microsoft.com/de-de/library/ee692290(v=ws.10).aspx

und checke auch folgende Google-Ergebnisse
http://www.google.de/search?q=the+shadow+copy+set+only+contains+only+a+ ...

Gruß jodel32
Bitte warten ..
Mitglied: sk7519
04.02.2015 um 17:14 Uhr
Danke für die Antwort.
Leider komme ich jetzt erst wieder dazu hier weiter zu machen.
Währenddessen lief ein Acronis Backup ohne Probleme. Der Kunde möchte dies aber nicht haben usw. blabla.

Fehler macht nur das Backup der Virtuellen Maschinen. Davon gibt es zwei, einen DC und einem mit einem Terminal Server (RDS01).
Anbei habe ich mal einen Screenshot der Partitionstabelle vom HOST eingefügt. Laufwerksbuchstaben in der Virtuellen Maschine kann ich nicht vergeben für System-reserviert.

16425ba804c8bb7715e7749cdf2855bf - Klicke auf das Bild, um es zu vergrößern

Traue mich jetzt nicht so wirklich die Partition zu vergrößern.
Was kann man noch tun?
Bitte warten ..
Mitglied: 114757
04.02.2015, aktualisiert um 20:04 Uhr
Da hat die Bootpartition zu wenig freien Speicher, gefordert sind hier mindestens 50 MB freier Speicher.

Wenn du kein Resizing vornehmen möchtest, musst du Platz schaffen. Dazu hast du folgende Möglichkeiten:

  • Eine Möglichkeit besteht darin das NTFS Transactionlog der Partition mit chkdsk zu verkleinern.
Ich gehen hier mal davon aus das die Partition als Laufwerk A:\ gemountet ist, dann geht das so:
chkdsk a: /l:4096 /f
  • Als weitere Option kann man das Recovery-Image (WinRE) auf der Bootpartition entfernen.

Gruß jodel32
Bitte warten ..
Mitglied: sk7519
05.02.2015, aktualisiert um 09:33 Uhr
Ich habe gestern das Recovery-Image verschoben, womit ich dann 87% freien Platz hatte auf der System-Partition.
Leider ist das wohl doch nicht die Fehlerursache.

Hier noch ein Screenshot vom gestrigen Backup.


44e41c7109697f84fc14770c08cb5451 - Klicke auf das Bild, um es zu vergrößern

Hat jemand noch eine Idee?
Immer wenn ich nach den Fehlermeldungen suche lande ich bei Sharepoint Problemen für den sbs2011.



Edith:

Hier noch ein Fehler beim Aufruf des vsswriter aus der cmd: vssadmin list writers

249e31379a1fb3d3c9452cbb9de144dd - Klicke auf das Bild, um es zu vergrößern
Bitte warten ..
Mitglied: 114757
05.02.2015, aktualisiert um 09:33 Uhr
Checke die Integrationstools in den VMs, besonders auf RDS01 welcher ja die Fehler wirft, und aktualisiere sie bei Bedarf. Die Verhindern ebenfalls oft eine erfolgreiche Sicherung auf dem Host, da dieser den VMs mitteilen muss das eine Sicherung stattfindet. Ebenso können Tools wie Acronis, die eigene VSS Module einpflanzen solche Probleme verursachen.
Bitte warten ..
Mitglied: sk7519
05.02.2015 um 09:54 Uhr
fca93f6f65928a9b2f65839b57c58779 - Klicke auf das Bild, um es zu vergrößern

Sind auf dem gleichen Stand.

Der Fehler bestand ja schon vor der Installation von Acronis.
Bitte warten ..
Mitglied: 114757
05.02.2015, aktualisiert um 10:23 Uhr
Was sagen die Eventlogs im Gast RDS01 ? Dort sollten ebenfalls VSS Errors auftauchen. More Input please
Haben alle Partitionen im Gast ebenfalls genug freien Speicher?, es gilt hier das gleiche wie für den Host !
Bitte warten ..
Mitglied: sk7519
05.02.2015 um 11:30 Uhr
sorry

also die eventlogs sagen im RDS01:

Fehler bei VSS Writer System Writer mit dem Status 8 und dem Writer-spezifischen Fehlercode 0x800423F0.
Quelle: vmicvss

Die partitionen im RDS01 (wiederherstellung und efi-systempartition) kann ich keinen laufwerksbuchstaben zuweisen über den datenträgerverwaltung.
hab das dann nun mit diskpart gemacht.
auf die efi darf ich komplett nicht drauf (fehlende zugriffberechtigungen die ich aber nicht abändern kann?) platz ist hier aber genug 3/4 frei.
auf die wiederherstellung komme ich nach ändern der rechte drauf. platz hier zu wenig habe das RE image wieder rausgeschoben.

lass gleich noch mal ein backup durchlaufen
Bitte warten ..
Mitglied: colinardo
05.02.2015, aktualisiert um 12:17 Uhr
Hallo sk7519,
wenn das alles nichts gebracht hat auch mal folgende Prozedur auf dem Gast durchführen, um die VSS Komponenten erneut zu registrieren:

  • Administrative Konsole öffnen
  • In das Verzeichnis C:\Windows\System32 wechseln und folgende Befehle nacheinander ausführen:
01.
net stop vss 
02.
net stop swprv 
03.
regsvr32 ole32.dll 
04.
regsvr32 vss_ps.dll 
05.
vssvc /Register 
06.
regsvr32 /i swprv.dll 
07.
regsvr32 /i eventcls.dll 
08.
regsvr32 es.dll 
09.
regsvr32 stdprov.dll 
10.
regsvr32 vssui.dll 
11.
regsvr32 msxml.dll 
12.
regsvr32 msxml3.dll 
13.
regsvr32 msxml4.dll
Danach den Server neu starten und danach mit
vssadmin list writers
überprüfen ob keine Fehler vorhanden sind.

Grüße Uwe
Bitte warten ..
Mitglied: sk7519
05.02.2015 um 13:40 Uhr
Hallo,

also ich habe die Befehle alle ausgeführt, einige davon gaben mir folgende Fehler aus:

regsvr32 /i swprv.dll --> fehlercode 0x80070715
regsvr32 /i eventcls.dll --> fehlercode 0x80070715
regsvr32 es.dll --> Fehler: stellen Sie sicher das es.dll eine gültige .dll- oder .ocx datei ist und wiederholen...
regsvr32 vssui.dll --> fehlercode 0x80070715
regsvr32 msxml.dll --> fehler beim laden des Moduls "msxml.dll" ... Das angegebene Modul wurde nicht gefunden
regsvr32 msxml4.dll --> fehler beim laden des Moduls "msxml4.dll" ... Das angegebene Modul wurde nicht gefunden

Server neu starten kann ich erst heute Abend.
Stellen die Fehler oben ein Problem dar?
Bitte warten ..
Mitglied: colinardo
05.02.2015 um 13:43 Uhr
Stellen die Fehler oben ein Problem dar?
Kenne das OS deines TS nicht ...
Bitte warten ..
Mitglied: sk7519
05.02.2015 um 13:46 Uhr
Sorry, 2012r2 Standard
Bitte warten ..
Ähnliche Inhalte
Backup

Problem mit Windows Serversicherung unter Server 2012

gelöst Frage von stormhunter1Backup3 Kommentare

Hallo, ich habe ein Problem mit der Sicherung eines Windows 2012 Standard Servers auf dem Exchange 2013 läuft mittels ...

Windows Server

Server 2012R2 DC - Fehler Rollen und Featureaktualisierung

Frage von quattrophilipWindows Server

Hallo Liebe Freunde der IT, Habe folgendes Problem ich habe einen Server 2012R2 zum DC gemacht. Danach wurden Windows ...

Windows Server

Windows Server 2012 - Probleme mit der Serversicherung..

gelöst Frage von KMUCenterWindows Server11 Kommentare

Hallo Leute, Wir haben seit kurzem einen Root Server bei Hetzner Wir haben Windows Server2012 darauf laufen. Aber mittlerweile ...

Windows Server

Windows Server Backup 2012R2 Schlägt fehl

gelöst Frage von BiGnoobWindows Server6 Kommentare

Hallo und guten Abend Ich erhalte bei einem Backup meines server folgende Fehlermeldung: Ich habe alle in Google auf ...

Neue Wissensbeiträge
Humor (lol)

WhatsApp-Nachrichten endlich auch per Bluetooth versendbar

Information von BassFishFox vor 12 StundenHumor (lol)3 Kommentare

Genau darauf habe ich gewartet! ;-) Der beliebte Messaging-Dienst WhatsApp erhält eine praktische neue Funktion: Ab dem nächsten Update ...

Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 1 TagGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Sicherheit

Intel gibt neue Spectre V2-Microcode-Updates frei (20.02.2018)

Information von kgborn vor 1 TagSicherheit

Intel hat zum 20. Februar 2018 weitere Microcode-Updates für OEMs freigegeben, um Systeme mit neueren Prozessoren gegen die Spectre ...

Microsoft
ARD-Doku - Das Microsoft Dilemma
Tipp von Knorkator vor 1 TagMicrosoft3 Kommentare

Hallo zusammen, vor einigen Tagen lief in der ARD u.a. Reportage. Das Youtube Video dazu dürfte länger verfügbar sein. ...

Heiß diskutierte Inhalte
Windows Server
AD DS findet Domäne nicht, behebbar?
Frage von schapitzWindows Server45 Kommentare

Guten Tag, ich habe bei einem Kunden ein Problem mit den AD DS. Umgebung ist folgende: Windows Server 2016 ...

Router & Routing
LANCOM VPN CLIENT einrichten
Frage von Finchen961988Router & Routing27 Kommentare

Hallo, ich habe ein Problem und hoffe ihr könnt mir helfen, wir haben einen Kunden der hat einen Speedport ...

Server-Hardware
Welche Rolle spielt Design bei Enterprise IT Hardware?
Frage von ApolloXServer-Hardware16 Kommentare

Ich arbeite für einen internationalen Elektronikhersteller in der Forschung und meine Aufgabe ist es, Feedback von Nutzern in Hinsicht ...

Switche und Hubs
Cisco SG350X-48 AdminIP in anderes VLAN
Frage von lcer00Switche und Hubs14 Kommentare

Hallo zusammen, ich habe ein Problem mir einem Cisco SG350X-48 bei der Erstinstallation wurde eine IP 192.168.0.254 (Default VLAN ...